VITAS

SpaceDock.info (Mod Hosting Site)

Recommended Posts

3 hours ago, godarklight said:

I should get inigma to sticky this - Anyone having problems registering PM me your username and I'll activate it ;)

EDIT: I mean change the original post, putting it in big letters :P

done.

2 hours ago, balika said:

Its good, but there are two problems with it:

  • 1 Its slooooooooooooow (I know It will be fixed)
  • 2 You just copy-pasted  the Kerbalstuff. I expected a new site....

 

That's your first post to the forum? Welcome! I think. :)

We're working hard on the site. It's taken a dozen or so people and hundreds of man hours to get a working site up fast. We used the KerbalStuff engine - it was free, and familiar to us, and to the modding community. The fact that you recognized it is a testament to our success (hopefully). We will customize and expand later. More to come, so stay tuned!

Edited by inigma
  • Like 3

Share this post


Link to post
Share on other sites

Well I, for one, truly appreciate you guys picking up the torch.  One thing I loved was the user-friendly simplicity, and I'm very happy that it's being maintained.  I've already changed over my bookmarks, and will be visiting on at least a weekly, if not more frequent, basis.

Share this post


Link to post
Share on other sites

First: Thank you for making KSP a better place. Curse is a nightmare that is best avoided.

I wouldn't bother you with this but I see no other alternative for support. I tried registering yesterday and have not yet received an email confirmation. Today I sent an email to support@spacedock.info and received this error. I know you guys are busy and will get this sorted out soon enough.

Delivery to the following recipient failed permanently:

     support@spacedock.info

Technical details of permanent failure:
Google tried to deliver your message, but it was rejected by the server for the recipient domain spacedock.info by s3n1.52k.de. [2a01:4f8:160:9023::2].

The error that the other server returned was:
530 Relaying not allowed
 

Edited by zKrieg

Share this post


Link to post
Share on other sites

My two cents. I'd like an actual check box or pull down your filter by ksp version because the text search filter used by kerbalstuff never seemed to work for me. 

 

Is there any way to implement a tagging system to better browse mods?

Share this post


Link to post
Share on other sites

Hey! Glad to have contributed my (astonomicallly tiny) bit to this thing. Best of luck moving it forward!

 

Rune. This community is so awesome, you can't help trying to keep up.

Share this post


Link to post
Share on other sites

 

I accidentally created a "mod pack" (instead of a "mod") when I was uploading a mod. I hit the wrong button, and didn't notice until it created the empty pack. There's no "delete" button that I can find. Can I get someone to delete it on the back-end? Or give me DB access so I can delete the row(s)? ;)

 

 

  • Like 1

Share this post


Link to post
Share on other sites
4 minutes ago, NecroBones said:

 

I accidentally created a "mod pack" (instead of a "mod") when I was uploading a mod. I hit the wrong button, and didn't notice until it created the empty pack. There's no "delete" button that I can find. Can I get someone to delete it on the back-end? Or give me DB access so I can delete the row(s)? ;)

 

 

Wasn't that something not in the original Kstuff? I saw modpacks that said "please don't download" and "Admins please delete" and such, that is something that modmakers need!

Edited by Andem

Share this post


Link to post
Share on other sites
25 minutes ago, Andem said:

Wasn't that something not in the original Kstuff? I saw modpacks that said "please don't download" and "Admins please delete" and such, that is something that modmakers need!

No it certainly is not, mod packs are a licensing and support nightmare.

11 minutes ago, DarthVader said:

There's mod packs now? So I could get all the MKS stuff in one go?

There are meta mod packs for a long time now, if you use ckan. I install my 70+ SETI meta mod pack with about 4 clicks using CKAN.

Just export the list of your currently CKAN installed mods in the "favorite" format.

Edited by Yemo
  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, balika said:

2 You just copy-pasted  the Kerbalstuff. I expected a new site....

I'm not sure whether to laugh or cry.  The guys here have done an EPIC job getting it back to running so quick (really glad we didn't place bets, 'cos I'da lost, I reckoned on end of the week!)

errr, sorry, I made a mod pack too, out of curiosity, can't delete it now.
Also I tried to upload a pic to profile page, but it didn't display (minor thing given everything else you've got going!)

  • Like 3

Share this post


Link to post
Share on other sites
22 minutes ago, Yemo said:

No it certainly is not, mod packs are a licensing and support nightmare.

I mean the delete button, not the modpacks...

  • Like 1

Share this post


Link to post
Share on other sites
Just now, Andem said:

I mean the delete button, not the modpacks...

Oh, missed that, thank you!

  • Like 1

Share this post


Link to post
Share on other sites

There are sudden surges of slowness on the server. first i thought its backups (and it still might be) but honestly ive no idea as of now.
But ill figure it out.

p.s. cpu load is arround 3-4% and bandwidth use is 1% the entire time (fast or slow phases).

  • Like 1

Share this post


Link to post
Share on other sites
11 minutes ago, VITAS said:

There are sudden surges of slowness on the server. first i thought its backups (and it still might be) but honestly ive no idea as of now.
But ill figure it out.

p.s. cpu load is arround 3-4% and bandwidth use is 1% the entire time (fast or slow phases).

 

Very odd. Other ideas that spring to mind: timeouts talking to the database, or dropped network packets. Dunno, grasping at straws. If the CPU and network loads look good then I tend to want to look at disk activity, swap usage, and timeouts connecting to services, etc.

Edited by NecroBones

Share this post


Link to post
Share on other sites

It's interesting. Two hours ago, the site wouldn't load. Just tried it and the whole thing loaded in 3 seconds according to my computer. My account is recognized, was able to check out my profile, edit, and log out just like it should.

So.....great job everybody, and keep up the good work. I'll see if I can scrub some funds for a couple of Pizza's. You deserve it.

EDIT: Still haven't got a e-mail notification (I use iCloud for e-mail) but since the website remembered me I'll consider a notification at this point as a moot issue. I'm good here.

Edited by GDJ

Share this post


Link to post
Share on other sites
8 minutes ago, NecroBones said:

 

Very odd. Other ideas that spring to mind: timeouts talking to the database, or dropped network packets. Dunno, grasping at straws. If the CPU and network loads look good then I tend to want to look at disk activity, swap usage, and timeouts connecting to services, etc.

EDIT: Also look at DNS resolution. If the software is trying to do reverse lookups on every IP that connects, that can be a source of slowness too. The forum software I run on one of my websites had that problem. Turned off DNS resolution on connecting IPs, problem went away.

  • Like 1

Share this post


Link to post
Share on other sites

yesterday i bumped up the timout to insane numbers to solve the upload timeout problem. i now reduced it back down a bit again. maybe that helps. after restarting the webserver everything is fine for a few minutes so my gist ist that the server is chocking to death on zombie connections.

Share this post


Link to post
Share on other sites
2 hours ago, NecroBones said:

 

I accidentally created a "mod pack" (instead of a "mod") when I was uploading a mod. I hit the wrong button, and didn't notice until it created the empty pack. There's no "delete" button that I can find. Can I get someone to delete it on the back-end? Or give me DB access so I can delete the row(s)? ;)

 

 

NecroBones can you submit a GitHub for this. I don't think we have one yet.

I'll update the OP guys to reflect that  support@spacedock.info   is not receiving email.

Share this post


Link to post
Share on other sites
48 minutes ago, cpone555 said:

I saw that you still use the old KerbalStuff logo so i attempted to design one for the new website. Image is 1024x1024. Don't want to annoy mobile users.

I love it! I want to give you rep but the forums saying that I've given too much today... :rolleyes:

Share this post


Link to post
Share on other sites
1 hour ago, inigma said:

NecroBones can you submit a GitHub for this. I don't think we have one yet.

I'll update the OP guys to reflect that  support@spacedock.info   is not receiving email.

Looks like I was beaten to it. Everyone's pretty aware of it already anyway.

Share this post


Link to post
Share on other sites
3 minutes ago, NecroBones said:

Looks like I was beaten to it. Everyone's pretty aware of it already anyway.

it's fixed now.

Share this post


Link to post
Share on other sites

i made some server tweaks i hope this solves the slowness surges. pls report your page load times

 

  • Like 1

Share this post


Link to post
Share on other sites
2 minutes ago, VITAS said:

i made some server tweaks i hope this solves the slowness surges. pls report your page load times

 

 

Wow, huge improvement! I'm still seeing some individual mod pages take several seconds, but many others are popping up almost instantly.

Share this post


Link to post
Share on other sites

This paragraph is from the original kerbalstuff code with just a search-and-replace on the name.  It was not written by the new devs for spacedock.  It sounds a bit contentious and might be softened a bit:

Quote

There have been a few poor modding sites for Kerbal Space Program in the past. SpaceDock aims to be different. We fix the problems with the old and make the new work great. Most of all, SpaceDock brings the Kerbal Space Program community back into the loop and puts the power in the modder's hands.

 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now