blackheart612

[1.7.x] Grounded - Modular Vehicles R5.0 (Mining Modules, Rotor Emergency Light) (Jun 5 2019)

Recommended Posts

36 minutes ago, Daniel Prates said:

Great,  lets see how this evolves. Actually I was not even thinking about damage models,  only something that looked like a proper tank hull. And yes, the parts size is indeed a bad match!

*snip*

Ladies and gentleman, the best thing that the koviet east-keuropean auto industry can give you: the kerbal yugo!  THE KUGO! 

Kool Kugo! Are you interested in sharing the .craft? I am in a Kugoslavian mood :)

Share this post


Link to post
Share on other sites
22 minutes ago, trooperMNG said:

Kool Kugo! Are you interested in sharing the .craft? I am in a Kugoslavian mood :)

Oh the car is not mine. Its a pic by blackheart that I quoted.... couldnt just NOT do the joke.... Lada also came to my mind.... as did the trabant!

Edited by Daniel Prates

Share this post


Link to post
Share on other sites

How can I get the free pivot to work? I switch from locked to free but it doesn't change anything. It won't pivot around.

1e8dd2d514e990634add28e3c3393c36.gif

Edited by SquaredSpekz

Share this post


Link to post
Share on other sites

Great new parts, I think I may no longer need the KSOS vehicles! I think we need some variation with the engine/fuel cells, though, in one of two ways, because currently every vehicle almost has to have a hybrid cell to be able to run for a good length of time, but that ruins some designs. Either batteries should be built into chassis parts, or a specific version of the chassis with a hybrid cell built in. I can't create trucks like the ones scattered around the KSC that run for any length of time due to this.

Other minor things are: taillights would be really nice, a fuel tank like the stock truck ones, and the wheels should have some more distinguishing descriptions.

Alternatively for the fuel tanks, a part that allows tanks with set radii to be attached.

Edited by Z3R0_0NL1N3

Share this post


Link to post
Share on other sites
12 hours ago, SquaredSpekz said:

How can I get the free pivot to work? I switch from locked to free but it doesn't change anything. It won't pivot around.

1e8dd2d514e990634add28e3c3393c36.gif

Same problem here.

Share this post


Link to post
Share on other sites

Is it just me or is there something off with the suspension? It looks like it's largely dysfunctional. And If I set it to a really low value to test if the suspension moves at all, the vehicle behaves like there is no grip at all.

Share this post


Link to post
Share on other sites

@theonegalen Your wheel problem's fixed now by the way

@nascarlaser1 Unfortunately no, it says so on my release post why.

@SquaredSpekz @Lvdovicvs Kerbal Joint Reinforcement?

@DocMop What's the problem? With tests so far, I see that there might be some damping problems but grip is just fine.

@Z3R0_0NL1N3 Improvements will always come, it's still the second release after all!

Edited by blackheart612

Share this post


Link to post
Share on other sites
56 minutes ago, Bottle Rocketeer 500 said:

@blackheart612 Now, you have made aircraft and the corresponding service vehicles. Now, go make an airport.

Kerbal Konstruct for airport

Share this post


Link to post
Share on other sites

at first i thought the widebodies will be looked like european trucks, i was wrong

btw u stole a landing leg for the airstairs :D 
coqRtle.png

Share this post


Link to post
Share on other sites

@blackheart612

I have build one simple car and set the spring strength of all wheels to 0.2 for testing purposes.

http://steamcommunity.com/sharedfiles/filedetails/?id=1337074481

The car is currently drifting sideways (in direction of the camera on the screenshot) with no friction at all.
I removed KerbalFoundries for this test but that didn't make a difference.

After some more testing:
The grip is missing only in the direction perpendicular to the driving direction. This means I can accelerate and brake but have no sideways grip.

 

This does not happen when the spring strength is higher. However I have no spring articulation whatsoever. I'll do some mod conflict tests.

 

Edit:
No spring articulation problem persists even with stock game.
No sideways grip under low spring power persists with stock game

Edited by DocMop

Share this post


Link to post
Share on other sites
12 hours ago, blackheart612 said:

@theonegalen Your wheel problem's fixed now by the way

@nascarlaser1 Unfortunately no, it says so on my release post why.

@SquaredSpekz @Lvdovicvs Kerbal Joint Reinforcement?

@DocMop What's the problem? With tests so far, I see that there might be some damping problems but grip is just fine.

@Z3R0_0NL1N3 Improvements will always come, it's still the second release after all!

No, I don't have KJR. I have KAS, that might be doing it.

Share this post


Link to post
Share on other sites

@Bottle Rocketeer 500 Kerbal Konstructs is always there for you :P 

@[INDO]dimas_1502 Reduce, Reuse, Recycle. Hehehe

@DocMop Haven't tested with your settings, right now they work as default though, I'll look into your issue more closely, I did notice that there is no damping for the suspension so that one's tested. KSPWheels has no issue here, it needs to use its module before it can affect something. These are fully stock wheels and 1.4 has some stricter transform rules so there are bound  to have problems.

@SquaredSpekz I have KAS and it works, try without any mods and see if it works properly, what version are you using?

Share this post


Link to post
Share on other sites

DID YOU WAKE UP TODAY FEELING ADVENTUROUS?

DID YOU WATCH A KROKODILE DUNDEE MOVIE AND WANTED TO EXPLORE A JUNGLE OR WHATEVER?

DID YOU GROW A MOUSTACHE AND ALL THE SUDDEN STARTED FEELING ALL TOM-SELLECK-KERMAN-LIKE?

THEN RUSH TO A KUGO DEALERSHIP RIGHT NOW AND BUY THE SPORTS-CROSS-KUGO! 

MCgWQUf.png4oq2j99.png

 

37.5 HP OF PURE ADVENTURE! 

ROOMY (COUGH) STORAGE SPACE! LUXURIOUS (DOUBLE-COUGH) INTERIOR! 

BUY ONE TODAY! 

(XX) Disclaimer: 1) engines may overheat due to ... use. 2) bumpers not actually designed to be bumped upon. 3) guarantee void if taken out of the store. 4) not guaranteed to climb the steeper slopes (9º limit). 5) Driver's moustache not included. 6) car is not certified neither 'cross' nor 'sports' for techninal reasons.(XX)

 

Share this post


Link to post
Share on other sites

Has anybody noticed the tires jittering when they are attached to a B-Type chassis? I'm building a little truck thing like in some of the promotional screenshots, but it would seem that the tires jitter and cause some "steering bias" in some direction. It also makes the main body of the vehicle seem to be misaligned. I have KSPWheel installed, so maybe this is a collision problem? I'm honestly clueless.

Here are a few screenshots if it helps any.

Spoiler

rpUDiTU.png

bCgrMY4.png

whtmbFH.png

 

 

Share this post


Link to post
Share on other sites
On 23/03/2018 at 3:53 AM, Gyrfalcon5 said:

Has anybody noticed the tires jittering when they are attached to a B-Type chassis? I'm building a little truck thing like in some of the promotional screenshots, but it would seem that the tires jitter and cause some "steering bias" in some direction. It also makes the main body of the vehicle seem to be misaligned. I have KSPWheel installed, so maybe this is a collision problem? I'm honestly clueless.

Here are a few screenshots if it helps any.

  Hide contents

rpUDiTU.png

bCgrMY4.png

whtmbFH.png

 

 

I have this problem too but it seems to be fixed by having the front wheels motors on 

Idk

Share this post


Link to post
Share on other sites
2 hours ago, memeconnoiseur said:

I have this problem too but it seems to be fixed by having the front wheels motors on 

Idk

What's the problem? I don't understand it much...

Share this post


Link to post
Share on other sites
2 hours ago, blackheart612 said:

What's the problem? I don't understand it much...

sometimes the vehicles lean to the left or right while driving

this occurs with some wheels and the B type wheel chasis part

Share this post


Link to post
Share on other sites

Hi @blackheart612. I'm currently playing KSP 1.3.1. right now, and I checked to see how the updated mod would look when I install it.

On 2/25/2018 at 11:22 PM, blackheart612 said:

Added Part Variant switcher to all parts

When I checked it, some parts that used to be yellow are now gray/white/silver. I assume, on 1.4., I should use the variant switcher to switch back to yellow? I'm not planning on updating to 1.4 soon, so just a quick question: Are there any plans to support KSP pre-1.4?

Thanks btw, and I've been enjoying building trucks and jeeps using the previous version. :)

Share this post


Link to post
Share on other sites

@memeconnoiseur I'm not able to replicate the issue, even with rear wheel drive. If anybody could provide visual footage, will probably help.

@johnkeale Some parts were used to export the white texture so yes, it's not going to work quite as well. Backwards compatibility will be impossible due to overlapping meshes from part variants, I might try to release a 1.3 version though, let's see.

Share this post


Link to post
Share on other sites

Hi @blackheart612! Mikasa's so cool right? > _ <

Oops, got off-topic there. I tried using the updated mod on 1.3.1. and there are no issues so far. Though I also experience @memeconnoiseur's issue. But I chalk that up to my impeccable piloting skills. (Or probably Jeb's?)

...anyway, backward compatibility is just a teeny tiny humble hope of mine :) Maybe you could just make the default color yellow and just be able to switch to white? (To make things consistent?) I'm sorry, I'm not familiar with that type of stuff, so I might just be rambling nonsense here. 

Either way, though I just tested things quickly, the parts seem to be working fine even in 1.3.1. I'll probably stick to the previous version for now though. Since I like how the color yellow blends in with that one seater truck that zips around inside the VAB.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.