• 0
billsails

IS 1.3 Ever going to work on a MAC?

Question

I have tried all the recommended workarounds, running from the root directory, with the -opengl flag, etc, etc.  None of them work for me.

Running macOS 10.13.3, and Kerbal ver 1.3.1

It might run for 10 minutes, or it might hang during loading.  but it always dies--just totally stops responding--with a blank screen.

Are Macs actually a supported platform anymore?

 

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

What’s your memory storage? You might have too many mods, or not enough RAM for stock KSP (2. so-and-so GB).

If none of the above, clarify more please 

Share this post


Link to post
Share on other sites
  • 0

No mods.  A fresh clean install.

Computer has 16GB of installed RAM...

MacBook Pro (Retina, 13-inch, Early 2015)

3.1 GHz Intel Core i7

16 GB 1867 MHz DDR3

Intel Iris Graphics 6100 1536 MB

A pretty standard machine, not a stripped down one.  

Edited by billsails

Share this post


Link to post
Share on other sites
  • 0

I have both a MacBook Pro and a MacBook Air from 2015 and 2016 respectively. Both run KSP without a problem. This would seem to indicate that it is your machine that has the problem.

I also run High Sierra 10.13.3 (17D102).

Share this post


Link to post
Share on other sites
  • 0

I had the same issues after the High Sierra upgrade on my MacBook Air (late 2013). What solved it for me was running KSP in a window rather than fullscreen. For some reason, KSP running fullscreen will lock up within a few minutes; in a window, I've never suffered such a lockup.

Share this post


Link to post
Share on other sites
  • 0

For me it actually works to turn of WiFi. Afterwards I could play >30h without any crash (for me there is no need for starting it with arguments, not in native fullscreen or similar). Try it out!

Share this post


Link to post
Share on other sites
  • 0
21 hours ago, billsails said:

No mods.  A fresh clean install.

Computer has 16GB of installed RAM...

MacBook Pro (Retina, 13-inch, Early 2015)

3.1 GHz Intel Core i7

16 GB 1867 MHz DDR3

Intel Iris Graphics 6100 1536 MB

A pretty standard machine, not a stripped down one.  

Hmm.... I'm blank, sorry.

Share this post


Link to post
Share on other sites
  • 0
14 hours ago, TheKSPBeginner said:

It's High Sierra. That's the problem.

err.... no... the problem is Kerbal...

If it does turn out that Kerbal can't work with the current version of macOS, then good-bye Kerbal. I am certainly not rolling back all the security updates just to play a game... even if it is a game I enjoy--my computer and data are too important for that.

 

 

 

6 hours ago, miallo said:

For me it actually works to turn of WiFi. Afterwards I could play >30h without any crash (for me there is no need for starting it with arguments, not in native fullscreen or similar). Try it out!

Holy crap...  That fixed it!  Not only is it now stable, it runs a lot faster and smoother!  

So much for all the other experts...  How come this is not at the top of the sticky thread about macOS problems????

I really do miss the long gone days when an Apples "just worked" and fussy crap like this was reserved for Microsoft machines.

Share this post


Link to post
Share on other sites
  • 0
4 hours ago, billsails said:

Holy crap...  That fixed it!  Not only is it now stable, it runs a lot faster and smoother!

It was quite funny. I bought the game on Steam and played it for two hours or so and was about to return it since it was unplayable. But then I needed to go on a train journey and just gave it one last shot. It worked perfectly fine then and it turns out: at my destination I had internet, but it was slow (200kbps at max). That also seems to resolve this issue...

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.