UomoCapra

Kerbal Space Program update 1.4 Grand Discussion thread.

Recommended Posts

The update is nice... I like the parachutes, even though they need some improvements. New particles look very smooth, i like that too. Oh, and the new spherical fuel tank, it's so cute ^_^

However, some changes are not good. Fairings now look weird, and new jet engine sounds are very high-pitched, i'd even say "more earrape-y" Overall, the update feels a little raw, so i'm hoping that devs will add much more stuff into the game.

Share this post


Link to post
Share on other sites

Looks like I may have found another issue in 1.4.

I have started a stock career (no mods period). I am playing with the option that makes you pay for your unlocked parts. When you unlock the Engineering 101 node, it shows 4 available parts for purchase, which have a grand total price of 5600 funds. However, the button to buy all parts says to buy 5 parts for 6800 funds. There is a phantom 5th part apparently. Also, the cost of the decoupler in this node went from 1200 funds in 1.3 to 1600 funds in 1.4. This may be intentional, but the phantom 5th part is definitely not.

I am attempting to submit a bug report at this time, but currently don't have access to a public file sharing site to upload the screenshot of proof. However, this should be fairly easy to reproduce.

 

ETA: if you buy the 4 parts in this node individually, the buy all parts button still shows 1 available part with a cost of 1200 funds. As i said above, that was the cost of the original decoupler in this node, before it got reskinned and replaced in 1.4 (and the cost got jacked up to 1600 funds). I believe it has been stated that the old parts were “hidden” so ships made with them in previous versions would still work, and I wonder if that is the cause of this phantom part? Perhaps they forgot to remove the “hidden” old decoupler from this research node?

Edited by Johnny Wishbone
Additional info

Share this post


Link to post
Share on other sites

To Tyko:

As I remember it, you get rid of the shroud if you just place your components in direct contact with each other. The shrouds only appear if you leave a gap.

Share this post


Link to post
Share on other sites

First of all great work with the new update.

I'll be posting this here, hopefully it will be the correct area to go. Is anyone experiencing issues with the icons of the parts being cut in half? The parts seem to work fine, just the icons are not correctly shown and my KSP is currently mod free
I've attached a snip i took from my icons so you can have a look

rmS5O6T.png

 

Edited by Devnull.13

Share this post


Link to post
Share on other sites

I got some more tips for you guys.  If you don't want to go to 1.4 because your favorite mod has not updated you can actually use the new 1.4 parts in 1.3.1 with some exceptions and a little editing of Config files. 

If you don't want to go to 1.4 because your favorite mod has not updated but want to play with the new parts in your game you can!

Just remember if you add anything that adds the Part Variant in the parts.cfg file you have to remove it.. For example this is located in the Rockmax8.cfg.

Remove this.  The module name is ModulepartVariants.  Of course make backups before you do this.. If you remove the wrong { you will mess up your part and it won't load.

MODULE
	{
		name = ModulePartVariants
		primaryColor = #ffffff
		secondaryColor = #000000
		baseDisplayName = #autoLOC_8007122
		baseThemeName = BlackAndWhite
		VARIANT
		{
			name = Orange
			displayName = #autoLOC_8007123
			themeName = Orange
			primaryColor = #f49841
			secondaryColor = #4c4f47
			TEXTURE
			{
				mainTextureURL = Squad/Parts/FuelTank/RockomaxTanks/rockomax_16 [AlbedoM] O
				_BumpMap = Squad/Parts/FuelTank/RockomaxTanks/rockomax_16 [Normal] O
			}
		}
	}

Most the new parts don't have this module so its not a big deal. 

Most of these files are located in this location:

C:\Steam\steamapps\common\Kerbal Space Program\GameData\Squad\Parts

Also some of the new parts don't have the New Locolization Names yet. You can also just add the New localization file from:

C:\Steam\steamapps\common\Kerbal Space Program\GameData\Squad\Localization its called dictionary.txt

Again this might cause some issues though incase they changed some Localization names from 1.3.1 to 1.4.  haven't tested enough.  The harder and safer way to change the name is just to edit the Name in the config file of the part and change it to what you want.

Of course Im not promising they will work right, some might be specifically tuned for Module changes that are specific for 1.4. But hey its something.

Of course non of this matters if you don't have an extra copy of 1.3.1 on your hardrive.. (yes you can do that) and this post assumes you have some knowledge Good luck.

And your mileage might vary.

Edited by malkuth

Share this post


Link to post
Share on other sites
13 hours ago, Third_OfFive said:

Ok so I've been playing around with this update some more and I immediately found some bugs:

 

1. There is a graphical bug with the parts selection menu in the VAB, something appears to be covering the top row of parts and makes them look glitchy

2. Music is silent in the Mission Control building

I noticed these in less than 2 minutes after starting a new career mode game. Are you guys planning to release a follow-up to patch some of the bugs in this release? Also, I am playing on Linux, so that might be a contributing factor...

I have the same issue with the part menu. If you look at a large menu "say the fuel tanks" you will see it is cut off at the top and the icons spill over the symmetry controls at the bottom. I am running Linux also and I think they have some problems with the new Unity compile? I can only run my game in the native resolution of my monitor and if I try to change it the game locks up or does funky stuff. So are you having any video problems other than the menu glitch? and if you don't mind me asking what video card & driver are you using?

 

Thank's

 

Edited by Delbrutis
fix typo

Share this post


Link to post
Share on other sites

Great update (although I'd prefer more big changes like 1.2 brought for example), I love the vessel naming system - no more renaming of sattelites!! 

I can see we've got two cone-shaped pods now - old Mk1 and new Mk1-3. I'm not sure whether it was one of my mods, but I recall having a bigger pod too. It was able to hold 4 kerbals. Was it there? Is it gone?

Share this post


Link to post
Share on other sites
1 hour ago, ades said:

To Tyko:

As I remember it, you get rid of the shroud if you just place your components in direct contact with each other. The shrouds only appear if you leave a gap.

Thanks for the suggestion...I tried it though. The top of the decoupler isn't smooth and the attach node is placed in such a way that it leaves a gap you can see through. Even if you manually move the decoupler closer it doesn't seat smoothly against the heat shield because the taller parts of the decoupler clip into the heat shield...take a look for yourself :)

Share this post


Link to post
Share on other sites

Just popped in to say that the new Mk 1-3 Pod has working RCS thrusters for translation etc.  Wow.

A couple of things, I dig the stock re-texturing on some of the tanks, but why not the Kerbodyne Tanks?  The Rockomax ones look sharp (if a little offset), but Kerbodyne and adaptor tank still looks meh.

Peace.

 

 

Share this post


Link to post
Share on other sites

Not sure if other people are seeing the same thing, but I just noticed that on quickloading my SSTO to re-try a landing, the engines which had been switched off were all enabled, which was disconcerting 500m from the runway as I went from having 1/3 throttle on 2 Whiplashes to having 2 Whiplashes and 6 Rapiers giving it the beans. Pretty sure that's a new one.

Share this post


Link to post
Share on other sites

 

@RoverDude The new fairings look just fine, but with them there is one small problem. 
When I change the quality of textures in the graphics settings, the quality of the fairing textures does not change (it remains still high). 
The same problem is with the new RCS tanks. I do not think that this is a big problem, but I hope that can be corrected 
in the next patch.
Edited by westmeath

Share this post


Link to post
Share on other sites
7 hours ago, RoverDude said:

I hear ya, but it's also a performance consideration.  Best thing to do is log this as feedback on the tracker so it does not get lost in the shuffle

@RoverDudeWill do. Quick thought, even going to something like an octagonal collider on the inside that closely hugs the inside of the drawn model as I (very crudely) attempted to draw here would be close enough to the shape to cover most usage scenarios, without adding the complexity that a fully attaching the collider to the mesh would entail. It would be plenty large enough for the 3.75m separator to allow a 2.5m part with accessories mounted to the side to pass through it, and for the upcoming 5m separator to allow a 3.75m part with accessories on the side to pass through. As it is the internal collider on the 3.75m separator is smaller than the diameter of a 2.5m tank, leaving me worried that the 5m collider won't let a 3.75m tank pass through it.

 

9wNdrjG.jpg

 

cheers :D

 

Share this post


Link to post
Share on other sites
2 hours ago, malkuth said:

If you don't want to go to 1.4 because your favorite mod has not updated but want to play with the new parts in your game you can!

Or you can stay on 1.3.1.

UiuiNKm.png

 

Share this post


Link to post
Share on other sites
2 hours ago, Devnull.13 said:

First of all great work with the new update.

I'll be posting this here, hopefully it will be the correct area to go. Is anyone experiencing issues with the icons of the parts being cut in half? The parts seem to work fine, just the icons are not correctly shown and my KSP is currently mod free
I've attached a snip i took from my icons so you can have a look

rmS5O6T.png

 

This happens to me in windows if I run KSP with the -force-opengl option. Also notice the icons overlapping the controls at the bottom of the list in opengl mode.

Forcing dx11 causes a different issue where the icons appear without texture. 

Running with the default dx9 works fine. 

Win x64 Opengl:

NmZcdT5.jpg

Win x64 dx11:

4AirNID.jpg

Edited by Frankenchokey
Add images

Share this post


Link to post
Share on other sites
2 hours ago, Devnull.13 said:

First of all great work with the new update.

I'll be posting this here, hopefully it will be the correct area to go. Is anyone experiencing issues with the icons of the parts being cut in half? The parts seem to work fine, just the icons are not correctly shown and my KSP is currently mod free

yeah I noticed this on KSP linux, was wondering if it was linux specific, or general. not had a chance to check that yet.
It's like there is a statically placed box, half an icon tall, at the top of the scrolling section, which covers whatever is at the top of the scrolling list.

Share this post


Link to post
Share on other sites

Liking the new decouplers, the Rokomax one was so bloated.

Loving the RCS on the large command pod :D.

Edited by DJWyre

Share this post


Link to post
Share on other sites
7 minutes ago, DJWyre said:

Liking the new decouplers, the Rokomax one was so bloated.

Loving the RCS on the large command pod :D.

The only issue I have with the new decouplers is that because of clipping issues, and the plain gray texture, they are very easy to miss when doing a visual inspection of the ship.

I have a couple times already went to add a decoupler because I thought I forgot it, only to realize that I indeed did not, it just blended in with the fuel tank or booster. 

Edited by MechBFP

Share this post


Link to post
Share on other sites

So what about a New PartTools to go with the new version of unity?

Share this post


Link to post
Share on other sites
1 hour ago, Superpenguin160 said:

@RoverDude I have a question about the parafoil since you have probably made that one. Is it possible to make a parafoil that is able to steer? So just with a config.

Not it :)  I think BJ did the code, and either Pablo or Leti did the modeling - though I expect one of the other team members can correct me if I am wrong :)

Share this post


Link to post
Share on other sites

After each update I check the really high 20m/s impact tolerance of the Twin Boar and Mammoth engines, and wonder why they get away with it. Why so high? Doesn't seem right.  I can practically use them as landing legs on larger craft :wink:   

Share this post


Link to post
Share on other sites

Squad, the humorous part descriptions are an integral part of the feel and style of the game. Please consider adding descriptions for the new parts in the next update.

Share this post


Link to post
Share on other sites
3 minutes ago, basic.syntax said:

After each update I check the really high 20m/s impact tolerance of the Twin Boar and Mammoth engines, and wonder why they get away with it. Why so high? Doesn't seem right.  I can practically use them as landing legs on larger craft :wink:   

Perhaps the parts are strong because they need to be that strong to not be destroyed by the awesome destructive force of their thrust...

"Jeb! Get away from there!"

Share this post


Link to post
Share on other sites

Just gave 1.4 a whirl. I was delighted to notice that my most important mods worked without a hitch too, other than the "UNCOMPATIBLE!!!11one" warning on startup. I like the look of the new parts, the QoL improvements like being able to switch instantly between VAB and SPH are nice, and the particle effects are much slicker too. Very nice job, SQUAD!

Share this post


Link to post
Share on other sites

Rockomax Jumbo-64: I miss the piping down the sides, its now a featureless cylinder. It works better in continuity that way, I suppose, since the 8, 16 and 32 size parts would need similar bits of visual fluff added to them in a redesign. 

I wish Squad would leave all the older parts accessible, they could be hid or exposed with a filtering button over the parts picker, and not leave this up to modders. Old parts would work well in career mode, where you could start a game using parts found at the side of the road, and after some VAB & tech tree upgrades your space program has 'modernized' and the newer parts are available.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.