Jump to content

Kerbal Space Program update 1.4 Grand Discussion thread.


Recommended Posts

1.4.1 Changelog


+++ Improvements
* Jet Engine Sounds.
* Further Improvements to landed vessel ground positioning.
* Vessel Naming is now enabled by default on the external command seat.
* Improved suspension oscillations.

+++ Localization
* Revision of several translation strings for German, French, Italian and Portuguese.
* Corrected Kerbal Parachute KSPedia page for Japanese being in a different language.

+++ Parts
* Fix Mk1-3 IVA model.
* Fixes for drag cubes for new decouplers.
* Fix drill animation.
* Fix ISRU bug with core heat.
* Re-introduced side piping to the Rockomax-64
* Corrected wet/dry masses on the foil tanks
* Removed the Entry Cost values for deprecated parts

+++ Bugfixes
* Fixes music briefly playing in loading screens after exiting the Editor.
* Fix parachute deployment when JetPack is active.
* Fix ability to repack personal parachute where kerbal is on EVA with cut parachute.
* Fixes to KSPedia loading order.
* Fix variant themes being listed as a custom category.
* Fix KSPedia not showing correctly on Linux.
* Fixes parts with variants affecting equal child parts in some cases.
* Fix Variant switcher icon in advance mode in the VAB/SPH editor.

Link to post
Share on other sites
On 3/11/2018 at 5:50 AM, The Flying Kerbal said:

I'd try changing it so it would have SAS in Career, just as it has in Science.

Here you go:

	MODULE
	{
		name = ModuleSAS
		SASServiceLevel = 3
	}

Add that to any part you want to have SAS, or

@PART[*]:HAS[@MODULE[ModuleCommand]]|HAS[@MODULE[KerbalSeat]]
{
	%MODULE[ModuleSAS]
	{
		%SASServiceLevel = 3
	}
}

this MM patch will add SAS level 3 (that means every stability mode is usable) to all command devices.

Edited by TDplay
fixed MM patch
Link to post
Share on other sites
3 hours ago, jrolson said:

+++ Improvements
* Jet Engine Sounds.

Do folks think they sound better or worse now? Compared to 1.3.x or 1.4.0?

(They honestly weren’t that bad for 1.4.0 if you assume the listener was in the center front of an Airbus A380 with earplugs in and headphones on.)

Link to post
Share on other sites

The new ship name priority system still needs some (read: a lot of) work. It only works on vessels that were spawned separately and docked afterwards. If you combine them in the VAB/SPH, there's no way to have each component get its own unique name - when you separate the components, the game will just do that thing where it names each component by appending "Ship" or "Station" or "Probe" or whatever to the end of the name of the craft. This is a huge problem for stuff like missions where you want to spawn the player at a station that has a ship docked to it and want the station and the ship to have unique names.

Link to post
Share on other sites
On ‎3‎/‎7‎/‎2018 at 1:41 PM, basic.syntax said:

Rockomax Jumbo-64: I miss the piping down the sides, its now a featureless cylinder.

 

Quote

* Re-introduced side piping to the Rockomax-64

Big things, little things - all kinds of things!  thanks @RoverDude :)

Edited by basic.syntax
Link to post
Share on other sites
9 hours ago, lodger said:

Oh, no more funny loading screens and jokes ... ;.;

They're still there, just the loading is so fast, and with three corp screens, there's no time for anything else. Install some mods and you'll get the good stuff again.

Chatterer with the extra sounds pack is sufficient to briefly get a non-corp shot.

Link to post
Share on other sites

First thing I tried to do as well was mess around with asteroids and got a big smack in the face when i realised how difficult it is to set up anything with asteroids involved. Additionally, I don't know if I am just overlooking things within the mission builder, but there doesn't seem to be a way to confirm two objectives at the same time. I wanted to make a mission where you just grab an asteroid from LKO and bring it back to the surface but the only way for me to do it is to create an objective that says something like "test distance from vessel to Asteroid" but there doesn't seem to be any way to keep checking, so one could easily just get near the asteroid, then leave it and go do the rest of the objectives.

Also, I noticed there is only a slider for setting starting cash, which was an interesting choice seeing that moving the slider one pixel changes the dollar amount you have wildly, and there is no box to just type a number in, which seems to be a huge oversight. Hopefully these things will get hammered out in updates soon, but so far I do think the mission builder is extremely cool as a concept.

Oh, and one more thing, since they didn't have any kind of in-game way to do mission sharing (which I think was a huge miss), where did Squad think people were going to go to share missions? I cannot find anywhere in these forums or in the KSP subreddit anywhere where people are even talking about sharing missions... Just my few thoughts.

Link to post
Share on other sites
28 minutes ago, punchyfist said:

Oh, and one more thing, since they didn't have any kind of in-game way to do mission sharing (which I think was a huge miss), where did Squad think people were going to go to share missions? I cannot find anywhere in these forums or in the KSP subreddit anywhere where people are even talking about sharing missions... Just my few thoughts.

I think they want us to use this place. :)

https://forum.kerbalspaceprogram.com/index.php?/forum/98-making-history-missions/

Link to post
Share on other sites

It's just me or new reentry effect sucks?

1)It makes vessel somehow transparent

2)it suddenly disappears/appears when zoom out/in

3)if setting of reentry effects below max, does not appear at all...

I guess new particle system in Unity broke it somehow? Or it is an "optimisation" done 

Also SRB effects are so much worse than old stock one (don't even ask about Real Plumes) 

Link to post
Share on other sites
11 hours ago, CaptainKorhonen said:

The new ship name priority system still needs some (read: a lot of) work. It only works on vessels that were spawned separately and docked afterwards. If you combine them in the VAB/SPH, there's no way to have each component get its own unique name - when you separate the components, the game will just do that thing where it names each component by appending "Ship" or "Station" or "Probe" or whatever to the end of the name of the craft. This is a huge problem for stuff like missions where you want to spawn the player at a station that has a ship docked to it and want the station and the ship to have unique names.

That honestly sounds like a bug. Avoiding the probe problem seemd like the main issue it was to solve (and what a loveing annoyance it was!).

Link to post
Share on other sites

So, "Kerbol" is now called "the Sun"? How did that happen?! I want Kerbol back!!

"It is however extremely important to note that the celestial body is called "The Sun" in the English game, and "Sun" in the game files. There is no such thing as Kerbol outside of the community forums and wiki."

oh, never noticed ...

Edited by lodger
Link to post
Share on other sites
2 hours ago, evileye.x said:

It's just me or new reentry effect sucks?

1)It makes vessel somehow transparent

2)it suddenly disappears/appears when zoom out/in

3)if setting of reentry effects below max, does not appear at all...

I guess new particle system in Unity broke it somehow? Or it is an "optimisation" done 

Also SRB effects are so much worse than old stock one (don't even ask about Real Plumes) 

1) Was already an issue before. I always had it that way. Thought it was normal, maybe a common bug?

2) Maybe a level of detail thing? Probably shouldn't happen on the player craft.

Link to post
Share on other sites
4 minutes ago, Temeter said:

1) Was already an issue before. I always had it that way. Thought it was normal, maybe a common bug?

2) Maybe a level of detail thing? Probably shouldn't happen on the player craft.

The effect seems to be on the wrong layer. And it changed from before since you can now see them thru the vessel.

Link to post
Share on other sites

On a more positive node, I'm positively surprised by the IVAs and tank models.  Looks pretty good, much better than just the new 2.5m tanks!

 

3 minutes ago, sarbian said:

The effect seems to be on the wrong layer. And it changed from before since you can now see them thru the vessel.

Weirdly enough, I've had it on that wrong layer for a long time before 1.4.^^

Edited by Temeter
Link to post
Share on other sites

Also, does anyone else see extremly high CPU/GPU usage? I got a small rocket on the launchpad, and I get 40% CPU and 100% GPU utilization, even a bit of stutter ingame. No mods.

In space it's just 30% to 45% each.

Edited by Temeter
Link to post
Share on other sites
2 hours ago, Temeter said:

That honestly sounds like a bug. Avoiding the probe problem seemd like the main issue it was to solve (and what a loveing annoyance it was!).

I think you might be right... I tried it again and it worked this time. I combined a station and a ship in the VAB, gave them unique names in the right click menu, set the priorities and now both vessels keep their names when I undock them.

Link to post
Share on other sites
9 minutes ago, CaptainKorhonen said:

I think you might be right... I tried it again and it worked this time. I combined a station and a ship in the VAB, gave them unique names in the right click menu, set the priorities and now both vessels keep their names when I undock them.

Neat!

Link to post
Share on other sites
3 hours ago, sarbian said:

The effect seems to be on the wrong layer. And it changed from before since you can now see them thru the vessel.

@sarbian

Actually you can see the effects through the ship in 1.3.1 as well. It is simply much more difficult because the effects are a lot more dense, but it indeed still happens. 

Link to post
Share on other sites
23 hours ago, TDplay said:

Here you go:

	MODULE
	{
		name = ModuleSAS
		SASServiceLevel = 3
	}

Add that to any part you want to have SAS, or

@PART[*]:HAS[@MODULE[ModuleCommand]]|HAS[@MODULE[KerbalSeat]]
{
	%MODULE[ModuleSAS]
	{
		%SASServiceLevel = 3
	}
}

this MM patch will add SAS level 3 (that means every stability mode is usable) to all command devices.

WOW!!  Thanks very much, this is EXACTLY what I was looking for, really appreciate this!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...