FreeThinker

[1.4.2 - 1.7.3, 1.8.1-1.9.1] KSP Interstellar Extended 1.25.17 Support Thread

Recommended Posts

2 hours ago, ArmchairPhysicist said:

I hope to not come across as impatient or such, I simply wish to know if this is coming. Are there plans in the works for KSPI to be made compatible with 1.4? I was caught off guard with the surprise release and I can’t revert to good old 1.3.1.

You can use the beta tab to go back to an older version.

Share this post


Link to post
Share on other sites

Version 1.17.3 for Kerbal Space Program 1.3.1 can be downloaded from here

Released on 2018-03-08

  • Added 4 additional fuel modes to Z-Pinch Fusion engine
  • Added permanent lithium and megajoule buffer to Z-Pinch Fusion engine
  • Balance: limited Z-Pinch thermal modes to static Isp
  • Fixed Tweakscaling issues on Z-Pinch Fusion engine

Share this post


Link to post
Share on other sites

@FreeThinker do you have any thoughts on my reported issue with thrust balancing in the case of thermal power reception?  ie, it works fine when I generate thermal power locally but when it's beamed in, it causes issues with both thrust balancing mods, to the point of destabilizing and crashing KSP entirely.  I suspect some engine parameters are reported differently in the received-power case?  I can ask on their forums too but it seems like the only delta here is in the way the engines receive power, so I figured I'd ask if you had suggestions here.

Or is this not worth dealing with until everything's updated to 1.4?  I still have 1.3.1 for now, but.. let me know if there's any tests/etc you want me to run.

Share this post


Link to post
Share on other sites

Updating your mod is annoying because I have to go in, find every (Obsolete) part, remove those then find each of the two types of trusses you have been shipping lately and remove both of those sets because they're either redundant to other mods I have or just aren't complete enough to have any useful purpose, (no adapters/nodes/etc...)... I think the game treats things in a directory called "Deprecated" as load but don't list in editor, I think this would be a good clean way to allow newer users to quickly remove parts that aren't needed and longer term users to still be able to load older designs. 

Share this post


Link to post
Share on other sites

Please help. I can't switch container types. I've tried for days to figure it out. I have module manager 3.x, mechjeb, kspie of course, planetary bases, scan sat, kis n kas, they all work well on 1.3.1. But I can't store anything in my bases. https://imgur.com/a/1SuOY

 

Edit. Here is a look at my game data folder. I also tried using configurable containers, but regolith is missing 

https://imgur.com/a/1PAfT

 

Edit 2. I can not store any mined resource, because I can't change my containers to store anything other than what they store by default. Ex  Ore, fuel, ox, xenon, etc. I am missing the little arrows next to the name of the resource that allows me to scroll through the different types of resources. I am reaching out after troubleshooting as much as I could. I'm not a programmer, so pokoing around at_utils and the bundled Co nfigureable Containers folder has prove. Fruitless. I know how annoying ppl asking like this are, but I just can't figure it out, and I am sorry to bother u guys..

Edited by KingKobral

Share this post


Link to post
Share on other sites
12 hours ago, AlonzoTG said:

Updating your mod is annoying because I have to go in, find every (Obsolete) part, remove those then find each of the two types of trusses you have been shipping lately and remove both of those sets because they're either redundant to other mods I have or just aren't complete enough to have any useful purpose, (no adapters/nodes/etc...)... I think the game treats things in a directory called "Deprecated" as load but don't list in editor, I think this would be a good clean way to allow newer users to quickly remove parts that aren't needed and longer term users to still be able to load older designs. 

They might still look the same but they are meant as high tech superlight alternative. Granted they might need a retexture.

Share this post


Link to post
Share on other sites
11 hours ago, KingKobral said:

Please help. I can't switch container types. I've tried for days to figure it out. I have module manager 3.x, mechjeb, kspie of course, planetary bases, scan sat, kis n kas, they all work well on 1.3.1. But I can't store anything in my bases. https://imgur.com/a/1SuOY

 

Edit. Here is a look at my game data folder. I also tried using configurable containers, but regolith is missing 

https://imgur.com/a/1PAfT

 

Edit 2. I can not store any mined resource, because I can't change my containers to store anything other than what they store by default. Ex  Ore, fuel, ox, xenon, etc. I am missing the little arrows next to the name of the resource that allows me to scroll through the different types of resources. I am reaching out after troubleshooting as much as I could. I'm not a programmer, so pokoing around at_utils and the bundled Co nfigureable Containers folder has prove. Fruitless. I know how annoying ppl asking like this are, but I just can't figure it out, and I am sorry to bother u guys..

9

I suggest you install IFS, which has many switchable solid storage tanks specifically intended for KSPIE

 

Edited by FreeThinker

Share this post


Link to post
Share on other sites
2 hours ago, FreeThinker said:

I suggest you install IFS, which has many switchable solid storage tanks specifically intended for KSPIE

 

U gotta PayPal link? Cause u r getting a beer on payday

Share this post


Link to post
Share on other sites
41 minutes ago, KingKobral said:

U gotta PayPal link? Cause u r getting a beer on payday

Donation links can be found the front page, right of PayPal logo

Share this post


Link to post
Share on other sites

Is there a way I can add the persistent thrust during timewarp to Near Future engines? I love this mod, but I'm trying to go with lower tech stuff this time around, and fusion engines are anything but :P I took a look through the part cfgs in hopes that it was simply a module I could add to an engine, like Persistent Thrust, but that does not seem to be the case. Is it hard coded for the specific engine controllers in this mod? I would use PT, but your version is so much better.

Share this post


Link to post
Share on other sites
https://imgur.com/a/nVGWY

So, I've got some sort of negative mass issue with atmospheric ISRU. I've got air intakes, wads and wads of beamed power, an ISRU Refrigerator, hydrogen tanks, and an ATTILA thruster on a ship. The goal was to boost it to low Kerbin orbit and fill up the tanks there. However, when I start up the atmospheric extraction process, it complains about insufficient storage, and shows a negative mass of stored ammonia, and a positive amount of available ammonia storage space. I've tried rebuilding the ship with minimal components, I've tried adding ammonia storage, both full and empty, and I've tried updating to the most current version of the mod. Enabling overflow doesn't do anything, and hydrogen isn't getting added to the tanks. I'm in a stable 80x80 orbit in the picture, and I've tried dropping to a 70x70 orbit that just skims above the atmosphere. The abundance shows non-zero percentage of hydrogen. I just don't know what to do at this point. Any thoughts? Do you need any more info?

Edited by Xheotris

Share this post


Link to post
Share on other sites
9 hours ago, Xheotris said:
https://imgur.com/a/nVGWY

So, I've got some sort of negative mass issue with atmospheric ISRU. I've got air intakes, wads and wads of beamed power, an ISRU Refrigerator, hydrogen tanks, and an ATTILA thruster on a ship. The goal was to boost it to low Kerbin orbit and fill up the tanks there. However, when I start up the atmospheric extraction process, it complains about insufficient storage, and shows a negative mass of stored ammonia, and a positive amount of available ammonia storage space. I've tried rebuilding the ship with minimal components, I've tried adding ammonia storage, both full and empty, and I've tried updating to the most current version of the mod. Enabling overflow doesn't do anything, and hydrogen isn't getting added to the tanks. I'm in a stable 80x80 orbit in the picture, and I've tried dropping to a 70x70 orbit that just skims above the atmosphere. The abundance shows non-zero percentage of hydrogen. I just don't know what to do at this point. Any thoughts? Do you need any more info?

The old atmospheric scoops worked fine, but I could never get this to work above the atmosphere. The moment you dip below 70 it works, but it's supposed to be a gradual transition.

Share this post


Link to post
Share on other sites

A quick newbie question guys; Does the CANDLE engine consume anything to generate power? It seems like I'm getting infinite EC just by toggling on then off the engine. It doesn't seem to be overheating my rocket neither.

Edited by Lymark1

Share this post


Link to post
Share on other sites

I installed the mod but on some of the research nodes it doesn't have any parts that it unlocks.

what do i do about this?

Share this post


Link to post
Share on other sites

Version 1.17.4 for Kerbal Space Program 1.3.1 can be downloaded from here

Released on 2018-03-10

  • Balanced atmospheric performance of non atmosphere/ compressed Air propellant modes
  • Fixed Fuel mode switching on Vista/Z-Pinch
1 hour ago, alekkat said:

I installed the mod but on some of the research nodes it doesn't have any parts that it unlocks.

what do i do about this?

What tech nodes?

To automatically hide any node that is not used in any way use

 

Share this post


Link to post
Share on other sites

Hello, i have found a problem with radiators: as you can see in the image in the link in the interstellar thrmal helper the radiator area is only 0,01 m^2 while the piece description states that is 2,50 m^2. Do you have any suggestions?

https://ibb.co/b2vASn

(i have kerbal space program version 1.3.0 and kspi 1.7.0)

Share this post


Link to post
Share on other sites
6 hours ago, Lymark1 said:

A quick newbie question guys; Does the CANDLE engine consume anything to generate power? It seems like I'm getting infinite EC just by toggling on then off the engine. It doesn't seem to be overheating my rocket neither.

If you click on "reactor control window" you'll see it consumes a tiny amount of uranium or plutonium. Should last for a few years.

And It does generate some wasteheat, but it has a built-in radiator big enough to manage all of it (and more, with upgrades).

Share this post


Link to post
Share on other sites
20 hours ago, LightThrust said:

Hello, i have found a problem with radiators: as you can see in the image in the link in the interstellar thrmal helper the radiator area is only 0,01 m^2 while the piece description states that is 2,50 m^2. Do you have any suggestions?

https://ibb.co/b2vASn

(i have kerbal space program version 1.3.0 and kspi 1.7.0)

Regardless of KSP version and KSPI-E version this bug is present (it's VERY old).

I'll add it to my backlog.

Share this post


Link to post
Share on other sites
19 minutes ago, alekkat said:

Well the tech nodes show up but it doesn't show any parts.

http://prntscr.com/ipnxiu

http://prntscr.com/ipnxmm

 

Ah, those nodes were inherited from CTT, which you apparently have not installed otherwise more icons would have been visible. When CTT is not installed it falls back into a kind of backup mode we it simply shows all CTT defined nodes. I agree with you that empty nodes should be excluded

Share this post


Link to post
Share on other sites
2 minutes ago, FreeThinker said:

Ah, those nodes were inherited from CTT, which you apparently have not installed otherwise more icons would have been visible. When CTT is not installed it falls back into a kind of backup mode we it simply shows all CTT defined nodes. I agree with you that empty nodes should be excluded

So installing CTT would fix this? 

Share this post


Link to post
Share on other sites
Just now, alekkat said:

So installing CTT would fix this? 

No, but all available icons will show up. If you want empty nodes to disappear you have to wait for next release or install

 

Share this post


Link to post
Share on other sites
1 hour ago, alekkat said:

So installing CTT would fix this? 

yes

 

Can I use magnetic scoop to collect fuel for thermal turbojet?

H2 can be used by it.

It appears I can't collect atmospheric gases.... or do I need something else?

I have magnetic scoop, refrigator, liquid H2 tank and more than enough electricity (5m fusion for thermal rocket and 2.5mm scoop)

It seems there is extreme bug with refrigerator gas-> liquid conversion.

I'm collecting hydrogen after all, but converter is at least 1000 times too slow

5m size refrigerator converts around 20g hydrogen per second.

kaVRgxv.jpg

Here is link to craft.

Or at least can we use gas versions of propellant when applicable?

That is if I don't have liquid hydrogen, then I can use gas hydrogen instead.

 

I increased max power usage 1000x

Now it converts quickly enough to feed thermal engine. It seems like max power usage doesn't scale with size.

40KP2LV.jpgIOFEi8F.jpg

Edited by raxo2222

Share this post


Link to post
Share on other sites

@FreeThinker it seems like you forgot to scale max power with size for  gas<->liquid conversion.

Edited by raxo2222

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.