FreeThinker

[1.4.2 - 1.7.3, 1.8.1-1.9.1] KSP Interstellar Extended 1.25.20 Support Thread

Recommended Posts

X6eetiq.jpg

Can someone tell me, where are 10-202 missing MW of power? :) Or some other number...

    ChargedParticleRatio = 0.985
    NeutronsRatio = 0.005
    NormalisedReactionRate = 0.9
    NormalisedPowerMultiplier = 0.936
    NormalisedPowerConsumption = 3
    MeVPerChargedProduct = 1.079411
    TechRequirement = advFusionReactions
    RequiresUpgrade = False
    RequiresLab = False
    TechLevel = 2

Here are numbers for this reaction type, but I coudn't find a way to lose exactly 202 MW.

Edited by Khalkion

Share this post


Link to post
Share on other sites

Hi, sorry for creating a first post like that, but I'm having a problem that's driving me insane. 

Every time I update/reinstall KSPIE I seem to end up with an extra set of items in research. I've tried removing the mods contained completely, removing the module manager files, without success. Any idea why that happens?

Share this post


Link to post
Share on other sites

Does KSPIE still react allergic to Near Future Electric? I do prefer the KSPIE reactors to those in Near Future, but I do miss the battery shapes. I could just install the parts manually regardless Oo.

Share this post


Link to post
Share on other sites

@FreeThinker I haven't been here to report any issues in a while but I've got.. three.  they've been going on for a while but they're relatively minor except #3.

1. resistojet RCS blocks show the animations backwards.  ie if it's thrusting to the left, the plume comes out of the left side instead of the right.  this started around KSP 1.4.0, it was fine in the 1.3.x line.  It can be a little disconcerting but they're still functional.  Side note, I updated the part cfg for these to allow a 2.5m version of them - which works great on my 20,000-50,000t starships :)  used to have to use 4 of the 1.2m ones and now I can use 1-2 of the 2.5m ones which saves on part count and is far mroe effective on ships that large.

2. Thermal ramjet nozzles are still able to breathe air at almost the same thrust as they get at sea level, all the way up to 70km.  it falls off a LITTLE with altitude but not like you'd expect.  This is only on the RAMJETS.  The TURBOJETS have the expected behavior.  This was reported before by myself and a couple others but it seems to remain unaddressed

3. The serious one - if I make a spaceplane with two engines (thermal ramjet nozzles) and each engine feeding off a separate thermal reactor (I'm using positron reactors in this case), the thrust isn't equal.  it's like the reactors ramp up at different rates.  This causes a fairly jarring yaw moment on initial throttle application.  At constant throttle it's stable, but they ramp up in such a way that produces differential thrust that is too powerful for RCS to compensate for in most cases, esp. on lighter (< 500t) craft.  If I use a single reactor with multiple engines, this problem goes away, so I think it has something to do with reactor warm-up rates not being equal.

Share this post


Link to post
Share on other sites

so, update.. 1.4.5 fixed .. something.  the issue #2 I reported in my previous post is gone with 1.4.5.  I didn't change anything else.

Share this post


Link to post
Share on other sites

I was about to install KSPI-E again (coming back for my yearly binge on KSP :V) and I noticed that there are a lot of mods in that zip file other than WarpPlugin.

There's no readme, so I figured I'd ask here: Which of the mod folders have required information for KSPI-E to function?

For example, TweakScale? The KJR install? FilterConfigs? Respectively, I already have it, already have it, and don't really want it, but if there's specific config information hiding in there somewhere that I might need, I'd probably want to copy it. Ditto for InterstellarFuelSwitch (which I'm actually fairly confident I don't need - I've got a different fuel tank switcher/config mod (and have a custom procedural tank for most of the KSPI-E stuff anyway))

For reference, here's the folder list:

WarpPlugin
TweakScale
PhotonSail
PersistentRotation
PatchManager
KerbalJointReinforcement
InterstellarFuelSwitch
HideEmptyTechTreeNodes
FSHangarExtender
CommunityTechTree
CommunityResourcePack
001_ToolbarControl
000_TexturesUnlimited
000_FilterExtensionsConfigs
000_FilterExtensions

That's a lot of stuff, and I've already got newer versions of at least some of these mods installed.

Edit: Just so this post isn't ONLY me whining: I really am grateful to you @FreeThinker - this has been one of my favorite mods since I discovered it back in 0.23 or so, and I'm glad you've continued it. I'm just worried about the bloat. :)

Edited by etmoonshade

Share this post


Link to post
Share on other sites
3 hours ago, etmoonshade said:

There's no readme, so I figured I'd ask here: Which of the mod folders have required information for KSPI-E to function?

For example, TweakScale? The KJR install? FilterConfigs? Respectively, I already have it, already have it, and don't really want it, but if there's specific config information hiding in there somewhere that I might need, I'd probably want to copy it. Ditto for InterstellarFuelSwitch (which I'm actually fairly confident I don't need - I've got a different fuel tank switcher/config mod (and have a custom procedural tank for most of the KSPI-E stuff anyway))

@FreeThinker

Well technically non of the mods are an absolute requirement, KSPIE will still function without them (even without CRP and CTT) but they are highly recommended to have the best interstellar play experience. You are obviously an experienced user and can find the latest releases by yourself but the majority is not and would handicap their interstellar experience if they did not install these mods. However some mods are more  recommended than others and the mod is balanced assuming all these mods are installed. For instance, Tweakscale is not just a nice to have, its an integral part of the KSPIE  gameplay as it  does not provide multiple size factor parts like most other mods do. You can play without filter extension but it will make it significantly harder to construct KSPIE vessels as they consist of unique modular parts that can only function in conjunction with each other. InterstellarFuelSwitch is not just a tank switch mod, but also a collection of quality resource tanks specifically designed to play along KSPIE. You may why  wonder why these storage parts are not in a separate mod, but there are historical reasons. However the current trend is that I try to modularize KSPIE, moving functionality in separate mod that can operate stand alone. A recent example of this Photon Sailor, which can function stand alone solar sail / laser propulsion mod and can interact with KSPIE beamed power network  if its installed. I have some vague plans to do the same for other functionality like ISRU and Beamed Power.

Edited by FreeThinker

Share this post


Link to post
Share on other sites
On 7/27/2018 at 7:03 AM, ss8913 said:

so, update.. 1.4.5 fixed .. something.  the issue #2 I reported in my previous post is gone with 1.4.5.  I didn't change anything else.

mm, yes, I always suspected KSP 1.4 introduced this problem because nothing realy changed in KSPIE. Good to hear it has resolved itself.

Share this post


Link to post
Share on other sites
8 hours ago, FreeThinker said:

Well non of the mods are an absolute requirement, KSPIE will still function without them (even without CRP and CTT) but they are highly recommended to have the best interstellar play experience. You are obviously an experienced user and can find the latest releases by yourself but the majority is not and would handicap their interstellar experience if they did not install these mods. However some mods are more  recommended than others and the mod is balanced assuming all these mods are installed. For instance, Tweakscale is not just a nice to have, its an integral part of the KSPIE  gameplay as it  does not provide multiple size factor parts like most other mods do. You can play without filter extension but it will make it significantly harder to construct KSPIE vessels as they consist of unique modular parts that can only function in conjunction with each other. InterstellarFuelSwitch is not just a tank switch mod, but also a collection of quality resource tanks specifically designed to play along KSPIE. You may why  wonder why these storage parts are not in a separate mod, but there are historical reasons. However the current trend is that I try to modularize KSPIE, moving functionality in separate mod that can operate stand alone. A recent example of this Photon Sailor, which can function stand alone solar sail / laser propulsion mod and can interact with KSPIE beamed power network  if its installed. I have some vague plans to do the same for other functionality like ISRU and Beamed Power.

I'd consider TweakScale a pretty hard dependency - kind of hard to resize anything without it, but hey, at least it won't blow up on me if I don't have it. :D

But otherwise, that's roughly what I'd hoped - it's just a bunch of really useful stuff that you're redistributing, not a bunch of mods with customized configs that will cause unexpected behavior if I install the original version rather than the version you provide. It pretty much means that I just need the WarpPlugin folder and I've got most of the rest of the stuff.

Thanks as always for the answer!

 

On 7/21/2018 at 8:20 AM, Zah said:

Does KSPIE still react allergic to Near Future Electric? I do prefer the KSPIE reactors to those in Near Future, but I do miss the battery shapes. I could just install the parts manually regardless Oo.

I can sort of lead you in the right direction on this, since I don't know exactly what you mean to "allergic."

For a long while, KSPI-E has included some configs that make it aware of the NFT stuff. The "problem" being that the power scale between the two is vastly different - a "stock" KSPI-E 0.625m reactor is enough to run a fair number of the NFP ion engines at full efficiency. I actually kinda like this. :D

Anyway, take a look in .\WarpPlugin\Patches\ - I literally just woke up so take this with a grain of salt, but I'm pretty sure it's the "NFTEnginesFix.cfg" that causes some of the behavior you're talking about. One of my first steps after reinstalling KSPI-E is to remove its awareness of certain other mods... and NFP is one of them.

Share this post


Link to post
Share on other sites
14 hours ago, FreeThinker said:

mm, yes, I always suspected KSP 1.4 introduced this problem because nothing realy changed in KSPIE. Good to hear it has resolved itself.

I take it back, it worked properly *once*.  now it's back to how it was.. I'm going to research a bit and see if this is one of those weird things that works when you 'revert to launch' and doesn't work out of the gate; I've seen that behavior before.

I did find that the asymmetrical thrust thing goes away if I put a single reactor on the craft and drive all the engines with it, as opposed to separate reactors for each thermal engine, which is why I think there's something weird going on with the reactors in the case #3 that I described earlier.

Share this post


Link to post
Share on other sites

Well I have at least issue 1 fixed in next release. The effect is mostly cosmetic but causes less confusion

Share this post


Link to post
Share on other sites
1 hour ago, FreeThinker said:

Well I have at least issue 1 fixed in next release. The effect is mostly cosmetic but causes less confusion

alright I did some testing on a heavier craft (my lighter craft are so powerful that they can make 3G all the way to 70km on positron reactors since they can make 20+G lower down in the atmosphere)... so my 800t construction/cargo spaceplane... if I launch from the SPH and limit acceleration to 30m/s/s it can pull that acceleration all the way to 62km altitude.  If I revert to launch, it only can do it up to about 21km altitude which seems like the correct behavior.
Now, the wrench in this is that I *am* using FAR, which hasn't officially updated in a while, although I have recompiled it against 1.4.5 (it didn't work at all, until I did), so the issue may be with the way FAR is modeling the air density between restarts(?) but it could also be something else.

Can anyone else repro this with stock aero?

Share this post


Link to post
Share on other sites

I'm not sure which topic is the right one as I was not able to find IFS support thread...

It seems that one of the two latest updates of IFS disabled patches to stock tanks and all my adapters turned into a pumpkins :(

From what I can think it is because configurable containers core (not full version) is dependecy of AT Utils which is dependency of several popular mods like USI colonization, TCA, Ground Construction and so on, but I have no idea how IFS can detect whether it is just core version or full.

If this behavior is intended should I just install full version of configurable containers to have KSPI fuels in stock form factors again? However it had already created some mess with old crafts >.<

For now I just deleted &!configurablecontainers from mmpatches, but if these changes will remain in effect I should think about some more elegant way...

 

PS Link to this topic from release thread is trying to lead us to edit your post. https://forum.kerbalspaceprogram.com/index.php?/topic/172026-142-ksp-interstellar-1186-support-thread/&amp;do=edit  /&amp;do=edit 

Edited by Khalkion

Share this post


Link to post
Share on other sites

This looks really cool and I tried to read and understand everything here, but half way through the reactors my eyes crossed and I haven't been able to uncross them. Now I'm getting a headache and my brain feels like it has contents under pressure.

I doubt I could get anything to work right if I used this....

 

 

Share this post


Link to post
Share on other sites
22 hours ago, JoE Smash said:

This looks really cool and I tried to read and understand everything here, but half way through the reactors my eyes crossed and I haven't been able to uncross them. Now I'm getting a headache and my brain feels like it has contents under pressure.

I doubt I could get anything to work right if I used this....

 

 

Maybe start in career mode, slowly gain access to the new stuff. Otherwise it's really overwhelming.

Share this post


Link to post
Share on other sites
1 hour ago, samooo2 said:

Maybe start in career mode, slowly gain access to the new stuff. Otherwise it's really overwhelming.

I think it WOULD be best to utilize this particular mod as a fresh start in a new career just for it. 

That makes it more of a question if I feel like starting everything over AGAIN.....from the beginning.

Are there guides or tutorial videos pertaining to this mod?

I feel if any mod ever needed a guide it would be this one.... 

It would probably be best to start this once they stop patching the game. I'm sure every update probably breaks this mod.

I finally decided to update to 1.4.5 because apparently that fixed Kerbal Konstructs and kerbin side, and Kopernicus was also updated to working with version 1.4.5....

Edited by JoE Smash

Share this post


Link to post
Share on other sites
10 minutes ago, JoE Smash said:

Are there guides or tutorial videos pertaining to this mod?

I feel if any mod ever needed a guide it would be this one....

There are some tutorials, but they're very out of date.  I haven't found up-to-date ones so far.  Same for the guides, unfortunately.

Share this post


Link to post
Share on other sites
1 hour ago, mbaryu said:

There are some tutorials, but they're very out of date.  I haven't found up-to-date ones so far.  Same for the guides, unfortunately.

Typical....oh well...

I guess I might check it out some day out of curiosity....

Right now I don't think I can anyway because it hasn't been updated for 1.4.5 yet

Edited by JoE Smash

Share this post


Link to post
Share on other sites

Download Version 1.19.4 for Kerbal Space Program 1.4.5 from here

Released on 2018-08-04

  • Compiled Against KSP 1.4.5
  • Added Atmospheric Particle Scoop (requires KarbonitePlus install)
  • Fixed RCS 's exhaust animation

Share this post


Link to post
Share on other sites

I'm building a ship with the Kerbstein drive and am lacking anywhere near enough LithiumHydride to even use the ship. Is there a way to get more LithiumHydride. All of the tutorials are to old to account for the Kerbstein Drive so I thought you might have the answer.

Edited by Jeb's Fireworks Guy

Share this post


Link to post
Share on other sites

Hi. I run into an issue with the ClosedCycleGasCoreEngine: Everytime I switch or load a ship in orbit with an activated engine of this kind, the vessel shows for a split second before warping out of existence. I'm having this issue with 1.19.3 on 1.4.4 and 1.19.4 (link above) on vanilla 1.4.5.  NullReferenceException is shown. Kerbal portrait stays. alt shows 0m. 

Share this post


Link to post
Share on other sites

Timberwind engine seems to never cool down in orbit once it reaches overheating state? watching it it takes like 10 seconds for it drop 0.001% overheating state in space with a dozen large radiator panels attached.

Lots of cooling seems to help keep it from overheating (reactor temp going up, loses max output thrust/power) but seems completely ineffective at cooling it down once reactor temp goes up.

Also does it seem right that power convected from one is 2MW when power radiated is 0.04KW? (when in the atmo). Career mode with none of the thermal upgrade techs.

Tried flying the same ship in sandbox, the rads radiated 100KW in orbit instead of 0.04KW. I can understand the upgrades improved them but I think 0.04KW vs 100KW is just a few magnitudes too much. They don't seem to actually heat up at all in my career save (Rad temp stays bone cold)

 

Still took forever for the engine to stop being overheated however (like 0.001% per second with the upgraded cooling tech in sandbox), and the rate stayed the same even under timewarp (ie, still 0.001% per real time second, so using timewarp to skip a few days in game will NOT cool the engines). This is with the built in generator set to off so it wouldn't produce any further heat.

Droping the ship back into the atmosphere seems to near instantly fix overheated state (5% overheat per second vs 0.001% per second in orbit), suggesting to me that convection values on those rads are crazy high and the radiation values are crazy low. I know radiation sucks but a factor of 5000?

PLEASE allow timewarp to be used to cool reactors off.

<edit> after updating KSPI, the insanely high convection dissipation of rads has gone down to normal levels, but now neither can cool off a timberwind effectively once it overheats.

 

Also, adding 2 of the large graphite folding rads (in sandbox, so max tech) still couldn't put a dent in a timberwinds overheat. I did notice you get a pretty long burn time before it overheats severely but just the built in generator being on can slowly build up overheat in regular time (But not so much in warp). Definitely could be an issue for someone who uses IRSU.

 

Might have something to do with the fact it starts to overheat at 2000 out of 400,000 waste heat, or 0.5% capacity. Don't rads output depend on waste heat level?

Edited by BlackMoons

Share this post


Link to post
Share on other sites
On 8/5/2018 at 6:48 PM, Jeb's Pirotecnics Guy said:

I'm building a ship with the Kerbstein drive and am lacking anywhere near enough LithiumHydride to even use the ship. Is there a way to get more LithiumHydride. All of the tutorials are to old to account for the Kerbstein Drive so I thought you might have the answer.

4

Interstellar Fuel Switch (IFS) Contains a solar fuel container which can contain any non-radioactive resource including lithium hydride.

MTdkCg9.png

They are the container at the right of the above image

 

 

On 8/6/2018 at 3:31 PM, comchris said:

Hi. I run into an issue with the ClosedCycleGasCoreEngine: Everytime I switch or load a ship in orbit with an activated engine of this kind, the vessel shows for a split second before warping out of existence. I'm having this issue with 1.19.3 on 1.4.4 and 1.19.4 (link above) on vanilla 1.4.5.  NullReferenceException is shown. Kerbal portrait stays. alt shows 0m. 

 

Could you please provide a log?

Share this post


Link to post
Share on other sites
LOG 19:27:01.142] [HighLogic]: =========================== Scene Change : From TRACKSTATION to FLIGHT (Async) =====================
[LOG 19:27:01.563] KbApp.OnDestroy Planet Resources
[LOG 19:27:01.564] KbApp.OnDestroy Vessel Info
[LOG 19:27:01.564] KbApp.OnDestroy Planet Info
[LOG 19:27:01.564] KbApp.OnDestroy Planet Parameters
[LOG 19:27:01.564] KbApp.OnDestroy NullName
[LOG 19:27:01.564] KbApp.OnDestroy Vessel Crew
[LOG 19:27:01.564] [UIApp] OnDestroy: KSPedia
[LOG 19:27:01.564] KbApp.OnDestroy Unowned Info
[LOG 19:27:01.789] [PlanetariumCamera]: Focus: Kerbin
[LOG 19:27:01.792] [UIMasterController]: HideUI
[LOG 19:27:03.203] UICanvasPrefabSpawner FlightUI spawning Flight
[LOG 19:27:03.228] UICanvasPrefabSpawner FlightUI spawning VesselLabels
[LOG 19:27:03.229] [UiApp] Awake: ResourceDisplay
[LOG 19:27:03.437] [AddonLoader]: Instantiating addon 'AeroGUI' from assembly 'KSP'
[LOG 19:27:03.438] [AddonLoader]: Instantiating addon 'ChangeTechTree' from assembly 'HideEmptyTechTreeNodes'
[LOG 19:27:03.439] [AddonLoader]: Instantiating addon 'FlightUIStarter' from assembly 'KSPInterstellar'
[LOG 19:27:03.439] [AddonLoader]: Instantiating addon 'FNImpactorModule' from assembly 'KSPInterstellar'
[LOG 19:27:03.439] [KSP] - FNImpactorModule listening for collisions.
[LOG 19:27:03.440] [AddonLoader]: Instantiating addon 'GameEventSubscriber' from assembly 'KSPInterstellar'
[LOG 19:27:03.440] [AddonLoader]: Instantiating addon 'BeamedPowerSources' from assembly 'Interstellar_Redist'
[LOG 19:27:03.440] [PlanetariumCamera]: Focus: Kerbin
[LOG 19:27:03.441] [UIMasterController]: HideUI
[LOG 19:27:04.005] [UIMasterController]: HideUI
[LOG 19:27:04.005] ------------------- initializing flight mode... ------------------
[LOG 19:27:04.016] Loading Depletion Nodes
[LOG 19:27:04.016] DepNodeCount:  0
[LOG 19:27:04.016] Loading Biome Nodes
[LOG 19:27:04.016] BiomeNodeCount:  0
[LOG 19:27:04.016] Loading Planet Nodes
[LOG 19:27:04.016] PlanetNodeCount:  0
[LOG 19:27:04.017] [ScenarioDestructibles]: Loading... 0 objects registered
[LOG 19:27:04.044] Target vessel index: 1  vessel count: 8
[LOG 19:27:04.044] [FLIGHT GLOBALS]: Switching To Vessel Untitled Space Craft ---------------------- 
[LOG 19:27:04.044] setting new dominant body: Kerbin
FlightGlobals.mainBody: Kerbin
[ERR 19:27:04.094] Cannot find fx group of that name for decoupler

[LOG 19:27:04.166] Camera Mode: AUTO
[LOG 19:27:04.720] all systems started
[LOG 19:27:04.720] [UIMasterController]: ShowUI
[LOG 19:27:04.725] [KSPI] - GameEventSubscriber Initialised
[LOG 19:27:04.725] [KSPI] - MicrowaveSources initialized
[LOG 19:27:04.734] [KSPI] - Creating Resource Manager for Vessel Untitled Space Craft (WasteHeat)
[LOG 19:27:04.741] [KSPI] - Creating Resource Manager for Vessel Untitled Space Craft (ThermalPower)
[LOG 19:27:04.741] [KSPI] - Creating Resource Manager for Vessel Untitled Space Craft (ChargedParticles)
[LOG 19:27:04.741] [KSPI] - Creating Resource Manager for Vessel Untitled Space Craft (Megajoules)
[LOG 19:27:04.744] [KSPI] - found 3 valid fuel types
[LOG 19:27:04.744] [KSPI] - grouped them into 1 valid fuel modes
[LOG 19:27:04.744] [KSPI] - CurrentFuelMode = Uranium-235
[LOG 19:27:04.745] [KSPI] - skipped calling Force on KspiLightbulb
[LOG 19:27:04.745] [KSPI] - Found power source localy
[LOG 19:27:04.745] [KSPI] - ThermalNozzleController - setup animation
[LOG 19:27:04.745] [KSPI] - ThermalNozzleController - calculate WasteHeat Capacity
[LOG 19:27:04.745] [KSPI] - ThermalNozzleController - find module implementing <ModuleEngines>
[LOG 19:27:04.745] [KSPI] - ThermalNozzleController - start BreadthFirstSearchForThermalSource
[LOG 19:27:04.745] [KSPI] - ThermalNozzleController - BreadthFirstSearchForThermalSource- Found thermal searchResult with distance 0
[LOG 19:27:04.745] [KSPI] - ThermalNozzleController - getPropellants
[LOG 19:27:04.746] [KSPI] - ThermalNozzleController - Setup propellant chosenpropellant 6 / 22
[WRN 19:27:04.748] BoxColliders does not support negative scale or size.
The effective box size has been forced positive and is likely to give unexpected collision geometry.
If you absolutely need to use negative scaling you can use the convex MeshCollider. Scene hierarchy path "KspiRadiatorConformal/model/LargeReactorRadiator"
[WRN 19:27:04.748] BoxColliders does not support negative scale or size.
The effective box size has been forced positive and is likely to give unexpected collision geometry.
If you absolutely need to use negative scaling you can use the convex MeshCollider. Scene hierarchy path "KspiRadiatorConformal/model/LargeReactorRadiator/LinkNub"
[WRN 19:27:04.748] BoxColliders does not support negative scale or size.
The effective box size has been forced positive and is likely to give unexpected collision geometry.
If you absolutely need to use negative scaling you can use the convex MeshCollider. Scene hierarchy path "KspiRadiatorConformal/model/LargeReactorRadiator"
[WRN 19:27:04.748] BoxColliders does not support negative scale or size.
The effective box size has been forced positive and is likely to give unexpected collision geometry.
If you absolutely need to use negative scaling you can use the convex MeshCollider. Scene hierarchy path "KspiRadiatorConformal/model/LargeReactorRadiator/LinkNub"
[LOG 19:27:04.808] [UiApp] Awake: CurrencyWidgetsApp
[LOG 19:27:04.809] [UiApp] Awake: ResourceDisplay
[LOG 19:27:04.809] [UiApp] Awake: KSPedia
[LOG 19:27:04.809] [ApplicationLauncher] OnSceneLoadedGUIReady: scene FLIGHT ShouldBeVisible() True ShouldBeOnTop() True iIsPositionedAtTop False
[LOG 19:27:04.809] [ApplicationLauncher] SpawnSimpleLayout: VerticalTopDown
[LOG 19:27:04.812] ScaleModList: listSize 41 maxListSize 519
[LOG 19:27:04.812] ScaleModList: listSize 41 maxListSize 510
[LOG 19:27:04.812] [KnowledgeBase] OnAppLauncherReady 23392
[LOG 19:27:04.840] [UIApp] OnDestroy: Contracts
[LOG 19:27:04.840] [UIApp] OnDestroy: Missions App
[LOG 19:27:04.875] [MessageSystem] Reposition 0.02 23393
[LOG 19:27:04.875] [GenericAppFrame] Reposition 0.02 23393
[LOG 19:27:04.875] [GenericAppFrame] Reposition 0.02 23393
[LOG 19:27:04.878] [KSPI] - ThermalNozzleController - Setup propellant chosenpropellant 6 / 22
[LOG 19:27:04.913] [FlightIntegrator]: Reloaded drag cube for zeroed cube root part mk1-3pod (Untitled Space Craft) on vessel Untitled Space Craft
[LOG 19:27:04.914] DragCubeSystem: Rendering procedural drag for KspiLightbulb
[LOG 19:27:04.975] ObT : NaN
M : NaN
E : NaN
V : NaN
Radius: NaN
vel: [NaN, NaN, NaN]
AN: [NaN, NaN, NaN]
period: Infinity

[WRN 19:27:04.975] [OrbitDriver Warning!]: Untitled Space Craft had a NaN Orbit and was removed.
[LOG 19:27:04.975] Untitled Space Craft Unloaded
[WRN 19:27:04.985] [KSPI] - detecting supplyable part Conformal Graphene Radiator is being destroyed
[WRN 19:27:04.985] [KSPI] - detecting supplyable part Conformal Graphene Radiator is being destroyed
[WRN 19:27:04.985] [KSPI] - detecting supplyable part Closed Cycle Gas Core Engine is being destroyed
[WRN 19:27:04.985] [KSPI] - detecting supplyable part Closed Cycle Gas Core Engine is being destroyed
[EXC 19:27:04.994] NullReferenceException
	TimeWarp.Update ()
    ...

same issue taken from a new install / ship

 

f8NbWVI.pngF8DEqFt.png

Edited by comchris
added pics

Share this post


Link to post
Share on other sites

ok this might be a fuel switch bug but my cryo tanks are spontaneously switching tank selection and fullness. between the time I push launch and the time the craft loads in. then after reverting flight back to VAB, the new tank selections remain.

spoiler for readers who like grinding for kerbucks the long, tedious way.

Spoiler

for example, my HTP factory has:

• 8 x IFS Cryogenic Tank (CT2504) set to H2O2 (HTP) all empty and scaled to 10m diameter

• 5 x IFS Cryogenic Tank (CT2504) set to 02 (LqdOxygen) all full and scaled to 10m

• 6 x IFS Cryogenic Tank (CT2504) set to H2O l (Liquid Water) all full and scaled to 10m

• 6 x IFS Cryogenic Tank (CT2504) set to H2 l (LH2) all empty and not scaled (2.5m default)

• 2 x ISRU Electrolyzer scaled to 10m with empty tanks

• 3 x ISRU Converter scaled to 10m

• 1 x Molten Salt Reactor scaled to 10m

• 1 x Thermal Electric Generator not scaled (2.5m default)

• 6 x Titanium Convector Radiator Inline scaled to 10m (the one that is cylindrical and 2.5m by default)

• 2 x ISRU Refrigerators both scaled to 5.9m and with the oxygen slider at 100 and the water slider at -100, but set the tank on one to be Water and the tank on the other to be Oxygen (keep default amounts in their storage hold)

• 1 x ISRU Refrigerator scaled to 1.53m, hydrogen slider set to -25 and oxygen slider set to 25, set tank to oxygen

• a bunch of launch clamps

• 1 x probe core

 those are instructions should you wanna try to reproduce it. I'm running IFS 3.6.3 and KSPIE 1.19.4 I took pre launch and post revert screenshots, take note of the resource readout on the bottom and the launch price. Even though the first one says launch cost is just under 25 mil, the actual price of putting it out on the launchpad is the post revert price. As an example, some of my empty HTP tanks become full of liquid fluorine, and full water tanks become full of HTP.  somewhere a tank switches to fusion pellets, idk it's weird. 

 

Edited by Jumberlack

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.