FreeThinker

[1.4.2 - 1.7.3, 1.8.1-1.9.1] KSP Interstellar Extended 1.25.20 Support Thread

Recommended Posts

Hey FreeThinker. I recently set up a helium-3 mining and refining operation on the mun. I was surprised to discover that specialised and enlarged regolith drills are massively inferior to the general purpose and smaller sized universal drills.

unknown.png

Using a scaled up regolith drill, 7.5 metre size, each drill only gives 0.1044 units/sec per drill. Using four of these, my total was 0.4176 units/second.

As you can see, they are also very power hungry, wanting 16.9Mw per drill.

 

unknown.png

Now compare that to using 6 universal drills of the standard 5m variety. Each of these drills is producing 1.123 units/second, AND the drill only asks for 100Kw of power.

 

Doesn't seem to make much sense that a specialised drill is performing so poorly against a smaller, more flexible, less energy demanding universal drill.

Share this post


Link to post
Share on other sites
Posted (edited)

Well your right there is a disbalance right now as the regolith was never mend to be minable with the Universal drill.

The Regolith "Drill" was never mend to be permanent solution but rather a stop get measure until I got access to a more suitable resource collecting model like this

uVGhQvY.png

allowing you to create something like this

ZiLLXdx.png

The increase in power consumption is to represent the addition power cost to heat up the regolith to release its gas contents which is then futher processed

 

lpaE1Ah.png

 

The Model was created by @riocrokite

Unfortunately the project is on hold, and might have died:(

For now I think I should do something to prevent the Universal Drill from collecting Regolith which is located on the top layer on the surface of the mun only

 

Edited by FreeThinker

Share this post


Link to post
Share on other sites

I found a 999_Scale_Redlist.dll in my latest KSPIE, what is this bundled for?

(sorry, I don't use this mod plenty like I was before)

Share this post


Link to post
Share on other sites
Posted (edited)
46 minutes ago, Nantares said:

I found a 999_Scale_Redlist.dll in my latest KSPIE, what is this bundled for?

(sorry, I don't use this mod plenty like I was before)

It is required to make Tweakscale function, it should be located in the root of your GameData folder

Tweakscale is required to play with KSPIE

 

Edited by FreeThinker

Share this post


Link to post
Share on other sites
Posted (edited)
On 3/30/2020 at 11:18 PM, FreeThinker said:

For now I think I should do something to prevent the Universal Drill from collecting Regolith which is located on the top layer on the surface of the mun only

Ahaha but please buff the regolith drills! Nerfing the universal and putting the performance of the regolith drills at what current universal drills do would be fine with me lol.

- I typed out a detailed example before my browser crashed, but I've noticed the thermal mechanics helper seems to be inaccurate.
Comparing area of radiators required to maintain a certain radiator temperature and obtain a given efficiency, it differs markedly from the in-game information. Upon testing in-game, the efficiency operates according
to the math given through the formulas on the discord wiki and not according to what the thermal window would suggest.

Edited by Olorin
Updated information on bugs

Share this post


Link to post
Share on other sites

In my experimenting with relatively low-tech beamed power, I notice that the old Thermal Rocket nozzle has been depreciated. So, what do you use in place of it if you want a beamed infrared launcher? The (somewhat broken but I've figured out some workarounds) Ablative Rocket Nozzles?

Also why the depreciation?

 

Share this post


Link to post
Share on other sites
21 hours ago, Mandella said:

In my experimenting with relatively low-tech beamed power, I notice that the old Thermal Rocket nozzle has been depreciated. So, what do you use in place of it if you want a beamed infrared launcher? The (somewhat broken but I've figured out some workarounds) Ablative Rocket Nozzles?

Also why the depreciation?

 

It's been split into multiple different nozzles. Krusader for atmospheric launches, aerospike for...I guess general use? And then Wyvern, Pelican and one more turbojet, those are air-breathing.

Also, they all have some fuel limitations now. Something about preventing chemical reactions between the propellant and the engine itself.

Share this post


Link to post
Share on other sites
1 hour ago, samooo2 said:

It's been split into multiple different nozzles. Krusader for atmospheric launches, aerospike for...I guess general use? And then Wyvern, Pelican and one more turbojet, those are air-breathing.

Also, they all have some fuel limitations now. Something about preventing chemical reactions between the propellant and the engine itself.

 

Ah okay. The Krusader is down the Nuclear Propulsion track, which is why I missed it.

Thanks!

Share this post


Link to post
Share on other sites

Hey @FreeThinker, I'm trying to make a LH2-based craft that can drill for hydrates, process them, electrolyze into H2, then cool it to refuel. I've got a universal drill and an all-in-one-ISRU refinery, and I'm testing my setup on the ground at kerbin (starting with full tanks of hydrates for the test).

I can successfully process hydrates into Water (not LqdWater), but my cryo tank (IFS CDT2002, but same issue with other tanks) that's set up to store LqdWater doesn't show me the slider to "pump" the 100 units in the refinery's storage into the other tank. As a result, the refinery won't let me do the electrolysis because it says "missing LqdWater". I've seen messages of a similar issue before, but I couldn't find an answer.

My LH2 tanks (IFS CDT2505) show the slider to convert between LH2<->H2, and I can freely move that fuel between the LH2 tanks and the refinery hydrogen storage when it's configured as such. I can also successfully electrolyze when my LqdWater tanks aren't empty.

Is there an issue that's incorrectly hiding the slider to pump between tanks? Or am I missing some intermediate step?

Thanks

Share this post


Link to post
Share on other sites

FYI, I think the latest release's version number got fat-fingered on SpaceDock:

FIf1sv9.png

I think that "2" is supposed to be a "25".

Share this post


Link to post
Share on other sites
15 minutes ago, HebaruSan said:

FYI, I think the latest release's version number got fat-fingered on SpaceDock:

FIf1sv9.png

I think that "2" is supposed to be a "25".

it is.  it's correct on CKAN at least, and installs cleanly from there.

Share this post


Link to post
Share on other sites
4 minutes ago, ss8913 said:

it is.  it's correct on CKAN at least, and installs cleanly from there.

I only noticed this because it's not correct on CKAN. CKAN has 1.25.13.1 and 1.2.13.5, but not 1.25.13.5:

SqF0Vlg.png

UQv1Jvy.png

(scrolling way down)

I5rPZPv.png

Share this post


Link to post
Share on other sites
10 hours ago, HebaruSan said:

FYI, I think the latest release's version number got fat-fingered on SpaceDock:

FIf1sv9.png

I think that "2" is supposed to be a "25".

Damn I was tired yesterday, I removed and reuploaded with correct version

Share this post


Link to post
Share on other sites
16 hours ago, FreeThinker said:

Could you explain in detail how to reproduce the log?

Well I don't know. I just play Kerbal Space Program... I don't know anything about those bugs.

Share this post


Link to post
Share on other sites

Hi, sure this has been already answered, but, what is the purpose of the solar array "activate receiver" clickbox? (during navigation)

Thanks and regards!

Share this post


Link to post
Share on other sites
On 2/10/2020 at 6:05 PM, Morphisor said:

The guys over at Bluedog Design Bureau consider me a loony for even trying to mix these two mods, but I do, so here I am...

I found a particular & peculiar compatibility issue between KSPI & B-DB. As you may or may not know, B-DB has a bunch of tiny probe cores with very small amounts of EC storage, even going as low as 5 ec for the most basic ones. When combined with KSPI however, every probe core from B-DB that has LESS than 30 ec starts out with exactly none when proceeding to the launch pad. In the VAB everything shows as it should. However on the launch pad the EC storage is 0. And of course the probe is uncontrollable as a result.

Any probe with 30 or more ec was tested to work normally, strangely.

The problem resolved itself when I uninstalled KSPI and the Interstellar fuel switch, so it's due to something being done by KSPI. 

It's not a major issue that cannot be overcome, but I figured it may be a symptom of a larger issue behind the scenes and worth mentioning.

Main culprit there is, I think, patch contained in file \WarpPlugin\Patches\SolarPanels.cfg, which enables WasteHeat mechanism for solar panels. When part has batteries too its makes them inoperable.

@PART[*]:HAS[@MODULE[ModuleDeployableSolarPanel]:HAS[#chargeRate[>0]]]:FOR[WarpPlugin]
{
    MODULE
    {
        name = FNSolarPanelWasteHeatModule
    }

    RESOURCE
    {
        name = Megajoules
        amount = 0
        maxAmount = 0.001
        isTweakable = false
        hideFlow = false
    }

    RESOURCE
    {
        name = ElectricCharge
        amount = 0
        maxAmount = 0.001
        isTweakable = false
        hideFlow = false
    }
}

As a crude workaround You can change first line into:

@PART[*]:HAS[@MODULE[ModuleDeployableSolarPanel]:HAS[#chargeRate[>0]],!MODULE[ModuleCommand]]:FOR[WarpPlugin]

It will disable WasteHeat for all parts with solar panels and ModuleCommand.

I hope some Module Manager whiz knows how to make better patch for this issue.

Share this post


Link to post
Share on other sites
On 2/6/2019 at 6:37 PM, FreeThinker said:

The Ticket to ride for a grand tour of the galaxy is a vessel with

  • Bussard Fusion Engine
  • Bussard Magnetic Scoop (which can collect solarwind from the interstellar medium or directly from the star)
  • ISRU Refrigerator (to convert collected solarwind into hydrogen, helium and traces of other resources)
  • Muon Catalyzed Fusion Reactor to power the Magnetic scoop  (in NTO fusion mode)
  • Frozen Hydrogen Storage (preferably 1 big spherical tank to minimize mass)
  • Sufficient amount of radiators (preferably static to minimize mass).

Although the Bussard Magnetic scoop allows you to refuel the vessel, it generates drag and the hydrogen is not distributed evenly and in the interstellar medium, you need a decent amount of speed (0.01c) before they start to collect a reasonable amount of hydrogen. Also note you need to store some helium to maintain the magnet scoop which is leaky.

I trying to fly to proksimus Kirbani(Galaxies Unbound : Nova Kirbani Planets pack) with these setups and it flies like a Shinkansen in space, but I want to know when I should slowing down(from 0.01c:0.0:) to get my place and not lost in space

Share this post


Link to post
Share on other sites

ha ... was watching star trek:enterprise again, since quarantine ... this one alien guy claims his ship can haul 1 million metric tons of freight at warp 4.5, which i believe is roughly 83c per the star trek memory alpha pages... guess there's a challenge for us KSPIE users :)  it'd have to be built in orbit, though, anything over 30,000 metric tons will explode on the runway/launchpad from the gravity stresses.  I'm not even sure if KSP can handle a ship of a million metric tons, but.. maybe?  turning it around might be a problem...

Which reminds me, @FreeThinker of an idea I had - add something to allow normal engines like the thermal turbojets, plasma nozzles, etc, to function as RCS as well as regular engines?  the resistojet RCS blocks aren't powerful enough for some of the larger designs I've made.  I've gone as far to modify the part config to allow tweakscale to push them to a 2.5m size which helps, but...

Share this post


Link to post
Share on other sites
9 hours ago, ss8913 said:

Which reminds me, @FreeThinker of an idea I had - add something to allow normal engines like the thermal turbojets, plasma nozzles, etc, to function as RCS as well as regular engines?  the resistojet RCS blocks aren't powerful enough for some of the larger designs I've made.  I've gone as far to modify the part config to allow tweakscale to push them to a 2.5m size which helps, but...

Yes, an RCS powered directly by an Thermal Reactor would be useful in this case.

Share this post


Link to post
Share on other sites
9 hours ago, FreeThinker said:

Yes, an RCS powered directly by an Thermal Reactor would be useful in this case.

does that already exist?

Share this post


Link to post
Share on other sites
Posted (edited)
On 4/7/2020 at 9:56 PM, ss8913 said:

does that already exist?

Well partially if you consider an thermal nozzle placed under a vessel as a kind of rcs, but definatly not controlled by stock rcs

Edited by FreeThinker

Share this post


Link to post
Share on other sites

I finally started using the Alcubierre drive for "useful" things. I went to Dres, picked up a homesick Kerbal, when I charged the drive, targeted Kerbin and hit Engage, em, I mean "Activate Warp Drive" it started moving to Dres instead. I un-targeted Kerbin and targeted it again, and this time it went in the right direction.

Any idea what's going on?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.