FreeThinker

[1.4.2 - 1.7.3, 1.8.1-1.9.1] KSP Interstellar Extended 1.25.20 Support Thread

Recommended Posts

Posted (edited)

Hello @FreeThinker I know that you have being busy with SolarSail and Persistent Thrust Extended but about the Kerbstein Fusion Drive,

today I found the source of all those messages in log, and that eventually after 2 or 3 hours kill the KSP and Crash... :( because of this and also because the log become too big, due to this problem.

ERRORS on log cause by Kerbstein Fusion Drive from KSPI.

[LOG 23:23:47.946] stageStartMass = NaN
[LOG 23:23:47.946] burnTime = Infinity
[LOG 23:23:47.946] StepEndMass   = NaN
[LOG 23:23:47.947] RCS exceeded loop count
[LOG 23:23:47.947] stageStartMass = NaN
[LOG 23:23:47.947] burnTime = Infinity
[LOG 23:23:47.947] StepEndMass   = NaN
[LOG 23:23:47.948] RCS exceeded loop count
[LOG 23:23:47.948] stageStartMass = NaN
[LOG 23:23:47.948] burnTime = Infinity
[LOG 23:23:47.948] StepEndMass   = NaN
[LOG 23:23:47.949] RCS exceeded loop count

When I remove the engine in the editor from the ship the spam of almost 100 messages per second stop.

Any idea of what is causing this?

Added a small video showing this behavior:

 

Edited by pmborg

Share this post


Link to post
Share on other sites
Posted (edited)

Actually @FreeThinker the KerbalEngineer (from @cybutek) is spamming this (post/video above) and causing a severe problem in to KSP stability:

[LOG 10:58:18.948] burnTime = Infinity
[LOG 10:58:18.948] StepEndMass   = NaN
[LOG 10:58:19.098] RCS exceeded loop count
[LOG 10:58:19.098] stageStartMass = NaN
[LOG 10:58:19.098] burnTime = Infinity

uninstall it, remove this spam.

 

Edited by pmborg

Share this post


Link to post
Share on other sites
Posted (edited)

But nevertheless its curious why this happening with this engine.

Edited by pmborg

Share this post


Link to post
Share on other sites
1 hour ago, pmborg said:

Actually @FreeThinker the KerbalEngineer (from @cybutek) is spamming this (post/video above) and causing a severe problem in to KSP stability:

[LOG 10:58:18.948] burnTime = Infinity
[LOG 10:58:18.948] StepEndMass   = NaN
[LOG 10:58:19.098] RCS exceeded loop count
[LOG 10:58:19.098] stageStartMass = NaN
[LOG 10:58:19.098] burnTime = Infinity

uninstall it, remove this spam.

 

I have this vague memory of something similar happening with MechJeb back in the day. It used to have the WORST problems understanding the KSPI-E engines, especially stuff that ramped up the max thrust or Isp values as they heated up. Handling seems to be a lot better than it used to be nowadays (i.e. I can actually use MJ to land on a thermal engine now.)

I'm not saying I know what causes the problem, but hopefully this gives a mental nudge in the right direction for someone?

Share this post


Link to post
Share on other sites

While nobody fix this I solved the problem recompiling KerbalEngineer and removing the spam:

FILE: C:\Users\pedro\KerbalEngineer\KerbalEngineer\VesselSimulator\Simulation.cs

ej868ve.png

This is just a Work-Around, for the stability problem, it's solved no more 1GB of log after some hours that kill KSP...

But the real problem with the engine is there.

Share this post


Link to post
Share on other sites
On 7/31/2020 at 2:49 PM, pmborg said:

While nobody fix this I solved the problem recompiling KerbalEngineer and removing the spam:

FILE: C:\Users\pedro\KerbalEngineer\KerbalEngineer\VesselSimulator\Simulation.cs

ej868ve.png

This is just a Work-Around, for the stability problem, it's solved no more 1GB of log after some hours that kill KSP...

But the real problem with the engine is there.

Please report at KerbalEngineer

Share this post


Link to post
Share on other sites
Posted (edited)
29 minutes ago, FreeThinker said:

Please report at KerbalEngineer

Are you sure that this is a bug of KerbalEngineer?

or a bug/particularity on this engine (which is the only one that lead to this behavior) and trigger this problem in KerbalEngineer?

Actually the work-arround/fix can be just this one:

W8Yzmj8.png

Fix the KSP stability but this will just hide the problem.

Edited by pmborg

Share this post


Link to post
Share on other sites

Besistes this one I will fix the other one (also already reported) in InterstelarSpace time for deltaV  bigger than a day...

Share this post


Link to post
Share on other sites

Bug report (although it's more of a misconfiguration):

I believe this is in the Near Future compatability patches, which scale down a bunch of stuff to match NF's power levels (okay, I looked - specifically, it's in the USI_NF_Mode.cfg, which is really poorly named considering it seems to have nothing to do with USI - I always forget about that one when removing these patches.) It seems they're incomplete - for example, it appears that at least some of the antenna power usages for communication (e.g. the Multi-Bandwidth Dish Transceiver) don't scale down their EC usage, although pretty much the only practical way to get 400k EC/s is using KSPI-E generators (and I assume that's what they were balanced for)

Discovering this would come to pass because, you guessed it, I forgot to remove the patch that actually does the stuff I don't like and played for a while like that, wondering why energy generation was wonky.

Share this post


Link to post
Share on other sites
Posted (edited)

Hi, i'm having problem in the loading screen with this mod, any of you guys had that problem?
I already tried to reinstall and install again, delete and install again.

I will upload a image for all of you to see it.

https://ibb.co/q7ndvqH

Edited by denniscm

Share this post


Link to post
Share on other sites
Posted (edited)
6 minutes ago, denniscm said:

Hi, i'm having problem in the loading screen with this mod, any of you guys had that problem?
I already tried to reinstall and install again, delete and install again.

I will upload a image for all of you to see it.

https://ibb.co/q7ndvqH

I'd be interested to see your addon list, especially if you've got anything that modifies aerodynamics.

You may try removing PartDatabase.cfg from your main KSP folder (one above GameData) and see if that helps too. It'll take a while for it to rebuild the cache, but it's relatively harmless. Edit: Also Physics.cfg from the same folder.

Edited by etmoonshade

Share this post


Link to post
Share on other sites
On 11/10/2019 at 9:02 AM, pmborg said:

The error is in "engineer redux" dv calculation because they don't expect deltaV > 24h, which is nothing in terms of interstellar Journeys.

I have good memory... :)

Finally got the problem: I had reported this last year to @cybutek but curiosity made the cat, and I was wondering why this problem was there.

In the end is a very simple thing file KerbalEngineer\VesselSimulator\Simulation.cs

 

                //stage.time = (stageTime < SECONDS_PER_DAY) ? stageTime : 0d;
                stage.time = stageTime;

This was the cause and finally we can see times bigger than 24h :)

hAbIu4b.png

I solved the problem for me but it would be nice to share the fix with the community!

 

Share this post


Link to post
Share on other sites
On 8/2/2020 at 1:17 AM, etmoonshade said:

I'd be interested to see your addon list, especially if you've got anything that modifies aerodynamics.

You may try removing PartDatabase.cfg from your main KSP folder (one above GameData) and see if that helps too. It'll take a while for it to rebuild the cache, but it's relatively harmless. Edit: Also Physics.cfg from the same folder.

Hullo. New here. I have the same issue and will try your solution. Here is my addon list as exported by CKAN. I'm new to this and terrible at everything. I include my modlist below. Using version 1.10.1.

I'm pretty sure I've done things wrong for at least two other reasons:

- Loading takes several minutes despite being on a fancy M2 SSD on a top of the line PC.

- When I gently crash a ship, such as in the Deltawing landing scenario, the remaining parts of the ship will go on spinning and flipping violently along the ground for eternity. I'm not sure which mod has made changes to the aerodynamics causing this, though I didn't seem to experience it in the un-modded game.

Spoiler

Astronomer's Visual Pack (AstronomersVisualPack 2:v4.05)
Astronomer's Visual Pack-4k Textures (AVP-4kTextures v1.11)
B9 Aerospace - HX Parts Pack (B9AerospaceHX 1:v6.6.0)
B9 Aerospace - Legacy Parts Pack (B9AerospaceLegacy 1:v6.6.0)
B9 Aerospace Parts Pack (B9 1:v6.6.0)
B9 Aerospace Procedural Wings - Fork (B9-PWings-Fork 1:v0.93)
B9 Aerospace Props (B9-props 1:v6.6.0)
B9 Animation Modules (B9AnimationModules v1.7.0)
B9 Part Switch (B9PartSwitch v2.17.0)
BetterBurnTime (BetterBurnTime 1.10)
C.E.D.A Aeronautics Division Stockalike Airplane Parts Pack v1.0 (CEDA-AeronauticsDivision 0.1)
Camera Tools (CameraTools v1.14.0)
Celestial Body Science Editor (CelestialBodyScienceEditor 12.0)
Chatterer (Chatterer 0.9.99)
ClickThrough Blocker (ClickThroughBlocker 1:0.1.10.11)
Colorful Fuel Lines (ColorfulFuelLines 0.3.3)
Community Resource Pack (CommunityResourcePack 1.3.0.0)
Community Tech Tree (CommunityTechTree 1:3.4.2)
Community Terrain Texture Pack (CommunityTerrainTexturePack 1:1.0.4)
Cryo Tanks (CryoTanks 1.5.2)
Cryo Tanks Core (CryoTanks-Core 1.5.2)
Cryogenic Engines (CryoEngines 1:1.1.4)
Custom Barn Kit (CustomBarnKit 1.1.20.0)
Deployable Engines Plugin (DeployableEngines 1.2.2)
Distant Object Enhancement Continued (DistantObject v2.0.0.2)
Distant Object Enhancement Continued default config (DistantObject-default v2.0.0.2)
Dynamic Battery Storage (DynamicBatteryStorage 2:2.1.7.0)
Environmental Visual Enhancements (EnvironmentalVisualEnhancements 2:EVE-1.8.0-2)
Filter Extensions - Default Configuration (FilterExtensionsDefaultConfig 3.2.5)
Filter Extensions - Plugin (FilterExtensions 3.2.5)
Firespitter (Firespitter v7.15)
Firespitter Core (FirespitterCore v7.15)
Firespitter Resources config (FirespitterResourcesConfig v7.15)
Heat Control (HeatControl 0.5.2)
Hide Empty Tech Tree Nodes (HideEmptyTechNodes 1.1.2)
IndicatorLights (IndicatorLights 1.7)
IndicatorLights Community Extensions (IndicatorLightsCommunityExtensions 1.6.2)
Interstellar Fuel Switch (InterstellarFuelSwitch 3.16.0.5)
Interstellar Fuel Switch Core (InterstellarFuelSwitch-Core 3.16.0.5)
Kerbal Actuators (KerbalActuators v1.8.3)
Kerbal Atomics (KerbalAtomics 1:1.1.4)
Kerbal Atomics - Other Mod Support (KerbalAtomics-NTRModSupport 1.1.4)
Kerbal Changelog (KerbalChangelog v1.3.0)
Kerbal Engineer Redux (KerbalEngineerRedux 1.1.7.2)
Kerbal Foundries2 (KerbalFoundriesContinued 2.4.8.18)
Kerbal Joint Reinforcement Continued (KerbalJointReinforcementContinued v3.5.1)
Kerbalism (Kerbalism 3.9)
Kerbalism - Default Config (Kerbalism-Config-Default 3.9)
KS3P (KS3P V6.1)
KSP Interstellar Extended (KSPInterstellarExtended 1.25.22.5)
KSP Wheel (KSPWheel 1:0.16.14.33)
Lithobrake Exploration Technologies (LithobrakeExplorationTechnologies 0.4)
Mark IV Spaceplane System (MarkIVSpaceplaneSystem 3.1.2)
Moar Filter Extension Configs (MoarFEConfigs 1.0.5.2)
Modular Rocket Systems (ModularRocketSystem 1.13.2)
ModularFlightIntegrator (ModularFlightIntegrator 1.2.7.0)
Module Manager (ModuleManager 4.1.4)
Near Future Aeronautics (NearFutureAeronautics 2.0.0)
Near Future Construction (NearFutureConstruction 1.2.3)
Near Future Electrical (NearFutureElectrical 1.1.3)
Near Future Electrical Core (NearFutureElectrical-Core 1.1.3)
Near Future Exploration (NearFutureExploration 1.0.10)
Near Future IVA Props (NearFutureProps 1:0.6.3)
Near Future Launch Vehicles (NearFutureLaunchVehicles 2.0.3)
Near Future Propulsion (NearFuturePropulsion 1.2.2)
Near Future Solar (NearFutureSolar 1.2.3)
Near Future Solar Core (NearFutureSolar-Core 1.2.3)
Near Future Spacecraft (NearFutureSpacecraft 1.3.3)
Patch Manager (PatchManager 0.0.17.2)
Photon Sailor (PhotonSailor 1.6.2.2)
PlanetShine (PlanetShine 0.2.6.3)
PlanetShine - Default configuration (PlanetShine-Config-Default 0.2.6.3)
Probes Before Crew [PBC] (ProbesBeforeCrew 2.80)
Procedural Parts (ProceduralParts v2.0.6)
RasterPropMonitor Core (RasterPropMonitor-Core 1:v0.31.4)
ReStock (ReStock 1.1.2)
ReStock+ (ReStockPlus 1.1.2)
scatterer (Scatterer 3:v0.0621b)
Scatterer Default Config (Scatterer-config 3:v0.0621b)
Scatterer Sunflare (Scatterer-sunflare 3:v0.0621b)
SmokeScreen - Extended FX Plugin (SmokeScreen 2.8.14.0)
SpaceY Expanded (SpaceY-Expanded 1.4)
SpaceY Heavy Lifters (SpaceY-Lifters 1.17.2)
Stockalike Station Parts Expansion Redux (StationPartsExpansionRedux 1.3.6)
TextureReplacer (TextureReplacer v4.2.1)
Textures Unlimited (TexturesUnlimited 1.5.10.25)
Toolbar (Toolbar 1:1.8.0.5)
Toolbar Controller (ToolbarController 1:0.1.9.4)
TweakScale - Rescale Everything! (TweakScale v2.4.3.21)
WorldStabilizer (WorldStabilizer 0.9.7-ksp-1.8.1)
Zero MiniAVC (ZeroMiniAVC 1:1.1.0.1)


Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Scribblette said:

Hullo. New here. I have the same issue and will try your solution. Here is my addon list as exported by CKAN. I'm new to this and terrible at everything. I include my modlist below. Using version 1.10.1.

I'm pretty sure I've done things wrong for at least two other reasons:

- Loading takes several minutes despite being on a fancy M2 SSD on a top of the line PC.

- When I gently crash a ship, such as in the Deltawing landing scenario, the remaining parts of the ship will go on spinning and flipping violently along the ground for eternity. I'm not sure which mod has made changes to the aerodynamics causing this, though I didn't seem to experience it in the un-modded game.

I won't claim top-of-the-line, but my system was a solid gaming system when I got it - i7-4770K, 32GB RAM, running KSP off an SSD. It takes me about 10 minutes 30 seconds on average to load up my 154 mods (lots of crossover with your list, too) so "several" minutes seems pretty reasonable. Fun fact - if you get "QuickStart," it actually puts a load time counter on your screen before it whisks you off to the KSC.

As for the spinning and flipping on a crash... heh. That's KSP for you, IMHO. Although I wonder if it's a side effect of KJR - I haven't played without KJR in forever, so it's possible.

Huh. No aero mods that I can see in your list, so maybe my guess was off (note that KJR affects physics, but not aero.) One thing to note @denniscm, I'm pretty sure the "warning" on your load screen is from ModuleManager, not KSP itself - under KSP\Logs\ModuleManager, you can browse through it to see what's causing that one.

I'll take a look at the debug console next time I restart KSP (in the middle of a Mun science mission right now) and see if I spot the same error y'all are. It's entirely possible that it's just a problem with that command center module (it sounds like the 6-crew cupola thing, which is at least new since I last played KSP) and it's not actually having any ill effects. Or maybe it is having ill effects if you actually try to use it - I've never had a reason to. :P

Edit: @FreeThinker - I'm not sure if this is actually the cause of the problem, but in WarpPlugin\Parts\Command\CommandCenterDome\part.cfg, this ain't right whether it's causing a problem or not:

	maximum_drag = 0.2
	minimum_drag = 0.3

If @denniscm or @Scribblette want to modify those lines in that file (if they're comfortable) to reverse those numbers, that might be the source of the issue.

Again, it takes me 10 minutes to fire up KSP - I'll do it after my Mun mission if nobody else wants to. :D

Second edit:

I just dug through my KSP.log while my ship does its SCANSatting on the Mun, and (for me, at least) that exception actually isn't associated with the CommandCenterDome - it's on the IXS Command Module:

[LOG 06:58:44.162] DragCubeSystem: Creating drag cubes for part 'kspiIXSCommandModule'

[EXC 06:58:44.166] IndexOutOfRangeException: Index was outside the bounds of the array.
	FNPlugin.FNHabitat.AssumeDragCubePosition (System.String name) (at <4e0ff788d78f47c787e8280dced5cbfc>:0)
	DragCubeSystem+<RenderDragCubes>d__34.MoveNext () (at <c1858a3f77504bd1aaa946fdccf84670>:0)
	UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) (at <5aeafee3fea24f37abd1315553f2cfa6>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	UnityEngine.MonoBehaviour:StartCoroutine(IEnumerator)
	<RenderDragCubesCoroutine>d__31:MoveNext()
	UnityEngine.MonoBehaviour:StartCoroutine(IEnumerator)
	<SetupDragCubeCoroutine>d__46:MoveNext()
	UnityEngine.MonoBehaviour:StartCoroutine(IEnumerator)
	<CompileParts>d__56:MoveNext()
	UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)

So I guess y'all can check the KSP.log in the KSP directory and see if you see a similar exception. One thing I can say is that this does NOT seem to affect the part - I have used the IXS Command Module before, and it flies fine.

I'll post a fresh log, again, once I have a "natural" reason to restart KSP. :P

Edited by etmoonshade

Share this post


Link to post
Share on other sites
36 minutes ago, denniscm said:

@etmoonshade @Scribblette
I solved the problem removing the Kerbalism Mod.

So wait, was it actually hanging on load? I thought you were just complaining about the error. :V

Share this post


Link to post
Share on other sites
37 minutes ago, etmoonshade said:

So wait, was it actually hanging on load? I thought you were just complaining about the error. :V

Yes, i was stuck on loading because of this. Hahaha
I don't know if this mod has some relation with Kerbalism to cause this problem, but, i will wait an update at Kerbalism to see if will fix it.

Share this post


Link to post
Share on other sites

Yup, it was hanging at load here with the same messages. Removing KSPI extended fixed the hanging. I've now removed Kerbalism and Reinforced Joints and re added kspi - no more loading issues and it looks like the insane flipping out is over too. Thank you! 

Share this post


Link to post
Share on other sites

Actually, deleting the problematic part (in this situation is CommandCenterDome) on KSPI-e folder is the temporary solution to using both KSPI-e and Kerbalism together until either mod fix this issue.

Share this post


Link to post
Share on other sites

I would like to know how to turn off a Warp plugin for some of parts? I don't like this so I want to turn it off on (FNSmallAugmentedArcjet) - name from cfg. I turned it off at Ion engine just by deleting it from folder, but i want to do the same with this plasma engine.

Share this post


Link to post
Share on other sites
Just now, CrazyGreenPilot_RUS said:

I would like to know how to turn off a Warp plugin for some of parts? I don't like this so I want to turn it off on (FNSmallAugmentedArcjet) - name from cfg. I turned it off at Ion engine just by deleting it from folder, but i want to do the same with this plasma engine.

What problem, exactly, are you trying to solve here?

I know there's a ton of patches that KSPI-E bundles that can have weird effects on gameplay, but it sounds like you're talking about MegaJoule power for the ArcJet RCS? Maybe?

Share this post


Link to post
Share on other sites
15 hours ago, etmoonshade said:

What problem, exactly, are you trying to solve here?

I know there's a ton of patches that KSPI-E bundles that can have weird effects on gameplay, but it sounds like you're talking about MegaJoule power for the ArcJet RCS? Maybe?

I mean decreasing thrust but adding an option to use an engine during warp

 

Share this post


Link to post
Share on other sites
38 minutes ago, CrazyGreenPilot_RUS said:

I mean decreasing thrust but adding an option to use an engine during warp

 

Hmm. I think it's actually PersistentThrust that does that, not anything specific in the WarpPlugin configs? You might want to look in that mod folder and see if there's patches that mess with things - I don't use it, myself.

Edit: Okay, PersistentThrust isn't even recommended by KSPI-E anymore in CKAN? So I'm not sure where you're getting this.

Which ion engine did you mess with, and what exactly did you remove? I looked at the Augmented Arcjet, and I don't see anything in there that explicitly refers to thrusting through warp - it may be something baked into ElectricEngineControllerFX, and I don't think it'll work right if you remove that from the part itself.

Also, weird - I'd swear there was a patch that added ElectricEngineControllerFX to the stock ion engine, but I can't find it anymore. If I could see what the original (whatever you "deleted it from the folder" was) did, I might be able to point you in a better direction.

Edited by etmoonshade

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.