FreeThinker

[1.7.3/1.6.1/1.5.1/1.4.5/1.3.1] KSP Interstellar Extended 1.23.1 Support Thread

Recommended Posts

is there a way to raise the maximum warp limit from 100c to however high your max power production will let you go?

Share this post


Link to post
Share on other sites

I've been having problems with my beamed power network, similar to the users above.  I did get it up and running before on Infrared, with 2 different generator power stations and 3 infrared mirror relays.  I launched several sats from the ground using it and ATILLA.  But now new things I build won't connect, and my unchanged ship and unchanged network doesn't even work!  What is going on?

Share this post


Link to post
Share on other sites
On 28/1/2017 at 9:50 AM, proteasome said:

I think I'm having the same problem, as I document below with screenshots. I have two craft, a power station with a gyrotron generating Ka-band microwave connected to a multi bandwith dish tranceiver that appears to be beaming 9 GW, rendezvoused at < 1 km in LKO. The reciever is a Mk1 inline thermal connected to a generator and oriented at 90 deg to the transmitter, but still shows no power. 

Wp4fSDK.jpg

 

2w0h1tO.jpg

 

seems that just the part ( whose "Power mode"  can change between "solar only" and "beamed power" ) can receive microwave power

circular rectenna receiver    work
circular thermophotovoltaic receiver    work
Double Pivoted Rectenna (Receiver)    work
Giant Wrapped Photovoltaic Receiver     work
Solar Thermal Power Mirror Receiver    work
stock: gigantor xl solar array    work

Deployable Microwave Phased Array Transiever Relay    notwork
Microwave Phased Array Relay Transceiver    notwork
Duel Mode Thermal/Rectenna Receiver (Inline)    notwork
Duel Mode Thermal Sphere Receiver    notwork
Duel Mode Thermal/Rectenna Receiver (Nose)    notwork
Multi Bandwidth Dish Transceiver (Medium)    notwork
Multi Bandwidth Dish Transceiver (Large)    notwork
Multi Bandwidth Dish Transceiver (Shielded)    notwork

mk1  and  mk2  notwork

 

 

KSP 1.2.2

Interstellar Extended 1.12.1

Edited by wsx1887

Share this post


Link to post
Share on other sites
1 hour ago, Liquid5n0w said:

I've been having problems with my beamed power network, similar to the users above.  I did get it up and running before on Infrared, with 2 different generator power stations and 3 infrared mirror relays.  I launched several sats from the ground using it and ATILLA.  But now new things I build won't connect, and my unchanged ship and unchanged network doesn't even work!  What is going on?

Could you describe a set of steps that let me reproduce the problem so that I can fix it? preferably also include some craft files

Share this post


Link to post
Share on other sites

Have the same problem with beam power. Receiver always says that 0/1 satellites connected (tried various combinations of receiver and transmitter). Issue reproduced on clean installation of KSP with only KSPIE from curse.com/ckan installed. I tried older versions of KSPIE and with 1.10 my ship with mk1 thermal receiver and thermal rocket jet launched eventually get launched, but this morning it says satellites connected 1/1 and have max thermal energy but producing no trust.

My test build using KSP 1.2.2 and KSPIE 1.12.1 clean install
transmitter:
8898655.png

receiver:
8875103.png

Share this post


Link to post
Share on other sites

@ms6107  Exactly in what order do you test. Also it to campaign or sandbox?

Edit, ok I can reproduce it now.

Edit2 I identified the problem and have fixed it

You can fix the problem for new vessels by adding the following property to MicrowavePowerReceiver

solarPowerMode = false

existing vessels can be fixed by changing the same property in a save file, or wait until the next patch is release, which will be soon

Edited by FreeThinker

Share this post


Link to post
Share on other sites
45 minutes ago, FreeThinker said:

@ms6107  Exactly in what order do you test. Also it to campaign or sandbox?

Edit, ok I can reproduce it now.

This tests was in sandbox. But i have no luck with my campaing to, but it uses other plugins.

Ok, I downloaded newer version of VS and your project from github. And added some debug information to MicrovawePoweReceiver.OnFixedUpdate()

The most usefult was, line 1215:

Debug.Log("[KSPI] - solarPowerMode: " + solarPowerMode + " Counter: " + counter);
if (solarPowerMode == false && (++counter + instanceId) % 11 == 0)       // recalculate input once per 10 physics cycles. Relay route algorythm is too expensive

and it says that Inline thermal receiver mk1 is in solar power mode.

Will check other receivers.

Edit, tested Duel mode thermal sphere receiver, Duel mode thermal/rectena receiver and stock solar panels. First two in solar only mode and I can change this property for stock panels in flight.

Edited by ms6107

Share this post


Link to post
Share on other sites

@FreeThinker In your commit https://github.com/sswelm/KSP-Interstellar-Extended/commit/75466992bb0d64775d995bbca7e35e3f93cb2da2#diff-c2a809c45779cd306941ed874bcef382 you changed default value for solarPowerMode, is it was intentional? I can't find other changes to concrete parts to set it to false. Btw I changed it back to false and now my thermal receiver can connect with transmitter, but now my thermal ramjet nozzle show no trust on hydrogen (due to atmothperic pressure I think) or blow up in a second on methane.

Edited, after enabling technology updates in sandbox and making bigger transmitter all became fine.
PS, My answers are premoderated so it takes longer to see it...

Edited by ms6107

Share this post


Link to post
Share on other sites
1 hour ago, ms6107 said:

@FreeThinker In your commit https://github.com/sswelm/KSP-Interstellar-Extended/commit/75466992bb0d64775d995bbca7e35e3f93cb2da2#diff-c2a809c45779cd306941ed874bcef382 you changed default value for solarPowerMode, is it was intentional? I can't find other changes to concrete parts to set it to false. Btw I changed it back to false and now my thermal receiver can connect with transmitter, but now my thermal ramjet nozzle show no trust on hydrogen (due to atmothperic pressure I think) or blow up in a second on methane.

Yes, this is what introduced the mistake. The reason was to make solar panels that can also function as receivers, start in solar mode by default. The problem however is that it affected all receiver, including thermal receivers that have no solar power ability

Edited by FreeThinker

Share this post


Link to post
Share on other sites
1 hour ago, FreeThinker said:

@ms6107  Exactly in what order do you test. Also it to campaign or sandbox?

Edit, ok I can reproduce it now.

Edit2 I identified the problem and have fixed it

You can fix the problem for new vessels by adding the following property to MicrowavePowerReceiver


solarPowerMode = false

existing vessels can be fixed b changing the same property in a save file, or wait until the next patch is release, which will be soon

Fixed in code :-). Btw thanks for realy great mod, will wait next releases.

Edited by ms6107

Share this post


Link to post
Share on other sites
3 hours ago, ms6107 said:

Fixed in code :-). Btw thanks for realy great mod, will wait next releases.

I'm having trouble as to where to fix this in code temporarily while waiting for the update, I suspect it needs to be added in each part under microwave but I didn't have much luck with that?

Share this post


Link to post
Share on other sites

Solar panels, at least the Gigantor displays "Activate Receiver" instead of "Extend Panels", and the right-click menu on the solar panels is full of beamed power stuff. Is this supposed to be the case?

Share this post


Link to post
Share on other sites

@Liquid5n0w You had to change it in GameData/WarpPlugin/Parts/Microwave/MicrowaveThermalPowerReceiver/MTER-M.cfg for example for thermal receiver mk1, just add line 

solarPowerMode = false
just after
module = Part
author = Conti

But it will help for new vessels only. But as @FreeThinker said, new release will be soon. And it easier to wait it.

 

Share this post


Link to post
Share on other sites
59 minutes ago, ms6107 said:

@Liquid5n0w You had to change it in GameData/WarpPlugin/Parts/Microwave/MicrowaveThermalPowerReceiver/MTER-M.cfg for example for thermal receiver mk1, just add line 


solarPowerMode = false

just after
module = Part
author = Conti

But it will help for new vessels only. But as @FreeThinker said, new release will be soon. And it easier to wait it.

 

oh, it's not inside the Module but in the base information for the part? I understand.

Share this post


Link to post
Share on other sites
7 minutes ago, Liquid5n0w said:

oh, it's not inside the Module but in the base information for the part? I understand.

Hm, i was wrong, this is part of module config. There is example /GameData/WarpPlugin/Parts/Microwave/CircularSolarPhotovoltaicReceiver/CircularPanel.cfg see module MicrowavePowerReceiverDish its almost the same as MicrowavePowerReceiver. So you have to change one of them in your part.cfg.

Share this post


Link to post
Share on other sites

Version 1.12.2 for Kerbal Space Program 1.2.2

Released on 2017-01-29

  • Added new part: Inline Thermal Receiver Relay Dish which can be deployed to receive or relay beamed power or act as a long range data relay
  • Added Ability of Umbrella Radiator to act as thermal receiver
  • Balance Microwave Transceiver is now capable of transmitting in multiple microwave wavelengths
  • Balance: Unlocking technology all Thermal engine parts to experimental rocketry
  • Balance: advanced thermal propellant modes are now unlocked with advanced storage technologies
  • Fixed Beamed power receivers for non solar power capable parts, preventing them for from receiving any beamed power

 

 

Edited by FreeThinker

Share this post


Link to post
Share on other sites
23 hours ago, Jumberlack said:

is there a way to raise the maximum warp limit from 100c to however high your max power production will let you go?

The maximum theoretical speed in KSPI-E is 1000c, good luck getting that high

Btw, Has anyone played around yet with the new atmosphere extractor yet, or any of the new functionally added recently?

Edited by FreeThinker

Share this post


Link to post
Share on other sites
On 1/26/2017 at 11:49 AM, ThirdOfSeven said:
13 hours ago, FreeThinker said:

 

  • Fixed Beamed power receivers for non solar power capable parts, preventing them for from receiving any beamed power

 

 

WOW! That was fast. FT your work on this mod is amazing. Getting rep from CKAN now and can't wait to try it out with existing and new craft.

Share this post


Link to post
Share on other sites
19 hours ago, FreeThinker said:
  • Balance: Unlocking technology all Thermal engine parts to experimental rocketry
  • Balance: advanced thermal propellant modes are now unlocked with advanced storage technologies

I'm having trouble finding the advanced propellants, what is the full name of the node in CTT?

Share this post


Link to post
Share on other sites
2 hours ago, Liquid5n0w said:

I'm having trouble finding the advanced propellants, what is the full name of the node in CTT?

It should be called  "Specialized Fuel Storage"

Share this post


Link to post
Share on other sites
On 29-1-2017 at 1:35 AM, Dawnstar said:

And, no doubt, any of these will work. But they yield very different games, due to the number of biomes to do science on, and the scale of the universe. They range from x1 to x10 stock, and that's a HUGE variance!

Plus, they differ in quality of planet textures and atmospherics.

What I need is advice. From players (including yourself if you like, most excellent FreeThinker). What sort of universe yields a fun KSPI-E game, and why? Any warning about memory usage that you'd like to share?

Also, while I'm here: Would anyone think it impracticable to simply not use the Science Lab at all for processing science? I'm looking to get a proper KSPI-E boot-strap game going, not "get all the tech before I leave Kerbin orbit", or "endless slog to get even half the tech tree", but rather something challenging yet not too rough.

As the designer of KSPI-E I would advice you to choose galactic neighborhood, with some interesting planet packs installed.  In my view the limited distance between star systems is an advantage, it will make interstellar travel between stars more manageable and more interesting. It will be more interesting because of the short distance, I simulate the speed of distance to be only 1/10 for what it realy is. This allows you to approach high enough speed that special relativity becomes noticeable. Compared to a real star distance that is realy short as they can easily take 50 or more years and you never get fast enough to notice much of special relativity because getting up to 10% of light speed is hard enough...

Edited by FreeThinker

Share this post


Link to post
Share on other sites
On 1/29/2017 at 2:01 PM, FreeThinker said:

Version 1.12.2 for Kerbal Space Program 1.2.2

Released on 2017-01-29

  • Added new part: Inline Thermal Receiver Relay Dish which can be deployed to receive or relay beamed power or act as a long range data relay
  • Added Ability of Umbrella Radiator to act as thermal receiver
  • Balance Microwave Transceiver is now capable of transmitting in multiple microwave wavelengths
  • Balance: Unlocking technology all Thermal engine parts to experimental rocketry
  • Balance: advanced thermal propellant modes are now unlocked with advanced storage technologies
  • Fixed Beamed power receivers for non solar power capable parts, preventing them for from receiving any beamed power

 

 

I think you goofed.

The Science Laboratory now shows a data cap of 10000 but the science cap is still at 1000, 3000 for the upgrade version.

This does nothing about the issue mentioned upthread about having to transmit frequently, by my understanding of how the labs work this is a major boost to what they can produce.  I think you changed the wrong variable!

Share this post


Link to post
Share on other sites

After updating to the most recent KSPI, I have lost my thermal engines. Wait! It's not what you may think... My most recent tech unlock was in fact 'experimental rocketry' and both KSPI thermal devices are present in the tech tree in their new location, but absent from the SPH/VAB. This was in my current career mode and when I tried in sandbox, the thermal turbojet and nozzle were both available in the construction buildings. Any ideas?

Thanks!

Share this post


Link to post
Share on other sites
4 hours ago, Swedishish said:

After updating to the most recent KSPI, I have lost my thermal engines. Wait! It's not what you may think... My most recent tech unlock was in fact 'experimental rocketry' and both KSPI thermal devices are present in the tech tree in their new location, but absent from the SPH/VAB. This was in my current career mode and when I tried in sandbox, the thermal turbojet and nozzle were both available in the construction buildings. Any ideas?

Thanks!

I think you have to re puchase it in the tech tree

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.