FreeThinker

[1.7.3/1.6.1/1.5.1/1.4.5/1.3.1] KSP Interstellar Extended 1.23.4 Support Thread

Recommended Posts

Posted (edited)
23 hours ago, FreeThinker said:

I have too little information but have you tried adding preecolers? They reduce heat production in your engines and will  reduce  wasteheat accumulation while in the atmosphere.

@FreeThinkerThe plane does indeed have pre-coolers. The problem isn't in the atmosphere, it's in vacuum. The Lightbulbs cause the B9 Sabre engines and adjacent OPT part to overheat despite ample radiators. What additional info would be helpful?

 

https://imgur.com/PMuxH7D

 

I've taken to turning off max temp when playing with this craft file.

Edited by davidle

Share this post


Link to post
Share on other sites
12 hours ago, flyguybc said:

I'm pretty sure ckan is up to date, even though whatever file it looks for the version may not be.  I know this because when he releases one I get a pop up about a day later in cKan.  Also bug troubleshooting we have done has been fixed in cKan updates indicating that it is indeed patching and up to date.  

I will say mine says the wrong version too, but the files are the up to date ones.

There is at least one missing file in the 1.6.1 version.

 

@Freethinker Many of the real fuels configs in KSPI  don't make much sense. Stock or procedural tanks configured for LqdHelium and many other KSPIE fuels have dry and wet masses which are more than 100x what they should be, while hydrogen tanks have very poor mass ratio (less than 3 if I recall correctly). This actually isn't limited to KSPIE; I've found some similar issues to a lesser extent with just RealFuels or RO. In any case,  they need to be redone if one wants to do anything with KSPI fuels in stock parts, so I was thinking about redoing the configs. But then I wonder, what are reasonable values? What is the balance you would want; should they reflect stock mass ratios or real fuels? Do you have any guidelines or references you would use to determine them?

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, kerbnub said:

There is at least one missing file in the 1.6.1 version.

 

@Freethinker Many of the real fuels configs in KSPI  don't make much sense. Stock or procedural tanks configured for LqdHelium and many other KSPIE fuels have dry and wet masses which are more than 100x what they should be, while hydrogen tanks have very poor mass ratio (less than 3 if I recall correctly). This actually isn't limited to KSPIE; I've found some similar issues to a lesser extent with just RealFuels or RO. In any case,  they need to be redone if one wants to do anything with KSPI fuels in stock parts, so I was thinking about redoing the configs. But then I wonder, what are reasonable values? What is the balance you would want; should they reflect stock mass ratios or real fuels? Do you have any guidelines or references you would use to determine them?

I haven't actually created that config but I agree they look very unrealistic. If you want to improve it, you are more than welcome. My advice would be to calculate tank mass utilization based on density and a fixed minimum amount, quite similar how I calculate Cryo Tanks tankmasses. For example for LqdHelium I calculated 0.00007085000 + 0.0001786 * 0.5 =  0.0001786 ton/L where is the density of LqdHelium and 0.00007085000 is the fixed amount per liter. By the way, please keep any development discussion in the KSPIE development thread

Edited by FreeThinker

Share this post


Link to post
Share on other sites

I am trying to build a big vtol capable ssto. It is going along nicely but thermal turbojets I am using for vtol purpose are very bumpy to use with TCA (throttle control avionics). The vessel make a very unstable launch when it tries to hover, I have to wait a long time for it to stabilized by TCA and sometimes it turn upside down altogether. Does anyone have a reasonable solution for this issue? 

I would go to TCA thread for this but engines have very unique characteristics in KSPIE. I am hoping that some of you resolved this kind of issues.

Share this post


Link to post
Share on other sites
Posted (edited)
33 minutes ago, yafeshan said:

I am trying to build a big vtol capable ssto. It is going along nicely but thermal turbojets I am using for vtol purpose are very bumpy to use with TCA (throttle control avionics). The vessel make a very unstable launch when it tries to hover, I have to wait a long time for it to stabilized by TCA and sometimes it turn upside down altogether. Does anyone have a reasonable solution for this issue? 

I would go to TCA thread for this but engines have very unique characteristics in KSPIE. I am hoping that some of you resolved this kind of issues.

Well depending on the used reactor, there a degree of latency to throttle responsiveness. Thermal antimatter reactors would suffer the least as the can eject the antimatter directly into fuel stream. Second would be inertial fusion reactor which can produce  near instant power, but the energy still needs to be convected to the propellant which takes a little time. Nuclear engines are inherently the slowest as it takes time before a reactor becomes supercritical. A way to compensate this is to force the reactor to full power before you throttle it. This can be accomplished by setting the minimum utilisation to the setting you power lever you think you will need. A disadvantage of that setting is that it produces a tremoundus amount of wasteheat. Fortunately, you can elevate this by using convector radiators while in an atmosphere. Perhaps even at full power, reaction speed this is still too slow and I need to make it respond faster configured for higher minimum utilisation.

Edited by FreeThinker

Share this post


Link to post
Share on other sites
Posted (edited)
On 5/27/2019 at 7:29 PM, kerbnub said:

Lol, I meant 1.20.20.3 :D

But now I'm confused...... I've been installing KSPI through CKAN, where I assumed it gave me the latest for my KSP version (1.6.1). But my CKAN compatible versions look a lot older.  Is CKAN several patches behind?0J9KQ91.png

 

I don't see any version file in the KSPI folders, so I'm half wondering if it's just a labelling issue. I'll try replacing what I have with a manual KSPI install from the OP here and see how it works.

Edit: it's clearly a newer version (has a kerbalism patch, wooo!), but I still have the same issues with it installed.

According to a discussion at CKAN Gibhub, the problem should have been resolved. Could you verify?

Edited by FreeThinker

Share this post


Link to post
Share on other sites
Posted (edited)

 @FreeThinker Found a strange bug.

When quicksaving and reloading my engines stopped working giving a NaN temperature.

This problem only occurs when combining several nuclear engines. I've only been able to recreate this problem using 2 liquid core engines combined with 2 Candle engines.

EDIT: Same problem occurs with 1 Liquid core engine combined with 1 Candle engine

Strangely when I shutdown the reactors everything works again at a fixed ISP (should be changing depending on thrust for the liquid core engines)

The before save/load and after screenshots:

yOY99CZ.jpg

gZMnksJ.jpg

following errors keep repeating:

Spoiler

[LOG 18:16:26.224] dT is NaN! tA: NaN, E: NaN, M: NaN, T: NaN
   at System.Environment.get_StackTrace()
   at Orbit.GetDTforTrueAnomaly(Double tA, Double wrapAfterSeconds)
   at PatchedConics._CalculatePatch(.Orbit p, .Orbit nextPatch, Double startEpoch, .SolverParameters pars, .CelestialBody targetBody)
   at PatchedConicSolver.Update()
[LOG 18:16:26.224] dT is NaN! tA: NaN, E: NaN, M: NaN, T: NaN
   at System.Environment.get_StackTrace()
   at Orbit.GetDTforTrueAnomaly(Double tA, Double wrapAfterSeconds)
   at PatchedConics._CalculatePatch(.Orbit p, .Orbit nextPatch, Double startEpoch, .SolverParameters pars, .CelestialBody targetBody)
   at PatchedConicSolver.Update()
[LOG 18:16:26.234] [KSPI]: supplyManagedFNResourcePerSecond  was called with illegal values.
[LOG 18:16:26.234] [KSPI]: supplyManagedFNResourcePerSecond  was called with illegal values.
[LOG 18:16:26.234] [KSPI]: supplyManagedFNResourcePerSecond  was called with illegal values.
[LOG 18:16:26.234] [KSPI]: supplyManagedFNResourcePerSecond  was called with illegal values.
[LOG 18:16:26.234] [KSPI]: supplyManagedFNResourcePerSecond  was called with illegal values.
[LOG 18:16:26.234] [KSPI]: supplyManagedFNResourcePerSecond  was called with illegal values.
[LOG 18:16:26.234] [KSPI]: supplyManagedFNResourcePerSecond  was called with illegal values.
[LOG 18:16:26.234] [KSPI]: supplyManagedFNResourcePerSecond  was called with illegal values.
[LOG 18:16:26.234] [KSPI]: managedProvidedPowerSupplyPerSecondMinimumRatio illegal values.
[LOG 18:16:26.234] [KSPI]: managedProvidedPowerSupplyPerSecondMinimumRatio illegal values.
[LOG 18:16:26.235] [KSPI]: managedProvidedPowerSupplyPerSecondMinimumRatio illegal values.
[LOG 18:16:26.235] [KSPI]: managedProvidedPowerSupplyPerSecondMinimumRatio illegal values.
[LOG 18:16:26.235] [KSPI]: managedProvidedPowerSupplyPerSecondMinimumRatio illegal values.
[LOG 18:16:26.235] [KSPI]: managedProvidedPowerSupplyPerSecondMinimumRatio illegal values.
[LOG 18:16:26.235] [KSPI]: managedProvidedPowerSupplyPerSecondMinimumRatio illegal values.
[LOG 18:16:26.235] [KSPI]: managedProvidedPowerSupplyPerSecondMinimumRatio illegal values.

 

 

Edited by Dollehz

Share this post


Link to post
Share on other sites
On 5/20/2019 at 10:09 PM, kerbnub said:

Anyone else seeing missing textures on the TORY Ramjet, Inflatable Airbag, and Thermal Receivers? All other parts seem fine. I'm running ksp 1.6.1. 

https://imgur.com/a/xzNGX5G

 

Turns out the missing textures were caused by the beautiful Restock mod, which blacklists stock parts that it replaces, stopping them from loading to reduce memory use. I did a search of KSPIE to find all the places stock textures/models were used, and got this list:

Spoiler

GID4JCw.png

Restock allows you to make a whitelist file which will load specific stock files for your mod, so I made one for the files above, which seems to fix it.  It includes some parts for which I can't see any difference, but I put them all in just to be safe. Put the below in a .restockwhitelist file (like KSPIE.restockwhitelist) and stick it in your GameData folder, and you won't have missing textures.

Squad/Parts/FuelTank/mk2FuselageLong/FuselageLongLFO
Squad/Parts/FuelTank/mk2FuselageLong/mk2Fuselage
Squad/Parts/Engine/liquidEngineSkipper/ksp_l_midrangeEngine_fairing_diff
Squad/Parts/Engine/liquidEngineSkipper/ksp_l_midrangeEngine_fairing_norm
Squad/Parts/FuelTank/mk3Fuselage/Mk3Fuselage
Squad/Parts/Engine/Size3AdvancedEngine/Size3AdvancedEngineDiffuse
Squad/Parts/Engine/Size3AdvancedEngine/Size3AdvancedEngineNormal
Squad/Parts/Engine/Size3AdvancedEngine/Size3AdvancedEngineEmissive
Squad/Parts/Engine/liquidEngineLV-N/model000
Squad/Parts/Engine/liquidEngineSSME/SSME
Squad/Parts/Engine/liquidEngineAerospike/AeroSpike
Squad/Parts/FuelTank/RCStankRadialLong/ksp_r_rcsCylTank_diff
Squad/Parts/Utility/parachuteMk2-R/model000
Squad/Parts/Resources/RadialDrill/DustParticle
Squad/Parts/Resources/RadialDrill/TriBitDrill

@FreeThinker you might want to add one in the patches folder for those who use Restock.

There is another possible way to resolve this, which is changing the textures in the list above to use restock textures. It would probably save a little memory and look better, but I didn't have the patience to figure out how to make such a patch for now.

Share this post


Link to post
Share on other sites
10 minutes ago, kerbnub said:

Turns out the missing textures were caused by the beautiful Restock mod, which blacklists stock parts that it replaces, stopping them from loading to reduce memory use. I did a search of KSPIE to find all the places stock textures/models were used, and got this list:

  Hide contents

GID4JCw.png

Restock allows you to make a whitelist file which will load specific stock files for your mod, so I made one for the files above, which seems to fix it.  It includes some parts for which I can't see any difference, but I put them all in just to be safe. Put the below in a .restockwhitelist file (like KSPIE.restockwhitelist) and stick it in your GameData folder, and you won't have missing textures.


Squad/Parts/FuelTank/mk2FuselageLong/FuselageLongLFO
Squad/Parts/FuelTank/mk2FuselageLong/mk2Fuselage
Squad/Parts/Engine/liquidEngineSkipper/ksp_l_midrangeEngine_fairing_diff
Squad/Parts/Engine/liquidEngineSkipper/ksp_l_midrangeEngine_fairing_norm
Squad/Parts/FuelTank/mk3Fuselage/Mk3Fuselage
Squad/Parts/Engine/Size3AdvancedEngine/Size3AdvancedEngineDiffuse
Squad/Parts/Engine/Size3AdvancedEngine/Size3AdvancedEngineNormal
Squad/Parts/Engine/Size3AdvancedEngine/Size3AdvancedEngineEmissive
Squad/Parts/Engine/liquidEngineLV-N/model000
Squad/Parts/Engine/liquidEngineSSME/SSME
Squad/Parts/Engine/liquidEngineAerospike/AeroSpike
Squad/Parts/FuelTank/RCStankRadialLong/ksp_r_rcsCylTank_diff
Squad/Parts/Utility/parachuteMk2-R/model000
Squad/Parts/Resources/RadialDrill/DustParticle
Squad/Parts/Resources/RadialDrill/TriBitDrill

@FreeThinker you might want to add one in the patches folder for those who use Restock.

 

Thanks, I added it to the Patch folder as you suggested

Share this post


Link to post
Share on other sites
On 5/26/2019 at 1:42 AM, FreeThinker said:

Alright, I have realized you wish, it will now automatically rendezvous or circularize based on you target. You can no simply target Moho, Charge and Active, jack up warp speed to maximum and see in real time how the warp drive will decrease speed at you approach Moho and exit warp just before it is about crash into moho, if exit warp and ends up in a near perfect circular orbit. Alternative select any target vessel or asteroid, warp to it at maximum warp and redevous a few kilomets from it in a similar orbit as the target.

Thank you <3

Share this post


Link to post
Share on other sites

Is it normal for the dry mass of fuel tanks to vary wildly based on what you put in them -- for example, the dry mass of a tank dropping considerably if you put liquid hydrogen in it (and maintaining the mass ratio)?

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, kraza said:

Is it normal for the dry mass of fuel tanks to vary wildly based on what you put in them -- for example, the dry mass of a tank dropping considerably if you put liquid hydrogen in it (and maintaining the mass ratio)?

If you are asking about IFS fuel tanks, then yes it should be, but only while switching in the VAB. Even better, some get better mass ratio as you scale them up.

Edited by FreeThinker

Share this post


Link to post
Share on other sites

By "IFS fuel tanks" do you mean tanks *affected* by IFS, or tanks *added* by IFS? Because for me it's affecting stock and stock-alike mod tanks. 

Share this post


Link to post
Share on other sites
7 hours ago, kraza said:

By "IFS fuel tanks" do you mean tanks *affected* by IFS, or tanks *added* by IFS? Because for me it's affecting stock and stock-alike mod tanks. 

It does both

Share this post


Link to post
Share on other sites
On 5/25/2019 at 4:42 PM, FreeThinker said:

Alright, I have realized you wish, it will now automatically rendezvous or circularize based on you target. You can no simply target Moho, Charge and Active, jack up warp speed to maximum and see in real time how the warp drive will decrease speed at you approach Moho and exit warp just before it is about crash into moho, if exit warp and ends up in a near perfect circular orbit. Alternative select any target vessel or asteroid, warp to it at maximum warp and redevous a few kilomets from it in a similar orbit as the target.

Somehow I missed this, awesome update! I'm enjoying warping around the system now, and can turn while warping with no random explosions. :D

By the way, were warp power requirements reduced? I feel like it's easier now with my test warp ssta but I didn't record anything to be sure now.

Share this post


Link to post
Share on other sites
20 minutes ago, kerbnub said:

By the way, were warp power requirements reduced? I feel like it's easier now with my test warp ssta but I didn't record anything to be sure now.

Yes. The light and medium warp drives strength were increased by 10x.

24 minutes ago, kerbnub said:

Somehow I missed this, awesome update! I'm enjoying warping around the system now, and can turn while warping with no random explosions. :D

Great you like it, next release will improve it further with automated accelation, which will allow you to warp to anywhere in the solar system less then 10 seconds

Share this post


Link to post
Share on other sites

Hey @FreeThinker  Can you help me understand which drills do what?  The regolith one is obvious, but I'm having a hard time getting the materials I need.

 

I was trying to get HTP from Duna, and I thought regolith was on any planet body, but its only ones with no atmosphere.  I have a Drill-o-matic on, but it can only grab ore and alumina correct?  I tried to do atmosphere grab, but apparently there isn't enough atmosphere on Duna to get enough water to make Hyrdrogen.

I also have a mining base with a Universal drill auger.  The only problem is how big that thing is vs the fact it doesn't reach that far.  The green one is only for ocean mining correct?

Thanks for the help!

Share this post


Link to post
Share on other sites
Posted (edited)
37 minutes ago, flyguybc said:

Hey @FreeThinker  Can you help me understand which drills do what?  The regolith one is obvious, but I'm having a hard time getting the materials I need.

 

I was trying to get HTP from Duna, and I thought regolith was on any planet body, but its only ones with no atmosphere.  I have a Drill-o-matic on, but it can only grab ore and alumina correct?  I tried to do atmosphere grab, but apparently there isn't enough atmosphere on Duna to get enough water to make Hyrdrogen.

I also have a mining base with a Universal drill auger.  The only problem is how big that thing is vs the fact it doesn't reach that far.  The green one is only for ocean mining correct?

Thanks for the help!

Although regolith literally means the top soil, in the context of space exploration we specifically mean the regolith on celestial bodies exposed to the solar wind, meaning it has no significant atmosphere or strong magnetic field. Solar Wind mainly consists of Protons (Hydrogen) and Alpha particles (Helium), but also contains trace amount of Heavier amount, effectively allowing you to make any fuel, its just a matter surface area, process volume and processing power. 

687474703a2f2f692e696d6775722e636f6d2f6c

Processing power is not a problem in KSP, volume and surface area is hard to simulate in KSP. My initial plan was to add specialized Regolith harvesting with the mining parts made by @riocrokite

It would looked like something like this.

Hsifhqe.png

Made for

Unfortunately, his development tread stopped a few years ago. The current regolith dril was merely mend as a temporary solution until I got access to the regolith harvester parts.

A second mining solution would be to dig a deep hole, allowing you access to mantle rock which would also contain a wide variety of resources. This is what the XL Auger was introduced for. The general idea is that you would first use a scanning tool to detect  raw resources which could be processed into desired resource.

 

 

Edited by FreeThinker

Share this post


Link to post
Share on other sites
On 5/29/2019 at 1:40 AM, davidle said:

@FreeThinkerThe plane does indeed have pre-coolers. The problem isn't in the atmosphere, it's in vacuum. The Lightbulbs cause the B9 Sabre engines and adjacent OPT part to overheat despite ample radiators. What additional info would be helpful?

 

https://imgur.com/PMuxH7D

 

I've taken to turning off max temp when playing with this craft file.

Looking at the image, I don't see a lot of surface area of radiators.

Share this post


Link to post
Share on other sites

I have a couple of jets I made before I installed KSPI and one I just made. They use Juno engines and they no longer work. A few seconds after starting the engines they have an intake air flameout and it's definitely not a lack of intake air problem. Don't know why they are doing this.

Share this post


Link to post
Share on other sites
56 minutes ago, Combatsmithen said:

I have a couple of jets I made before I installed KSPI and one I just made. They use Juno engines and they no longer work. A few seconds after starting the engines they have an intake air flameout and it's definitely not a lack of intake air problem. Don't know why they are doing this.

This might happen because the stock part is modified (the stock NERV is modified by KSPIE). Does this happen if you load the saved craft, remove and re-add the  Juno engine?

Share this post


Link to post
Share on other sites
2 hours ago, flyguybc said:

Hey @FreeThinker  Can you help me understand which drills do what?  The regolith one is obvious, but I'm having a hard time getting the materials I need.

 

I was trying to get HTP from Duna, and I thought regolith was on any planet body, but its only ones with no atmosphere.  I have a Drill-o-matic on, but it can only grab ore and alumina correct?  I tried to do atmosphere grab, but apparently there isn't enough atmosphere on Duna to get enough water to make Hyrdrogen.

I also have a mining base with a Universal drill auger.  The only problem is how big that thing is vs the fact it doesn't reach that far.  The green one is only for ocean mining correct?

Thanks for the help!

The green drill is for mining ocean water I believe. I haven't used that yet.

 

I was able to make 51,000 units of HTP in 120 days

Universal drill -> regolith

Processor -> Regolith process

Electrolizer -> water electrolysis

Converter -> Amthraquinone process = HTP

I myself have a question;

SxegIp6.png

What does the 'max secondary power usage', 'electric priority' and 'electric power control' do? In my testing, I have not seen any change when I toggle these

Share this post


Link to post
Share on other sites
2 hours ago, wkwied said:

This might happen because the stock part is modified (the stock NERV is modified by KSPIE). Does this happen if you load the saved craft, remove and re-add the  Juno engine?

Well like I said I built a new plane AFTER I installed KSPIE and I have the same issue of engine flameout. 

Share this post


Link to post
Share on other sites

Interesting. I think I may have just encountered the same problem.

It seems like, air breathing engines do not register intake atm as replenishing. So even if you have air intakes on the engine, it will not register and once the initial (small) supply of 'intake air' is burnt up, the engine flames out.

 

I've replicated this on KSPIE latest and game version 1.7.0

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.