FreeThinker

[1.7.3/1.6.1/1.5.1/1.4.5/1.3.1] KSP Interstellar Extended 1.23.8 Support Thread

Recommended Posts

I'm not sure how to describe it but ever since I upgraded to 1.13.5 I am getting NAN floating point errors in console, as soon as I reload my quick save my altitude goes to 000000 and my ship disappears,electric charge value is NAN /2420 and thermal power and mega joules are 0.00/0.00, reverting tracking station the ship reads as being on escape trajectory out of the sun, planets disappear, clicking on other ships shows nothing. also my probe has the "candle" engine on it

Error.log https://pastebin.com/NGzuS7cR

Share this post


Link to post
Share on other sites

Hi every one, in the console i get some error related to KSPI :

"did not get techic advEMsystem"

and

"did not get technic ionpropulsion"

Is this normal ?

Share this post


Link to post
Share on other sites
4 hours ago, Sovietsanta said:

I'm not sure how to describe it but ever since I upgraded to 1.13.5 I am getting NAN floating point errors in console, as soon as I reload my quick save my altitude goes to 000000 and my ship disappears,electric charge value is NAN /2420 and thermal power and mega joules are 0.00/0.00, reverting tracking station the ship reads as being on escape trajectory out of the sun, planets disappear, clicking on other ships shows nothing. also my probe has the "candle" engine on it

Error.log https://pastebin.com/NGzuS7cR

Could you describe how to reproduce?

Share this post


Link to post
Share on other sites

I simply updated from 1.13.3 or 1.13.4 mid game and loaded my save up and it immediately happened when I went back to my probe, also I had a probe of the exact same design arround duna that had the same issue, I think it has to do with the change between versions to the candle engine I ended up having to re load a backup then remove all probes with the candle engine from the persistent.sfs, which ultimately fixed the issue because before even relaunching a separate new probe with the candle caused the issue to happen to the new probe at the launch pad with the ships that existed with the candle before the update. I am not to sure how to reproduce other than trying the update process mid flight from one of those older versions to 1.13.5 with a probe with that engine. Maybe it was an isolated issue I'm not really sure

Share this post


Link to post
Share on other sites

@FreeThinker - new update has done a few things for sure, maybe 1 other thing:

1. Framerates are a lot better.  Not sure why, but they are.
2. This was mentioned on the other forum - electric charge bug.  Electric generators stop generating electric charge after any dock/undock operation.  F5/F9 save/reload fixes it, but this is definitely a new bug.
3. (this was 2 updates ago) - Umbrella radiators no longer deploy automatically in automated mode.  have to deploy them manually now in all cases.
4. The game is... very crashy.  After the EC bug is hit, that F5/F9, about 25% of the time will crash KSP completely - this is the one that I'm not 100% sure is a KSPIE issue - the logs are no help, just normal normal normal <<CRASH>> with no evidence pointing a finger at *any* specific mod.

Share this post


Link to post
Share on other sites

4C9AsX.jpg

I'm currenty hanging on this everytime i try and start the game with your mod.  Any ideas?

Isg3vL.jpg

These are the mods i currently have installed.

Edited by fullbashreturns

Share this post


Link to post
Share on other sites
5 hours ago, fullbashreturns said:

4C9AsX.jpg

I'm currenty hanging on this everytime i try and start the game with your mod.  Any ideas?

Isg3vL.jpg

These are the mods i currently have installed.

 

You'll want to look at your ksp.log and see what it says near the end.  Probably will want to post it and make it available to FreeThinker too, or he (or anyone) will likely not be able to help.

Share this post


Link to post
Share on other sites

[LOG 19:20:05.763] PartLoader: Compiling Internal Prop 'Squad/Props/ledPanelSpeed/prop/ledPanelSpeed'
[LOG 19:20:05.766] PartLoader: Compiling Internal Prop 'Squad/Props/Monitor/DockingMode/MonitorDockingMode'
[LOG 19:20:05.768] PartLoader: Compiling Internal Prop 'Squad/Props/NavBall/prop/NavBall'
[LOG 19:20:05.771] PartLoader: Compiling Internal Prop 'Squad/Props/PropsGeneric/Button_DockingMode/Button_DockingMode'
[LOG 19:20:05.774] PartLoader: Compiling Internal Prop 'Squad/Props/PropsGeneric/CargoBagA/CargoBagA'
[LOG 19:20:05.775] PartLoader: Compiling Internal Prop 'Squad/Props/PropsGeneric/CargoBagB/CargoBagB'
[LOG 19:20:05.777] PartLoader: Compiling Internal Prop 'Squad/Props/PropsGeneric/CargoBagC/CargoBagC'
[LOG 19:20:05.779] PartLoader: Compiling Internal Prop 'Squad/Props/PropsGeneric/Hatch_Plane/Hatch_Plane'
[LOG 19:20:05.781] PartLoader: Compiling Internal Prop 'Squad/Props/PropsGeneric/Hatch_Plane_Curve90/Hatch_Plane_Curve90'
[LOG 19:20:05.783] PartLoader: Compiling Internal Prop 'Squad/Props/PropsGeneric/Hatch_Plane_Frame/Hatch_Plane_Frame'
[LOG 19:20:05.785] PartLoader: Compiling Internal Prop 'Squad/Props/PropsGeneric/Seat_Passenger/Seat_Passenger'
[LOG 19:20:05.787] PartLoader: Compiling Internal Prop 'Squad/Props/PropsGeneric/Seat_Pilot/Seat_Pilot'
[LOG 19:20:05.789] PartLoader: Compiling Internal Prop 'Squad/Props/PropsGeneric/Seat_Pilot_Helmet/Seat_Pilot_Helmet'
[LOG 19:20:05.791] PartLoader: Compiling Internal Prop 'Squad/Props/PropsGeneric/SideStick/SideStick'
[LOG 19:20:05.793] PartLoader: Compiling Internal Prop 'Squad/Props/pullSwitch/prop/pullSwitch'
[LOG 19:20:05.795] PartLoader: Compiling Internal Prop 'Squad/Props/radarAltitude/prop/RadarAltimeter'
[LOG 19:20:05.800] PartLoader: Compiling Internal Prop 'Squad/Props/squareButton/prop/squareButton'
[LOG 19:20:05.802] PartLoader: Compiling Internal Prop 'Squad/Props/standingSwitch/prop/standingSwitch'
[LOG 19:20:05.805] PartLoader: Compiling Internal Prop 'Squad/Props/switch/prop/switch'
[LOG 19:20:05.807] PartLoader: Compiling Internal Prop 'Squad/Props/switchGuard/prop/switchGuard'
[LOG 19:20:05.809] PartLoader: Compiling Internal Prop 'Squad/Props/switchWithGuards/prop/switchWithGuards'
[LOG 19:20:05.812] PartLoader: Compiling Internal Prop 'Squad/Props/throttle/prop/throttle'
[LOG 19:20:05.816] PartLoader: Compiling Internal Prop 'Squad/Props/VSI/prop/VSI'
[LOG 19:20:05.821] PartLoader: Compiling Internal Space 'NearFutureSpacecraft/Spaces/crewutilitypod/crewUtilityPod-internal-rpm/crewUtilityPodInternals-RPM'
[LOG 19:20:05.836] PartLoader: Compiling Internal Space 'NearFutureSpacecraft/Spaces/crewutilitypod/crewUtilityPod-internal/crewUtilityPodInternals'
[LOG 19:20:05.846] PartLoader: Compiling Internal Space 'NearFutureSpacecraft/Spaces/inlineCmdPod/internal/inlineCmdPodinternals'
[LOG 19:20:05.873] PartLoader: Compiling Internal Space 'NearFutureSpacecraft/Spaces/mk3-9pod/mk3-9pod-internal-rpm/mk3-9podinternals-rpm'
[LOG 19:20:05.903] PartLoader: Compiling Internal Space 'NearFutureSpacecraft/Spaces/mk3-9pod/mk3-9pod-internal/mk3-9podinternals'
[LOG 19:20:05.934] PartLoader: Compiling Internal Space 'NearFutureSpacecraft/Spaces/mk4-1pod/internal/mk4-1pod-internals'
[LOG 19:20:05.963] PartLoader: Compiling Internal Space 'PlanetaryBaseInc/BaseSystem/Spaces/Airlocks_internal/airlock_end_g_internal/KKAOSS_Airlock_end_internal'
[LOG 19:20:05.966] PartLoader: Compiling Internal Space 'PlanetaryBaseInc/BaseSystem/Spaces/Airlocks_internal/airlock_garage_g_internal/KKAOSS_garage_adapter_internal'
[LOG 19:20:05.968] PartLoader: Compiling Internal Space 'PlanetaryBaseInc/BaseSystem/Spaces/Airlocks_internal/airlock_mid_g_internal/KKAOSS_Airlock_Mid_internal'
[LOG 19:20:05.971] PartLoader: Compiling Internal Space 'PlanetaryBaseInc/BaseSystem/Spaces/Central_Hub_internal/internal/KKAOSS_Central_Hub_internal'
[LOG 19:20:05.985] PartLoader: Compiling Internal Space 'PlanetaryBaseInc/BaseSystem/Spaces/Control_g_internal/internal/KKAOSS_Control_g_internal'
[LOG 19:20:05.993] PartLoader: Compiling Internal Space 'PlanetaryBaseInc/BaseSystem/Spaces/Cupola_g_internal/internal/KKAOSS_Cupola_g_internal'
[LOG 19:20:06.005] PartLoader: Compiling Internal Space 'PlanetaryBaseInc/BaseSystem/Spaces/Gangway_Hatch_internal/internal/KKAOSS_Gangway_Airlock_internal'
[LOG 19:20:06.007] PartLoader: Compiling Internal Space 'PlanetaryBaseInc/BaseSystem/Spaces/Greenhouse_g_internal/internal/KKAOSS_Greenhouse_g_internal'
[LOG 19:20:06.012] PartLoader: Compiling Internal Space 'PlanetaryBaseInc/BaseSystem/Spaces/Habitat_MK1_g_internal/internal/KKAOSS_Habitat_MK1_internal'
[LOG 19:20:06.017] PartLoader: Compiling Internal Space 'PlanetaryBaseInc/BaseSystem/Spaces/Habitat_MK2_g_internal/internal/KKAOSS_Habitat_MK2_internal'
[LOG 19:20:06.022] PartLoader: Compiling Internal Space 'PlanetaryBaseInc/BaseSystem/Spaces/Science_g_internal/internal/KKAOSS_Science_g_internal'
[LOG 19:20:06.027] PartLoader: Compiling Internal Space 'PlanetaryBaseInc/ModSupport/Parts/DeepFreeze/Spaces/Cry-5000Internals/Cry-5000Internals/Cry-5000Internals'
[LOG 19:20:06.033] PartLoader: Compiling Internal Space 'PlanetaryBaseInc/ModSupport/Parts/Extraplanetary Launchpads/Internal/internal/KKAOSS_Workshop_Internal'
[LOG 19:20:06.038] PartLoader: Compiling Internal Space 'Squad/Spaces/crewCabinInternals/internal/crewCabinInternals'
[LOG 19:20:06.045] PartLoader: Compiling Internal Space 'Squad/Spaces/cupolaInternal/internal/cupolaInternal'
[LOG 19:20:06.054] PartLoader: Compiling Internal Space 'Squad/Spaces/GenericSpace1/internal/GenericSpace1'
[LOG 19:20:06.057] PartLoader: Compiling Internal Space 'Squad/Spaces/GenericSpace3/internal/GenericSpace3'
[LOG 19:20:06.062] PartLoader: Compiling Internal Space 'Squad/Spaces/landerCabinInternals/internal/landerCabinInternals'
[LOG 19:20:06.067] PartLoader: Compiling Internal Space 'Squad/Spaces/landerCabinSmallInternal/internal/landerCabinSmallInternal'
[LOG 19:20:06.074] PartLoader: Compiling Internal Space 'Squad/Spaces/LargeCrewedLabInternals/internal/Mobile_Processing_Lab_Int'
[LOG 19:20:06.078] PartLoader: Compiling Internal Space 'Squad/Spaces/mk1CabinInternal/internal/mk1CabinInternal'
[LOG 19:20:06.088] PartLoader: Compiling Internal Space 'Squad/Spaces/mk1CockpitInternal/internal/mk1CockpitInternal'
[LOG 19:20:06.102] PartLoader: Compiling Internal Space 'Squad/Spaces/mk1InlineInternal/internal/mk1InlineInternal'
[LOG 19:20:06.112] PartLoader: Compiling Internal Space 'Squad/Spaces/mk1PodCockpit/internal/mk1PodCockpit'
[LOG 19:20:06.117] PartLoader: Compiling Internal Space 'Squad/Spaces/mk2CockpitStandardInternal/internal/mk2CockpitStandardInternals'
[LOG 19:20:06.139] PartLoader: Compiling Internal Space 'Squad/Spaces/Mk2CrewCabinInternal/internal_MK2_CrewCab/MK2_CrewCab_Int'
[LOG 19:20:06.148] PartLoader: Compiling Internal Space 'Squad/Spaces/mk2InlineInternal/internal/mk2InlineInternal'
[LOG 19:20:06.291] PartLoader: Compiling Internal Space 'Squad/Spaces/MK3CockpitInternal/internal_MK3/MK3_Cockpit_Int'
[LOG 19:20:06.312] PartLoader: Compiling Internal Space 'Squad/Spaces/MK3_CrewCab_Int/internal_MK3_CrewCab/MK3_CrewCab_Int'
[LOG 19:20:06.318] InternalSeat: Cannot find portraitCamera of name 'Camera_Left003'
[LOG 19:20:06.329] PartLoader: Compiling Internal Space 'Squad/Spaces/Placeholder/internal/Placeholder'
[LOG 19:20:06.343] PartLoader: Compiling Internal Space 'Squad/Spaces/PodCockpit/internal/PodCockpit'
[LOG 19:20:06.355] PartLoader: Compiling Internal Space 'WarpPlugin/Spaces/sci/internal/crewtestInternals'
[LOG 19:20:06.422] Loading Systems: Elapsed time is 311.2084s
[WRN 19:20:13.899] The referenced script on this Behaviour (Game Object '<null>') is missing!
[WRN 19:20:13.899] The referenced script on this Behaviour (Game Object '<null>') is missing!
[WRN 19:20:13.900] The referenced script on this Behaviour (Game Object '<null>') is missing!

 

4 minutes ago, ss8913 said:

You'll want to look at your ksp.log and see what it says near the end.  Probably will want to post it and make it available to FreeThinker too, or he (or anyone) will likely not be able to help.

 

Share this post


Link to post
Share on other sites

A new release of KSPI -E 1.13.6  is available from here

Changelog

* Added ability of Antimatter container to explode a will

* Added ability of all reactors to adjust maximum power output

* Added Magnetic Nozzle  isp will be reduced when insufficient powered

* Balance: Increased maximum Isp for Magnetic Nozzle connect to Antimatter Beam Core to 20000000s

* Balance: increased density antimatter storage to 1/10 of frozen hydrogen and storage mass scales linear with size

* Balance: increased beam core  antimatter reactor for Magnetic Nozzle Charged Particle propulsion to 720 GW

* Balance: increased density and lower mass of Gas tank making XenonGas have an effective dry/wet mass ratio of 1:20

* Balance: restored power requirement magnetic nozzle to 1% of propelled charged power

* Balance: reduced mass truss structure and remove electric charge store

* Balance: increased refrigerator switchable gas capacity

* Balance: Increased Mass Ratio Cryogenic storage tanks and Sphere Cryogenic tank

* Fixed Thermal Generator starving Magnetic Nozzle

* Fixed Sorting in power management windows

* Fixed Changing warp time will no longer give short burst of power

* Fixed Antimatter out explode when out of power

* Fixed Wrapper tanks ability to switch resource in Editor

* Fixed Integrated Thermal Electric Effect Generator in Near Future to generate meaning full amount of power

Edited by FreeThinker

Share this post


Link to post
Share on other sites
17 minutes ago, FreeThinker said:

A new release of KSPI -E 1.13.6  is available from here

Changelog

* Added ability of Antimatter container to explode a will

Ahem, to explode at will?

Share this post


Link to post
Share on other sites
10 minutes ago, Nansuchao said:

Ahem, to explode at will?

Yes, don't accidentally push the button. Could be useful  if you are afraid of running into kerbin/earth, or to clean up everything in the neighborhood.

You know this is a standard tvtrope right?

Edited by FreeThinker

Share this post


Link to post
Share on other sites
29 minutes ago, FreeThinker said:

Yes, don't accidentally push the button. Could be useful  if you are afraid of running into kerbin/earth, or to clean up everything in the neighborhood.

You know this is a standard tvtrope right?

MMmm weaponized antimatter.

How close to exploding antimatter tank I could float in space assuming effectively 1 g of antimatter-matter mix will be converted to energy during explosion?

That equals 90 TJ of total energy. Lets say reaction lasts one microsecond - this means total power of explosion is  90 000 TW.

 

 

Share this post


Link to post
Share on other sites

I'm not sure if anyone else is seeing this behavior, but when I use the Direct Cycle Nuclear Turbojet engine, the temperature continues to rise indefinitely and results in exploding the engine. I can get this to happen just by sitting on the runway at about 1% throttle. If I up the max temperature in the config file (to something like 1 million degrees k), it can watch the engine temp just rise and rise -- essentially without limit. The nuclear core temp looks normal, just the part temp rises.

Share this post


Link to post
Share on other sites

0.625m antimatter reactor and same sized thermal ramjet can generate 1.5 MN of thrust!

This is totally not OP ;^)

 

Share this post


Link to post
Share on other sites
24 minutes ago, raxo2222 said:

0.625m antimatter reactor and same sized thermal ramjet can generate 1.5 MN of thrust!

This is totally not OP ;^)

 

Lol, it should not be able to draw more than 5% power. Seems I overlooked something

Share this post


Link to post
Share on other sites
3 hours ago, FreeThinker said:

Yes, don't accidentally push the button. Could be useful  if you are afraid of running into kerbin/earth, or to clean up everything in the neighborhood.

You know this is a standard tvtrope right?

Ok, now it's clear. I supposed (wrongly) that they will randomly explode, lol.

Ando no, I wasn't aware of that site. It seems interesting.

Edited by Nansuchao

Share this post


Link to post
Share on other sites

Seems like there may be a mass/size scaling problem with the antimatter reactors and (at least) the plasma nozzles.

To illustrate:

 

Create a simple craft with a 3.75m antimatter reactor and a 3.75m plasma nozzle.  Note the observed max acceleration using MJ/KER.  Now scale these up to 5m using the same propellant; the acceleration goes DOWN, since the scale of the 3.75m antimatter reactor to the 5.0m adds so much weight that it cannot compensate for the additional thrust.  @FreeThinker is th is intentional?

Share this post


Link to post
Share on other sites

Just updated to the last version of KSPI-E. This SSTO worked flawlessy until few days ago. In the video the Kraken was awaked every time I activate the TORY by AG. Am I the only one with this issue? This was the third try. The logs show nothing at all, until the kraken is summoned.

 

 

 

 

Edited by Nansuchao

Share this post


Link to post
Share on other sites

@FreeThinker - latest update has broken cooling almost 100%.  I can't get more than a couple of seconds of thrust out of *anything* in atmosphere without an overheat.  I know you said you were going to reduce atmospheric effectiveness of graphene radiators, but:

1. I thought you did this 2 updates ago and it wasn't going to get more nerfed(?)
2. There is no titanium radiator comparable to any of the graphene radiators
3. There's no amount of radiators that can physically fit on any of my craft that will even come close to cooling the system enough to even get 5000 meters up in the air...

Help?  Am I doing something wrong or is something badly broken?

Share this post


Link to post
Share on other sites
10 hours ago, ss8913 said:

1. I thought you did this 2 updates ago and it wasn't going to get more nerfed(?)

 

Indeed, I'm surprised as well this is suddenly a problem

10 hours ago, ss8913 said:

2. There is no titanium radiator comparable to any of the graphene radiators

 

Have you tried the stock radiators, They count  as titanium radiators for KSPI-E

Edited by FreeThinker

Share this post


Link to post
Share on other sites
3 hours ago, FreeThinker said:

Indeed, I'm surprised as well this is suddenly a problem

Have you tried the stock radiators, They count  as titanium radiators for KSPI-E

 

haven't, but I may... still, I went from a perfectly good set of usable, flyable craft (SSTO mostly), to 100% useless from last patch to this one.  Can't even get halfway to takeoff speed before everything overheats and shuts down.  Was a serious drastic change to cooling behavior on graphene radiators in atmosphere; if you could take a look and make sure it's working as intended, I'd appreciate it, since I'm not sure this is the effect that you were going for :)

Share this post


Link to post
Share on other sites
46 minutes ago, ss8913 said:

haven't, but I may... still, I went from a perfectly good set of usable, flyable craft (SSTO mostly), to 100% useless from last patch to this one.  Can't even get halfway to takeoff speed before everything overheats and shuts down.  Was a serious drastic change to cooling behavior on graphene radiators in atmosphere; if you could take a look and make sure it's working as intended, I'd appreciate it, since I'm not sure this is the effect that you were going for :)

 
 
 
 
 
 
 

I have not made any changes to wasteheat in particular since the last release. What has changed is the amount of power Antimatter reactor produces from which you can only use 5% for electric power, the remaining 95%of thermal heat should become wasteheat. Now this should not be a problem unless you use the magnetic nozzle. obviously this is not the case, which I wil fix ASAP.

For the moment I have degraded the 1.13.6 release to a beta.

Could you send me the your test/play vessels, it allows me to get a better understanding of the problems you are facing

Edited by FreeThinker

Share this post


Link to post
Share on other sites
8 hours ago, FreeThinker said:

I have not made any changes to wasteheat in particular since the last release. What has changed is the amount of power Antimatter reactor produces from which you can only use 5% for electric power, the remaining 95%of thermal heat should become wasteheat. Now this should not be a problem unless you use the magnetic nozzle. obviously this is not the case, which I wil fix ASAP.

For the moment I have degraded the 1.13.6 release to a beta.

Could you send me the your test/play vessels, it allows me to get a better understanding of the problems you are facing

 

I'll get some examples... I think I can make a simple craft to illustrate the problem using only stock + KSPIE parts, which is likely what you'd need since most of my craft use parts from several sources.

Share this post


Link to post
Share on other sites
9 minutes ago, ss8913 said:

I'll get some examples... I think I can make a simple craft to illustrate the problem using only stock + KSPIE parts, which is likely what you'd need since most of my craft use parts from several sources.

If you want something quicker than I can provide, capsule -> 3.75m antimatter tank (tweakscaled large) -> 3.75m hydrazine tank -> 3.75m charged particle generator -> 3.75m antimatter reactor -> 3.75m thermal launch nozzle or thermal ramjet in closed-cycle mode.
Put 4-8 "winged edge radiator - med" radially attached to the tank.  RCS optional.  Launch it and watch the wasteheat.

Share this post


Link to post
Share on other sites

OK, @FreeThinker - here is a craft file using only stock + KSPIE parts which illustrates the problem: https://www.dropbox.com/s/uuyohyb7oy0p1t3/TEST-wasteheat.craft?dl=0

Fairly spectacularly.  gives less than 2 seconds of thrust before it overheats and fails, and this/similar craft worked fine in the last version.  Also, the MJ max thrust calculations are... a bit off.  this is a fairly high thrust design, but I don't think it's capable of 50+G of acceleration(?)  as the screenshot shows.  I'm linking 2 screenshots, one in the VAB showing the dV calc, and the other showing overheat on the launchpad before I even had time to release the docking clamps:

https://www.dropbox.com/s/u8tm5a7abk4oi67/thermal-launch-failure.jpg?dl=0

https://www.dropbox.com/s/b5n43tumo22hb43/thermal-launch-vab.jpg?dl=0

Edited by ss8913

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.