FreeThinker

[1.8.1-1.10.1] KSP Interstellar Extended 1.25.27 Support Thread

Recommended Posts

13 hours ago, EatenOrpheus30 said:

I'm not able to warp more than 1x because the game think's my altitude is negative, but I'm interstellar. How do I fix this? It's too far away to physical warp.

Link to pictures since I can't find out how to insert them normally: https://imgur.com/a/FHjpOMd

Looks like a Kopernicus issue.

Share this post


Link to post
Share on other sites
Posted (edited)

After installing Interstellar Extended (current version) I'm unable to use two technologies because they have missing prerequisites.

 

Long Term Habitation is sitting on its own below the rest of the tech tree, and requires "short term habitation," which does not exist.

 

Similarly, Logistics is below that, and requires the nonexistent "storage technology."

 

Any clues?

 

using version 1.9.1 of KSP (from Steam), current version of Interstellar Extended, no other mods. Already fully uninstalled and reinstalled everything.

Edited by jkp
clarification.

Share this post


Link to post
Share on other sites
1 hour ago, jkp said:

After installing Interstellar Extended (current version) I'm unable to use two technologies because they have missing prerequisites.

 

Long Term Habitation is sitting on its own below the rest of the tech tree, and requires "short term habitation," which does not exist.

 

Similarly, Logistics is below that, and requires the nonexistent "storage technology."

 

Any clues?

 

using version 1.9.1 of KSP (from Steam), current version of Interstellar Extended, no other mods. Already fully uninstalled and reinstalled everything.

You probably need to grab the Community Tech Tree, if I had to take a guess. I'm pretty sure that's one of the hard dependencies.

Share this post


Link to post
Share on other sites
1 minute ago, etmoonshade said:

You probably need to grab the Community Tech Tree, if I had to take a guess. I'm pretty sure that's one of the hard dependencies.

thanks! 

 

You said "one of the hard dependencies."  What other mods do I need to grab?

 

Share this post


Link to post
Share on other sites
Just now, jkp said:

thanks! 

 

You said "one of the hard dependencies."  What other mods do I need to grab?

 

I don't remember off the top of my head, but they should be in the OP.

Share this post


Link to post
Share on other sites
5 hours ago, etmoonshade said:

You probably need to grab the Community Tech Tree, if I had to take a guess. I'm pretty sure that's one of the hard dependencies.

Thanks again -- this immediately fixed the problem.

Share this post


Link to post
Share on other sites
Posted (edited)

Bug Report

My propellant select window will not open on the thermal turbo jet.

 

Can someone help with this? I click the propellant window and it "opens" but only shows the x to close it. and I cant change propellants by clicking next propellant either

 

EDIT- I figured it out, it was because my reactors were not producing thermal power... so new question why do some reactors produce thermal power and some do not? mods with reactors are NF Electrical KSPIE and USI

Edited by HughesHeadHunter

Share this post


Link to post
Share on other sites
Posted (edited)
5 hours ago, HughesHeadHunter said:

 so new question why do some reactors produce thermal power and some do not? mods with reactors are NF Electrical KSPIE and USI

It realy depend on the design and power conversion mechanism. In general you want to keep the reactors energy in a as pure form as possible, conversion (especialy thermal to electric power) incure a lot of losses which end up as wasteheat. Therefore you are adviced to use the most suitable reactor for the job but some reactors are more generic while other reactors are more specialized, with limited options

Edited by FreeThinker

Share this post


Link to post
Share on other sites

Hi, so I have two problems with my craft. First, the daedilus engine isn't giving very much, if any, thrust, despite having a TWR of over 16. I've flown this ship from ike to dres before, but it's now not giving very much thrust to get away from dres ( I'm trying to fly to kerbin). I've tried qucksaving and loading, but it's not giving any discernable thrust

 also, the thrust through time warp function isn't working, it's saying the propellant is deleted, when it's not. any fixes to these problems?

Share this post


Link to post
Share on other sites
Posted (edited)
11 hours ago, TomfooleryYT said:

Hi, so I have two problems with my craft. First, the daedilus engine isn't giving very much, if any, thrust, despite having a TWR of over 16. I've flown this ship from ike to dres before, but it's now not giving very much thrust to get away from dres ( I'm trying to fly to kerbin). I've tried qucksaving and loading, but it's not giving any discernable thrust

What is important with the Daedalus is that the build in capacitators are charged otherwise it cannot start the initial fusion reaction. Once started it will produce slightly more power than it consumes creating a net power production.

To charge the build in capacitators, simple make sure you produce more power than you consume, even a single solar panel will be enough if your close enough to the sun.

Edited by FreeThinker

Share this post


Link to post
Share on other sites

Is the Gamma Ray Spectrometer now broken in 1.10?  I'm trying to find some Urananananite on Minmus and the wiki says it should tell me how much there is below the craft and show hotspots on the map but the only option I have on the part is Scan Gamma Rays which I already collected as science.

Share this post


Link to post
Share on other sites
1 hour ago, raath said:

Is the Gamma Ray Spectrometer now broken in 1.10?  I'm trying to find some Urananananite on Minmus and the wiki says it should tell me how much there is below the craft and show hotspots on the map but the only option I have on the part is Scan Gamma Rays which I already collected as science.

The Gamma Ray Spectrometer currently only serves as an experiment. Use Stock orbital/surface scanner instead to find Uraninite. For next version I will add a high altitde ModuleResourceScanner for Mopedantte and Uraninite to GammaRaySpectrometer

Share this post


Link to post
Share on other sites
Posted (edited)

Why my Nuclear reactor doesn't work? This is a second technology thermal reactor. Ask something to translate from Russian if you need.

I use it on my Space Station to produce Electric Charge and Megajoules for the whole station and for my hydrogen engine. It was built separately (Reactor and generator block + Radiator block) and I did it 2 times to provide more thrust to ion engine. No one of reactors don't work and don't produce thermal energy. Manual restart doesn't work.

9D053092A25D5F28977A37A2B8737D853EAB956A

 

Edited by CrazyGreenPilot_RUS

Share this post


Link to post
Share on other sites
15 hours ago, FreeThinker said:

What is important with the Daedalus is that the build in capacitators are charged otherwise it cannot start the initial fusion reaction. Once started it will produce slightly more power than it consumes creating a net power production.

To charge the build in capacitators, simple make sure you produce more power than you consume, even a single solar panel will be enough if your close enough to the sun.

I definitely charged the daedalus prior to firing it, it gave the thrust effect in the engine and the context menu showed I was supposed to have 3000kN of thrust, but it wasn't going anywhere. I think it had something to do with how I originally spawned the vessel with launch clamps. or something. I fixed it by spawning a new model of the ship with new launch clamps and releasing the clamps before cheating it up into orbit.

I also am still having the issue with thrust through time warp. could it be because I have bettertimewarp installed?

Share this post


Link to post
Share on other sites
Posted (edited)

I have a couple of questions regarding ISRU mechanics.  I've set up a refinery base on the mun which has access to Monaztte, Urananite and Regolith which I'm refining UF4, ThF4, UraniumNidride and Hydrazine as the main products.  First off I'm bottle necked by Ammonia.  I've added 10 inline ISRU Converters and each only produces 1 T/hour but I need to produce about 10 times that to keep up with all the reactions.  Is there a way to increase how much resource a converter produces?

Secondly does it only produce resources while focused?  I use MKS which update production the next time you focus on a base.  I have a couple of missions to other plants which I attended too and hadn't focused on my muna or minmus colonies for about 150 days.  The MKS all updated fine but the KSPI related resources hadn't produced anything at all in that time.  The drills are also stopped when I focus on the base dispite having a pebblebed reactor and plenty of cooling.

Edited by raath

Share this post


Link to post
Share on other sites
Posted (edited)

Im not sure if this is a bug with KSPIE or Ineterstellar Fuel Switch but whenever i go to check on my bases on moons and planets, my science research fills up in a couple of seconds which kind of breaks the immersion.

I think this might be caused because ckan said they needed to be updated so i did.

Edited by Drupegod02

Share this post


Link to post
Share on other sites
Posted (edited)
10 hours ago, Drupegod02 said:

Im not sure if this is a bug with KSPIE or Ineterstellar Fuel Switch but whenever i go to check on my bases on moons and planets, my science research fills up in a couple of seconds which kind of breaks the immersion.

Tha definatly has nothing to do with KSPIE / IFS. It is not touched by KSPIE / IFS

Edited by FreeThinker

Share this post


Link to post
Share on other sites
6 hours ago, FreeThinker said:

Tha definatly has nothing to do with KSPIE / IFS. It is not touched by KSPIE / IFS

Yes, sorry about that after i transmitted the science twice it was fixed and i also quickloaded

 

Share this post


Link to post
Share on other sites

What parts do I need to make uranium nitride? I can't find it on any of the ISRU reactors.

Share this post


Link to post
Share on other sites
On 8/30/2020 at 8:53 AM, nonono said:

What parts do I need to make uranium nitride? I can't find it on any of the ISRU reactors.

https://github.com/FractalUK/KSPInterstellar/wiki/Uranium-Nitride

Click the toggle refinery button on the refinery context menu and it should be listed as an available option if you have the resources.

 

Potential bug report.  I created a self refuelling craft using CO2 with the fuel scoop and had them turned on during reentry.  When the tanks filled the game dropped to about 1 frame every 60 seconds with the following in the log

 

InvalidOperationException: Sequence contains no elements
  at System.Linq.Enumerable.Min (System.Collections.Generic.IEnumerable`1[T] source) [0x00022] in <fbb5ed17eb6e46c680000f8910ebb50c>:0 
  at FNPlugin.Refinery.AtmosphericExtractor.ExtractAir (System.Double rateMultiplier, System.Double powerFraction, System.Double productionModifier, System.Boolean allowOverflow, System.Double fixedDeltaTime, System.Boolean offlineCollecting) [0x00dc1] in <f1d7585dabaa4eeba51e757112346ca8>:0 
  at FNPlugin.Refinery.AtmosphericExtractor.UpdateFrame (System.Double rateMultiplier, System.Double powerFraction, System.Double productionModidier, System.Boolean allowOverflow, System.Double fixedDeltaTime, System.Boolean isStartup) [0x00000] in <f1d7585dabaa4eeba51e757112346ca8>:0 
  at FNPlugin.Refinery.InterstellarRefineryController.FixedUpdate () [0x00133] in <f1d7585dabaa4eeba51e757112346ca8>:0 
UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
UnityEngine.DebugLogHandler:LogException(Exception, Object)
ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
UnityEngine.Logger:LogException(Exception, Object)
UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)
 
(Filename: <fbb5ed17eb6e46c680000f8910ebb50c> Line: 0)

After about 10 of those in the log the game runs another frame. 

Share this post


Link to post
Share on other sites

the gas and liquid chromatographs disappear if you throw in a some mods in the gamedata --- i can't tell which one is causing this... so a rather ill-defined question: what can cause a part like this to stop showing up?

Share this post


Link to post
Share on other sites
1 minute ago, pp3d said:

the gas and liquid chromatographs disappear if you throw in a some mods in the gamedata --- i can't tell which one is causing this... so a rather ill-defined question: what can cause a part like this to stop showing up?

A part with the exact same name would do this. I recommend looking for the name "FNLCMS"

Share this post


Link to post
Share on other sites

Is there a trick to using the titanium radial convection radiators (the ones specifically designed to ge a bonus in atmosphere)? I placed two of them on my ship in the hopes they will aid with aerobreaking but they are the first parts to explode. Even before solar panels !!!

Edited by Nicky21

Share this post


Link to post
Share on other sites
8 hours ago, Nicky21 said:

Is there a trick to using the titanium radial convection radiators? I placed two of them on my ship in the hopers they will aid with aerobreaking but they are the first parts to explode. Even before solar panels !!!

They are very mechanically weak. Rads are made to be thin after all. Idk who would win in real life, Epic RAD VS SOLAR PANEL! FIGHT XD

Share this post


Link to post
Share on other sites

I'm having an issue where the discovery engine doesn't use any liquid hydrogen (or any of the propellants) if the ISP throttle is set to the max value, I tested this on the two year journey from the screenshot and confirmed that not a single liquid hydrogen had been used, though other resources are draining properly

YBhEDJB.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.