Jump to content

KSP Interstellar Extended Support Thread


FreeThinker
 Share

Recommended Posts

Hi, I installed interstellar on ksp 1.12.2, and I got error during the load ksp, ADDON BINDER: Cannot resolve assembly: Scale.PartDB.18x, but file Scale.PartDB.18x.dll exists.

https://ibb.co/HtsdMbV
This error dissapear, if I delete file 999_Scale_Redist.dll or folder TweakScale, but then I of course can't change parts scale. How to fix this issue?

Link to comment
Share on other sites

2 hours ago, alexander_xxx said:

Hi, I installed interstellar on ksp 1.12.2, and I got error during the load ksp, ADDON BINDER: Cannot resolve assembly: Scale.PartDB.18x, but file Scale.PartDB.18x.dll exists.

https://ibb.co/HtsdMbV
This error dissapear, if I delete file 999_Scale_Redist.dll or folder TweakScale, but then I of course can't change parts scale. How to fix this issue?

please ask here

https://forum.kerbalspaceprogram.com/index.php?/topic/179030-130/

Link to comment
Share on other sites

Anyone else notice oddities with the metallic hydrogen engines?

with mix ratio of 50%

Both mechjeb and the game's internal delta v says 17k in the hangar, then I load into game in a vaccum and it's suddenly down to 12.5k. Then I fire it to completion and I get 18.7k out of it.

If I manually calculate out the delta v, it comes out to the 12.5k that it said when I loaded in.

 

In the hangar Mechjeb/KSP seems to always assume the isp is 1700, no matter what mix ratio I put in, then I get into game and it starts correctly calculating ISP, but then the delta V I get out of it in the end is more than that.

Link to comment
Share on other sites

12 hours ago, Raptoer said:

Anyone else notice oddities with the metallic hydrogen engines?

with mix ratio of 50%

Both mechjeb and the game's internal delta v says 17k in the hangar, then I load into game in a vaccum and it's suddenly down to 12.5k. Then I fire it to completion and I get 18.7k out of it.

If I manually calculate out the delta v, it comes out to the 12.5k that it said when I loaded in.

 

In the hangar Mechjeb/KSP seems to always assume the isp is 1700, no matter what mix ratio I put in, then I get into game and it starts correctly calculating ISP, but then the delta V I get out of it in the end is more than that.

I was just getting 1100isp in flight while KER said I should see 1700 in the VAB. I didn't go and check how much change I would get out of a burn, but why does the estimate in KER switch from VAB to in game?

Link to comment
Share on other sites

I'm having a problem with ion engines. They simply do not produce any thrust, despite being activated and having all requirements met. 

HuNZR5Y.png

MMXHqoB.png

 

I've search and have seen this exact same problem here, which is why I've posted it in this thread, but I'm confused by OP's resolution. I've uninstalled KSP-IE and reinstalled older versions, but I just can't get the ion engines to work.  I do not have Realism Overhaul installed which seems to be a conflict. 

 

My player log is here. Modlist is here.

Link to comment
Share on other sites

On 11/20/2021 at 10:46 PM, theicon32 said:

I'm having a problem with ion engines. They simply do not produce any thrust, despite being activated and having all requirements met. 

HuNZR5Y.png

MMXHqoB.png

 

I've search and have seen this exact same problem here, which is why I've posted it in this thread, but I'm confused by OP's resolution. I've uninstalled KSP-IE and reinstalled older versions, but I just can't get the ion engines to work.  I do not have Realism Overhaul installed which seems to be a conflict. 

 

My player log is here. Modlist is here.

Have you tried stock solar panels?

Link to comment
Share on other sites

Hi. I'm having problem with time warp and electric charge depletion. I can use 1000x time warp but as soon as I try to use bigger time warp (second to last) my electric charge depletes fast even though I have lots of solar panels and no problem with lower time warp. I tracked down issue to this mod. Am I doing something wrong? Is there solution other then not using time warp greater then x1000 ( gonna be pain in the ass for any long travel)?

EDIT: Looks like it's not problem with interstellar. I have tac life so maybe it's the culprit. I have no other mod that I can think of that could interact with electric charge.

Edited by KingZoky
Link to comment
Share on other sites

  • 2 weeks later...

Hi,

I'm trying out the beamed power parts of this, and the giantic "Solar Concentrating Mirror" caught my attention. Maintanance free hard x-rays from a low sun orbit and all that.

But how on earth does one launch this monstrosity? It has so much drag the rocket is seemingly crawling upwards even with high twr - the aerodynamic overlay is showing what looks like an infinitely long drag line, and the shroud/s has about 99 % chance of blowing up the payload and craft transporting it when jettisoning once you actually reach an acceptable height.

Is this WAD to make it harder to get that free energy or am i doing something very wrong?

Link to comment
Share on other sites

19 hours ago, anotherlurker said:

Hi,

I'm trying out the beamed power parts of this, and the giantic "Solar Concentrating Mirror" caught my attention. Maintanance free hard x-rays from a low sun orbit and all that.

But how on earth does one launch this monstrosity? It has so much drag the rocket is seemingly crawling upwards even with high twr - the aerodynamic overlay is showing what looks like an infinitely long drag line, and the shroud/s has about 99 % chance of blowing up the payload and craft transporting it when jettisoning once you actually reach an acceptable height.

Is this WAD to make it harder to get that free energy or am i doing something very wrong?

Why not build it in space with Global Construction? Just need to launch the mass in nice and compact form.

Link to comment
Share on other sites

1 hour ago, Liquid5n0w said:

Why not build it in space with Global Construction? Just need to launch the mass in nice and compact form.

May be an option, though i was thinking more about just changing some value in a cfg file somewhere to bring its drag in line with that of a normal fairing. The two huge shells it has as protection do quite literally nothing in that regard.

Link to comment
Share on other sites

Hi, why, if I use microwave receiver with big energy, waste heat buffer is decreasing and then sharply filled in, and receiver shutting down? 
Perhaps it's because of some calculating required energy for cooling, when waste heat buffer is empty, cooling is switching off, and then can not get in time switching on again, how to prevent switching off cooling?

https://drive.google.com/file/d/1Ed8v4vLraC9_cV_tUt4XNkjZtx7prEqT/view?usp=sharing

Edited by alexander_xxx
Link to comment
Share on other sites

I think i found an exploit while playing around with beamed power.

With the patch from warpplugin active (don't know if this really works this way) the nuclear reactors from Near Future Electric produce a constant amount of MW power that is required by pretty much everything from Interstellar Extended. Scale them up or down, they always produce the same MW.

Now for the exploit: Scale them down to 0.1 m and place multiple of them underneath an infrared laser, apply apropriate cooling. It's free energy, costs 1/100 the money that it would take with a pebble bed reactor and will run for 5 years. For a career playthrough this is game breaking.

Link to comment
Share on other sites

On 11/20/2021 at 1:46 PM, theicon32 said:

I'm having a problem with ion engines. They simply do not produce any thrust, despite being activated and having all requirements met. 

HuNZR5Y.png

MMXHqoB.png

 

I've search and have seen this exact same problem here, which is why I've posted it in this thread, but I'm confused by OP's resolution. I've uninstalled KSP-IE and reinstalled older versions, but I just can't get the ion engines to work.  I do not have Realism Overhaul installed which seems to be a conflict. 

 

My player log is here. Modlist is here.

 

On 11/23/2021 at 12:42 AM, FreeThinker said:

Have you tried stock solar panels?

Same issue here with a full stock craft. Obligatory log.

Edited by Sirius628
Link to comment
Share on other sites

Hi all, thank you @FreeThinker for such a comprehensive mod. I'm unable to find any storage containers that store PVC (rocket fuel tanks, holding tanks, logistic modules, etc). Are there any known interactions with other mods that could be hiding the required components? Or where is this expected to be stored? Thanks!

Link to comment
Share on other sites

Hi, WarpPlugin is causing a hang on load with 1.12.2  --    WarpPlugin/Parts/Electrical/MCFStellarator/MagneticConfinementFusionReactorStellarator2/FURMaCoSt2

Any ideas how to fix? I have tried a fresh installation of all my mods, and deleted miniAVC and installed ZeroMiniAVC, but to no avail. 

Link to comment
Share on other sites

Hi, is there a config setting that could prevent the diamagnetic antimatter container from exploding?  If not, would you be willing and able to add such a setting?  Any craft I have carrying any antihydrogen in a diamagnetic antimatter container that does anything more than sit on the launchpad/runway(ie, flying around, docking, etc) eventually gets blipped, leaving me with only a fading green message that the antimatter container ran out of power. I know I've got *plenty* of power, both stored and being generated,  and the temps/g's are far lower than their max settable values.  I'm thinking it might be caused by lag, but I have no evidence to support that hunch.

Link to comment
Share on other sites

Question for any:

Trying to use TORY Nuclear ramjet. It keeps exploding. I've tried three things:
1. Stock engine - hits ~1100kn thrust and explodes
2. Add a bunch of titanium radiators for in-atmosphere conduction (Titanium Convector Radiator Inline, tweakscaled to 1.25m). These go to full heat and the engines still explode - although the max thrust the ramjet provides is much lower.(810kn)
3. Throttle down - doesn't matter. Still heats and explode

As this engine is supposed to heat up air intake for thrust, I understand the increasing temperatures being correlated with thrust - as in #2. However, right now these only seem practical as boosters - they can't be run for more than a minute or two without needing to turn them off. Is this the correct expectation? These engines are meant to be run hot and short, then disabled?

Thanks!

Link to comment
Share on other sites

For whatever reason I can't see the upgrades for graphene radiators in the tech tree except for the one in nanolathing (I can see the nodes but not the upgrade icons in the preview). I'm playing on ksp 1.12.3 with kspie version 1.29.6 (I also had the problem with 1.29.5). I also had the problem with some of the other upgrades like the nuclear salt water reactor, but they were fixed once I redownloaded community tech tree.

Link to comment
Share on other sites

On 1/12/2022 at 5:12 PM, Voqk said:

Trying to use TORY Nuclear ramjet. It keeps exploding.

You have two options:

a) install one or more heat exchangers. Not sure if they're from Interstellar or one of the recommended mods, maybe Heat Control. They act like radiators with almost zero heat dissipation but very high heat capacity, so you can keep the engine running for longer.

b) install a pre-cooler. This reduces the heat generated by all air-breathing engines.

Perhaps even combine a) and b), if it's not enough.

Link to comment
Share on other sites

22 hours ago, samooo2 said:

You have two options:

a) install one or more heat exchangers. Not sure if they're from Interstellar or one of the recommended mods, maybe Heat Control. They act like radiators with almost zero heat dissipation but very high heat capacity, so you can keep the engine running for longer.

b) install a pre-cooler. This reduces the heat generated by all air-breathing engines.

Perhaps even combine a) and b), if it's not enough.

Thanks! Yeah, I think I was getting carried away with the 'Look at all that thrust!'  and noted that precoolers would reduce it. But I guess letting a thermal engine heat up to the point it explodes may be good for thrust, but not for Jeb's lifespan.

Link to comment
Share on other sites

Hi all, I put together a 'KSPIE for dummies' (like me) / practical guide on this forum. If anyone is interested it's here. Lots of sample crafts and 'how tos' on everything from power relay set up, bandwidth selection, launch vehicle stats, etc.



would appreciate any feedback - feel free to leave comments and I'll update when I can.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...