• 0
Sign in to follow this  
Aeroboi

Monitor signalling in/out only in KSP (GTX 1080 TI)

Question

Since recently I became a owner of a new computer that has a Gigabyte Aorus GTX 1080 TI graphics card on the new Z370 platform with a 8800K by the way.  I like the this over pouring of graphical juice in my videogames and it works nice on my Acer Z35P Ultra Wide Quad HD monitor which can display 120hz nicely.

Unfortunately, KSP does not like this graphical setup, for whatever reason that is currently unimaginable to me.

My experience and knowledge goes as far to try out the spare variety of graphics drivers from the Nvidia site, but beyond that I do not know what to do.

Whats your issue at hand mate?

Whenever I play KSP (that is beyond the main menu) my monitor starts signalling in and out randomly, as if the physical cable were disconnected. It then stays like that for 5 to 7 seconds or thereabout and then the signal gets back again. Sometimes it happens several times in a row. So the monitor signals out and in again and repeatedly.
This is completely random, I say, completely.

However, when I then at the time of incident put the displayport cable in another port it always remedies the problem, but again, for a random given time and then it re-appears again, on any of the display ports I must add.
This happens only in KSP, not any other game, application or graphical environment does suffer from this anomaly (at least those programs that I run) 

Hence why I registered on this forum instead of some computer help site or Steam since it's then clearly KSP related, am I right?

So I tried all the latest drivers for the GTX 1080 TI. I tried putting my display port cable in all 3 the display ports on the back of the videocard, and I used a secondary display port cable to see if it was the cable itself. Which can't be as logic tells me because then it would be reproduceable in other games also.
The same goes for the argument that it may be faulty ports. Which it can't be because then all 3 of them would be faulty and isn't that just to unlikely to happen on a new videocard? I think it would be.

I know you and I like plentiful of information in troubleshooting scenarios but I don't know what to give, so just ask me.

I currently play 1.4 but I got my new rig still in the 1.3.1 phase and both versions have the same problem, my bet any version before that also.

 

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

I have not encountered this problem myself but some experiences with other bugs suggests you might want to try configuring the display driver settings to see if there is one in there which can have an effect. It sounds as though it is activating some kind of autodetect and is changing the output to the monitor for some reason.

Also make sure you have the correct monitor driver / inf installed in the OS. i.e. Look through the display driver and make sure it recognises the monitor by model name, if not fix.

If so check it is not innappropriately configured for multiple displays or stereoscopic 3D etc.

Try changing any autodetects or "let application decide" to manual configuration e.g. in the nVidia control panel "3D settings", "adjust image settings with preview" panel you can select an alternative to letting the application decide, since the issue seems to be application related. 

Also if the monitor has a control panel with settings it may be worth taking a look at these to see if it has any autodetects going on.

I hope that helps. For offering specific info you cannot miss if quoting a DXDIAG.exe text log in a code panel (see <> symbol in the text editor).

If it happens in any other application (and I accept you say it hasn't... yet) then your first port of call would be trying a replacement cable obviously.

Hope that helps.

Share this post


Link to post
Share on other sites
  • 0

A million bucks says you're overloading the clock for the DP (3 ports? pfft!) - disconnect all other ports, and then see what it does? This smells like a poor design/hardware problem.

Before you complain, my nVidia (a 960 or 980 or something, not as fancy as yours) board has the same problem - there are 4 connectors on the back but it only has enough clocks to supply 3 of them. It's commerce/false advertising gone rampant.

Edited by surge

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this