N70

[1.3.1/1.4.5] Kerbalism v1.7.1

Recommended Posts

Cant update through CKAN, throws error

Share this post


Link to post
Share on other sites
6 hours ago, Battou said:

Cant update through CKAN, throws error

Same issue. I posted in the CKAN thread about it but I am unsure where the problem is. I can install manually but I would prefer to use CKAN because I tend to use many mods and I don't want to manually update.

This is the error that occurs just before/as the download is done.

CKAN.InvalidModuleFileKraken: Kerbalism 1.6.0: C:\Users\jerbe\AppData\Local\Temp\tmp2A0F.tmp has length 3789554, should be 3786341
   at CKAN.NetModuleCache.Store(CkanModule module, String path, String description, Boolean move)
   at CKAN.NetAsyncModulesDownloader.ModuleDownloadsComplete(NetModuleCache cache, Uri[] urls, String[] filenames, Exception[] errors)

Share this post


Link to post
Share on other sites
Posted (edited)
On 5/28/2018 at 11:43 AM, N70 said:

it's a  CKAN problem, tell them

@N70

Alright, HebaruSan from CKAN took care of the problem being caused by CKAN. Thanks for pointing me to the source of the problem!

Edited by GJNelson

Share this post


Link to post
Share on other sites
Posted (edited)

@PiezPiedPy @N70 booting up KSP with newest repo

Edit:

Some more info, at least a manufacturer, could be added:
nEzeUpy.png

Edit:

@PiezPiedPy

On staging in high atmosphere from stage 2 to stage 3 the "signal loss and signal back" happened - I never had this under these circumstances.
(no nullrefs)

Normally only under scene change.

Edited by Gordon Dry

Share this post


Link to post
Share on other sites
21 hours ago, Gordon Dry said:

@PiezPiedPy @N70 booting up KSP with newest repo

Edit:

Some more info, at least a manufacturer, could be added:
nEzeUpy.png

Edit:

@PiezPiedPy

On staging in high atmosphere from stage 2 to stage 3 the "signal loss and signal back" happened - I never had this under these circumstances.
(no nullrefs)

Normally only under scene change.

Any ideas what info you would like to see ?

Share this post


Link to post
Share on other sites
1 hour ago, PiezPiedPy said:

Any ideas what info you would like to see ?

At least in the right side that this is related to Kerbalism in some kerbalized manner, the name of the manufacturer - dunno which it should be.
Perhaps the same as the Chemical Plant: Rookies Inc.

Share this post


Link to post
Share on other sites
6 hours ago, Gordon Dry said:

At least in the right side that this is related to Kerbalism in some kerbalized manner, the name of the manufacturer - dunno which it should be.
Perhaps the same as the Chemical Plant: Rookies Inc.

I don't think you can add stuff to the right side for Upgrade parts :( (I have not found a way, unless someone else knows).

Slots are pretty specific to Kerbalism I would think the title and description kind of imply that it is for Kerbalism.

I've added a Manufacturer though (missed that bit).

Share this post


Link to post
Share on other sites

None of the icons are appearing anywhere in the Kerbalism GUI for the latest release.

Share this post


Link to post
Share on other sites
On 3/16/2018 at 1:34 AM, lordcirth said:

The Kerbalism planner in the VAB tells you whether you'll be able to reach a given planet.  Also Kerbalism's range formula is just the range of the best antenna, as best I remember, so you don't really need a calculator.

@PiezPiedPy that quote is perhaps obsolete, but without AntennaHelper I don't see a comprehensive way of finding out if the antenna(s) are strong enough.

So how about AntennaHelper now?

I used it, actually I just removed it for testing out Kerbalism, but in VAB I see only the antenna range. A number. But no real info how far I can get.

So when re-adding it, it's okay? Are there still incompatiblities or are these just gone because the Kerbalism signal is removed?

Share this post


Link to post
Share on other sites
9 hours ago, Daedalus451 said:

None of the icons are appearing anywhere in the Kerbalism GUI for the latest release.

Does this happen every time you load KSP ? If so all I can suggest is delete Kerbalism from your GameData folder and reinstall.

Also this can sometimes happen if you move out of the KSP window (say with Alt-Tab or similar) while it is loading.

Share this post


Link to post
Share on other sites
Posted (edited)

@N70 @PiezPiedPy Just an information, but could be the reason for later patches:

Last session I was building a BluedogDB Saturn-Apollo manned Mun mission.

Everything was fine, but .... because of the maxed out shielding in the Apollo Command Block II and the LEM ascent module as well I had a problem - the LEM ascent module was way too heavy to launch from Mun surface*.

The higher pod mass also could create problems in classic rentry-parachute situations, when the parachutes have no RealChute configs and so be stockalike, it could happen that the lowest speed is above 250 m/s and so the chutes are not "safe to deploy".
For this case it also makes sense to balance out the mass of the pod.
 

So I came to the conclusion:

When there is Kerbalism with maxed out shielding there is a need to alter the pod mass to balance out, so I use SMURFF with the following values inside the GameData\SMURFF\SMURFF.cfg

    tanklever = 0.1
    enginelever = 0.75
    podlever = 1.0

*Fun fact:

Spoiler

I managed it to get the 2 Kerbals back to the Apollo Block II orbiter by EVA RCS ... in 77 km altitude. Both of them had an intersect after nearly 90 minutes, it was a high excentric orbit to get it done quick. They both became hungry and thirsty, but they survived the trip fearlessly.

 

Edited by Gordon Dry

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, Gordon Dry said:

Everything was fine, but .... because of the maxed out shielding in the Apollo Command Block II and the LEM ascent module as well I had a problem - the LEM ascent module was way too heavy to launch from Mun surface*.

You shouldn't need max shielding for a short trip to the Mun and back, not sure if the weight savings there would affect things.

Edited by Maeyanie
  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

I am having two issues with this mod. The first one is with pods and shielding. They no longer float. This really isn't that big of a problem because I land at the KSC most of the time, but sometimes I miss. Is this intended? If so, Is there a way to change buoyancy on the pods? I don't mind the mass penalty for shielding but I'd like to not sink to the bottom of the ocean.

I built a medium sized station (~250 parts, medium for me) that is powered by 8 single fuel cells and 8 1x6 PV cells(15000+ EC battery capacity). I set the automation to kick on the fuel cells when power is low and turn off when power is high. This was not firing at all. I set the messages to tell me when the scripts fired. I never received a notification. I changed the the automation to light the fuel cells in shadow and turn them off in light. This also did not fire. After observing the behavior for a while, I noticed that when in shadow and when the station is not the active vessel I have 15 minutes of EC and in sun it is perpetual. When the vessel is active everything works, scripts fire, fuels cells act normally, power is eternal(well as long as the hydrogen lasts). After reloading, I receive the messages for the automation but the power runs out when the station goes into shadow when I am controlling another vessel.

I run 47 mods currently and I see no exceptions in the log. Is there any known issue like this occurring with a mod conflict? I'm looking for a place to start solving this if this is indeed a problem on my end.

Edit: I have found the problem. I had a universal storage alkali fuel cell on board as a test to see if this mod controls those. It does not. I also left it on and it is not calculated in the background. It provided the extra EC I needed when the vessel was loaded. The script behavior is slow to react, though, when the vessel in unloaded.

Edited by AngrybobH

Share this post


Link to post
Share on other sites
Posted (edited)

@AngrybobH Yes, there are still some quirks, most of them mod incompatibilities or better said - missing mod integration patches.

  • as you said, it lacks the recognition of background processing of anything that is not native Kerbalism
  • same goes to RealBattery, which also uses background processing, in focus it's okay but out of focus the batteries get empty, CO2 levels rise and Kerbals just die
  • the additional weight of shielded pods is a problem, either Kerbalism itself should provide patches to make them lighter so that they have the same mass incl. LS resources and max. shielding than default (without Kerbalism), or they all need buoyancy embedded natively by Kerbalism (could be integrated into heat shield parts).
  • I scratched that part because too heavy pods:
    • no return from Mun
    • too fast on reentry for stock chutes (non-RealChute)

There is a mod named Comfortable Landing that provides parts and also patches for several pods, inflating buoyancy integrated into the pods, has to be activated by either the PAW (right-click menu) or by action groups (Smart Parts are good for this).

Edited by Gordon Dry
  • Like 2

Share this post


Link to post
Share on other sites
5 hours ago, Gordon Dry said:

@AngrybobH Yes, there are still some quirks, most of them mod incompatibilities or better said - missing mod integration patches.

  • as you said, it lacks the recognition of background processing of anything that is not native Kerbalism
  • same goes to RealBattery, which also uses background processing, in focus it's okay but out of focus the batteries get empty, CO2 levels rise and Kerbals just die
  • the additional weight of shielded pods is a problem, either Kerbalism itself should provide patches to make them lighter so that they have the same mass incl. LS resources and max. shielding than default (without Kerbalism), or they all need buoyancy embedded natively by Kerbalism (could be integrated into heat shield parts).
  • I scratched that part because too heavy pods:
    • no return from Mun
    • too fast on reentry for stock chutes (non-RealChute)

There is a mod named Comfortable Landing that provides parts and also patches for several pods, inflating buoyancy integrated into the pods, has to be activated by either the PAW (right-click menu) or by action groups (Smart Parts are good for this).

Making pods lighter would throw off early game balance, making early orbit *easier* in Kerbalism.  Comfortable landing seems great, installing it now!

Share this post


Link to post
Share on other sites
2 minutes ago, lordcirth said:

Making pods lighter would throw off early game balance, making early orbit *easier* in Kerbalism.

I meant to make them lighter, but with Kerbalism resources (Food, Water etc.) and full shielding it would have the same weight as "normal".

Share this post


Link to post
Share on other sites
Posted (edited)
30 minutes ago, Gordon Dry said:

I meant to make them lighter, but with Kerbalism resources (Food, Water etc.) and full shielding it would have the same weight as "normal".

Yes, but early launches don't need any shielding.  So no-shielding pods would be extremely light.

Edited by lordcirth

Share this post


Link to post
Share on other sites

Personally I think the solution is for Kerbalism to add some heavy Storm shelter parts, and have kerbals automatically hide inside those during times of high radiation.  Then players can just de-couple those before re-entry and landing. 

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)
12 hours ago, lordcirth said:

Yes, but early launches don't need any shielding.  So no-shielding pods would be extremely light.

Hmm, @PiezPiedPy perhaps this could be taken into account by PartUpgrade? Just decrease the pod's mass by the amount of mass the max shielding would add as soon as the tech tree node is unlocked?

Perhaps also the part should default to max. shielding then, not to no shielding ...

6 hours ago, AVaughan said:

Personally I think the solution is for Kerbalism to add some heavy Storm shelter parts, and have kerbals automatically hide inside those during times of high radiation.  Then players can just de-couple those before re-entry and landing. 

Well, that would break the design of many part packs. Do you really want to add a storm shelter part to an Apollo mission because the capsule is not shielded?

Edited by Gordon Dry

Share this post


Link to post
Share on other sites
9 minutes ago, Gordon Dry said:

Well, that would break the design of many part packs. Do you really want to add a storm shelter part to an Apollo mission because the capsule is not shielded?

Apollo missions really don't need much shielding, they're only out for a few days. Even Minmus isn't THAT far away.

Only time you start needing a ton of shielding is if you're going on interplanetary trips and expect to be out there for months, if not years. And even then, you could just have the re-entry capsule unshielded so it floats, the part of the vessel which doesn't have to land can be as heavy as it needs.

Honestly, I'm fine with the capsule weight balance the way it is, it's never been a significant problem for me. Just have to design with it in mind.

  • Like 1

Share this post


Link to post
Share on other sites

Hmm, perhaps an "is shielding needed and if yes, how much?" - calculator would come handy...

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now