N70

[1.4.0 <-> 1.7.1] Kerbalism v3.0.2

Recommended Posts

Coming in Kerbalism 1.4:

 

N92Ds5W.png

TZRRQEt.png

Edited by N70

Share this post


Link to post
Share on other sites

It no longer connects to the center of kerbin

Share this post


Link to post
Share on other sites

So, what are the major differences between CommNet and Kerbalism's Signal once this change is made?  CommNet has sqrt() range scaling on multiple antennas; what else?

Share this post


Link to post
Share on other sites
Just now, lordcirth said:

So, what are the major differences between CommNet and Kerbalism's Signal once this change is made?  CommNet has sqrt() range scaling on multiple antennas; what else?

Kerbalism's signal is based on low-gain and high-gain antennas. The current change is making it so the antennas just need to connect to like, the KSC, rather then the center of kerbin

Share this post


Link to post
Share on other sites

@N70

A quote from @Electrocutor about forced glcore and shaders:

Quote

Some mods do not do support glcore; I would suggest you let the mod authors know this when you run across them, as they merely need to check a box when compiling their shader to have it work.

 

Share this post


Link to post
Share on other sites
Quote

// ============================================================================
// ISRU drills
// ============================================================================

@PART[MiniDrill,RadialDrill]:NEEDS[ProfileDefault]:FOR[Kerbalism]
{
  !MODULE[ModuleResourceHarvester] {}
  !MODULE[ModuleOverheatDisplay] {}
  !MODULE[ModuleCoreHeat] {}

  MODULE
  {
    name = Harvester
    title = Water Extraction
    drill = ImpactTransform
    length = 1.25
    type = 0
    resource = Water
    min_abundance = 0.01
    rate = 0.0005
    ec_rate = 1.0
  }

  MODULE
  {
    name = Harvester
    title = Ore Extraction
    drill = ImpactTransform
    length = 1.25
    type = 0
    resource = Ore
    min_abundance = 0.02
    rate = 0.0025
    ec_rate = 1.0
  }

  MODULE
  {
    name = Configure
    title = Drill
    slots = 1

    SETUP
    {
      name = Water Extraction
      desc = Extract <b>Water</b> from the surface.

      MODULE
      {
        type = Harvester
        id_field = resource
        id_value = Water
      }

      RESOURCE
      {
        name = Water
        amount = 0
        maxAmount = 50
      }
    }

    SETUP
    {
      name = Ore Extraction
      desc = Extract <b>Ore</b> from the surface.

      MODULE
      {
        type = Harvester
        id_field = resource
        id_value = Ore
      }

      RESOURCE
      {
        name = Ore
        amount = 0
        maxAmount = 50
      }
    }
  }

  MODULE:NEEDS[FeatureReliability]
  {
    name = Reliability
    type = Harvester
    title = Harvester
    repair = Engineer
    mtbf = 72576000 // 8y
    extra_cost = 1.0
    extra_mass = 0.2
  }
}
@PART[RadialDrill]:NEEDS[ProfileDefault]:FOR[Kerbalism]
{
  @MODULE[Harvester],*
  {
    @rate *= 5
    @ec_rate *= 5
    @length = 5.0
  }
}

 

The bug drills are not drilling (because no button to press start) may caused here right? - for more details look here - Anyone an idea how to fix? @N70

Share this post


Link to post
Share on other sites

With drill i have probem too ...

(and about my previous question: key for disable all notifications is pause break)

Edited by popos1

Share this post


Link to post
Share on other sites

Kerbalism 1.4.0 will be released in a few hours. Here's a changelog!

 

* Signals no longer connect to the center of Kerbin. They now rather connect to ground stations, which are configurable in profile configs!

* Stuff should now display properly on OpenGL/GLcore mode.

* Science transmission dots now display properly.

* Fixed the drill problems... the Harvester module had disappeared from the code somehow?

Share this post


Link to post
Share on other sites

K6UsPd1.png

Is this suppose to be normal? The gravity rings didn't seem to work normally.

 

 

BTW I also made some changes about the SSPX containers, they can hold the resources from Kerbalism now. If anyone think this would be a good idea?:)QbTgI09.png

Just to show a comparison between a kerbalism and a SSPX containers, that Chinese of resource is water.

Share this post


Link to post
Share on other sites
2 hours ago, VoidST said:

K6UsPd1.png

Is this suppose to be normal? The gravity rings didn't seem to work normally.

 

 

BTW I also made some changes about the SSPX containers, they can hold the resources from Kerbalism now. If anyone think this would be a good idea?:)QbTgI09.png

Just to show a comparison between a kerbalism and a SSPX containers, that Chinese of resource is water.

SSPX support isn't complete yet.

KFKdIya.png 

Thanks @Papa_Joe for the radar dish sprites!

Share this post


Link to post
Share on other sites

Hey,

great improvements with the latest update.

I got a problem: In map screen I can't get the body info window appear again. It disappeared (in version 1.3.2) at some point (or I accidentaly closed it) and I can't find a way to make it show up again. Tried the old Alt+N, reinstalling, updating to the latest version, checking the wiki and google, but no success.

Share this post


Link to post
Share on other sites
On 3/25/2018 at 7:07 AM, Z4ys said:

When i am timewarping and my craft runs out of ox, food, ec, water I get the message that my craft runs out of xxx and it pulls me out of the warp. Everything fine so far. But normally that pull comes to late by the time the warp needs to stop the kerbals are already dead. Is it possible to edit the kerbalism settings so the message, pull is triggered earlier while warping?

I'm not currently using Kerbalism in my current 1.4.1 career game, but what I used to do is limit my max warp speed, and it would usually stop before things got too bad.

Share this post


Link to post
Share on other sites
1 minute ago, njbrown09 said:

@N70 How are we supposed to get the fuel cell working? There is no hydrogen tanks we can use.

try supply tank?

20 minutes ago, acc said:

Hey,

great improvements with the latest update.

I got a problem: In map screen I can't get the body info window appear again. It disappeared (in version 1.3.2) at some point (or I accidentaly closed it) and I can't find a way to make it show up again. Tried the old Alt+N, reinstalling, updating to the latest version, checking the wiki and google, but no success.

key is B

Share this post


Link to post
Share on other sites

The food/water canisters can be switched between food/water/oxygen/ammonia/etc.

 

Also make sure you have CommunityResourcePack.

Share this post


Link to post
Share on other sites
1 minute ago, N70 said:

The food/water canisters can be switched between food/water/oxygen/ammonia/etc.

 

Also make sure you have CommunityResourcePack.

Oh lol im an idiot. Thanks

Share this post


Link to post
Share on other sites

1.4.0.1 is now out. It fixes some background errors that were spamming the logs.

Share this post


Link to post
Share on other sites
Spoiler

 

I seems that AntennaHelper is really borked now, it was already like that with Kerbalism 1.4.0.0 - but not from scratch, it happened in the middle of my session.

As I've seen you updated Kerbalism to 1.4.0.1 I hoped THAT issue is gone.

Now, with Kerbalism 1.4.0.1 it's from scratch, as soon as I enter the SPC I get asked by kOS which connnectivity manager I should use - so the info was gone.

And the AntennaHelper icon is gone...

I found this in the log:


NullReferenceException: Object reference not set to an instance of an object
  at AntennaHelper.AHShipList.GetShipList (Boolean editorShip, Boolean flyingShip) [0x00000] in <filename unknown>:0 
  at AntennaHelper.AHEditor.GetShipList () [0x00000] in <filename unknown>:0 
  at AntennaHelper.AHEditor.Start () [0x00000] in <filename unknown>:0 
 

Full log:
https://www.dropbox.com/s/sjyntm0zr74dryx/2018-03-27_1 KSP.log.7z?dl=1

 

Edit:

Sorry, my bad, I just have overwritten the Kerbalism settings prior updating...

Suggestion:
Add a file DefaultSettings.cfg and put both into a PluginData folder and let the mod create the settings file from the default settings as long no settings are existing ...

It's because in most other mods it's something like that and the chance to just overwrite the settings is not so big.

Edited by Gordon Dry

Share this post


Link to post
Share on other sites

I love and strongly support the signal to KSC rather than the centre of the Kerbin. Well done! This may make me shift from remote tech (although I am addicted to sognal delay and that nav computer).

@N70 personally I'd love to see tac-ls containers in kerbalism. Do you think it's something achievable and implementable?

Share this post


Link to post
Share on other sites

Are you planning to support the Making History expansion? Currently I have to remove Kerbalism every time I want to play/build a mission, otherwise I get a constant nullref spam when piloting and the scenario starts falling apart until Kthulhu swallows the universe... The vanilla scenarios are fine (Kerbalism simply disables itself in those) but missions are borked.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.