N70

[1.4.0 <-> 1.7.1] Kerbalism v3.0.2

Recommended Posts

Cannot understand how to use communications with 1.4 Kerbalism update. >.<

High-gain antennas can connect only with KSC, and cannot relay signal. But all other ground stations have very low range.

So, how i can relay signal form Mun then KSC is beyond the horizon?

Share this post


Link to post
Share on other sites
3 hours ago, m4ti140 said:

Are you planning to support the Making History expansion? Currently I have to remove Kerbalism every time I want to play/build a mission, otherwise I get a constant nullref spam when piloting and the scenario starts falling apart until Kthulhu swallows the universe... The vanilla scenarios are fine (Kerbalism simply disables itself in those) but missions are borked.

I don't have Making History.

 

4 hours ago, Bersagliere81 said:

I love and strongly support the signal to KSC rather than the centre of the Kerbin. Well done! This may make me shift from remote tech (although I am addicted to sognal delay and that nav computer).

@N70 personally I'd love to see tac-ls containers in kerbalism. Do you think it's something achievable and implementable?

Try using configs?

2 hours ago, Domin1c said:

Cannot understand how to use communications with 1.4 Kerbalism update. >.<

High-gain antennas can connect only with KSC, and cannot relay signal. But all other ground stations have very low range.

So, how i can relay signal form Mun then KSC is beyond the horizon?

Kerbin relay network? Also, high-gain can connect with anything,  but they can't act as relays?

Share this post


Link to post
Share on other sites
5 minutes ago, N70 said:

I don't have Making History.

Do you have access to the related API then? So that you could make it disable itself when the missions are run, like it does in scenarios? It's kinda cumbersome having to uninstall it every time I want to go anywhere near the mission system

Share this post


Link to post
Share on other sites
5 minutes ago, m4ti140 said:

Do you have access to the related API then? So that you could make it disable itself when the missions are run, like it does in scenarios? It's kinda cumbersome having to uninstall it every time I want to go anywhere near the mission system

Even if I did, I can't test it.

Share this post


Link to post
Share on other sites
19 minutes ago, N70 said:

Also, high-gain can connect with anything,  but they can't act as relays?

Exactly.
At least i don't have such option.

Share this post


Link to post
Share on other sites
1 hour ago, Domin1c said:

Exactly.
At least i don't have such option.

Just... have a both high gain and low gain on the craft?

Share this post


Link to post
Share on other sites
On 3/26/2018 at 6:51 PM, popos1 said:

(and about my previous question: key for disable all notifications is pause break)

 

About the notifications, when you click on a vessel in the kerbalism monitor, click on the cfg tab.

WLnmubz.jpg

Once you click on that you'll see a list of notification tabs (like signal, batteries etc..) with a 'green tick' on the right column, click on the one you don't want to get alerts for.

 

23 hours ago, acc said:

Hey,

great improvements with the latest update.

I got a problem: In map screen I can't get the body info window appear again. It disappeared (in version 1.3.2) at some point (or I accidentaly closed it) and I can't find a way to make it show up again. Tried the old Alt+N, reinstalling, updating to the latest version, checking the wiki and google, but no success.

 

Try pressing B in the map view.

 

 

22 hours ago, Jade_Falcon said:

I'm not currently using Kerbalism in my current 1.4.1 career game, but what I used to do is limit my max warp speed, and it would usually stop before things got too bad.

 

Clever :cool:

 

 

6 hours ago, m4ti140 said:

Are you planning to support the Making History expansion? Currently I have to remove Kerbalism every time I want to play/build a mission, otherwise I get a constant nullref spam when piloting and the scenario starts falling apart until Kthulhu swallows the universe... The vanilla scenarios are fine (Kerbalism simply disables itself in those) but missions are borked.

 Why not create a different install?

Edited by Nathangun

Share this post


Link to post
Share on other sites
2 hours ago, Domin1c said:

Exactly.
At least i don't have such option.

I came here to ask the same thing. I'm being stupid. If you go to one of your commsats with a low gain antenna you can set it to act as a relay. I don't know if I just missed that part or if I have screwed something up along the way but now my networks seem to be working :)

 

@N70  Thank you for picking the development of this mod up. I have thousands of hours of experience with all sorts of difficulty mods and so far this is probably the most fun I've had. I really look forward to taking my current career further. I've only been using this since KSP 1.4.1 but the changes you have implemented are great!

Share this post


Link to post
Share on other sites
14 hours ago, Zoso14892 said:

I came here to ask the same thing. I'm being stupid. If you go to one of your commsats with a low gain antenna you can set it to act as a relay. I don't know if I just missed that part or if I have screwed something up along the way but now my networks seem to be working :)

Ok, I'm sending a probe with high & low gain antennas to Duna. There is link with DSN, but only few hours per day, when KSC Mission Control antenna (strongest one) facing my probe. So I can't establish stable connection without relaying high-gain signal, even with most powerfull antenna.

Share this post


Link to post
Share on other sites

I run in a odd problem on my early space program, where I only have directional solar panels. The Kerbalism calculations for EC seems to not take into account that a craft would align itself to the sun all the time, so I have to jump from craft to craft to make the game recognize that it still has power input. This is especially a big issue when you want to timewarp for a while (as example to finish one or more time based contracts) and on manned vessels, since the life support systems are shutting down.

Is there a way around this issue? I really like the mod, but it's no fun to jump from vessel to vessel all the time.

Edited by acc

Share this post


Link to post
Share on other sites
20 hours ago, N70 said:

Just... have a both high gain and low gain on the craft?

It doesn't help, high-gain antenna cannot connect with high-gain antenna.

b85c7-clip-500kb.jpg?nocache=1

Share this post


Link to post
Share on other sites

Kerbalism 1.4.0.2 is out. The only changes is that it is now compiled against KSP 1.4.2, and that the signal monitor will now show the ground station it's connected to.

2 hours ago, Domin1c said:

It doesn't help, high-gain antenna cannot connect with high-gain antenna.

b85c7-clip-500kb.jpg?nocache=1

yes, but you can connect a powerful high gain to a low gain.

Share this post


Link to post
Share on other sites
28 minutes ago, N70 said:

yes, but you can connect a powerful high gain to a low gain.

Hmm. How?

I'm feeling like missing something important tbh. I see that high-gain antenna can only connect to ground stations IF both sides have sufficient range.

Edited by Domin1c

Share this post


Link to post
Share on other sites

Does the last fix has something to do with

[Kerbalism] error while trying to parse 'HideGroundStationsDist' from Kerbalism (Input string was not in the correct format)

?

Because I still use 1.4.0.1 - I didn't jump-switch to KSP 1.4.1 :D

Share this post


Link to post
Share on other sites
3 hours ago, Domin1c said:

Hmm. How?

I'm feeling like missing something important tbh. I see that high-gain antenna can only connect to ground stations IF both sides have sufficient range.

I am pretty sure that high-gain antennas can connect to relays, they just can't BE relays

Share this post


Link to post
Share on other sites
On 27/3/2018 at 9:36 PM, N70 said:

Try using configs?

I don't know, I am not familiar with programming.

Btw I am updating Kerbalism via CKAN and it gives me an error message. I would say it's CKAN issue, but other mods have been successfully updated.

KSP 1.41 - Kerbalism installed 1.4.0.1 - Update 1.4.0.2

Error message:

Spoiler

Unhandled exception:
CKAN.InvalidModuleFileKraken: C:\Users\kmock\AppData\Local\Temp\tmpAD4B.tmp has length 3722547, should be 3722557
   in CKAN.NetModuleCache.Store(CkanModule module, String path, String description, Boolean move)
   in CKAN.NetAsyncModulesDownloader.ModuleDownloadsComplete(NetModuleCache cache, Uri[] urls, String[] filenames, Exception[] errors)
   in CKAN.NetAsyncModulesDownloader.<>c__DisplayClass8_0.<DownloadModules>b__3(Uri[] _uris, String[] paths, Exception[] errors)
   in CKAN.NetAsyncDownloader.triggerCompleted(Uri[] file_urls, String[] file_paths, Exception[] errors)
   in CKAN.NetAsyncDownloader.FileDownloadComplete(Int32 index, Exception error)
   in System.Net.WebClient.OnDownloadFileCompleted(AsyncCompletedEventArgs e)
   in System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   in System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   in System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
   in System.Threading.ThreadPoolWorkQueue.Dispatch()

 

Share this post


Link to post
Share on other sites
1 hour ago, Bersagliere81 said:

I don't know, I am not familiar with programming.

Btw I am updating Kerbalism via CKAN and it gives me an error message. I would say it's CKAN issue, but other mods have been successfully updated.

KSP 1.41 - Kerbalism installed 1.4.0.1 - Update 1.4.0.2

Error message:

  Reveal hidden contents

Unhandled exception:
CKAN.InvalidModuleFileKraken: C:\Users\kmock\AppData\Local\Temp\tmpAD4B.tmp has length 3722547, should be 3722557
   in CKAN.NetModuleCache.Store(CkanModule module, String path, String description, Boolean move)
   in CKAN.NetAsyncModulesDownloader.ModuleDownloadsComplete(NetModuleCache cache, Uri[] urls, String[] filenames, Exception[] errors)
   in CKAN.NetAsyncModulesDownloader.<>c__DisplayClass8_0.<DownloadModules>b__3(Uri[] _uris, String[] paths, Exception[] errors)
   in CKAN.NetAsyncDownloader.triggerCompleted(Uri[] file_urls, String[] file_paths, Exception[] errors)
   in CKAN.NetAsyncDownloader.FileDownloadComplete(Int32 index, Exception error)
   in System.Net.WebClient.OnDownloadFileCompleted(AsyncCompletedEventArgs e)
   in System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   in System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   in System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
   in System.Threading.ThreadPoolWorkQueue.Dispatch()

 

Still a CKAN issue, report it to them

Share this post


Link to post
Share on other sites
10 hours ago, N70 said:

I am pretty sure that high-gain antennas can connect to relays, they just can't BE relays

Feeling I'm doing something wrong = / Relay1 has 1 high-gain & 4 low-gain antennas, 2 of them are in relay mode. Relay2 has 2 high-gain & 2 low-gain antennas. Relay2 can connect to DSN only when there is a dirrect link. I was able to establish a relay connection only between 2 low-gain antennas.
Could you please provide some tutorial or guide how to establish relay network?

Spoiler

Image

Share this post


Link to post
Share on other sites

@Domin1c I had the same issue, switched to comm net until the update fixed the bug ...

Right now on Unix CKAM the update leads to a CTD - manual installation works, of course.

Edited by micha_ms
did forget to mention ..

Share this post


Link to post
Share on other sites

First a very big Thank You for maintaining Kerbalism, the best mod besides KSPIE - what leads to my question:

- Emulating the devices of KSPIE in Kerbalism is to much to be done, but: if only the electricity generating reactors (or the generators) would get a fixed value instead of beieng not simulated at all.

Would it be possible to set a fixed production rate for parts (not only KSPIE) instead of not simulating them?

- Since ever I get the message "electronic producer shows unexpected behavior at high warp ...." This is another example where "less would be more" - IMHO - or I need to know how to "not to get this error", I already know how I can live with it, but it is SO annoying!

Thanks again, these are the by far biggest issues I have with this wonderful mod and I hope to express the wishes of others with this as well.

Share this post


Link to post
Share on other sites

Since you updated Kerbalsim last, I get an error massage, while updating. So I deinstalled Kerbalism and now I am not able to install it again with the fallowing massage:

Spoiler

Unhandled exception:
CKAN.InvalidModuleFileKraken: C:\Users\steve\AppData\Local\Temp\tmp9DD4.tmp has length 3722547, should be 3722557
   bei CKAN.NetModuleCache.Store(CkanModule module, String path, String description, Boolean move)
   bei CKAN.NetAsyncModulesDownloader.ModuleDownloadsComplete(NetModuleCache cache, Uri[] urls, String[] filenames, Exception[] errors)
   bei CKAN.NetAsyncModulesDownloader.<>c__DisplayClass8_0.<DownloadModules>b__3(Uri[] _uris, String[] paths, Exception[] errors)
   bei CKAN.NetAsyncDownloader.triggerCompleted(Uri[] file_urls, String[] file_paths, Exception[] errors)
   bei CKAN.NetAsyncDownloader.FileDownloadComplete(Int32 index, Exception error)
   bei System.Net.WebClient.OnDownloadFileCompleted(AsyncCompletedEventArgs e)
   bei System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   bei System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   bei System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
   bei System.Threading.ThreadPoolWorkQueue.Dispatch()

 

Other mods are not a problem to installed. I use CKAN however.

Hope you can help. Thanks in advance and kind regards.

 

EDIT:

Just saw  Bersagliere81 has the same issue and your answer, that it's caused by CKAN. So, please don't mind the post (haven't found a possbility to delete my post yet).

 

Edited by zulu354

Share this post


Link to post
Share on other sites

@N70 Hi! I have an issue: sometimes connection suddenly disappear. After that if I exit to main menu, all options are faint and inactive — I can't click on any of them. After that I check local files in steam, it says that one file is damaged and download it, but nothing fixes. My Kerbalism version is 1.4.0.2; KSP v. 1.4.2.

XDK9Ivb.jpg

 

fMTq5SP.png

Edited by player101

Share this post


Link to post
Share on other sites

@N70 just a heads up, the new connection ground station thing doesn’t work with RSS or any planet packs that aren’t kerbins radius (I’ve only tried RSS and GPP). It seems that the stations are under the ground.

Edited by njbrown09

Share this post


Link to post
Share on other sites
5 hours ago, micha_ms said:

I had the same issue, switched to comm net until the update fixed the bug ...

Its not bug actually.

HG antennas cant relay signal. Its intended behavior. But to establish a connection, both sides must have sufficient range, and so HG antenna in the moon's orbit can not establish a connection with the  LG antenna in the LKO.

Previously, this system worked well. But now, when we have these awesome ground stations - no longer. The range is sufficient only for KSC.

I have made simple test - modified configs so all antennas become LG, in these case signal network works just fine.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.