N70

[1.5.0 <-> 1.8.1] Kerbalism v3.2

Recommended Posts

 

On 18/04/2018 at 3:16 AM, mikegarrison said:

Hi, I played the old Kerbalism for a while and there were two things that ended up driving me away. One was that for missions of any reasonable length I had to totally spam the spacecraft with nitrogen bottles. The other, that was even more gamebreaking, was that it would occasionally decide my near future reactor-powered ships in warp had no electricity and would insta-kill my crews. Have these issues been addressed?

It also bothered me that I couldn't build a "storm shelter" for radiation. The overall ship radiation protection was always averaged out, even if I tried to have some parts of the ship that were thinly protected and others with heavy shielding. Is this still how it works?

The nitrogen issue you discuss is probably still there.  One way to stop the tank spam would be to repurpose the largest monoprop tank and fill it with nitrogen.

For storm shelters, @geb is right.  It still works this way i believe.  Turning off the habitat is the only way.  I think ShotgunNinja couldn't work out a great way to force players to use a shelter - kerbalism treats kerbals as roaming free across a vessel like engineers manipulating ISRU rates in stock.

In saying that, a storm shelter could perhaps be coded like the stock science lab.  Only provides shelter when kerbals are living inside it? The weight of shielding would be applied when the module is 'setup' in kerbalism but would operate differently to stock shielding by only working when used by kerbals with penalties of suspending the rest of the vessel's volume counter for stress.  Pinging @N70.

Perhaps that coding model could be applied to a good, working recieved radiation health clinic or even a pyscho-analysis studio for reducing accumulated stress?

Peace.

EDIT I'm unsure as to the high warp stability these days.

Edited by theJesuit

Share this post


Link to post
Share on other sites
1 hour ago, Valyria said:

Hello, I have a problem with Kerbalism I think. The consumption of resources (oxigen, water ...), research and data transmission stops when I no longer control the ship. I tested the vetion 88 and the 90 (small additional bug with this one, the distance of interseption during a maneuvre does not appear any more) and I am under KSP 1.4.2
An idea of how to solve my temporal problem?

I take the opportunity to thank you and congratulate you for your mod.

try jenkins build

Share this post


Link to post
Share on other sites

At some point Kerbalism was intended to be run alongside the Connected Living Spaces mod, but that was many versions ago, and the link seems to have disappeared from the wiki anyway.

I have absolutely no idea how the two mods interact now.

That was one of the original intended methods to create a storm shelter, or an airlock. I guess ShotgunNinja never wanted to add CLS as a requirement, but then if it was optional nobody ever used it.

Edited by geb

Share this post


Link to post
Share on other sites
2 hours ago, Valyria said:

Hello, I have a problem with Kerbalism I think. The consumption of resources (oxigen, water ...), research and data transmission stops when I no longer control the ship. I tested the vetion 88 and the 90 (small additional bug with this one, the distance of interseption during a maneuvre does not appear any more) and I am under KSP 1.4.2
An idea of how to solve my temporal problem?

I take the opportunity to thank you and congratulate you for your mod.

Read KSP.log.  Usually when this happens the log spams nullrefs that point to the source of the problem.  Previously CryoTanks caused this, for example.

EDIT: Oops, didn't refresh. Sure, try the jenkins build.

Edited by lordcirth

Share this post


Link to post
Share on other sites

I tested the build 92, without change.
I then removed the folder "CryoTanks", and there, victory! Time is running out !
Domage for Cryogenic Engines, but in between, I prefer Kerbalism !

Thank you for the help !

Share this post


Link to post
Share on other sites

Kerbalism 1.5.1 will be out as soon as Haully finalizes SSPX support

Share this post


Link to post
Share on other sites

Hello! I'm getting a couple errors from ModuleManager upon launching the game related to Kerbalism. I have over 60 mods installed and started with a clean install to determine which one was causing the problem. It's affecting both MKS and StationPartsExpansionRedux mod.

Any idea why?

Is there any way to provide you with a better log?

Thanks for the help.

QPDklyx.jpg

Edited by 1990eam

Share this post


Link to post
Share on other sites

... KERBALISM DOESN'T WORK WITH MKS, AND IT WON'T WORK WITH SSPX UNTIL 1.5.1!

Share this post


Link to post
Share on other sites
On 4/18/2018 at 6:22 PM, 1990eam said:

Hello! I'm getting a couple errors from ModuleManager upon launching the game related to Kerbalism. I have over 60 mods installed and started with a clean install to determine which one was causing the problem. It's affecting both MKS and StationPartsExpansionRedux mod.

Any idea why?

 

The SSPX one is caused by Kerbalism replacing the inflatable things with its own, then SSPX tries to add MKS workspace for them and errors. I fixed this in my own copy (until 1.5.1 is available) by adding checks and using the values from Kerbalism's stuff if it's installed. If you want it, just replace the SSPX file (the location is in your screenshot) with this one: SSPXR-MKS-Extras.cfg

The MKS one is caused by it trying to add Water as an output to the stock fuel cells. I just commented this one out, but again if you want it, same deal: StockTweaks.cfg

Edited by Maeyanie

Share this post


Link to post
Share on other sites

SSPRx isn't working with this well, the rotating habitats don't rotate and they don't allow people in them, they also don't allow you to remain pressurized and they close when pressurized is enabled

Share this post


Link to post
Share on other sites
28 minutes ago, The-Doctor said:

SSPRx isn't working with this well, the rotating habitats don't rotate and they don't allow people in them, they also don't allow you to remain pressurized and they close when pressurized is enabled

Two posts above yours.

Edited by theJesuit

Share this post


Link to post
Share on other sites

I have an question about Kerbalism. Most of it works for me but 1 thing I cant get to work for me.

on the groups and filtering toolbar i can see my crafts/ current craft and select them. But then the Toolbar does nothing at all.

It does not show any Info except battery and sunlight status. the settings button does not show and no info is shown. the popup window that should appear does not show up,

Link to some pics

https://imgur.com/2dmFAa8

 

Is this a bug or a feature or do I miss something?

Deinstalled KSP, deleted the KSP folder and only installed Kerbaism. still the same.

Looked at the config and settings files everything is enabled there so I am lost.

Edit:

Same problem on an running Flight. Steam Version of the game set to english (because most mods don´t work localized)

English is not my native language, sry for error and i hope it is understandable.

 

Edit 2: Game version 1.42 latest kerbalism release, can provide a savegame if needed,  search on google for the problem : no results.  Some tests made fresh install, downloded kerbalism from spacedock and with ckan.

Edited by SchitzoSchaf
added even more info

Share this post


Link to post
Share on other sites

when i hover my mouse to see how much time is left(food wáter etc) i cant zoom in or out

Edited by KerbolExplorer

Share this post


Link to post
Share on other sites

Any chance we can get limited compatibility with MKS so the MKS parts at least somewhat function (having appropriate living spaces/stress reducing bonus things that I can't think of the right word for) while using Kerbalism systems? I don't care too much about getting the various MKS systems to function with Kerbalism (would be nice, but I can imagine how much of a pain in the rear it would be haha), but I like the looks of MKS parts in my stations/surface outposts. Some of the parts already have appropriate volumes, but the inflatable habitats don't have any function.

Share this post


Link to post
Share on other sites

I know Kerbalism's internal signal mechanic was removed a few builds ago, but when in use with RemoteTech, Kerbalism signal isn't detecting other connected ships/satellites in the background. The only time all flights/ships/satellites are showing connected is when you view them from the tracking station. This is causing crew stress (No Calls home) for ships in the background to rise more quickly despite a connection being maintained. I'm using the latest Kerbalism Jenkins build w/ RT 1.8.10.3. Is there a work-around/fix for this?

 

7093E3100FC1074BE68B44B2432CF5D4345F5CCE

Share this post


Link to post
Share on other sites

@N70 As a humble reminder and to ask "again" - I just want to know if there is a workaround yet or

  1. can this be fixed within Kerbalism alone?
  2. can this only be fixed with a new Module Manager build? (> 3.0.6)
  3. or can this only be fixed by KSP core itself?

I ask because I have some answers, but not enough for a clear picture of what's really going on:

[EXC 19:25:21.518] NullReferenceException: Object reference not set to an instance of an object
	ConfigNode.CopyToRecursive (.ConfigNode node, Boolean overwrite)
	ConfigNode.CopyToRecursive (.ConfigNode node, Boolean overwrite)
	ConfigNode.CopyTo (.ConfigNode node, System.String newName)
	ModuleManager.MMPatchLoader.ModifyNode (ModuleManager.Collections.ImmutableStack`1 original, .ConfigNode mod, PatchContext context)
	ModuleManager.PatchApplier.ApplyPatches (System.String stage, IEnumerable`1 patches)
	UnityEngine.Logger:LogException(Exception)
	ModuleManager.Logging.ModLogger:Exception(String, Exception)
	ModuleManager.Logging.ExceptionMessage:LogTo(IBasicLogger)
	ModuleManager.<ProcessPatch>d__33:MoveNext()
	UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)
[ERR 19:25:21.518] [ModuleManager] Processed node was
Kerbalism/Support/ContractConfigurator/@CONTRACT_TYPE[*]
  @CONTRACT_TYPE[*]
  {
    @PARAMETER[*]:HAS[#partModule[ModuleScienceLab]]
    {
      @partModule = Laboratory
    }
    @PARAMETER[*]
    {
      @PARAMETER[*]:HAS[#partModule[ModuleScienceLab]]
      {
        @partModule = Laboratory
      }
      @PARAMETER[*]
      {
        @PARAMETER[*]:HAS[#partModule[ModuleScienceLab]]
        {
          @partModule = Laboratory
        }
        @PARAMETER[*]
        {
          @PARAMETER[*]:HAS[#partModule[ModuleScienceLab]]
          {
            @partModule = Laboratory
          }
        }
      }
    }
    @REQUIREMENT[*]:HAS[#partModule[ModuleScienceLab]]
    {
      @partModule = Laboratory
    }
    @REQUIREMENT[*]
    {
      @REQUIREMENT[*]:HAS[#partModule[ModuleScienceLab]]
      {
        @partModule = Laboratory
      }
      @REQUIREMENT[*]
      {
        @REQUIREMENT[*]:HAS[#partModule[ModuleScienceLab]]
        {
          @partModule = Laboratory
        }
        @REQUIREMENT[*]
        {
          @REQUIREMENT[*]:HAS[#partModule[ModuleScienceLab]]
          {
            @partModule = Laboratory
          }
        }
      }
    }
  }


 

Share this post


Link to post
Share on other sites

After reading the last 5 pages I solved the problem with downloading build 92 from jenkins. Strange that I could not find that solution earlier.

Share this post


Link to post
Share on other sites
19 hours ago, evilman222 said:

Any chance we can get limited compatibility with MKS so the MKS parts at least somewhat function.

I've been working on this, as soon as its ready I will throw in a PR for @N70 to look at

 

19 hours ago, KerbolExplorer said:

when i hover my mouse to see how much time is left(food wáter etc) i cant zoom in or out

Try the latest Jenkins build :wink:

https://jenkins.spaceball.cf/job/Kerbalism/92/artifact/Kerbalism.zip

Edited by PiezPiedPy

Share this post


Link to post
Share on other sites

Is it possible to reset materials bay and mystery goo from laboratory as it was without Kerbalism? EVA each time is kind of boring.

Share this post


Link to post
Share on other sites
14 hours ago, PiezPiedPy said:

I've been working on this, as soon as its ready I will throw in a PR for @N70 to look at

 

Okay awesome!

Share this post


Link to post
Share on other sites

I don't think it is related to Kerbalism... but I'm still asking. Maybe someone knows something. ... could you imagine why ships in 1.4.2 are rotating? SAS runs constantly and after a while it cannot control the rotation anymore and ... the longer the mission goes, the more I do have this rotations. After a while I cannot keep it... not even manually. I already said, I don't think it is related to Kerbalism... but I've been told that it could be some sort of "mod conflict" ... I don't know... I personally think, that it also happens without mods installed. But... maybe you know more...

sorry for asking this here... I know it's not a "support thread" ... but I do have to exclude this possibility. Otherwise all I will hear from support is "it could be related to mod xy"

Share this post


Link to post
Share on other sites
2 hours ago, Rudolf Meier said:

I don't think it is related to Kerbalism... but I'm still asking. Maybe someone knows something. ... could you imagine why ships in 1.4.2 are rotating? SAS runs constantly and after a while it cannot control the rotation anymore and ... the longer the mission goes, the more I do have this rotations. After a while I cannot keep it... not even manually. I already said, I don't think it is related to Kerbalism... but I've been told that it could be some sort of "mod conflict" ... I don't know... I personally think, that it also happens without mods installed. But... maybe you know more...

sorry for asking this here... I know it's not a "support thread" ... but I do have to exclude this possibility. Otherwise all I will hear from support is "it could be related to mod xy"

Perhaps trim settings?  Mod+X to cancel trim.  But that's odd if it applies to multiple craft.

Share this post


Link to post
Share on other sites

@Rudolf Meier I use a mod called 'PersistentRotation' to solve craft rotation problems.

Btw your problem probably wont be an issue with any mods you have installed, I've had it happen in stock KSP.

Share this post


Link to post
Share on other sites
58 minutes ago, PiezPiedPy said:

@Rudolf Meier I use a mod called 'PersistentRotation' to solve craft rotation problems.

Btw your problem probably wont be an issue with any mods you have installed, I've had it happen in stock KSP.

thanks ... that's what I think too... I'm currently writing a "trim surveillance mod" to investigate this

Share this post


Link to post
Share on other sites

The not being able to access status display in flight, and not being able to zoom out are caused by communication net being enabled in KSP under basic settings.

You can turn them off, or as someone earlier posted yes the 95 patch seems to fix it..

Edited by jmsmit2
tested, and because I'm old and slow

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.