N70

[1.5.0 <-> 1.8.1] Kerbalism v3.2

Recommended Posts

Hi, just installed the latest version but noticed the small supply container has disappeared from build menu.

Tried replacing new files in parts folder with old kerbalism files but no luck

Anyone have the same issue?

Any ideas how to solve? Cheers

Share this post


Link to post
Share on other sites

Hello, new member, but have been using Kerbalism since making history came out.  Steam updated my KSP, to 1.6, and Kerbalism ceased to work.  I was happy to see it was updated to work, however, as with all things it is not so simple.   I installed this update the same as I installed the mod before (dropping the "kerbalism" folder into game data.  But when I start the game I get AVC asking if it can look for updates, and when the program starts I do get the icon for Kerbalism, BUT resorces such as food, oxygen, and other consumables are missing.  The little lunch box icon for these is absent from the status board.  In the VAB, none of the pods are configurable.  I have tried reinstalling the mod with the same results.  Any idea what is happening?

Share this post


Link to post
Share on other sites
8 hours ago, nc8184l said:

Hello, new member, but have been using Kerbalism since making history came out.  Steam updated my KSP, to 1.6, and Kerbalism ceased to work.  I was happy to see it was updated to work, however, as with all things it is not so simple.   I installed this update the same as I installed the mod before (dropping the "kerbalism" folder into game data.  But when I start the game I get AVC asking if it can look for updates, and when the program starts I do get the icon for Kerbalism, BUT resorces such as food, oxygen, and other consumables are missing.  The little lunch box icon for these is absent from the status board.  In the VAB, none of the pods are configurable.  I have tried reinstalling the mod with the same results.  Any idea what is happening?

Kerbalism requires the Community Resource Pack.

 

Share this post


Link to post
Share on other sites

The Community Resource Pack should work regardless of being updated or not.

Peace.

Share this post


Link to post
Share on other sites

I don't recall dealing with a community resource pack when I first install Kerbalism.  Where is it located?

Share this post


Link to post
Share on other sites
1 hour ago, nc8184l said:

I don't recall dealing with a community resource pack when I first install Kerbalism.  Where is it located?

Peace.

Share this post


Link to post
Share on other sites

That is for modders, not for those implementing the mods.  The mod worked fine BEFORE 1.6 hit.  Now it only partially works, but is missing the consumables features.

 

 

Edited by nc8184l
added second sentence

Share this post


Link to post
Share on other sites

Some mods include it @nc8184l others list it as a dependency.  It is possible you installed it with something else previously? The first post in kerbalism lists it as a requirement along with Module Manger which is also not supplied in the kerbalism downloads.

When you say consumables do you mean oxygen nitrogen ammonia food and water... or actual 'Consumables'?

Peace.

Share this post


Link to post
Share on other sites

Consumables like food, water, oxygen.  The stuff that appears in the little box in the status indicator (which is missing).  Electrical stuff works though.  Also, why was this not included in the update of the mod?  I just would like Kerbalism so work really.

 

Edited by nc8184l

Share this post


Link to post
Share on other sites

I found the issue.  I had USI installed, but I removed it, but also removed the folder "Community Resorces pack.  It was my error, and has been corrected.  My Kerbals now have and need food.  :P

 

Share this post


Link to post
Share on other sites
4 hours ago, nc8184l said:

why was this not included in the update of the mod?

Personal preference of the mod makers

Share this post


Link to post
Share on other sites

New issue.  Got the mod to work, food is back, but now electrical systems are messed up.  They charge up, but then CRASH, and I mean crash, right to 0, no flow, no anything, just ZAP, gone.  This is on all my ships, gonna lose some kebals to this I fear.  Trying to get the ones out, home, while sorting out what is going on.  ***  Nevermind, issue sorted.  Another missing file)

 

Edited by nc8184l

Share this post


Link to post
Share on other sites
2 hours ago, nc8184l said:

New issue.  Got the mod to work, food is back, but now electrical systems are messed up.  They charge up, but then CRASH, and I mean crash, right to 0, no flow, no anything, just ZAP, gone.  This is on all my ships, gonna lose some kebals to this I fear.  Trying to get the ones out, home, while sorting out what is going on.  ***  Nevermind, issue sorted.  Another missing file)

LOL.  Panic panic panic. Oh nah it's all sweet as.

Peace.

Share this post


Link to post
Share on other sites

@N70 I discovered a rather game breaking bug with the latest version of kerbalism in 1.6. It prevents you from right clicking the parts.

Share this post


Link to post
Share on other sites
3 hours ago, The-Doctor said:

@N70 I discovered a rather game breaking bug with the latest version of kerbalism in 1.6. It prevents you from right clicking the parts.

That sounds unfortunately  like the documented bug with ksp 1.6.  If it happens exit the game through the menus ie exit to KSC scene, exit to main menu and exit the game via the men option.  Then restart the game having NOT adjusted anything.  The game should now work properly.  This fault is in the way the game generates the partdatabase.cfg or somesuch.

Peace, and goodwill to you.

Share this post


Link to post
Share on other sites

Oh that's a shame, 1.6 so far has been fantastic. You think they'll drop a 1.6.1 soon? I've done exiting but it comes back. I realized it comes when I choose the new lander can

Share this post


Link to post
Share on other sites
On 12/24/2018 at 12:38 AM, theJesuit said:

Personal preference of the mod makers

He is speaking the truth. The consumables don't show even with community resource pack. I'll give it a second try 

Share this post


Link to post
Share on other sites
32 minutes ago, The-Doctor said:

Oh that's a shame, 1.6 so far has been fantastic. You think they'll drop a 1.6.1 soon? I've done exiting but it comes back. I realized it comes when I choose the new lander can

Have a look in the technical help forums.  The exit thing seems to be deal, but maybe verifying install through steam might be necessary for you too.

11 minutes ago, The-Doctor said:

He is speaking the truth. The consumables don't show even with community resource pack. I'll give it a second try 

Maybe bring it up in the discord server.  This must be a widely experienced issue.  I haven't got round to playing in 1.6 yet!

Peace.

Share this post


Link to post
Share on other sites

I have an issue with automation and spam log

KSP 1.5.1 

Kerbalism 2.1.1

 

[EXC 23:53:07.319] ArgumentNullException: Argument cannot be null.
Parameter name: key
    System.Collections.Generic.Dictionary`2[System.String,KERBALISM.Lib+Module_prefab_data].TryGetValue (System.String key, KERBALISM.Module_prefab_data& value)
    KERBALISM.Lib.ModulePrefab (System.Collections.Generic.List`1 module_prefabs, System.String module_name, System.Collections.Generic.Dictionary`2 PD)
    KERBALISM.Computer.Boot (.Vessel v)
    KERBALISM.DevManager.Devman (KERBALISM.Panel p, .Vessel v)
    KERBALISM.Monitor.Update ()
    KERBALISM.Launcher.Update ()
    KERBALISM.UI.Update (Boolean show_window)
    KERBALISM.Kerbalism.Update ()

Share this post


Link to post
Share on other sites
10 hours ago, theJesuit said:

Have a look in the technical help forums.  The exit thing seems to be deal, but maybe verifying install through steam might be necessary for you too.

Maybe bring it up in the discord server.  This must be a widely experienced issue.  I haven't got round to playing in 1.6 yet!

Peace.

@N70 how does signal work now? Does it work with commnet or is it meant to be it's own thing that replaces commnet?

Share this post


Link to post
Share on other sites
56 minutes ago, The-Doctor said:

@N70 how does signal work now? Does it work with commnet or is it meant to be it's own thing that replaces commnet?

It works with CommNet.  The big difference is that the connection always takes EC so that trains smiting doesn't require *more* EC.  Ie in stock you take along enough battery to do your one off transmissons.  In kerbalism now you have to generate enough to effectivly be always transmitting.  If you don't, your connection is lost when EC is drained but  then the batteries recharge, but then connection is made the batteries drain again.  So take enough generation.

Peace.

Share this post


Link to post
Share on other sites
18 minutes ago, theJesuit said:

It works with CommNet.  The big difference is that the connection always takes EC so that trains smiting doesn't require *more* EC.  Ie in stock you take along enough battery to do your one off transmissons.  In kerbalism now you have to generate enough to effectivly be always transmitting.  If you don't, your connection is lost when EC is drained but  then the batteries recharge, but then connection is made the batteries drain again.  So take enough generation.

Peace.

that sounds absolutely amazing, only question is will the blue orbs return? They were overly to show science returning home. Also I heard that kerbalism now has a way to heal radiation and madness to allow permanent bases? Does it really exist? I this true? And if so what parts and how does it work? I plan to run many space stations to test long term survival before I launch really long term missions, I mean interstellar sleeper ships. Starships, it's what I do.

Share this post


Link to post
Share on other sites
35 minutes ago, The-Doctor said:

that sounds absolutely amazing, only question is will the blue orbs return? They were overly to show science returning home. Also I heard that kerbalism now has a way to heal radiation and madness to allow permanent bases? Does it really exist? I this true? And if so what parts and how does it work? I plan to run many space stations to test long term survival before I launch really long term missions, I mean interstellar sleeper ships. Starships, it's what I do.

No, and I and i don't tend to get that far in saves to utilise them.  That are modules to add to parts.  You also need big numbers of resources. 

Also radiation is now cumulative. So for interstellar, deep freeze is still probably required as you don't want to keep habitats pressurised losing all that Nitrogen. But Deep Freeze doesn't reset kerbals stress and radiation either. 

Peace.

Share this post


Link to post
Share on other sites
11 hours ago, theJesuit said:

No, and I and i don't tend to get that far in saves to utilise them.  That are modules to add to parts.  You also need big numbers of resources. 

Also radiation is now cumulative. So for interstellar, deep freeze is still probably required as you don't want to keep habitats pressurised losing all that Nitrogen. But Deep Freeze doesn't reset kerbals stress and radiation either. 

Peace.

I don't understand. Is the no to the blue orbs? Also are you saying yes kerbalism has a way to heal radiation and madness now but it will just take a lòt of resources? I don't mind as long as I can make it closed looped. May I also suggest once again for a larger active shielding that takes a lot of power but provides total protection? If not can you tell me how to edit the values for the active shield? It is the only way I can have my interstellar missions with kerbalism which I'm in the prospect of testing the ship life support by making orbital stations 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.