maja

[KSP 1.7.3] Bon Voyage (0.5.3) - 2019-08-29

Recommended Posts

Just started using bon voyage but it says "bon voyage control lock active" trying to make a route several clicks out of the KSC for testing.

I followed all the steps and I have enough power.

Share this post


Link to post
Share on other sites
2 hours ago, Aeroboi said:

Just started using bon voyage but it says "bon voyage control lock active" trying to make a route several clicks out of the KSC for testing.

I followed all the steps and I have enough power.

You have to look away so the magic can happen. Rovers are known to be shy, so just switch to another scene or watch the progress secretly from the tracking station ;)

Share this post


Link to post
Share on other sites
1 hour ago, 4x4cheesecake said:

You have to look away so the magic can happen. Rovers are known to be shy, so just switch to another scene or watch the progress secretly from the tracking station ;)

A watched rover never roves...

Share this post


Link to post
Share on other sites

I want to second the requests for BV operating with fuel cells.  I've just upgraded my rover to use 4x TR-2L wheels drawing 3.5 amps each for a total of 14 amps.

I have one PB-NUK for standby current (0.75) plus 4x fuel cells providing 1.5 amps each for a total of 6.75.  The fuel cells are enough to keep the battery charged between mixed acceleration and coasting.

(So I'd need a total of 8 PB-NUKS to get the equivalent without fuel cells...?  I'll give this a try since I'd really like to have BV in operation again.)

I'll report back here on success -- or otherwise.  OK!  Well, it looks like it works comparably.  7 NUKs with the fuel cells turned off was not bad and the BV did work.  So, OK, I'll look at a redesign with no fuel/cells...  (The PB-NUKs are pretty bulky is the main drawback...)

UPDATE: OK, looks like a happy ending on this: I actually had 6 fuel cells under that buggy.  I've now got 6 NUKs and 2 fuel cells.  Everybody is happy.  I've posted this as Ninja for the curious...

POEHALI!!

Edited by Hotel26

Share this post


Link to post
Share on other sites
12 minutes ago, Hotel26 said:

I want to second the requests for BV operating with fuel cells.  I've just upgraded my rover to use 4x TR-2L wheels drawing 3.5 amps each for a total of 14 amps.

I have one PB-NUK for standby current (0.75) plus 4x fuel cells providing 1.5 amps each for a total of 6.75.  The fuel cells are enough to keep the battery charged between mixed acceleration and coasting.

(So I'd need a total of 8 PB-NUKS to get the equivalent without fuel cells...?  I'll give this a try since I'd really like to have BV in operation again.)

Noted :)

Share this post


Link to post
Share on other sites

Hi :)

I use Bon Voyage for the first time and it's awesome ! But i only use unmanned rover and the 80% malus of average speed is too slow !!

Is it possible to remove this feature ?

Share this post


Link to post
Share on other sites
5 hours ago, AK-pulco said:

Hi :)

I use Bon Voyage for the first time and it's awesome ! But i only use unmanned rover and the 80% malus of average speed is too slow !!

Is it possible to remove this feature ?

No. A remotely controlled rover doesn't have the same reaction time as a skilled pilot behind a wheel.

Share this post


Link to post
Share on other sites

Notice about the new update:

I'm in the middle of an overhaul, so you can wait few more days for me to finish it or if there is some critical bug (not counting a burried rover, this can be fixed by World stabilizer right now) I can do quick recompile for KSP 1.5.

Share this post


Link to post
Share on other sites

Small teaser. UI is almost done. The rest will be easier :)

TYSkTUal.png

Edited by maja
New image

Share this post


Link to post
Share on other sites

I just used CHEATS to attach a BV module to one of my rovers on IKE. Hope it works.

UPDATE: After it reached its destination I reloaded to it, and it was falling through the surface of Ike. I now have to reload the game from my backup drive.

Has this mod been abandoned?

Edited by Zosma Procyon

Share this post


Link to post
Share on other sites
38 minutes ago, Zosma Procyon said:

I just used CHEATS to attach a BV module to one of my rovers on IKE. Hope it works.

UPDATE: After it reached its destination I reloaded to it, and it was falling through the surface of Ike. I now have to reload the game from my backup drive.

Has this mod been abandoned?

No, it's not abandoned....just one post above yours, maja told us about the work on an overhaul and that the 'burried rover'' bug (which is probably the reason for your rover falling through Ike) can be fixed by using the world stabilizer mod.

 

Share this post


Link to post
Share on other sites
1 hour ago, Zosma Procyon said:

I just used CHEATS to attach a BV module to one of my rovers on IKE. Hope it works.

UPDATE: After it reached its destination I reloaded to it, and it was falling through the surface of Ike. I now have to reload the game from my backup drive.

Has this mod been abandoned?

As @4x4cheesecake wrote, you can use World stabilizer or alternativelly change vessel height in a save file. It seems, that KSP is sometimes returning wrong terrain height at given coordinates.

And no, this mod isn't abandoned. There is a devel branch and issue on the github, where you can see the progress of the overhaul.

Share this post


Link to post
Share on other sites
11 hours ago, maja said:

As @4x4cheesecake wrote, you can use World stabilizer or alternativelly change vessel height in a save file. It seems, that KSP is sometimes returning wrong terrain height at given coordinates.

And no, this mod isn't abandoned. There is a devel branch and issue on the github, where you can see the progress of the overhaul.

When I say it was falling through the surface, I mean it was IN FREE FALL under the surface, and I don't actually know how to edit the save file on a mac, or PC for that matter, but I use a Mac.

I'll look into this "world stabilizer" when I get the chance.

Share this post


Link to post
Share on other sites
21 minutes ago, Zosma Procyon said:

When I say it was falling through the surface, I mean it was IN FREE FALL under the surface, and I don't actually know how to edit the save file on a mac, or PC for that matter, but I use a Mac.

I'll look into this "world stabilizer" when I get the chance.

I understand, what you meant by falling through suface. It happens sometimes and I have fixes in the new version which hopefully deals with it once and for all.

 

Share this post


Link to post
Share on other sites
46 minutes ago, maja said:

I understand, what you meant by falling through suface. It happens sometimes and I have fixes in the new version which hopefully deals with it once and for all.

 

Do you have it for the last release of 1.4? I haven't updated yet as the Mac version of 1.5 doesn't seem to work yet.

Share this post


Link to post
Share on other sites
32 minutes ago, Zosma Procyon said:

Do you have it for the last release of 1.4? I haven't updated yet as the Mac version of 1.5 doesn't seem to work yet.

Go to the Spacedock page of the mod, switch to Changelog tab and download the propper version. I see there version 0.9.2 for Kerbal Space Program 1.4.3.

Share this post


Link to post
Share on other sites

Nearly there...

a7iK3mjm.png

...aaand we are moving :cool:

Just "a few" fixes remains and it's ready.

Edited by maja

Share this post


Link to post
Share on other sites

I just added a BV module and a better antenna to my oldest mobile base, and sent is a quarter of the way around Ike. It got there, but even with World Stabilizer it was partially inside Ike when I loaded back into it. It ended up the right way up, but the ordeal still broke it a bit. Still since I didn't have to drive it 174 km, it's fair trade. 

LU7fj08.png

Share this post


Link to post
Share on other sites

*drums*

Ladies and gentlemens, WE ARE LIVE!

Bon Voyage 0.14.0 for KSP 1.5.1 is here. It took a while, but that time has finally come. Overhaul is done and BV is prepared for a new voyage, which brings us to the seas in the near future.

Download it on Spacedock and GitHub

Enjoy! :cool:

 

0.14.0 - New voyage
Changes

  • KSP 1.5.1 compatibility
  • Major overhaul - We are getting ready to extend our operations to the water in the future.
  • Localization support
  • KSPWheel module system check change
    • Required EC is scaled by a motor's output setting
    • Maximum speed is taken from maxDrivenSpeed field, which is scaled by gear setting, and capped at max safe speed
  • Direct input of target coordinates
  • Stabilization of a rover during scene switching into flight, if it's moving or just arrived at a destination. The function is switched off, if World Stabilizer or BD Armory is present.
  • Updated Wiki
  • Added MiniAVC
Edited by maja

Share this post


Link to post
Share on other sites

@maja thanks for the update, you did a really good job on the overhaul! The new UI is wonderful and so far, my rover spawns perfectly fine, slightly above the surface, even on a slope :)

Well, I may found a little bug anyway. The result of the 'System check' is just displayed within the console (actually it is a warning saying  'maxWheelSpeed = 59'). Not quiet sure what is supposed to happen but I've expected a message on the screen, telling me the result of the test or something similar. So far, I cannot see anything happens when I hit the button.

 

Share this post


Link to post
Share on other sites
18 minutes ago, 4x4cheesecake said:

@maja thanks for the update, you did a really good job on the overhaul! The new UI is wonderful and so far, my rover spawns perfectly fine, slightly above the surface, even on a slope :)

Well, I may found a little bug anyway. The result of the 'System check' is just displayed within the console (actually it is a warning saying  'maxWheelSpeed = 59'). Not quiet sure what is supposed to happen but I've expected a message on the screen, telling me the result of the test or something similar. So far, I cannot see anything happens when I hit the button.

 

Ah, I see it. This is only a debug message I forgot to delete.

You can see the result of a system check in the controller window. It just automatically runs when you open that window. System check button is there to rerun it, if you change some setting (start reactor, switch off wheel motor etc.) and have controller window open. I may add tooltip to the buton or screen message to make it clearer.

 

The advantage of the new UI is automatic rescale depending on main settings. And of course, it was past due to use the new gui functions.

And try right click on the toolbar button. It opens Controller window ;)

Edited by maja

Share this post


Link to post
Share on other sites
5 minutes ago, maja said:

Ah, I see it. This is only a debug message I forgot to delete.

You can see the result of a system check in the controller window. It just automatically runs when you open that window. System check button is there to rerun it, if you change some setting (start reactor, switch off wheel motor etc.) and have controller window open. I may add tooltip to the buton or screen message to make it clearer.

Ok :)

Every other button actually displays a message (or open the map view), so I got confused when nothing happened after the system check. A tooltip sounds like a good idea :)

7 minutes ago, maja said:

And try right click on the toolbar button. It opens Controller window ;)

Handy little feature, nice!

Share this post


Link to post
Share on other sites

Small bug fix release:

BonVoyage 0.14.0.1 for KSP 1.5.1

Download it on Spacedock and GitHub

 

0.14.0.1
Fixes

  • Fixed rover skipping kilometers forward to the target under some circumstances
  • Removed forgotten harmless debug warning message

Changes

  • Added tooltip to the *System check* button to better explain it's function
Edited by maja

Share this post


Link to post
Share on other sites

New update. If you found problems with rover rotating in wrong direction (wheels up for example), please report it to me.

Wiki and OP was updated with the list of supported mods.

 

BonVoyage 0.14.1.1 for KSP 1.5.1

Download it on Spacedock and GitHub

 


Fixes

  • Fixed detection of KSP Interstellar Extended generators

Changes

  • Kopernicus support - solar panels are working even when you are around other stars
  • Added support for Bison Cab from Wild Blue Industries
  • Bon Voyage will try to rotate a rover perpendicularly to a terrain
Edited by maja

Share this post


Link to post
Share on other sites

If someone downloaded the update before this post, redownload it again, if you want get rid off some debug messages. It was a long day :confused:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.