maja

[KSP 1.8.1] Bon Voyage (1.0.1) - 2019-11-04

Recommended Posts

@RealGecko stopped supporting this mod and turned this over to me. Original thread is here: https://forum.kerbalspaceprogram.com/index.php?/topic/147876-ksp-131-bon-voyage-01321-make-your-wheels-rolling-2017-10-15/

 

What's the best way of getting science from celestial body? The answer is DRIVE!

What's the best way of delivering ore or supplies from distant location to your base? The answer is make your wheels rolling and whips rowing!

But did you try to drive for 110 km for two hours, avoiding obstacles and keeping your speed in sane limits? It's not fun anymore.

Don't worry!  Automagic Industries brings you a new autopilot, which reduces driving accidents by 100%. Bon Voyage is here and it will drive your rovers and ships in background!

iUeRBio.png

 

Source: https://github.com/jarosm/KSP-BonVoyage

Download: https://spacedock.info/mod/950/BonVoyage

Wiki: https://github.com/jarosm/KSP-BonVoyage/wiki

License: GPL-3.0

Superb "Bon Voyage Pathfinder" model was created by @Enceos and is licensed under CC-BY-NC-SA 4.0

Cool and colorized app launcher icon made by Madebyoliver and licensed under Creative Commons BY 3.0

 

How it works:

  1. Rover must be landed and ship (boat) splashed.
  2. It has to have Bon Voyage Controller aboard. Controller is in the Control tab or part of some rover cabs (Malemute, Karibou, Buffalo, Bison and FUR).
  3. At least three rover wheels must be intact, operable and in contact with the ground.
  4. Unmanned rover or ship must have an active connection to set a target or issue the GO command if you are using the CommNet or RemoteTech.
  5. To start moving, your power production must be at least 35% of wheels max consumption in case of rovers. In case of ships, you must have enough of fuel or electric power for operating engines.
  6. Rover will move with varying speed depending on number of wheel motors online, power production and crew. Ship will move with varying speed depending on power production (in case of electric motors) and crew.
  7. Rover or ship can be solar powered or have alternative power source (RTGs, Nuclear Reactors, Fission Reactors, Antimatter Reactors etc.).
  8. If rover or ship cannot move without a solar power, then it will idle until the Sun is 0 degrees above the horizon. .

 

How to:

  1. Add Bon Voyage Controller to your rover or ship (seek it in theControl tab).
  2. If you have MM installed, then Rover body and Malemute, Karibou, Buffalo, Bison and FUR cabs get BV automatically. 
  3. Launch your rover or ship.
  4. If you're just playing with BV and launch a rover at KSC, then at start your rover state will be "Prelaunch". BV won't work at that state and displays message, that your rover must be landed. Move your rover a little so that MET starts ticking and then BV is ready to be activated.
  5. Select the proper autopilot type (land or naval) from the PAW menu Bon Voyage Controller. Default is Land autopilot.
  6. Right click on BonVoyage icon or module (or rover cab, if you use some) and open BV window. This window is different for each type of autopilot
  7. Unmanned rover must have an active connection to set a target or issue the GO command if you are using the CommNet or RemoteTech.
  8. Click "Pick on map", "Current target" or "Current waypoint" to select target coordinates or enter the coordinates manually.
  9. Click "Set" to start computing a path to the target.
  10. Path finding may take some time, be patient.
  11. If path will not be found in ten seconds, it will stop. Try some closer point.
  12. Click "GO!"
  13. Go to tracking station...or launch a new vessel...or do whatever you want...

 

There are few things to note:

  1. Pilots, USI Scouts and crew members with Autopilot skill can increase average speed dramatically
  2. Low on power? Your rover or ship will be slower
  3. Night rides of manned rovers and ships are slower
  4. Unmanned rovers and ships are very slow
  5. Batteries can be used during a night for rovers, if there is enough solar power to recharge them. Up to 50% of the total capacity of all enabled batteries will be used.

 

Supported mods:

Spoiler

Fully supported:

  • Kerbal Foundries
    • All wheels and tracks are supported
    • Wheels based on KSPWheel module are supported. If not, send me a message.
  • Kopernicus
    • Solar panels are working even around other stars
  • Umbra Space Industries
    • Reactors and MKS Power Pack are supported
    • Karibou and Malemute rovers have integrated Bon Voyage controller
    • Otter submarine engines from Exploration pack
  • Wild Blue Industries
    • Reactors are supported
    • Buffalo and Bison rovers have integrated Bon Voyage controller
  • Near Future
    • Reactors and solar panels are supported
  • KSP Interstellar Extended
    • Generators are supported
  • RemoteTech
    • Unmanned vessels must have a working connection to issue commands
  • Feline Utility Rovers
    • Electric engines are supported
  • Community Tech Tree
    • The last part update is added to the Artifical Intelligence tech node

 

Changelog:

Spoiler

1.0.1

Changes

  • Minimum height of a rover over the terrain was changed to avoid some clipping issues
  • KSP 1.8.1 compatibility

 

1.0.0

Changes

  • KSP 1.8 compatibility

 

0.5.4

Changes

  • Path is computed immediately after selecting a target (point on map, current target or waypoint)

Fixes

  • Fixed null ref when closing main window after hiding the application button
  • Fixed distance display in the control panel after setting a route

 

0.5.3

Changes

  • Cheats for infinite electricity and propellant are accepted (your game, your rules)
  • Part upgrades were reworked to support their placement into different tech trees by MM's config
    • By default, two upgrades are in the stock tech tree (plus the base part). Third upgrade is placed into Artificial intelligence node of CTT if you have it.

 

0.5.2

Changes

  • BonVoyage modul added to RoveMate by default
  • Added part upgrades which raise the speed of unmanned rovers and ships. The last upgrade is only for Community Tech Tree.

 

0.5.1

Changes

  • Suport of servo rotors from the Breaking Ground DLC for ship controller

 

0.5.0 - Come all you young sailormen, listen to me
Changes

  • We are ready to extend our operations to the water
    • Stock jet and rocket motors are supported
    • Support of electric motors from Feline Utility Rovers and USI Exploration Pack mods (and other mods, which has motors based on stock modules)
    • Electric motors are the best ones for extended naval operations
  • MiniAVC removed from the installation, because planned updates are done. If you need notification about new versions, use AVC instead

 

Edited by maja

Share this post


Link to post
Share on other sites

YAY, now i can build my mining operation without having to worry about long rover sessions. THANK YOU. :D

Share this post


Link to post
Share on other sites

 

maja I'm getting this really weird graphical glitch where the line that I assume, should be leading from my rover to its destination, just zig-zags randomly around the screen. Looks crazy. It also appears in the map view when I'm flying other ships, so I can't really ignore it. 

Edited by Spaaaaaace!

Share this post


Link to post
Share on other sites

Thank you Maja for taking over and maintaining this mod (and thank you to Real Gecko for having written this in the first place!) ! It's a very good mod, and it would have been a pity to see it abandoned.

Share this post


Link to post
Share on other sites
6 hours ago, Spaaaaaace! said:

 

maja I'm getting this really weird graphical glitch where the line that I assume, should be leading from my rover to its destination, just zig-zags randomly around the screen. Looks crazy. It also appears in the map view when I'm flying other ships, so I can't really ignore it. 

What version of BonVoyage do you have?

Share this post


Link to post
Share on other sites

I've set a waypoint with WayPoint Manager, selected is as an active one, pressed "Poehali!!!".... aaaand... nothing happens. Just a "Bon Voyage control lock active" message across the screen. The rover's not moving. EC capacity & generating volume are sufficient.

Share this post


Link to post
Share on other sites
7 minutes ago, Horus said:

I've set a waypoint with WayPoint Manager, selected is as an active one, pressed "Poehali!!!".... aaaand... nothing happens. Just a "Bon Voyage control lock active" message across the screen. The rover's not moving. EC capacity & generating volume are sufficient.

After poehali did you left rover and return space center? the rovers are moving only after you return space center.

ksp wheels are reported not contacting ground... Vers. 1.4.1

Edited by Acvila

Share this post


Link to post
Share on other sites
10 hours ago, Spaaaaaace! said:

I was using the latest version, 0.13.3 for KSP 1.4.1

Can you reproduce it with BonVoyage and stock game only? Can you make video? Because right now, I don't see any line at all (yes, missing line looks like a bug or I forgot something during my tests :) )

 

7 minutes ago, Horus said:

I've set a waypoint with WayPoint Manager, selected is as an active one, pressed "Poehali!!!".... aaaand... nothing happens. Just a "Bon Voyage control lock active" message across the screen. The rover's not moving. EC capacity & generating volume are sufficient.

10. Click "Poehali!!!"

11. Go to tracking station...or launch a new vessel...or do whatever you want...

Share this post


Link to post
Share on other sites
Just now, Horus said:

My bad. Thanks for the hint :)

No problem, I make it bigger in OP :)

Share this post


Link to post
Share on other sites
24 minutes ago, Acvila said:

ksp wheels are reported not contacting ground... Vers. 1.4.1

If it's a bug report, then I must say, that KSP Wheels are generating exception spam in KSP 1.4.1. KSP Wheels author knows about that. I recommend not using them until it's fixed.

Edited by maja

Share this post


Link to post
Share on other sites
16 hours ago, maja said:

Can you reproduce it with BonVoyage and stock game only? Can you make video? Because right now, I don't see any line at all (yes, missing line looks like a bug or I forgot something during my tests :) )

 

I have created a video of it happening but how do I get it to you?

Share this post


Link to post
Share on other sites
8 hours ago, Spaaaaaace! said:

I have created a video of it happening but how do I get it to you?

Upload it somewhere. Youtube, dropbox etc.

Share this post


Link to post
Share on other sites
On 3/17/2018 at 5:23 PM, Spaaaaaace! said:

 

maja I'm getting this really weird graphical glitch where the line that I assume, should be leading from my rover to its destination, just zig-zags randomly around the screen. Looks crazy. It also appears in the map view when I'm flying other ships, so I can't really ignore it. 

This happened a lot in 1.3 with orbital lines too, under certain angle drawn orbits start to wobble and jump across the screen. IMO this "feature" is unfixable on mod level.

Share this post


Link to post
Share on other sites

I gotta ask out of curiosity, if I have two rovers, can I set one to autpilot, then drive alongside it with the other rover?

Share this post


Link to post
Share on other sites
17 minutes ago, Gnoyze said:

I gotta ask out of curiosity, if I have two rovers, can I set one to autpilot, then drive alongside it with the other rover?

You can't. If you try it you'll see that the second rover will stop and change to idle in the rovers list. Rover must be unloaded in order to move it by BonVoyage.

Share this post


Link to post
Share on other sites
2 hours ago, maja said:

You can't. If you try it you'll see that the second rover will stop and change to idle in the rovers list. Rover must be unloaded in order to move it by BonVoyage.

A watched rover never roves? :wink:

Share this post


Link to post
Share on other sites
38 minutes ago, Beetlecat said:

A watched rover never roves? :wink:

Don't blink :cool:

Share this post


Link to post
Share on other sites

Anyone else having an issue where rovers respawn underground when switched to? 

First time it happened upping the terrain detail to maximum stopped it (once). Currently two test rovers on kerbin are inaccessible. One on the mun seems to be working better but has clipped into the ground catastrophically before. Seems to be more of an issue on angled surfaces.

I'm not sure if this is a game issue or your mod?

I can shift the rover around in the save file manually but this is hit and miss and a bit of a pain. Would it be possible to access the BV controller without loading the vehicle to order it to move to an alternate site?

Share this post


Link to post
Share on other sites
58 minutes ago, maja said:

@Matt Can you post somewhere your savefile?

I've posted it here https://ufile.io/5aanu

Never used that site before, let me know if it doesn't work. Thanks for the quick response!

 

Rover 1 and Rover 2 are experiencing the problem on kerbin. Mun around is on the mun and appears ok at last load.

 

Mod list: No part mods just 1.4.1 and the DLC

Automated Science sampler

Better burn time

Bon Voyage

Contract configurator

Docking port alignment indicator

Kerbal alarm clock

Kerbal engineer

Mandatory RCS

Precise node

RCS build aid

Scansat

Science revisited revisited

Transfer window planner

x science

 

 

Share this post


Link to post
Share on other sites
On 21.03.2018 at 9:03 AM, Matt said:

Anyone else having an issue where rovers respawn underground when switched to? 

First time it happened upping the terrain detail to maximum stopped it (once). Currently two test rovers on kerbin are inaccessible. One on the mun seems to be working better but has clipped into the ground catastrophically before. Seems to be more of an issue on angled surfaces.

 

Yes, me too. Created two rovers on Kerbin and Mun and both ended stuck in landscape after a while. I guess mod spawns vehicle horizontally, but for long vehicles or steep landscapes it is not always sufficient. My last vehicle was rather long sausage-shaped (mk1 command pod, mk1 crew cabin, 1 structural fuselage, and tvelwe or so small wheels), and after a voyage it spawned on a slightly sloped hill with its back deeply burried in a ground. A second after loading it explodes. 

Is there some kind of normals map accessible from KSP API ? Is it possible to adjust vehicle orientation so it would be perpendicular to current place's normal?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.