Jump to content

[KSP 1.9.1 + 1.10.1] Bon Voyage (1.1.1 + 1.2.0) - 2020-08-12


Recommended Posts

24 minutes ago, jaunco325 said:

would this not?

http://www.mediafire.com/file/b7q5mpnbwu9kvia/Player.log/file

If I'm not mistaken in that session I had a couple of problems.

I don't see any exceptions regarding BonVoyage, but you are using bunch of mods, that are not compatible with KSP 1.8.*. This could lead to various problems.

If you have a save file from before switching to that problematic rover, send it to me.

Link to post
Share on other sites

I was testing autosave that I already had and I noticed something very strange in the autosave "mini rover kerbin". I started loading and piloting said rover again and again, without making any modifications. one would think that by doing the same thing many times it would always give the same result, no, sometimes it explodes at fall and sometimes the wheels manage to cushion the fall. even disabling rotation.

http://www.mediafire.com/file/ln6ynmx2itwjxhw/Desktop.rar/file

With respect to the old mods, if they don't update them I have to settle for old versions.
These are the mods I have:

http://prntscr.com/prmoxn

Then I will launch more rovers in search of more of these bugs.

Edited by jaunco325
Link to post
Share on other sites

@jaunco325 I think, that there are two possible reasons for a failure. The collider for little rover wheels is badly defined and BV gets wrong informations about the lowest point of the rover or the rover is too wide and therefore clips on one side to the terrain. I disabled the move down feature (it can be done only by editing the code) during my tests and the rover was high enough to not clip to the terrain. I must do more tests with different rovers and wheels to decide, which reason it is.

Edited by maja
Link to post
Share on other sites
1 hour ago, jaunco325 said:

I didn't understand what he meant by that last.

English isn't my first language, neither yours as I understand, but I try to explain it to you as best as I can :)

When a rover moves behind the scene, the Bon Voyage sets its latitude, longitude and altitude based on computations and data about terrain on that spot. The problem is, that the terrain information isn't exact, so the rover is sometimes underground or too high. Bon Voyage handles these situations by moving the rover up or down when you switch to it during a ride or after it arrives to the destination. How high or low BV moves the rover is computed from the position of colliders of rover's parts. If the colliders are wrongly defined, then the computations are wrong and the rover can be moved too high or too low, so it clips to the terrain and after resuming the physics it explodes. I tested your rover with modified Bon Voyage, which skipped the move down step, so the tested rover wasn't moved and stayed above terrain. That means, that it wasn't clipping through the terrain and therefore no explosion happened. Now I must find what is the reason, that the rover is moved too low by BV. Is it wrong collider? Is it the rover construction? Or is it something else?

Edited by maja
Link to post
Share on other sites

Hi, I've just started using this mod, and I found that my rovers, when under the control of Bon Voyage, are flipped upside down when switched to. They'll continue moving if I switch away again, but I can't give them new directions because the wheels aren't touching the ground.

GXNNfJo.jpg

Is there something I can do to stop this from happening?

Link to post
Share on other sites
8 minutes ago, BTAxis said:

Hi, I've just started using this mod, and I found that my rovers, when under the control of Bon Voyage, are flipped upside down when switched to. They'll continue moving if I switch away again, but I can't give them new directions because the wheels aren't touching the ground.

GXNNfJo.jpg

Is there something I can do to stop this from happening?

If you click the BV controller it should give you the option to change the rotation vector. This helps BV determine what “up” is for your rover. I’m not 100% on the details, but if you try the options there should be one that works. :) 
 

Edit: They look kinda cute and helpless on the 2nd image btw. :P 

Edited by Jognt
Link to post
Share on other sites
10 hours ago, BTAxis said:

Hi, I've just started using this mod, and I found that my rovers, when under the control of Bon Voyage, are flipped upside down when switched to. They'll continue moving if I switch away again, but I can't give them new directions because the wheels aren't touching the ground.

GXNNfJo.jpg

Is there something I can do to stop this from happening?

https://github.com/jarosm/KSP-BonVoyage/wiki/Settings

Look for Rotation vector advance tweakable section

 

 

9 hours ago, jaunco325 said:

 

La posición del móvil está determinada por la pieza raíz. Si esta pieza se gira durante la construcción, su móvil aparecerá volteado.

English please.

Edited by maja
Link to post
Share on other sites
30 minutes ago, BTAxis said:

Hi, I've just started using this mod, and I found that my rovers, when under the control of Bon Voyage, are flipped upside down when switched to. They'll continue moving if I switch away again, but I can't give them new directions because the wheels aren't touching the ground.

GXNNfJo.jpg

Is there something I can do to stop this from happening?

The mobile position is determined by the root piece. If this part is rotated during construction, your mobile will appear flipped.

Link to post
Share on other sites
9 hours ago, jaunco325 said:

The forum is bad for me. the answer is below

No problem. I understand, that you must translate it to/from english, but I can't translate your text, if I'm looking at it on my phone.

 

10 hours ago, Jognt said:

Edit: They look kinda cute and helpless on the 2nd image btw. :P 

Like small bugs :D

Edited by maja
Link to post
Share on other sites
10 hours ago, Jognt said:

If you click the BV controller it should give you the option to change the rotation vector. This helps BV determine what “up” is for your rover. I’m not 100% on the details, but if you try the options there should be one that works. :) 

 

Thanks! The controller was set to "back". I set it to "forward" and now all is well. I'm not sure if that was the default setting or if I managed to bollix it during construction. Either way, off they go to their intended destinations.

Link to post
Share on other sites
1 minute ago, BTAxis said:

Thanks! The controller was set to "back". I set it to "forward" and now all is well. I'm not sure if that was the default setting or if I managed to bollix it during construction. Either way, off they go to their intended destinations.

It's the default which works for the most rovers with some sort of a cabin. It also depends, where the real top of the root part (RoveBody in your case) is.

Link to post
Share on other sites

Seems to be a bug in this mod since 1.8.* version of KSP:

 

I started a new career mode and the Bon Voyager controller was available far before had to research Bon Voyager (Unmanned Tech) in the tech tree. Don't remember seeing this behavior in the older version.

 

 In addition in my current game mentioned above, I never had to pay $ to unlock  the Bon Voyager part. My tech tree still shows Bon Voyager as greyed out but Bon Voyager is available in the VAB/SPH.

Edited by fragtzack
Link to post
Share on other sites
49 minutes ago, fragtzack said:

Seems to be a bug in this mod since 1.8.* version of KSP:

 

I started a new career mode and the Bon Voyager controller was available far before had to research Bon Voyager (Unmanned Tech) in the tech tree. Don't remember seeing this behavior in the older version.

 

 In addition in my current game mentioned above, I never had to pay $ to unlock  the Bon Voyager part. My tech tree still shows Bon Voyager as greyed out but Bon Voyager is available in the VAB/SPH.

:cool::cool::cool:  (sorry :D )

There was change in the tech tree node for the part, because there are now part updates later in the tree, which affects unmanned penalties.

Check your difficulty settings, because buying parts depends on them.

Link to post
Share on other sites

@maja, the description of BV says that is supports nuclear reactors, but I tested a rover with BV module and a fission reactor from Near Future Electrics mod, and it doesn't seem to recognize it, it says that electricity production is 0, even though the reactor is active:

AlWLgKn.png

How do I make this work?

Link to post
Share on other sites
8 hours ago, aluc24 said:

@maja, the description of BV says that is supports nuclear reactors, but I tested a rover with BV module and a fission reactor from Near Future Electrics mod, and it doesn't seem to recognize it, it says that electricity production is 0, even though the reactor is active:

How do I make this work?

I checked it (KSP 1.8.1, BV 1.0.1, NF Electrical 1.1.0) and it worked as intended.

Edited by maja
Link to post
Share on other sites
5 hours ago, maja said:

I checked it (KSP 1.8.1, BV 1.0.1, NF Electrical 1.1.0) and it worked as intended.

Sorry, I forgot to mention I am running KSP 1.7.3. Was the support for NF Electrical added only for KSP 1.8.1 version of BV?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...