maja

[KSP 1.9.1 + 1.10.1] Bon Voyage (1.1.1 + 1.2.0) - 2020-08-12

Recommended Posts

6 hours ago, maja said:

@4x4cheesecake There is a new prerelease. I hope, that I identified the code, which generates that nullref. I don't know why it is generated, but catching it will help. There must be something not fully initialized during a scene change. Also, I halved move down cycle (this means quicker transition to a flight scene) and raised the altitude limit for the up movement.

If it was a game event, always check for nulls. I have in the past caught the same game event firing multiple times when it should only fire once, and only one of those had valid objects being passed as arguments. onVesselOffRails being an example offender; fired several times with a null vessel reference. I don't know how often that still happens but I always assume it to be the case.

Share this post


Link to post
Share on other sites
17 minutes ago, Starwaster said:

If it was a game event, always check for nulls. I have in the past caught the same game event firing multiple times when it should only fire once, and only one of those had valid objects being passed as arguments. onVesselOffRails being an example offender; fired several times with a null vessel reference. I don't know how often that still happens but I always assume it to be the case.

Weird thing is, that I check for a null vessel reference and there is still one generated sometimes. As usual, not in my test instance, so I can't replicate it.

Share this post


Link to post
Share on other sites

@maja So far, everything works perfectly fine :)

I drove my rover half around Kerbin by setting up 6 smaller routes. I got no NullRefs, the rover spawned perfectly fine everytime (switched to the rover a few times while it was still driving) and without a CommNet connection, I wasn't able to set up a new route. Well, there is still the big performance impact when switching to the rover but it feels like the game will return to a normal state a bit faster.

One question: Is it intended that the rover keeps driving when loosing the CommNet connection? I kinda expected the rover to stop and switch to 'Await CommNet signal' status, similar to a solar powered rover in the night but it also makes sense for the rover to recieve all the relevant informations at the beginning of a tour so the CommNet is not required to drive.
If this behaviour is actually intended, I would like to suggest to add a difficutly option so the rover will also require a connection even while driving :)

Edited by 4x4cheesecake
typo

Share this post


Link to post
Share on other sites
4 hours ago, 4x4cheesecake said:

 

One question: Is it intended that the rover keeps driving when loosing the CommNet connection? I kinda expected the rover to stop and switch to 'Await CommNet signal' status, similar to a solar powered rover in the night but it also makes sense for the rover to recieve all the relevant informations at the beginning of a tour so the CommNet is not required to drive.
If this behaviour is actually intended, I would like to suggest to add a difficutly option so the rover will also require a connection even while driving :)

It's intended. The route is found and stored in the controller beforehand, so there is no need for the autopilot a working connection later.

And thanks for trying it :)

Share this post


Link to post
Share on other sites

BonVoyage 0.14.2 for KSP 1.5.1

Download it on Spacedock and GitHub


Changes

  • Unmanned rover must have an active connection to set a target or issue the GO command if you are using the CommNet or RemoteTech
  • Batteries can be used during a night, if there is enough solar power to recharge them. Up to 50% of the total capacity of all enabled batteries will be used.
  • Added toggle to the Settings to disable rotation of a rover perpendicularly to the terrain after arriving to a target and during a ride
  • Added Rotation vector advanced tweakable
    • Rotation of a rover depends on the orientation of the root part. You can now set the vector used for rotating the rover.
    • This setting is accessible after enabling Advanced tweakables in the KSP settings
    • Default value is "Back" - for rovers, whose root part is a probe or a cab oriented in such a way, that you see horizont line on the navball
    • Other usual values are "Up" and "Down", if the default setting is putting your rover on it's (usually) shorter side. You need experiment a little bit in this case to find the right setting.
Edited by maja

Share this post


Link to post
Share on other sites

There is CKAN error with last update. Error appears when mod is downloading to CKAN cache:

CKAN.InvalidModuleFileKraken: BonVoyage 0.14.2: E:\Temp\tmp8647.tmp has length 161362, should be 161357
   at CKAN.NetModuleCache.Store(CkanModule module, String path, String description, Boolean move)
   at CKAN.NetAsyncModulesDownloader.ModuleDownloadsComplete(NetModuleCache cache, Uri[] urls, String[] filenames, Exception[] errors)

 

Share this post


Link to post
Share on other sites

@GRAleX I'm not maintaining CKAN record of BonVoyage. Bring this up in the CKAN thread, please.

I was updating the mod twice yesterday. You need to wait for a synchronization probably.

Share this post


Link to post
Share on other sites

Is it normal for this mod to often be unable to calculate a route when clicking on the map?

I've specifically noticed that longer routes have the tendency to be "un-calculable" , can anyone else clarify this?

Share this post


Link to post
Share on other sites
42 minutes ago, RB101 said:

Is it normal for this mod to often be unable to calculate a route when clicking on the map?

I've specifically noticed that longer routes have the tendency to be "un-calculable" , can anyone else clarify this?

Yes, it is normal for this mod, especially when calculating longer routes.

To elaborate on this, there is an internal timeout, which aborts pathfinding when it's longer then ten seconds. The duration of the pathfinding algorithm depends not only on distance, but also on passability of the terrain (height difference, water in the way etc.)

Share this post


Link to post
Share on other sites
1 minute ago, maja said:

Yes, it is normal for this mod, especially when calculating longer routes.

To elaborate on this, there is an internal timeout, which aborts pathfinding when it's longer then ten seconds. The duration of the pathfinding algorithm depends not only on distance, but also on passability of the terrain (height difference, water in the way etc.)

Is there any way to turn this "Abort" function off? I'm getting kind sick of having to constantly check on my equatorial rovers, to set the next way-point.

Share this post


Link to post
Share on other sites

I tried to use this mod but when the rover arrives at it's destination it spawns on it's side or back.... every time consistently it puts it where no wheels touch the ground

Share this post


Link to post
Share on other sites
4 hours ago, Rocketdyno said:

I tried to use this mod but when the rover arrives at it's destination it spawns on it's side or back.... every time consistently it puts it where no wheels touch the ground

Nobody reads changelog or wiki these days ;.;

 

  • Added toggle to the Settings to disable rotation of a rover perpendicularly to the terrain after arriving to a target and during a ride
  • Added Rotation vector advanced tweakable
    • Rotation of a rover depends on the orientation of the root part. You can now set the vector used for rotating the rover.
    • This setting is accessible after enabling Advanced tweakables in the KSP settings
    • Default value is "Back" - for rovers, whose root part is a probe or a cab oriented in such a way, that you see horizont line on the navball
    • Other usual values are "Up" and "Down", if the default setting is putting your rover on it's (usually) shorter side. You need experiment a little bit in this case to find the right setting. 

Share this post


Link to post
Share on other sites

Currently my unmanned rovers cannot make use of a bon-voyage autopilot, clicking the "Bon Voyage Control Panel" button doesn't open the control panel. I have a full connection to the KSC and my unmanned rover is fully charged, with enough solar power to charge whilst moving.

Anybody got any ideas as to whats up with it, or is this a known bug?

Share this post


Link to post
Share on other sites
1 minute ago, RB101 said:

Currently my unmanned rovers cannot make use of a bon-voyage autopilot, clicking the "Bon Voyage Control Panel" button doesn't open the control panel. I have a full connection to the KSC and my unmanned rover is fully charged, with enough solar power to charge whilst moving.

Anybody got any ideas as to whats up with it, or is this a known bug?

Hi, if you want a help, then you must give me more details. Screenshots, logs. Until then I can only say: "It's working as intended"

Share this post


Link to post
Share on other sites
5 minutes ago, maja said:

Hi, if you want a help, then you must give me more details. Screenshots, logs. Until then I can only say: "It's working as intended"

Managed to fix it myself ^_^ , just had switch to the space centre and back.

I also just did some testing and it appears to be to do with when you decouple a rover from a landing craft (specifically when the detached rover wasn't the original root part), resulting in the bon-voyage control menu not opening.

The same also seems to happen (though not always) when constructing a rover with KIS/KAS (which is also fixable by going to the space centre, and then back to the rover)

My Mods include:

- KIS

- KAS

- Nearfuture (Everything from near future)

- Mk2 Expansion

- Mk3 Expansion

- Universal Storage 1 

- Scansat

- Research & Development

 

Hope this helps :)

Share this post


Link to post
Share on other sites
19 minutes ago, RB101 said:

Currently my unmanned rovers cannot make use of a bon-voyage autopilot, clicking the "Bon Voyage Control Panel" button doesn't open the control panel. I have a full connection to the KSC and my unmanned rover is fully charged, with enough solar power to charge whilst moving.

Anybody got any ideas as to whats up with it, or is this a known bug?

Did you add the Bon Voyage Module to your rover? It is located in the 'control' category (the same with RCS thrusters and reaction wheels).

edit: well, ok than^^

Edited by 4x4cheesecake

Share this post


Link to post
Share on other sites
1 hour ago, RB101 said:

Managed to fix it myself ^_^ , just had switch to the space centre and back.

I also just did some testing and it appears to be to do with when you decouple a rover from a landing craft (specifically when the detached rover wasn't the original root part), resulting in the bon-voyage control menu not opening.

The same also seems to happen (though not always) when constructing a rover with KIS/KAS (which is also fixable by going to the space centre, and then back to the rover)

Hope this helps :)

https://github.com/jarosm/KSP-BonVoyage/issues/6

Share this post


Link to post
Share on other sites

@maja Great mod! Really helpful for when I'm feeling lazy and don't want to drive my rover halfway around the planet :D

A suggestion: Would it be possible to have KAC integration, so I can set an alarm for when my rover arrives? I know it already notifies you through the stock messages app but I think a KAC alarm would be super-useful too :)

Ninja-edit: If I'm being blind and BV already has this, apologies! :blush:

Edited by RealKerbal3x

Share this post


Link to post
Share on other sites
1 minute ago, RealKerbal3x said:

A suggestion: Would it be possible to have KAC integration, so I can set an alarm for when my rover arrives? I know it already notifies you through the stock messages app but I think a KAC alarm would be super-useful too :)

There isn't the precise time when a rover arrives. It mostly depends on the available light during the travel, so it can't be predicted.

Share this post


Link to post
Share on other sites
1 minute ago, maja said:

There isn't the precise time when a rover arrives. It mostly depends on the available light during the travel, so it can't be predicted.

OK, makes sense. Thanks :)

Edited by RealKerbal3x

Share this post


Link to post
Share on other sites
On 11/25/2018 at 8:12 PM, RB101 said:

Currently my unmanned rovers cannot make use of a bon-voyage autopilot, clicking the "Bon Voyage Control Panel" button doesn't open the control panel. I have a full connection to the KSC and my unmanned rover is fully charged, with enough solar power to charge whilst moving.

Anybody got any ideas as to whats up with it, or is this a known bug?

I am having the same issue and I just installed v0.14.2 but the issue is still there (issue happened when I had v0.14.0.1). Also, I can't find the reload button; is it in the control panel by any chance?

I tried the solutions RB101 mentioned but nothing seems to be fixing it. Every rover I make has this issue. I just made a barebones one and the control panel doesn't open even on the Launch pad. Trying from the tool bar or from settings doesn't open it either.

 

Here's the barebones rover: https://prnt.sc/lqck6x

Here's the Mun Rover: https://prnt.sc/lqcpfy

 

They have batteries, solar power, connection and the Mun one has a scientist in it. The first time I opened the control panel it worked (I was on the Mun with my first rover). I set a target but pathfinding must've took more than 10 seconds because nothing happened. I didn't know about the 10 secs rule so I went to the Space center and when I got back to it, a few days later, it was in the same place and the control panel wouldn't open. Note the "Time to apoapsis" as shown by Kerbal engineer. It constantly flicks between that time and 0, sometimes 10 times per second. Not sure of this is normal or may be connected to the issue.

 

Mods: Kerbal Engineer, Contracts Window+, Contract Parser, Progress Parser, Kerbal Alarm Clock, Colission FX, Chatterer, Docking Port Aliingment indicator, Planet Shine, Real Plume-Stock.

Let me know what else you need.

Share this post


Link to post
Share on other sites

I actually have a problem with Bon Voyage now. After I set the coordinates for my Munar Mini-bus and activate it, when I return it's bouncing on the surface (whether it be Kerbin, Minmus, or Eve) and at least one thing's damaged - despite the "no crash damage" cheat being on.

 

Any idea how to fix that issue?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.