TriggeredSnake

[1.X.X] Old Parts Redux - For all your nostalgic needs!

Recommended Posts

This mod reimplements the old parts. For all your Nostalgic needs! The mod used to use multiple configs, but now it simply combines all the parts into one folder and restores the old versions of every removed or modified part. Currently parts from 0.13.3 are restored, and everything nerfed/changed in 1.3, 1.4, 1.5, 1.6, and 1.7 has a classic version too! Version 0.7.3 and below of the mod have two configs, one reimplements the old parts from 0.13.3, with some minor balance changes, and the other reimplements the 1.3.1 parts which were replaced, modified, nerfed or removed in 1.4. To install, just choose which config you want, and extract that config's .zip file into your GameData directory.

Version 0.9.0, "The Great Reorganization", has just come out, and has improved the way the parts are stored, named, and sorted, and everything has Tech Tree integration now. Many parts have even been moved into a different category too, matching their modern equivalents better. Unfortunately, some parts (the plane cockpits) have temporarily been removed, until I can post the massive 0.10 update, which is going to include every Classic part between 0.17 and 1.1, along with a bugfix patch, which will take a couple of days. If you really need these parts, stick to 0.8.2 as it is still fully functional in 1.7, although it won't include Classic editions of the 1.7 parts. 0.9.1 has come out now, and fixes some bugs, but the massive 0.10 update isn't out yet.

When this next update is done, my mod is going to fully supersede Kerbal Historical Institute, as I'll be able to reimplement every part from that long-abandoned mod. Although I have acquired a version of 0.17, after nearly 5 years, which is what is going to allow me to add so many parts next update, I still need to acquire 0.16, 0.15, and 0.14 to complete my classic KSP version collection. If anyone has these versions, or knows where I can acquire them, please message me either on the forums, @TriggeredSnake, or on reddit at /u/TriggeredSnake, as you will be a great help to both OldPartsRedux and my personal collection. Anyone who finds me an old version will get their name in included into OldPartsRedux somewhere to credit them. (if they want.)

Known Bugs:

  • There's an issue with the Classic RCS thrusters, they fire way too much exhaust and in the opposite direction. This issue has persisted since some very early versions of OldPartsRedux, and I'm still not entirely sure how to fix it, but I think I can manage it now.
  • Not every part is in the correct tech-tree location or editor category yet.

Most of these bugs will be fixed in a patch tomorrow. The reason for the abnormal amount is the complete recode, much like when KSP was rewritten and ported to Unity 5, a rewrite brings loads of new bugs.

EDIT: Should now be compatible with AVC!

Download on Spacedock.

EDIT EDIT: Proof for reddit

Edited by TriggeredSnake
Changed title, updated description.

Share this post


Link to post
Share on other sites

FYI, CKAN can't handle the ZIP-within-a-ZIP structure that this mod has in the latest update, so the latest version of this mod that's indexed is 6.4. If you're able to choose which of the sub-ZIPs is the "better" version, I'd suggest simplifying the download by releasing only that file.

Share this post


Link to post
Share on other sites
13 hours ago, blspblackdeath said:

Well, there is another mod for that. Cough cough.

I do know about your mod, but as you will notice if you installed my mod, we implement the parts differently. Your mod adds them with different names and descriptions, I use the original description and add ‘Classic’ to the part name. I personally prefer my method, hence why I made my own mod.

Share this post


Link to post
Share on other sites

Your .version file is badly formed and has incorrect data:

{
    "NAME":"Old Parts Redux Alpha",
    "URL":"https://spacedock.info/mod/1744/Old%20Parts%20Redux",
    "DOWNLOAD":"https://spacedock.info/mod/1744/Old%20Parts%20Redux/download/0.6.3",
    },
    "VERSION":
    {
        "MAJOR":1,
        "MINOR":0,
        "PATCH":0,
        "BUILD":0
    },

You have a closing brace where it doesn't belong. 

And the URL needs to return a valid .version file, what you have is returning the spacedock page

This is causing the KSP-AVC to get errors

Share this post


Link to post
Share on other sites
On 3/24/2018 at 8:32 PM, linuxgurugamer said:

Your .version file is badly formed and has incorrect data:


{
    "NAME":"Old Parts Redux Alpha",
    "URL":"https://spacedock.info/mod/1744/Old%20Parts%20Redux",
    "DOWNLOAD":"https://spacedock.info/mod/1744/Old%20Parts%20Redux/download/0.6.3",
    },
    "VERSION":
    {
        "MAJOR":1,
        "MINOR":0,
        "PATCH":0,
        "BUILD":0
    },

You have a closing brace where it doesn't belong. 

And the URL needs to return a valid .version file, what you have is returning the spacedock page

This is causing the KSP-AVC to get errors

Thanks for bringing this to my attention, I completely overlooked that when I coded this. The corrected version should be up on Spacedock. However, I don't know what you mean with the URL thing, can you tell me how to fix it? Also, I love your mods.

Share this post


Link to post
Share on other sites
28 minutes ago, TriggeredSnake said:

Thanks for bringing this to my attention, I completely overlooked that when I coded this. The corrected version should be up on Spacedock. However, I don't know what you mean with the URL thing, can you tell me how to fix it? Also, I love your mods.

The URL should, when pasted into a browser, return the current .version file.  Many people use the ksp-avc web site, many others, including myself, have the source at Github and reference the file there directly.

Worst case, just leave it, all it means is that AVC will not be able to check for newer versions of the mod

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites
19 hours ago, linuxgurugamer said:

The URL should, when pasted into a browser, return the current .version file.  Many people use the ksp-avc web site, many others, including myself, have the source at Github and reference the file there directly.

Worst case, just leave it, all it means is that AVC will not be able to check for newer versions of the mod

As I still don't know how to fix it I'm probably gonna have to leave it.

Share this post


Link to post
Share on other sites
On 3/25/2018 at 10:43 PM, linuxgurugamer said:

The URL should, when pasted into a browser, return the current .version file.  Many people use the ksp-avc web site, many others, including myself, have the source at Github and reference the file there directly.

Worst case, just leave it, all it means is that AVC will not be able to check for newer versions of the mod

I think the issue is fixed now. Hopefully AVC will work with version 0.7.3 and onwards.

Share this post


Link to post
Share on other sites

Is it updated with all of the other retired textures for 1.6?

Please say yes

Share this post


Link to post
Share on other sites
On 12/28/2018 at 5:31 PM, Hojoz said:

Is it updated with all of the other retired textures for 1.6?

Please say yes

No, 'fraid not. I'm about to try 1.6 for the first time. Do you know where I can find a list of the parts changed so I can update the mod?

On 3/16/2018 at 10:21 PM, blspblackdeath said:

Well, there is another mod for that. Cough cough.

Also my mod is updated to 1.6. What happened to KHI? It's like 2 versions out of date. Am I now the dominant Old Part restorer?

Share this post


Link to post
Share on other sites
43 minutes ago, TriggeredSnake said:

Do you know where I can find a list of the parts changed so I can update the mod?

No, not sure at least. My best guess would be the KSP changelog on their website, or wherever that's found. I do know that they changed the Mk2 lander can and Poodle though (Because of backlash) 

44 minutes ago, TriggeredSnake said:

Am I now the dominant Old Part restorer?

There are others? I just went looking for a parts restorer mod an the first Kottabos video I found was about your mod. That said, I have thought about copypasting the 1.4.5 folders and renaming the parts. Although it's probably not that easy. 

Share this post


Link to post
Share on other sites
41 minutes ago, Hojoz said:

No, not sure at least. My best guess would be the KSP changelog on their website, or wherever that's found. I do know that they changed the Mk2 lander can and Poodle though (Because of backlash) 

There are others? I just went looking for a parts restorer mod an the first Kottabos video I found was about your mod. That said, I have thought about copypasting the 1.4.5 folders and renaming the parts. Although it's probably not that easy. 

Sorry, the second bit was directed to someone else who shamelessly plugged his classic part restorer a while ago, (his mod is only for 1.4.3, so probably abandoned.) but the forums combined my replies. But thanks for telling me about that Kottabos video, I had no idea a huge Youtuber had covered my mod! That's incredible! (Also yes copying the folders is exactly how I do it, and yes it takes a while.)

Thanks for the advice about finding the parts, I'll have a look tonight or tomorrow.

Share this post


Link to post
Share on other sites

Pre-1.4 fairing textures anyone?

Pre-1.1 Mk2 Inline Cockpit anyone?

Share this post


Link to post
Share on other sites
On 1/7/2019 at 3:42 PM, Gapone said:

Pre-1.4 fairing textures anyone?

Pre-1.1 Mk2 Inline Cockpit anyone?

I’ll be adding the faring in future, and I what changed with the Mk2 Inline in 1.1? I know it got a redesign in 1.0.5; the pre-1.0.5 version and the pre-0.25 version are currently in OldPartsRedux.

Share this post


Link to post
Share on other sites
5 minutes ago, TriggeredSnake said:

what changed with the Mk2 Inline in 1.1?

Here's a plane using Mk2 Inline in 1.0.5:

MRL6u67.png

And here's a thing using Mk2 Inline in 1.1:

ac085c8550f724ec80ce090fd515431f.jpg

See the diffirence?

Share this post


Link to post
Share on other sites
1 minute ago, Gapone said:

Here's a plane using Mk2 Inline in 1.0.5:

MRL6u67.png

And here's a thing using Mk2 Inline in 1.1:

ac085c8550f724ec80ce090fd515431f.jpg

See the diffirence?

Oh crap that Mk2 Inline. Sorry, back in the old days the Mk2 Inline meant what is now the Mk1 Inline. Sorry.

But yeah, that has changed. I’ll work on adding it next update. Also, OldPartsRedux does revert the Twin-nozzled Poodle, so don’t worry, you don’t have to kill yourself.

Share this post


Link to post
Share on other sites
1 minute ago, TriggeredSnake said:

OldPartsRedux does revert the Twin-nozzled Poodle, so don’t worry, you don’t have to kill yourself

I've removed it from the game by myself some time after i got the 1.6 :)

Share this post


Link to post
Share on other sites
5 minutes ago, Gapone said:

I've removed it from the game by myself some time after i got the 1.6 :)

Don’t blame you. I added the old version to OldPartsRedux the same day I started playing 1.6 and tried to get it out as soon as possible. That’s the main reason version 0.8.1 came out without any bug fixes, I wanted to save everyone from Squad’s latest terrible decision.

Share this post


Link to post
Share on other sites

Now that I've started getting back into KSP, I'm going to publish a new update porting OldPartsRedux up to 1.7. I'll also be adding some new parts soon, as I've finally aquired a copy of 0.17 which will allow me to add a bunch of new stuff.

Share this post


Link to post
Share on other sites

0.9.0 Update has been published! Changelog:

0.9.0: "The Great Reorganizing"

Features:

  • Every part file has been recreated using files from their original versions.
  • Every part has been renamed to state the version the part was taken from, e.g. (0.13.3), or (1.4), rather than using the 'Classic' and 'Classic Classic' suffixes.
  • Every part now has Tech Tree integration.
  • Some parts have been moved to different categories.
  • Rewritten readme file.
  • AVC compatibility should be possible due to a .version file modification, but as I don't use it I'm not entirely sure.
  • CKAN compatibility should be possible now, but I don't use it so I'm not entirely sure.

Parts:

  • Every part changed or modified in 1.7 now has a Classic version.
  • Unfortunately, a few parts have been temporarily removed, specifically the Classic spaceplane parts, as I need to find a backup hard drive to check which versions they are from. They will be reimplemented soon in a new update, which will be coming out in a couple of days, and will be incorporating every part between 0.17 and 1.1, plus a few other parts.

 

Share this post


Link to post
Share on other sites
Posted (edited)

0.9.1 Update has been published! Changelog:

0.9.1 is fully compatible with 1.7.2, but I'm posting this as a 1.7.1 mod because that's the version I'm stuck with until Kopernicus updates.

Bugfixes:

  • The RT-5 (1.4) now loads the correct texture and loads properly.

  • The RT-10 (0.13.3) is now correctly named the RT-10 (0.7.3) and no longer conflicts. I will be adding a 0.13.3 version when I can update the 0.13.3 model to be modern KSP compatible.

  • The LV-T45 (0.13.3) has been properly named in its file, and now loads correctly without conflict.

  • The LV-T30 (0.13.3) is now named correctly.

  • Some parts have had their categories and tech tree positions fixed.

Edited by TriggeredSnake

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.