Jump to content

[1.4+ & 1.8+] Hyperspace - Load KSP faster on HDD (or not)


Recommended Posts

Does the KSP unity version still has that bug with massive slowdowns the more active network adapters you are running? Because unity loads assset via URLs, then would scan all adapters first.

In my case deactivating all network adapters also seem to improve loading time. 

Isn't there any method to disable this behavior with a plugin?

Link to post
Share on other sites
8 hours ago, hendrack said:

Does the KSP unity version still has that bug with massive slowdowns the more active network adapters you are running? Because unity loads assset via URLs, then would scan all adapters first.

In my case deactivating all network adapters also seem to improve loading time. 

Isn't there any method to disable this behavior with a plugin?

As far as I know this has been fixed a long time ago. And KSP does not uses Unity Asset loading mechanisms for 98% of its loading. Only the Kerbopedia and a couple of DLC related stuff is loading with Unity assets.

5 hours ago, xD-FireStriker said:

This sound like black magic, two questions. 
Will it work with SSDs? and second, does it still work in 1.9 cause boi i hate how long it takes to boot ksp saving a milisecond is worth it to me.

I doubt this will have a significant impact with an SSD. Some in the thread posted an improvement but that may be related to how they test. Or I am THAT good :wink:

I am quite certain that KSP loading speed could be significantly improved but it is something that would be a lot easier to do for Squad than for us. But I will have an other look since it is a cool puzzle.

Link to post
Share on other sites
2 minutes ago, sarbian said:

As far as I know this has been fixed a long time ago. And KSP does not uses Unity Asset loading mechanisms for 98% of its loading. Only the Kerbopedia and a couple of DLC related stuff is loading with Unity assets.

I doubt this will have a significant impact with an SSD. Some in the thread posted an improvement but that may be related to how they test. Or I am THAT good :wink:

I am quite certain that KSP loading speed could be significantly improved but it is something that would be a lot easier to do for Squad than for us. But I will have an other look since it is a cool puzzle.

Im currently fixing one of my faulty patches and once that is working i will do a speed test and see how it fairs on my laptop with 8gb of ram and a bunch of mods.

Link to post
Share on other sites
2 hours ago, sarbian said:

As far as I know this has been fixed a long time ago. And KSP does not uses Unity Asset loading mechanisms for 98% of its loading. Only the Kerbopedia and a couple of DLC related stuff is loading with Unity assets.

I am quite certain that KSP loading speed could be significantly improved but it is something that would be a lot easier to do for Squad than for us. But I will have an other look since it is a cool puzzle.

Cool, but for me loading time is only one issue. Even with 32gb of RAM, the more big parts mods I add, the more "sluggish" KSP becomes, aside from loading time. Clib VAB, wait 10 seconds, add the first part, wait 5 seconds. Go to launchpad, wait 20 seconds. Thats really grinding my patience. :confused: 

I got kinda Adrian Monk on my mods, looking for exceptions, bad MM patches etc., even manually deleting parts that are redundant with the big mods. 

It's the same with Cities: Skylines though, good base game, exceptional with mods, but the more mods you add, the more it crumbles under it's own weight. I really hope KSP2 will have some improvement with this.

Link to post
Share on other sites
  • 2 weeks later...

First load after a fresh reinstall of RSS/RO/RP1 and associated mods - 354s

2nd load - 257s

After adding this mod - 255s

 

Meh... I'll keep it ;)

 

1.8.1 with a boatload of mods (including visual (EVE with added modifications) and audio mods for the first time) running on 2.3Ghz i5 laptop with 8gb ram - 64bit Win10 and KSP without dlcs installed.

 

Numbers are much quicker than it feels while loading though, i put it perceptually at about 10 minutes... nice surprise. Thanks for the mod.

Edited by Kerbalnaut #55487
Link to post
Share on other sites

First load after a fresh reinstall of RSS/RO/RP1 and associated mods - 354s


2nd load - 257s
After adding this mod - 255s

Really makes me wonder if someone could write a mod that simulates ZX Spectrum cassette tape loading sounds and the flashing border... although I'd probably uninstall it after the second time through :)

EDIT: Bonus points if the sounds aren't simply canned audio, but actually convey information about the loading process. Edited by Corax
Link to post
Share on other sites
  • 5 months later...
2 hours ago, theleg said:

Does it work with KSP 1.10.1?

Try it and find out!

 

Decided to try this out on my current 1.8.1 RP-1/RO/RSS setup as the load times are pretty long due to well over a hundred mods:

Before: Elapsed time is 538.028s

First time, with 55k(!) MM patches created: Elapsed time is 663.4737s

Second time with cached MM patches: Elapsed time is 338.0936s

Wow! That's over 3 minutes faster, a 37% improvement. And that's with 32GB RAM and a 512GB SSD dedicated solely to KSP.

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...