Jump to content

[1.8.1-1.11.x] Modular Launch Pads v2.1.6: Launch clamps evolved: Real-style launch bases and towers [1 Nov 2020] ** Not Compatible With RO **


Recommended Posts

v2.1.1 is now out on Spacedock and GitHub.  Very small update to fix two silly errors:

Changelog:

  • Added missing Launch Plates tech tree node for the Unkerballed Start tree.
  • Fixed typo in Mounting Platform description.

Completely forgot to add the new launch plates custom tech node for the Unkerballed Start tree for the release. :D 

Link to post
Share on other sites
Just now, AlphaMensae said:

v2.1.1 is now out on Spacedock and GitHub.  Very small update to fix two silly errors:

Changelog:

  • Added missing Launch Plates tech tree node for the Unkerballed Start tree.
  • Fixed typo in Mounting Platform description.

Completely forgot to add the new launch plates custom tech node for the Unkerballed Start tree for the release. :D 

Yay! An update! :D

Link to post
Share on other sites
22 hours ago, AlphaMensae said:

@pTrevTrevsI've did test runs with both the Cormorant and SOCK shuttle stacks on the pad, and they worked fine.  Make sure no parts of the stack are clipping into the shuttle base, tower and arms. Particularly watch out for the SRB nozzle and skirt, if the SRB is a stock one the collider(s) may not match the visual object and could be clipping the launch base. Realistically, only the nozzle itself should be down in the exhaust hole, the aft skirt should be slightly above the deck. Might have to raise the whole shuttle stack so the nozzles are clear of the base.

Yeah, I thought about that after I closed the game, but I don't think I moved the Mobile Launcher at all since my last flight; only the FSS and RSS. I'll double check and let you know.

Link to post
Share on other sites
10 minutes ago, computercat04 said:

From what mod(s) are those rockets?

 

7 minutes ago, Clamp-o-Tron said:

reDIRECT.  Both also use procedural fairings for the fairing section and maybe the interstage on the Jupiter.

Those two screenshots were made by @Friznit, so I don't know exactly what's in them, but yes, ReDIRECT is the main one. :) 

Link to post
Share on other sites

It looks like my problem wasn't directly related to this mod after all, because it still happens exactly the same way even when I remove all the Modular Launch Pads hardware from the craft file and test it on the pad. Fortunately by doing that, I was able to get a better look at what exactly was happening to the ship, and it seems that whenever an animation was triggered, such as a cargo bay opening or landing gear extending, all the radial decouplers would break off. So the SRBs and Orbiter all fell off the ET, which became unsupported and fell to the ground and exploded. Switching the SRB decouplers for bigger and stronger ones seemed to fix the problem.

I think I can likely chalk the problem down to one of the dependencies for this mod, probably Animated Attachments. Having said that, I now see the disclaimer in the original post regarding that particular mod. It seems you were not the one to whom I ought to have raised this issue.

Link to post
Share on other sites

v2.1.2 is now on Spacedock and GitHub.

This was a fix for the inability of Kerbals on EVA to send the crew elevators down. Turns out I had forgotten about the evaDistance value for ModuleAnimateGeneric, which defaults to a very low amount if not specified. So I added that line to all the crew elevator .cfgs, making it appropriately large enough to cover the car at its highest position. Now Kerbals can send the car down as well as up! :) 

Also added another MLP v2.1 Example craft file, #5, this for the General Round Launch Stand.

Link to post
Share on other sites
11 hours ago, infinite_monkey said:

Now that Elon mentioned that he intends to go back landing the Super Heavy booster back to its launch clamps - would it be possible to have a docking port module on the launch pad?

#StuffElonSays

Seriously, I bet right now that's about as likely to happen as Crew Dragon making a propulsive landing on a helipad was when Elon promised it years ago.

Link to post
Share on other sites

Love this mod it really adds something extra to big rockets especially, I do have two requests though, the SpaceX style fallback towers are great, but the biggest clamp option is for a 2.5m rocket, which was sufficient earlier in my current career save, but I've since moved on to 3.75m and 5m reusable launchers and the clamps don't fit those, I tried making my own clamp from the modular girder segments but while it attaches to the tower, it doesn't follow the tower when it angles back. I'd like larger clamps and if possible that if you attach extra stuff to the fallback tower that it follows it when it moves back.

Regarding the Elon stuff: I don't see how it's a good idea to land right back onto your launch pad, if the landing goes wrong you'll wipe out a lot of expensive machinery, makes more sense to just land on a big flat landing pad nearby and move the rocket over back to the launch pad imo. Crew Dragon in theory can land using its superdracos instead of chutes, the problem is that it's much harder to make NASA sign of a propulsive landing than chutes, so SpaceX opted for the easier option.

Link to post
Share on other sites
On 11/15/2020 at 12:15 PM, FabioofSpace said:

Hey, so I'm using the test stand, and I got this weird problem. 

 

It basically started spinning when warping, and when I enter map view, it ends up like this. 

 

 

I don't know what's going on there, sorry. I can timewarp just fine, though my KSP is very light on mods. Just be sure the launch bases are not the root part and autostrut them to something on top of the rocket (like the proper root part). Sometimes KSP just glitches out.

Link to post
Share on other sites

I can not get the small launch rails to move the rocket when I adjust it.  The decoupler also does not function.  Do you think I have something borked on my install? 

I have tried making the stand and the rail the root, and attaching the rocket before or after moving the root. Seems like no matter what I try the rocket is frozen in place regardless of the rail movement. 

Edited by eberkain
Link to post
Share on other sites
5 minutes ago, eberkain said:

I can not get the small launch rails to move the rocket when I adjust it.  The decoupler also does not function.  Do you think I have something borked on my install? 

I have tried making the stand and the rail the root, and attaching the rocket before or after moving the root. Seems like no matter what I try the rocket is frozen in place regardless of the rail movement. 

Do you have Animated Attachment installed? That's needed for the launch rails in order to move the rocket with the rail.

For that to work though, the rail or whatever it is mounted on has to be the root part.  However, to decouple the rocket, something on the rocket has to be the root part.

Link to post
Share on other sites
21 minutes ago, AlphaMensae said:

Do you have Animated Attachment installed? That's needed for the launch rails in order to move the rocket with the rail.

For that to work though, the rail or whatever it is mounted on has to be the root part.  However, to decouple the rocket, something on the rocket has to be the root part.

Yes I have animated attachment installed... or not... 

Shazbot...  I have animated decouplers installed...  My bad. :)

 

EDIT:  Yep, that works.  And its Awsome!  Wish it had an adjustment for rotation angle too. :)

Edited by eberkain
Link to post
Share on other sites
18 minutes ago, eberkain said:

So, it works fine in the editor, but not so much in flight. 

 

To me this looks like a conflict with autostruts.  I do have this installed, mainly to keep my FAR planes from falling apart. 

Yeah, once you reroot to something on the rocket (like a probe core or nose), Animated Attachment won't work.  It needs the root to be a part that is "before" the decoupler, i.e. the rail, usually whatever the rail is mounted on.  But then the rail won't decouple.  So the movement is just a VAB-only thing.

 

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...