Jump to content

[1.8.1-1.12.x] Modular Launch Pads v2.2.3: Launch clamps evolved: Real-style launch bases and towers [5 July 2021]


AlphaMensae
 Share

Recommended Posts

1 hour ago, NotMyProblem said:

dJttRag.png

Will a Starship-Superheavy Orbital Launch Pad ever be added?

Eh, the current launch tower already looks like the one SpaceX uses on LC-39A. Just leave them gray. The catcher stuff will probably come from Tundra Exploration.

Link to comment
Share on other sites

2 hours ago, NotMyProblem said:

Will a Starship-Superheavy Orbital Launch Pad ever be added?

SAMCG14 has made the SpaceX mount and tower as an expansion for Tundra Exploration, you can ask about it on that thread.

My contribution was to make the standalone Saturn Milkstool Launch Stand with the short-height variant.

Link to comment
Share on other sites

1 hour ago, flart said:

"Titan III service tower section" doesn't  have the height switcher, ksp 1.12.2, last version of MLP.

The Titan III Tower sections (the core and separate section) are fixed in height, as they are so detailed that adding height variants would make the .mu sizes rapidly increase.

Stack Core sections (turning off the base pad on the additional sections), then stack the 2.5m separate section to fine-tune the height of the tower.

Link to comment
Share on other sites

10 hours ago, AlphaMensae said:

they are so detailed that adding height variants would make the .mu sizes rapidly increase.

Does b9ps support duplicate same model in the config with shifting position?
Without b9 it looks like that

@MODEL { %position = 0,0.7961068,0 } // %rotation = 0, 0, 0
+MODEL { %position = 0,0.3980534,0 }
+MODEL { %position = 0,0,0 }
+MODEL { %position = 0,-0.3980534,0 }
+MODEL { %position = 0,-0.7961068,0 }

 Maybe it is supported by ModuleB9PartSwitch/Subtypes/MODULE 

Link to comment
Share on other sites

I just installed this mod (on a brand new install) from CKAN, and it when doing so a popup appeared asking if I wanted to overwrite a number of files (.cfg files I think, I hit "yes" before really looking at it).  Is this normal, or should I reinstall my directory?  Never seen this popup before.

Link to comment
Share on other sites

45 minutes ago, ble210 said:

I just installed this mod (on a brand new install) from CKAN, and it when doing so a popup appeared asking if I wanted to overwrite a number of files (.cfg files I think, I hit "yes" before really looking at it).  Is this normal, or should I reinstall my directory?  Never seen this popup before.

Don't know, as I don't use CKAN. Maybe you already had newer versions of Module Manager and B9PartSwitch?

Link to comment
Share on other sites

20 hours ago, TruthfulGnome said:

When the BDB Saturn/Apollo update comes out is there a possibility of making the Saturn I/IB launch tower? 

I have no desire to make that tower, as it's an unsymmetrical tapered nightmare. I'm only interested in symmetrical square towers that can be built by stacking a single modular section.

Link to comment
Share on other sites

  • 2 weeks later...

Hey Alpha, first up amazing mod this is awesome stuff.

Probably a dumb question but I'm having trouble working out how to release rockets I've attached to the launch bases. I attach the bottom of the engine to the centre node, but when i stage and release the clamp it doesn't move, like its still attached.

Any help will be greatly appreciated.

Link to comment
Share on other sites

35 minutes ago, My_Friend_JD said:

Hey Alpha, first up amazing mod this is awesome stuff.

Probably a dumb question but I'm having trouble working out how to release rockets I've attached to the launch bases. I attach the bottom of the engine to the centre node, but when i stage and release the clamp it doesn't move, like its still attached.

Any help will be greatly appreciated.

The launch base/stand can't be the root part, or it won't work, which sounds like what's happening.

Link to comment
Share on other sites

Hello everyone.

I have a bit of a problem, and I'm not sure if it is just a proble related to my heavily modded 1.12.2 game (so it could be some strange interation/incompatibility):

up to now I had no problem with the "old" Modular Launch Pads (v.2.1.6) that used the stok "ModuleAnimatedGeneric"
I saw the latest version (v.2.2.0), I updated it (installing "Staged Animation"), but now none of the sliders are now showing in the VAB (to adjust any option), plus NO tower is actually animated on launch (multiple failure/rocket crashes on towers/umbillicals etc etc).

I'm a bit on a loss on trouble shooting why is not working, so, if anyone could shout me a couple of indication if it's probably just a problem about my own, or it is related to KSP 1.12.2, I'd really apreciate.

Thank you.

(Meanwhile is not a big loss: I kept playing with 2.1.6 with no issues, but...)

Nevermind!
Somehow I ended installing Staged Animation v.1.0 (that was not working)
... I did a recheck of all the dependencies, found Staged Animation v.2.0 and everything is ok!
Sorry for the false alarm!

Edited by Araym
Link to comment
Share on other sites

I was hoping someone would be able to help me. I have some kind of problem but maybe it's easy to fix. I don't know if it's a specific part but currently I have an SLS rocket on the Saturn Launch Pad with all the Saturn infrastructure. For some reason it doesn't show any info in the Staging Panel. It just shows "0 m.s" on each stage panel and when I expand the panel it's just blank. I would really appreciate it if someone could help me. 

Link to comment
Share on other sites

5 hours ago, GamingHen said:

I was hoping someone would be able to help me. I have some kind of problem but maybe it's easy to fix. I don't know if it's a specific part but currently I have an SLS rocket on the Saturn Launch Pad with all the Saturn infrastructure. For some reason it doesn't show any info in the Staging Panel. It just shows "0 m.s" on each stage panel and when I expand the panel it's just blank. I would really appreciate it if someone could help me. 

May be more of a KSP problem, but having the launch base as the root part will also not properly show delta-V information.

It's always best to attach the launch base after the rocket is complete, or you probablty forget to reroot to the probe core or pod or whatever at the top.  :) 

On 9/5/2021 at 5:29 AM, Araym said:

Nevermind!
Somehow I ended installing Staged Animation v.1.0 (that was not working)
... I did a recheck of all the dependencies, found Staged Animation v.2.0 and everything is ok!
Sorry for the false alarm!

I know you fixed it yourself, but I will add that the StagedAnimation included with ModularLaunchPads is actually the v2.0 version, as NathanKell gave me the updated .dll before putting it on the GitHub as v2.0

Link to comment
Share on other sites

On 9/7/2021 at 1:00 AM, AlphaMensae said:

I know you fixed it yourself, but I will add that the StagedAnimation included with ModularLaunchPads is actually the v2.0 version, as NathanKell gave me the updated .dll before putting it on the GitHub as v2.0

It was totally MY fault, indeed:

I was debugging my instal for unrelated reasons to MLP,  and I forgot from where I got StagedAnimation, so I did a fast github resesearch, found Nathan repository and, by various other "reasons", landed on the wrong file.
Only after that I found the problem with your mod and had to resolve the issue with an outdated plugin...

---

Unrelated, but another little "bug", not only from your mod, but anyone adding some "Custom Part List" file:

each time the game is loaded, the game add a new istance of the list: I'm ending with dozen of your Modular Launc Pad category.
As "ModuleManager" is basically an hardcore dependency for many of them, I think that could be more "friendly user/coding etiquette" to add some MM "logical command", if they could work, alike "%" (edit) or something similar (I'm not very MM capable, aside basic modification-usage) to just updating the same category, rather than use the actual "plain version" that had the issue to add multiple one, one for each time the game is loaded...

 

Edited by Araym
Link to comment
Share on other sites

13 hours ago, Araym said:

Unrelated, but another little "bug", not only from your mod, but anyone adding some "Custom Part List" file:

each time the game is loaded, the game add a new istance of the list: I'm ending with dozen of your Modular Launc Pad category.
As "ModuleManager" is basically an hardcore dependency for many of them, I think that could be more "friendly user/coding etiquette" to add some MM "logical command", if they could work, alike "%" (edit) or something similar (I'm not very MM capable, aside basic modification-usage) to just updating the same category, rather than use the actual "plain version" that had the issue to add multiple one, one for each time the game is loaded...

 

If you get duplicates of the custom category, go to GameaData/Squad/PartList and delete the CustomCategory.cfg file (or similar name) that will be there.

With mod-provided stock custom categories, you can't manually create your own in-game or click on (even accidentally) the little '+' sign that will be in the corned of the part icons, as KSP will create its own custom category .cfg and copy all the mod-provided ones into it, resulting in duplicate icons.

Link to comment
Share on other sites

  • 3 weeks later...

Are there plans to update this mod once BDB's next update is fully released?

the saturn the hold downs saturn I and V, the service masts for the Saturn v, and the milkstool aren't high enough and there's this weird ring on on the saturn I engine mount.

Link to comment
Share on other sites

2 hours ago, zakkpaz said:

Are there plans to update this mod once BDB's next update is fully released?

the saturn the hold downs saturn I and V, the service masts for the Saturn v, and the milkstool aren't high enough and there's this weird ring on on the saturn I engine mount.

MLP works perfectly for the in development saturn parts, having already been set up for a more appropriately sized saturn since before the Apollo Saturn Revamp has started. As for the ring around the Saturn I engine mount go to ModularLaunchpads/Compatibility_Patches/BluedogDB_MLP_Patches.cfg and delete lines 9-15 (keeping the node_stack_bottom line!)

Edited by Jcking
some fixes for the hack
Link to comment
Share on other sites

3 hours ago, Jcking said:

MLP works perfectly for the in development saturn parts, having already been set up for a more appropriately sized saturn since before the Apollo Saturn Revamp has started. As for the ring around the Saturn I engine mount go to ModularLaunchpads/Compatibility_Patches/BluedogDB_MLP_Patches.cfg and delete lines 9-15 (keeping the node_stack_bottom line!)

The Saturn tower is not correctly scaled to the new Saturn parts and the umbilicals don't fit properly so i wouldn't say properly 

Link to comment
Share on other sites

7 hours ago, TruthfulGnome said:

The Saturn tower is not correctly scaled to the new Saturn parts and the umbilicals don't fit properly so i wouldn't say properly 

You sure about that? (granted the crew access arm for Saturn IB is not in a place that would be traversable by the crew, but I think it was like that for the old parts as well).

HGCzunG.jpg

A2sIh8D.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...