linuxgurugamer

[1.5.1, 1.6.1, 1.7.2] KSP-AVC Add-on Version Checker Plugin - MiniAVC

Recommended Posts

9 hours ago, COL.R.Neville said:

so got the notice via ksp avc that a new versions of engine light relit, ksp avc, pebkac was out but....

the kspavc download link for engine light relit went to the old engine light on spacedock. 

ksp avc keeps reporting that my current ksp avc build is 1.2 something instead of the 1.303 that is in the version file

also the pebkac spacedock download link in ksp avc goes to a dead link.

i really hate these posts cuz you should be sainted for keeping all these mods going over the years so just letting you know whats going on.  

Appreciate it, will get the enginelight one fixed asap

 

Share this post


Link to post
Share on other sites
Posted (edited)
9 hours ago, COL.R.Neville said:

so got the notice via ksp avc that a new versions of engine light relit, ksp avc, pebkac was out but....

the kspavc download link for engine light relit went to the old engine light on spacedock. 

ksp avc keeps reporting that my current ksp avc build is 1.2 something instead of the 1.303 that is in the version file

also the pebkac spacedock download link in ksp avc goes to a dead link.

i really hate these posts cuz you should be sainted for keeping all these mods going over the years so just letting you know whats going on.  

Fixed the Engine Light Relit download link

Fixed the Pebkac download link

Not sure what's going on with AVC yet, could you post a complete log?

Also, an FYI, for something like this, ping me so I get notified.  I only came across this by accident

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites
Posted (edited)
Spoiler

KSP: 1.7 (Win64) - Unity: 2017.1.3p1 - OS: Windows 7 Service Pack 1 (6.1.7601) 64bit
000_AT_Utils - 1.7
ClickThroughBlocker - 0.1.7.2
Filter Extensions - 3.2.2.17
TexturesUnlimited - 1.4.7.21
Toolbar - 1.7.18
USI Tools - 1.0
ToolbarControl - 0.1.6.20
All Tweak!!! - 
AllYAllContinued - 0.11.16.3
Animated Decouplers - 1.4.2
Astrogator - 0.9.1
B9 Animation Modules - 1.5
B9 Part Switch - 2.7.1
BD Animation Modules - 0.6.5.7
Better Science Labs Continued - 0.1.11
Bon Voyage - 0.14.4
Chatterer Extended - 0.6.2
Chatterer - 0.9.96.2332
CommNetAntennasExtension - 2.0.1
CommNetAntennasInfo - 2.1
Community Category Kit - 4.1
Community Resource Pack - 1.0
CommunityTechTree - 3.3.7
Community Trait Icons - 1.1.1
ConfigurableContainers - 2.4.5
Contract Configurator - 1.27.1
Contract Pack: Anomaly Surveyor - 1.7.1
Contract Pack: Bases and Stations - 3.7.1.4
Contract Reward Modifier - 1.0.2.6
CryoTanks - 1.1.2
CustomBarnKit - 1.1.19
DeployableEngines - 1.0.1
DistantObjectEnhancement - 1.9.1
DMagic Orbital Science - 1.4.2
Contract Parser - 1.0.8
Contracts Window Plus - 1.0.9.2
Progress Parser - 1.0.10
Easy Vessel Switch - 1.11.7052.36539
Endurance Continued - 1.8
Engine Lighting Relit - 1.6.0.1
EVA Transfer - 1.0.8.1
Firespitter - 7.9
FMRS (Flight Manager For Reusable Stages) - 1.2.7.4
FShangarExtender - 3.5.3.5
Fuel Tanks Plus - 2.0.2
GroundConstruction - 2.3.2
HideEmptyTechTreeNodes - 1.1.1
HullcamVDSContinued - 0.1.12
Interstellar Fuel Switch - 3.8.2.4
Joolian Discovery - 0.8
JSIPartUtilities - 0.4.2.2
JSIAdvTransparentPods - 0.1.19
RasterPropMonitor - 0.30.5
KAS - 1.3.7050.3681
KerbalAtomics - 1.0.1
Kerbal Engineer Redux - 1.1.6
Kerbal Foundries - 2.3.7.17
Kerbal Joint Reinforcement - 4.0.9
HyperEdit - 1.5.8
Kerbal Inventory System - 1.21.7075.35942
KSP-AVC Plugin - 1.3.0.3
KSPRescuePodFix - 1.6.4.14
KSPWheel - 0.15.13.32
MarkIVSystem - 3.0.4
KSP-AVC Plugin - 1.3.0.3
KSP-AVC Plugin - 1.2.0.2

Mission Controller 2.0 - 2.0.4.1
MOARdV's Avionics Systems - 0.97
MOARdVPlus Advanced IVAs - 1.0
Modular Rocket Systems - 1.13.2
Docking Port Alignment Indicator - 6.8.3
NearFutureAeronautics - 1.0.4
NearFutureConstruction - 1.1.1
NearFutureElectrical - 1.0.1
NearFutureLaunchVehicles - 1.1.11
NearFutureProps - 0.5.1
NearFuturePropulsion - 1.1.1
NearFutureSolar - 1.0.2
NearFutureSpacecraft - 1.2.4
Nehemiah Engineering Orbital Science (NEOS) - 0.8.0.25
Final Frontier - 1.5.3.3465
OPT Legacy Spaceplane Parts - 1.3.1
OPT Reconfig - 1.5
PEBKAC Launch Escape - 1.4.1.2
PlanetShine - 0.2.6.1
Portrait Stats - 1.0.17
Precise Editor - 1.2
Precise Maneuver - 2.4.2
RCS Build Aid - 0.9.7.6
RCS Sounds - 5.2
RealPlume - Stock - 1.3.1
Recovery Controller - 0.0.3.7
ReentryParticleEffect - 1.4
DeepFreeze Continued... - 0.25
ResearchBodies - 1.9.8
ResonantOrbitCalculator - 0.0.4.1
ReStock - 0.1.4
SCANsat - 1.1.8.10
Celestial Body Science Editor - 1.0.11
Science Relay - 1.0.5.1
ShipManifest - 5.2.1
ShowFPS - 0.2.0.3
SmartParts - 1.9.13.4
Space Age - 1.0.1
RecycledParts - 0.1.6.1
StageRecovery - 1.9.1
StationScienceContinued - 2.5.3
Strategia - 1.7.3
Surface Experiment Package - 2.7
TarsierSpaceTechnology - 7.5
TextureReplacer - 3.7
Trajectories - 2.2.2
Kerbal Alarm Clock - 3.10
Alternate Resource Panel - 2.9.3
Transfer Window Planner - 1.6.3
TweakScale - 2.4.2
USI Core - 1.0
Asteroid Recycling Tech - 1.0
USI Exploration Pack - 1.0
Freight Transport Tech - 1.0
Karbonite - 1.0
Konstruction - 1.0
USI-LS - 1.0
Malemute Rover - 1.0
MKS - 1.0
NuclearRockets - 1.0
USI Alcubierre Drive - 1.5
Universal Storage 2 - 1.7.0.10
Unmanned before Manned - 1.3.0.2
VesselViewerContinued - 0.8.7.2
Kerbal Actuators - 1.7.1
[x] Science! - 5.20

so this is a copy to clipboard from the screen in the upper left where it looks like 2 versions of 1303 and one version of 1202 of the dll are running but when i search thru my files i only see the one in ksp avc. the rest are all mini avc's. 

im working on getting you the full logs. and ill send you a download link. 

also if you just run ksp-avc and the two squad files everything seems to work fine. 

Edited by COL.R.Neville

Share this post


Link to post
Share on other sites
17 hours ago, COL.R.Neville said:
  Reveal hidden contents

KSP: 1.7 (Win64) - Unity: 2017.1.3p1 - OS: Windows 7 Service Pack 1 (6.1.7601) 64bit
000_AT_Utils - 1.7
ClickThroughBlocker - 0.1.7.2
Filter Extensions - 3.2.2.17
TexturesUnlimited - 1.4.7.21
Toolbar - 1.7.18
USI Tools - 1.0
ToolbarControl - 0.1.6.20
All Tweak!!! - 
AllYAllContinued - 0.11.16.3
Animated Decouplers - 1.4.2
Astrogator - 0.9.1
B9 Animation Modules - 1.5
B9 Part Switch - 2.7.1
BD Animation Modules - 0.6.5.7
Better Science Labs Continued - 0.1.11
Bon Voyage - 0.14.4
Chatterer Extended - 0.6.2
Chatterer - 0.9.96.2332
CommNetAntennasExtension - 2.0.1
CommNetAntennasInfo - 2.1
Community Category Kit - 4.1
Community Resource Pack - 1.0
CommunityTechTree - 3.3.7
Community Trait Icons - 1.1.1
ConfigurableContainers - 2.4.5
Contract Configurator - 1.27.1
Contract Pack: Anomaly Surveyor - 1.7.1
Contract Pack: Bases and Stations - 3.7.1.4
Contract Reward Modifier - 1.0.2.6
CryoTanks - 1.1.2
CustomBarnKit - 1.1.19
DeployableEngines - 1.0.1
DistantObjectEnhancement - 1.9.1
DMagic Orbital Science - 1.4.2
Contract Parser - 1.0.8
Contracts Window Plus - 1.0.9.2
Progress Parser - 1.0.10
Easy Vessel Switch - 1.11.7052.36539
Endurance Continued - 1.8
Engine Lighting Relit - 1.6.0.1
EVA Transfer - 1.0.8.1
Firespitter - 7.9
FMRS (Flight Manager For Reusable Stages) - 1.2.7.4
FShangarExtender - 3.5.3.5
Fuel Tanks Plus - 2.0.2
GroundConstruction - 2.3.2
HideEmptyTechTreeNodes - 1.1.1
HullcamVDSContinued - 0.1.12
Interstellar Fuel Switch - 3.8.2.4
Joolian Discovery - 0.8
JSIPartUtilities - 0.4.2.2
JSIAdvTransparentPods - 0.1.19
RasterPropMonitor - 0.30.5
KAS - 1.3.7050.3681
KerbalAtomics - 1.0.1
Kerbal Engineer Redux - 1.1.6
Kerbal Foundries - 2.3.7.17
Kerbal Joint Reinforcement - 4.0.9
HyperEdit - 1.5.8
Kerbal Inventory System - 1.21.7075.35942
KSP-AVC Plugin - 1.3.0.3
KSPRescuePodFix - 1.6.4.14
KSPWheel - 0.15.13.32
MarkIVSystem - 3.0.4
KSP-AVC Plugin - 1.3.0.3
KSP-AVC Plugin - 1.2.0.2

Mission Controller 2.0 - 2.0.4.1
MOARdV's Avionics Systems - 0.97
MOARdVPlus Advanced IVAs - 1.0
Modular Rocket Systems - 1.13.2
Docking Port Alignment Indicator - 6.8.3
NearFutureAeronautics - 1.0.4
NearFutureConstruction - 1.1.1
NearFutureElectrical - 1.0.1
NearFutureLaunchVehicles - 1.1.11
NearFutureProps - 0.5.1
NearFuturePropulsion - 1.1.1
NearFutureSolar - 1.0.2
NearFutureSpacecraft - 1.2.4
Nehemiah Engineering Orbital Science (NEOS) - 0.8.0.25
Final Frontier - 1.5.3.3465
OPT Legacy Spaceplane Parts - 1.3.1
OPT Reconfig - 1.5
PEBKAC Launch Escape - 1.4.1.2
PlanetShine - 0.2.6.1
Portrait Stats - 1.0.17
Precise Editor - 1.2
Precise Maneuver - 2.4.2
RCS Build Aid - 0.9.7.6
RCS Sounds - 5.2
RealPlume - Stock - 1.3.1
Recovery Controller - 0.0.3.7
ReentryParticleEffect - 1.4
DeepFreeze Continued... - 0.25
ResearchBodies - 1.9.8
ResonantOrbitCalculator - 0.0.4.1
ReStock - 0.1.4
SCANsat - 1.1.8.10
Celestial Body Science Editor - 1.0.11
Science Relay - 1.0.5.1
ShipManifest - 5.2.1
ShowFPS - 0.2.0.3
SmartParts - 1.9.13.4
Space Age - 1.0.1
RecycledParts - 0.1.6.1
StageRecovery - 1.9.1
StationScienceContinued - 2.5.3
Strategia - 1.7.3
Surface Experiment Package - 2.7
TarsierSpaceTechnology - 7.5
TextureReplacer - 3.7
Trajectories - 2.2.2
Kerbal Alarm Clock - 3.10
Alternate Resource Panel - 2.9.3
Transfer Window Planner - 1.6.3
TweakScale - 2.4.2
USI Core - 1.0
Asteroid Recycling Tech - 1.0
USI Exploration Pack - 1.0
Freight Transport Tech - 1.0
Karbonite - 1.0
Konstruction - 1.0
USI-LS - 1.0
Malemute Rover - 1.0
MKS - 1.0
NuclearRockets - 1.0
USI Alcubierre Drive - 1.5
Universal Storage 2 - 1.7.0.10
Unmanned before Manned - 1.3.0.2
VesselViewerContinued - 0.8.7.2
Kerbal Actuators - 1.7.1
[x] Science! - 5.20

so this is a copy to clipboard from the screen in the upper left where it looks like 2 versions of 1303 and one version of 1202 of the dll are running but when i search thru my files i only see the one in ksp avc. the rest are all mini avc's. 

im working on getting you the full logs. and ill send you a download link. 

also if you just run ksp-avc and the two squad files everything seems to work fine. 

Ok, this was EXTREMELY helpful.

The very short answer is: Nothing is wrong.

The reason is that the MiniAVC is included in mods, not all of which may be running the latest version.  That's what you are seeing.  In your case, since you are running the full KSP-AVC, while they are there, they do not run because they see the full KSP-AVC.

I'd suggest installing the ZeroMiniAVC mod (available from Spacedock here:  https://spacedock.info/mod/1614/ZeroMiniAVC) which will rename all the MiniAVC files so they won't run at all after the first time

Share this post


Link to post
Share on other sites

okay but you have ksp avc and mini avc right?  2 distinct elements and from what ksp avc writes in the logs it appears to be tracking them separately but it looks like

somehow a mini avc version value is being put in the ksp avc column. maybe thats why im getting the popup for ksp avc being out of date when it isnt and if i dont have any mini avc's in gamedata just squad and ksp avc installed everything seems to work fine.

kinda sounds like what going on right?

because the popup will give you a separate entry for mini avc being out of date as well as ksp avc being out of date.

but i could be wrong wouldnt be the first time hehe.  

 

 

Share this post


Link to post
Share on other sites
1 minute ago, COL.R.Neville said:

okay but you have ksp avc and mini avc right?  2 distinct elements and from what ksp avc writes in the logs it appears to be tracking them separately but it looks like

somehow a mini avc version value is being put in the ksp avc column. maybe thats why im getting the popup for ksp avc being out of date when it isnt and if i dont have any mini avc's in gamedata just squad and ksp avc installed everything seems to work fine.

kinda sounds like what going on right?

because the popup will give you a separate entry for mini avc being out of date as well as ksp avc being out of date.

but i could be wrong wouldnt be the first time hehe.  

Sorry, I think you are missing one fact.

KSP-AVC is a fill mod, and is running correctly.

Mini-AVC is included with EACH mod that uses it, which means that you can potentially have as many MiniAVC DLLs installed as mods.  It’s up to the mod au5er to put in an updated version.  But since you have the full AVS mod installed, you can ignore them.  I suggest that you install MiniAVC to eliminate the messages entirely

Share this post


Link to post
Share on other sites

yeah ive got the zero mini mod installed now.

thanks for fixing the links appreciate it.  

Share this post


Link to post
Share on other sites
Posted (edited)

@linuxgurugamer is there a way in which I can specify in my AVC version file specifc versions of KSP that a mod can work with. In this particular case, being a planet pack it requires Kopernicus and due to Kopernicus backporting current development for very specific versions of KSP, I would need a way in KSP-AVC to be able to say something like: Only work for these versions: 1.3.1, 1.4.5, 1.5.1, 1.6.1 & 1.7.1 and onwards (specifically disallowing 1.7.0). Disallowing 1.7.0 is also critical as there was functionality added to Kopernicus from 1.7.1 onwards that causes this planet pack to fail on 1.7.0 versions of Kopernicus due to syntax changes. To reiterate the requirements would be:

  • 1.3.1
  • 1.4.5
  • 1.5.1
  • 1.6.1
  • 1.7.1 - 1.7.99

Does KSP-AVC allow for this kind of pick and choose nature of versioning whilst also allowing for ranges of versions to be specified alongside?

For reference, the current version file in question: https://github.com/Poodmund/Outer-Planets-Mod/blob/master/GameData/OPM/OuterPlanetsMod.version

Edited by Poodmund

Share this post


Link to post
Share on other sites
26 minutes ago, Poodmund said:

@linuxgurugamer is there a way in which I can specify in my AVC version file specifc versions of KSP that a mod can work with. In this particular case, being a planet pack it requires Kopernicus and due to Kopernicus backporting current development for very specific versions of KSP, I would need a way in KSP-AVC to be able to say something like: Only work for these versions: 1.3.1, 1.4.5, 1.5.1, 1.6.1 & 1.7.1 and onwards (specifically disallowing 1.7.0). Disallowing 1.7.0 is also critical as there was functionality added to Kopernicus from 1.7.1 onwards that causes this planet pack to fail on 1.7.0 versions of Kopernicus due to syntax changes. To reiterate the requirements would be:

  • 1.3.1
  • 1.4.5
  • 1.5.1
  • 1.6.1
  • 1.7.1 - 1.7.99

Does KSP-AVC allow for this kind of pick and choose nature of versioning whilst also allowing for ranges of versions to be specified alongside?

For reference, the current version file in question: https://github.com/Poodmund/Outer-Planets-Mod/blob/master/GameData/OPM/OuterPlanetsMod.version

Not at present, but there is an outstanding PR from @blowfish to add it.  Problem is compatibility with CKAN, since CKAN looks at the file as well.  I'll ping @HebaruSan about it

Share this post


Link to post
Share on other sites
7 minutes ago, linuxgurugamer said:

Not at present, but there is an outstanding PR from @blowfish to add it.  Problem is compatibility with CKAN, since CKAN looks at the file as well.  I'll ping @HebaruSan about it

Looks like that PR is about something else.

Poodmund's comment: Marking a release as supporting a non-contiguous set of versions.

That PR: Listing multiple releases in a version file, each of which still supports either one KSP version or a contiguous range of KSP versions.

Share this post


Link to post
Share on other sites
7 minutes ago, HebaruSan said:

Looks like that PR is about something else.

Poodmund's comment: Marking a release as supporting a non-contiguous set of versions.

That PR: Listing multiple releases in a version file, each of which still supports either one KSP version or a contiguous range of KSP versions.

It accomplishes the same thing in a different way.  Either way, CKAN would need to be able to support an updated version of the .version file

Share this post


Link to post
Share on other sites
4 minutes ago, linuxgurugamer said:

It accomplishes the same thing in a different way.

Does it? Howso?

Share this post


Link to post
Share on other sites
Posted (edited)
9 minutes ago, HebaruSan said:

Does it? Howso?

It helps to read closely while running a temperature.

I suppose it could be handled by adding an EXCLUDE and allowing multiple such as:

 

“EXCLUDE_KSP_VERSION” : “1.7.0”,

 

 

This would have the advantage of not forcing CKAN to be updated (although it really should to get the best benefit)

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites

Thanks guys for even glossing over my post however prominent it may be for a backlog. I was going to post about this in the CKAN thread once LGG had given some feedback but it seems you guys are already sparking a discussion. :D 

Share this post


Link to post
Share on other sites
2 hours ago, Poodmund said:

Disallowing 1.7.0 is also critical as there was functionality added to Kopernicus from 1.7.1 onwards that causes this planet pack to fail on 1.7.0 versions of Kopernicus due to syntax changes.

1 hour ago, Poodmund said:

Thanks guys for even glossing over my post however prominent it may be for a backlog. I was going to post about this in the CKAN thread once LGG had given some feedback but it seems you guys are already sparking a discussion. :D 

For the CKAN side of things, you could try banning the bad version of Kopernicus:

"conflicts": [
    { "name": "Kopernicus", "version": "2:release-1.7.0-1" }
],

I can't say for sure whether that would work, but it's the first thing I'd try.

Share this post


Link to post
Share on other sites
1 hour ago, linuxgurugamer said:

It helps to read closely while running a temperature.

I suppose it could be handled by adding an EXCLUDE and allowing multiple such as:

 


“EXCLUDE_KSP_VERSION” : “1.7.0”,

 

 

This would have the advantage of not forcing CKAN to be updated (although it really should to get the best benefit)

This would actually be something like:

  "KSP_VERSION_EXCLUDE": {
    "MAJOR": 1,
    "MINOR": 5,
    "PATCH": 1
  },

I know it's more lines, but it's compatible with everything else in AVC

Share this post


Link to post
Share on other sites
Just now, linuxgurugamer said:

This would actually be something like:


  "KSP_VERSION_EXCLUDE": {
    "MAJOR": 1,
    "MINOR": 5,
    "PATCH": 1
  },

I know it's more lines, but it's compatible with everything else in AVC

That would work for the specific case of excluding just one version. What if you needed to exclude more? It should probably take an array, if not a _MIN / _MAX style range.

Share this post


Link to post
Share on other sites
2 minutes ago, HebaruSan said:

That would work for the specific case of excluding just one version. What if you needed to exclude more? It should probably take an array, if not a _MIN / _MAX style range.

I'll allow multiple entries,  it's easier to code than creating a nested stanza

Share this post


Link to post
Share on other sites
17 minutes ago, linuxgurugamer said:

I'll allow multiple entries,  it's easier to code than creating a nested stanza

That's invalid JSON, though. An object can only have one of each property.

Share this post


Link to post
Share on other sites
1 hour ago, HebaruSan said:

That's invalid JSON, though. An object can only have one of each property.

So i found out.  Working on it, when I’m feeling up to it

Share this post


Link to post
Share on other sites

@Poodmund @HebaruSan

Here is a beta to try out.

Syntax is:

		  "KSP_VERSION_EXCLUDE": [
			{      "MAJOR": 1,      "MINOR": 6,      "PATCH": 1    },
			{      "MAJOR": 2,      "MINOR": 6,      "PATCH": 2    }
		  ]

One line for each version being excluded.

Share this post


Link to post
Share on other sites

Could the same be done for an include as you have suggested for exclude?

Share this post


Link to post
Share on other sites

Just stepping by for a little heads up:

If this is going to interfere with the "IsCompatible" boolean of "AddonInfo", I would suggest to put:

"DISALLOW_VERSION_OVERRIDE": True,

within the version file as well. Otherwise, the compatibility override is still able to do his job and well...may overrides it^^ As far as I can tell, this wouldn't be helpful in this case ;)

@linuxgurugamer While looking up the correct entry, I've noticed that I mixed up something in the log entries created by AVC and since I'm not used to JSON: it's not a valid JSON syntax either, isn't it?^^ I'll fix that later the day and open a PR ;)

Share this post


Link to post
Share on other sites
4 hours ago, Poodmund said:

Could the same be done for an include as you have suggested for exclude?

Jeez, give a man an inch and he’ll take a mile :D

yes, but it won’t be until later.

4 hours ago, 4x4cheesecake said:

Just stepping by for a little heads up:

If this is going to interfere with the "IsCompatible" boolean of "AddonInfo", I would suggest to put:


"DISALLOW_VERSION_OVERRIDE": True,

within the version file as well. Otherwise, the compatibility override is still able to do his job and well...may overrides it^^ As far as I can tell, this wouldn't be helpful in this case ;)

@linuxgurugamer While looking up the correct entry, I've noticed that I mixed up something in the log entries created by AVC and since I'm not used to JSON: it's not a valid JSON syntax either, isn't it?^^ I'll fix that later the day and open a PR ;)

I’ll have to check, but I think this will have priority over the compatibility override.  Would still be a good idea to put that in.

Share this post


Link to post
Share on other sites
2 hours ago, linuxgurugamer said:

Jeez, give a man an inch and he’ll take a mile :D

yes, but it won’t be until later.

:D In my case I think it would be more useful that way anyway as it's only a small amount of versions to be compatible with.

... and there's no rush. I've got a small performance update to push out but everyone's been coping up until this point so it's not mission critical, for me. I'll be happy to see any progress whenever you get a chance to give it some time.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.