Jump to content

[1.12.x PlanetShine 0.2.6.6, Feb 22, 2022


Papa_Joe
 Share

Recommended Posts

46 minutes ago, jjansen said:

Just chiming in about how much I miss this mod.

It's actually breaking the game for me because I don't want to do anything that might look good enough to screenshot, and without PS, screenshots look like crap to me now.

It's been updated over here:

https://forum.kerbalspaceprogram.com/index.php?/topic/189071-18x-planetshine-0262-oct-19-2019/&tab=comments#comment-3690968

Edited by therealcrow999
Link to comment
Share on other sites

  • 3 weeks later...
  • 2 weeks later...

Hi everyone !

My planet shine add light on my ships but no color at all. I tried to move all settings but all I can do is modify luminosity. Even at 90km above Ocean on day light.

I play on 1.7.3, 2.5 scale with rescale, and on KSRSS (Kerbin Size Real Solar System).

So did I miss something like a special config because of KSRSS or something like that ?

Thanks for you help :)

Link to comment
Share on other sites

  • 2 years later...

Necroing an old thread.

I've pulled the latest from @prestja's git repo and brought this mod up to date for KSP 1.12.3.  I've reached out to @prestja in his thread to offer to resume maintenance.  Given the last time it was updated was 2019, unless I hear otherwise I'm going to go ahead and release a new version, and reclaim maintenance of this mod.

New release:  v0.2.6.4
- Recompiled for KSP 1.12.3
- Papa_Joe resumes maintenance.  Many thanks to Prestja for keeping this mod alive in my absense!
- Refactored some code for newer C# styles and .NET 4.8
- Revised build pipeline to match PapaJoe's multi mod build pipeline.
 

  Edit:  corrected version.  Seem we had some version conflicts in the past.  Bumped to to 0.2.6.4.  Hopefully that is clean.

New version is on my GitHub, shown in the OP.
@HebaruSan  Just a heads up.  For the purposes of CKAN, I've resumed maintenance, and a new version is on my Github.

Edited by Papa_Joe
Corrected versioning info to reflect a clean version going forward.
Link to comment
Share on other sites

2 minutes ago, Papa_Joe said:

Necroing an old thread.

I've pulled the latest from @prestja's git repo and brought this mod up to date for KSP 1.12.3.  I've reached out to @prestja in his thread to offer to resume maintenance.  Given the last time it was updated was 2019, unless I hear otherwise I'm going to go ahead and release a new version, and reclaim maintenance of this mod.

New release:  v0.2.6.3
- Recompiled for KSP 1.12.3
- Papa_Joe resumes maintenance.  Many thanks to Prestja for keeping this mod alive in my absense!
- Refactored some code for newer C# styles and .NET 4.8
- Revised build pipeline to match PapaJoe's multi mod build pipeline.
 

  

Prestja FWIW is/was one of the maintainers on Kopernicus.  I believe he's just busy with real life/school...  happens to the best of us some days.  Glad to see you picking this up.

Edited by R-T-B
Link to comment
Share on other sites

1 hour ago, R-T-B said:

Prestja FWIW is/was one of the maintainers on Kopernicus.  I believe he's just busy with real life/school...  happens to the best of us some days.  Glad to see you picking this up.

Indeed.  It happened to me as well.  Life is now allowing me to spend time on modding again.  I've heard from @prestja and am resuming support of this mod.

Link to prestja's forum thread:  

 

Edited by Papa_Joe
Link to comment
Share on other sites

I installed your new version 2.6.4 to my running RSS/RP-1 game.  Launched the game and went to fly one of the existing satellites to find it had a purple/pink square artifact attached to the top.  Looks like what you see in the first image here: https://imgur.com/a/6sau9mg  from  weird pink square keeps appearing

Reverted back to 2.6.3 and the pink artifact is no longer there. 

Link to comment
Share on other sites

3 hours ago, randomjgj said:

I installed your new version 2.6.4 to my running RSS/RP-1 game.  Launched the game and went to fly one of the existing satellites to find it had a purple/pink square artifact attached to the top.  Looks like what you see in the first image here: https://imgur.com/a/6sau9mg  from  weird pink square keeps appearing

I am also seeing this pink square on the cockpit of my Blackbird, have Mk2 Expansion, EVE/AVP and Galaxies Unbound installed if that helps

Link to comment
Share on other sites

10 hours ago, Papa_Joe said:

Necroing an old thread.

I've pulled the latest from @prestja's git repo and brought this mod up to date for KSP 1.12.3.  I've reached out to @prestja in his thread to offer to resume maintenance.  Given the last time it was updated was 2019, unless I hear otherwise I'm going to go ahead and release a new version, and reclaim maintenance of this mod.

New release:  v0.2.6.4
- Recompiled for KSP 1.12.3
- Papa_Joe resumes maintenance.  Many thanks to Prestja for keeping this mod alive in my absense!
- Refactored some code for newer C# styles and .NET 4.8
- Revised build pipeline to match PapaJoe's multi mod build pipeline.
 

  Edit:  corrected version.  Seem we had some version conflicts in the past.  Bumped to to 0.2.6.4.  Hopefully that is clean.

New version is on my GitHub, shown in the OP.
@HebaruSan  Just a heads up.  For the purposes of CKAN, I've resumed maintenance, and a new version is on my Github.

Oh, that's excellent news. Can you maybe look at the problem of Planet Shine not working on the new kerbal models? We were discussing that a couple of pages ago in prestja's thread.

Iamsodarncool's message there:
 

Spoiler

Hi, I don't have any experience coding KSP mods, but I'm a full time Unity dev so I think I can help.

The problem here is that lights have a culling mask that determines which layers of objects their light affects. Kerbals and ships are on different layers, and the PlanetShine lights do not have the Kerbal layer in their culling mask.

According to the KSP modding documentation on layers, Kerbals are on layer 16. So I think this bug would be fixed by changing line 124 of PlanetShine.cs from light.cullingMask = (1 << 0); to light.cullingMask = (1 << 0) | (1 << 16);. However if that doesn't work (the modding docs seem pretty out of date so I wouldn't be surprised) you can write a script to find the layer of the Kerbal renderer components and use that number instead of 16.

I deleted the old pictures from my imgur account, so they will not show there anymore. If you need new ones, just let me know. 

Edited by dok_377
Link to comment
Share on other sites

6 hours ago, dok_377 said:

Oh, that's excellent news. Can you maybe look at the problem of Planet Shine not working on the new kerbal models? We were discussing that a couple of pages ago in prestja's thread.

Iamsodarncool's message there:
 

  Reveal hidden contents

Hi, I don't have any experience coding KSP mods, but I'm a full time Unity dev so I think I can help.

The problem here is that lights have a culling mask that determines which layers of objects their light affects. Kerbals and ships are on different layers, and the PlanetShine lights do not have the Kerbal layer in their culling mask.

According to the KSP modding documentation on layers, Kerbals are on layer 16. So I think this bug would be fixed by changing line 124 of PlanetShine.cs from light.cullingMask = (1 << 0); to light.cullingMask = (1 << 0) | (1 << 16);. However if that doesn't work (the modding docs seem pretty out of date so I wouldn't be surprised) you can write a script to find the layer of the Kerbal renderer components and use that number instead of 16.

I deleted the old pictures from my imgur account, so they will not show there anymore. If you need new ones, just let me know. 

 

5 hours ago, Glimmerglint said:

Glad to see an update for this! I also got the purple square artifact immediately after downloading the new version, so you may want to look at that.

 

49 minutes ago, TaintedLion said:

Pink square for me too.

I discussed with @prestja the issue of PlanetShine not working with EVA Kerbals.  Is this the issue you describe?  Photos will help.  As for the pink square, I got a report of that in GitHub.  From research it seems that if you do a clean install of PlanetShine (delete any previouls versions in your GameData folder) it works.  Let me know it that is not true.

Link to comment
Share on other sites

18 minutes ago, Papa_Joe said:

From research it seems that if you do a clean install of PlanetShine (delete any previouls versions in your GameData folder) it works.  Let me know it that is not true.

tried that, still getting the pink square.  looks the same as the post above

Link to comment
Share on other sites

32 minutes ago, Papa_Joe said:

I discussed with @prestja the issue of PlanetShine not working with EVA Kerbals.  Is this the issue you describe? 

Yes. The issue is pretty easy to see if you EVA a kerbal. The craft that you EVA'd from will receive the reflected Planet Shine light just fine, but the kerbal itself will not.

Planet Shine on and off, you can clearly see that the light doesn't show on kerbal in either case. Every single suit variant is affected. 
 

Spoiler

NzEM3Jy.png6brHEzU.png

And on top of that, that pink square issue doesn't get fixed with a clean install. I just did a clean install.

Edited by dok_377
Link to comment
Share on other sites

Ok found the issue with the Pink square.  Unity changed the hierarchy of the shaders with version 2017, so it needed the proper path to locate the required shader.  That explains why the problem has been around since 1.8...  I'll fire off a release with this pronto.

 

v0.2.6.5 Feb 20, 2022
- Corrected pink square by changing an incorrect shader path for "Particles/Additive.  now "Legacy Shaders/Particles/Additive"
  Unity changed the location of the shader in the object hierarchy as of Unity 2017.
 

Looking into the kerbal eva issues now.  I'm trying to characterize the issue, so images of kerbals EVA may help.  looking at the code, the shine appears to affect only the currently active vessel, so any other vessels in the immediate vicinity would be unaffected.  If I'm understanding the code correctly, then pictures of a kerbal as the main focus and the vessel nearby as the main focus would help.

Edited by Papa_Joe
released 0.2.6.5 for shader issue
Link to comment
Share on other sites

1 hour ago, Papa_Joe said:

then pictures of a kerbal as the main focus and the vessel nearby as the main focus would help

My pictures above do exactly that. I'm controlling the kerbal in these pictures. As far as controlling active vessel does, it has nothing to do with the craft that you are currently controlling, you can control anything in the scene, but only kerbals will be unaffected by the Planet Shine. Everything else will be illuminated properly. 

Link to comment
Share on other sites

1. Broken blizzy toolbar (the exception prevents from button appearing at all)

[EXC 20:30:13.386] ArgumentNullException: Value cannot be null.
Parameter name: method
    System.Delegate.CreateDelegate (System.Type type, System.Object firstArgument, System.Reflection.MethodInfo method, System.Boolean throwOnBindFailure, System.Boolean allowClosed) (at <9577ac7a62ef43179789031239ba8798>:0)
    System.Delegate.CreateDelegate (System.Type type, System.Object firstArgument, System.Reflection.MethodInfo method) (at <9577ac7a62ef43179789031239ba8798>:0)
    PlanetShine.Utils.Button.AttachEventHandler (System.Reflection.EventInfo event, System.String methodName, System.Object realButton) (at <2b12c5ac0a4d4274817dacc52f772def>:0)
    PlanetShine.Utils.Button..ctor (System.Object realButton, PlanetShine.Utils.ToolbarTypes types) (at <2b12c5ac0a4d4274817dacc52f772def>:0)
    PlanetShine.Utils.ToolbarManager.Add (System.String ns, System.String id) (at <2b12c5ac0a4d4274817dacc52f772def>:0)
    PlanetShine.Gui.GuiManager.UpdateToolbarBlizzy () (at <2b12c5ac0a4d4274817dacc52f772def>:0)
    PlanetShine.Gui.GuiManager.Start () (at <2b12c5ac0a4d4274817dacc52f772def>:0)
    UnityEngine.DebugLogHandler:LogException(Exception, Object)
    ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
    UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)


2. Now instead of pink square you got this

Spoiler

ERituu6.png


Version compiled for 1.8 still works though

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...