Papa_Joe

[1.4.1 PlanetShine 0.2.6.1, Mar 28, 2018

Recommended Posts

23 minutes ago, HaydenTheKing said:

How do I tell if it’s working?

Go into orbit and turn the mod on and off in the GUI

Edited by Kwebib

Share this post


Link to post
Share on other sites
4 minutes ago, Kwebib said:

Go into orbit and turn the mod on and off in the GUI

I don’t see the planet shine thing in my toolbar. I have the default toolbar and have a bunch of mods on it. Maybe I just missed it, what does it look like?

im using 1.3.1

Edited by HaydenTheKing

Share this post


Link to post
Share on other sites

Should be a blue ball that says "PS". If you look under ...\GameData\PlanetShine\Icons that's what they look like.

Share this post


Link to post
Share on other sites
2 hours ago, Kwebib said:

Should be a blue ball that says "PS". If you look under ...\GameData\PlanetShine\Icons that's what they look like.

Thanks I found it

Share this post


Link to post
Share on other sites
4 hours ago, HaydenTheKing said:

How do I tell if it’s working?

You'll see planetshine on the surfaces of in-orbit vessels that face the planet.

Share this post


Link to post
Share on other sites
6 hours ago, Brigadier said:

You'll see planetshine on the surfaces of in-orbit vessels that face the planet.

It is a very subtle effect, but it is noticeable when you look closely.  Also you can increase the effect using the advanced settings (same place where you can turn on and off the effects...)

 

Share this post


Link to post
Share on other sites

@Papa_Joe Thanks for adopting this mod, and I'm sorry for asking this, but is there any plan to migrate this upkept version to the CKAN index?

Share this post


Link to post
Share on other sites
1 hour ago, Moose said:

@Papa_Joe Thanks for adopting this mod, and I'm sorry for asking this, but is there any plan to migrate this upkept version to the CKAN index?

Is it not yet listed?  Ok I'll  pop a note to the CKAN folks.

Edited by Papa_Joe

Share this post


Link to post
Share on other sites

Ok, CKAN should be updated:

 

  • Like 1

Share this post


Link to post
Share on other sites

@Papa_Joe Because there has never been a proper release for KSP 1.3.1 (latest officially supports 1.2.x) and as you jumped on the train just headed over to KSP 1.4.x I ask you if you could also release a backport for KSP 1.3.1 - for all the RO/RSS players?

  • Like 1

Share this post


Link to post
Share on other sites
5 hours ago, Gordon Dry said:

@Papa_Joe Because there has never been a proper release for KSP 1.3.1 (latest officially supports 1.2.x) and as you jumped on the train just headed over to KSP 1.4.x I ask you if you could also release a backport for KSP 1.3.1 - for all the RO/RSS players?

I'm not sure why you would require a "proper" release.  All the feedback I see on the original forum thread indicate that the mod worked just fine with KSP 1.3.1.  Now, I cannot speak for an RO/RSS install, but I cannot imagine why it would not work.

If you can provide a compelling reason for a "proper" release on a known working mod, I would be happy to entertain you.  However, with all due respect,  I think my efforts are better placed supporting and updating mods that have issues.

Edited by Papa_Joe
Grammar
  • Like 2

Share this post


Link to post
Share on other sites
14 hours ago, PossiblyPrecarious said:

Is there a 1.3.1 version?

As a start, read the post directly above yours.  There is also some info on the OP about the previous thread that might be of use.

  • Like 1

Share this post


Link to post
Share on other sites

@Gordon Dry and @PossiblyPrecarious, the only reason I can think of to support a KSP 1.3.1 release would be to update KSP-AVC and allow CKAN indexing for that version of KSP.  With that said, I will look to see If I still have a 1.3.1 install available to recompile against.  I make no promises.

Update:  I have recompiled a branch to target KSP 1.3.1.  This release is version specific and can be found here:

https://github.com/PapaJoesSoup/ksp-planetshine/releases/tag/0.2.5.3

the OP has been updated to provide a link for the KSP 1.3.1 version and the KSP 1.4.x version.  I will notify CKAN of the release.

Edited by Papa_Joe
updated for release of KSP 1.3.1 version (0.2.5.3)
  • Like 3

Share this post


Link to post
Share on other sites

@Papa_Joe @MOARdV When high in the atmosphere, so that the sky already is no more blue when looking up, the stars are still invisible.
Could this be changed?

Share this post


Link to post
Share on other sites
12 minutes ago, Gordon Dry said:

@Papa_Joe @MOARdV When high in the atmosphere, so that the sky already is no more blue when looking up, the stars are still invisible.
Could this be changed?

I feel like I've missed part of a conversation.  I'm not sure how this relates to planetshine...  

I would need a log (which will tell me what mods you have installed, and steps to reproduce.  Altitude, velocity, etc might help.  but even with that info I'm at a loss as to how planetshine would cause an issue.  

Have you tried to reproduce the issue with and without planetshine installed?

  • Like 1

Share this post


Link to post
Share on other sites

Distant Object Enhancement has a sky dimming option. I think that may be what Mr Dry is talking about. Maybe he could look at the settings for that mod. 

Share this post


Link to post
Share on other sites

Sorry I'm super out of the loop.


Running RSS / RO i see you have the 1.3.1 version uploaded and I have it, But do i need to find a .cfg elsewhere for RSS planets specifically or is it included in RO or something? Can't really find any info on this. I realize this question isn't really related to PS but I figured somebody here would know.

Edited by Subcidal

Share this post


Link to post
Share on other sites
4 hours ago, Subcidal said:

Sorry I'm super out of the loop.


Running RSS / RO i see you have the 1.3.1 version uploaded and I have it, But do i need to find a .cfg elsewhere for RSS planets specifically or is it included in RO or something? Can't really find any info on this. I realize this question isn't really related to PS but I figured somebody here would know.

RSS already supplies an extra config file for PlanetShine, it should be in GameData/RealSolarSystem/Compatibility/PlanetShineColors.cfg

Which means that you don't have to do anything, it already automatically works with PlanetShine.

 

I see that the file hasn't been modified since 2+ years, but it should still work fine, can anyone confirm that?

https://github.com/KSP-RO/RealSolarSystem/blob/master/GameData/RealSolarSystem/Compatibility/PlanetShineColors.cfg

 

Edited by Valerian

Share this post


Link to post
Share on other sites

Two thots. I would like more shine at night, but without more during the day.  

Is there a way to make the Mun shine more on the night side of Kerbin?

Are these possible by tweaking the config?

Also, is there a key shortcut to bring it up to adjust while in KSC or tracker?

...and I like it a lot. Immersion, and all that.

 

Share this post


Link to post
Share on other sites

I'm running 1.4.1 and had the old planetshine running on it perfectly. I updated to the new one just because. But then I got greedy and added kopernicus, OPM, chatterer, and distant object enhancement all at the same time. Now planetshine is screwed up. The bodies being orbited still emit light, but there's no color to it. Minmus and Kerbin were both reflecting white light. So I deleted kopernicus, OPM, and DOE because I'd rather have planetshine than any of those. But now the problem still persists. I started thinking about it, and I had this problem back in 1.3 as well. It's gotta be kopernicus screwing it up right? I'm too bummed to keep messing with it tonight. I'll test it on a fresh install tomorrow. A couple quick google searches makes it seem this isn't a common problem. 

Share this post


Link to post
Share on other sites
5 hours ago, Ahres said:

I'm running 1.4.1 and had the old planetshine running on it perfectly. I updated to the new one just because. But then I got greedy and added kopernicus, OPM, chatterer, and distant object enhancement all at the same time. Now planetshine is screwed up. The bodies being orbited still emit light, but there's no color to it. Minmus and Kerbin were both reflecting white light. So I deleted kopernicus, OPM, and DOE because I'd rather have planetshine than any of those. But now the problem still persists. I started thinking about it, and I had this problem back in 1.3 as well. It's gotta be kopernicus screwing it up right? I'm too bummed to keep messing with it tonight. I'll test it on a fresh install tomorrow. A couple quick google searches makes it seem this isn't a common problem. 

When bodies emit light without color it's usually because PlanetShine can't find the config for this body : can you find any error in the logs that seem related to that?

If you are not sure how to look for error in the logs, please share it to us.

Did you install PlanetShine with CKAN? If yes, know that it's split in two parts: the core mod and the config, maybe there is some issue that made CKAN somehow remove or omit the config.

Check that the file "Kerbal Space Program\GameData\PlanetShine\Config\CelestialBodies.cfg" is present.

 

On 4/22/2018 at 1:45 AM, Hangdog said:

Two thots. I would like more shine at night, but without more during the day.  

Is there a way to make the Mun shine more on the night side of Kerbin?

Are these possible by tweaking the config?

Also, is there a key shortcut to bring it up to adjust while in KSC or tracker?

...and I like it a lot. Immersion, and all that.

 

Currently PlanetShine only works when you are in the vessel view, and adds light only to the vessel, and only from the planet or moon you are orbiting.

Planets and moon are not shining on each other.

Edited by Valerian

Share this post


Link to post
Share on other sites

If I adjust the vacuum ambient lighting setting, I somewhat get what I am thinking of.  But my desire is the same, more light in the dark and less light in the sun.  Perhaps there is another mod that might do this?

Share this post


Link to post
Share on other sites

Apologies for not following up sooner. It's the weekend before finals week here. I didn't ever get to look at the logs or check for the celestialbodies config because I just deleted kopernicus, OPM, DOE, and Planetshine, started and quit the game, then put DOE and planetshine back in and now it's working perfectly. So it was kopernicus or OPM that messed it up. But we'll learn more when I try it all again on my new copy of 1.4.3 later this week. Thanks for the help @Valerian!

By the way, a couple other things:

1) Cool to see @Valerian helping out in the planetshine thread once again! 

2) @Papa_Joe, the planned feature of having sunrise/sunset light is a very exciting one. If I knew anything about modding I'd be all over that. Just watching the live feed of the ISS and seeing the whole structure baked in red-orange light is pretty cool. Just throwing this out there in case you're trying to figure out which feature to get into next. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now