UomoCapra

Kerbal Space Program 1.4.2 is live!

Recommended Posts

17 minutes ago, Mark Kerbin said:

It does run a little better. Its really only noticeable if your one of those people who make 500 part ships.

How am I supposed to fly a 500-part ship without my joystick? :P

Share this post


Link to post
Share on other sites
9 minutes ago, steve_v said:

How am I supposed to fly a 500-part ship without my joystick? :P

Touche :wink:

Share this post


Link to post
Share on other sites

I actually looked forward to the Making History expansion and thought it was a good call from Squad to make the mission builder.
Mainly because I thought, (and still think) that KSP, as a game, is pretty well suited for providing challenge missions. Maybe the weekly challenges on the forum are not that populair, but the weekly challenges on Reddit are quite polulair. I could see why Squad may have thought a mission builder, and providing the community tools to make interesting challenges, would be a welcome addition to KSP.

I still have hope that the mission builder gets more populair, and look forward to playing crazy missions created by the community. I don't think its Squad's 'job' to come up with those missions, and that the pre-made missions should function as a small showcase of the mission builders capabilities, and then indeed leave it to the community to play with.

The pessimism I can understand though, with these bugs being replaced with more bugs.... All though saddend by the bugs, I try to keep positive that both the base game as the MH expansion will get fixed and gain popularity.

Share this post


Link to post
Share on other sites
5 hours ago, klesh said:

With regards to the DLC pricing, I am tending to think its pricepoint took into account that it was going to be given away for free to many, many potential purchasers.  If we all had to pay for it, I would posit that it may’ve been in the $10 price range though of course that is just a guess.

Unfortunately, this “always free dlc forever to early adopters” policy may see higher prices for all future KSP DLC as well.

I know that this is just speculation, but if their goal behind a DLC was to attract new customers then the pricing totally doesn't make sense.

5 hours ago, klesh said:

Clearly, quite a few people would’ve preferred a way to enhance their career mode experience, rather than having another game mode altogether.

I don't have anything against having another game mode. Do have another game mode, it's always nice to have more content. But the mission builder, what I've seen of it through streams and YT videos has so much potential to improve the career mode that it doesn't make sense to not be able to integrate it. It doesn't have to be a required feature of career mode, but if I'm buying the DLC, give me an option to extend career mode with the mission builder.

I can't justify buying the DLC as it stands right now, maybe squad will improve it in the future, maybe not. If they do, I will gladly buy it. But even the stock game has these bugs / missing features..

The biggest ones are how ugly the new reentry heating looks and a lack of directx 11 support. I get definite improvement upto 1.3.1 with dx11, which 1.4 just broke. Then there's also the annoying diagonal line from top left corner to bottom right corner, which I guess was present in 1.2.2 but had been fixed in 1.3 (or forcing dx11 fixed it, I don't know). The thrust being off centre bugs in MH, I have no idea how those have survived. I can kind of understand graphics bugs avoiding attention of devs, but do you not check for gameplay affecting things or what? Apparently even after people had reported those?

Share this post


Link to post
Share on other sites
On 3/29/2018 at 7:31 AM, Electrocutor said:

[Observations]

  • Wheel suspensions/springs inherit the mass compensation of their previous vessel mass even after undocked, resulting in launching the new lower mass far into the air.

In addition to the bugs you've observed in your post, the one quoted above is the one that is really bothering me.   I cannot launch any sort of rover, or lander with legs, because when they are deployed, they end up "sprung" as if they were trying to hold up the weight of the entire launching stack.   I noticed this on 1.4.1, and was hoping this update would have fixed it.   For now, I  reverted to 1.4.0 just because of this reason. 

Share this post


Link to post
Share on other sites
44 minutes ago, cgjunk2 said:

In addition to the bugs you've observed in your post, the one quoted above is the one that is really bothering me.   I cannot launch any sort of rover, or lander with legs, because when they are deployed, they end up "sprung" as if they were trying to hold up the weight of the entire launching stack.   I noticed this on 1.4.1, and was hoping this update would have fixed it.   For now, I  reverted to 1.4.0 just because of this reason. 

Good observation - there's a running theory that there is a cached mass value associated with the launch stack, and the legs adjust themselves to that cached value.  Try this: separate your rover/lander, wait for it to settle down (if it ever does), then save and reload.  Seems to force the cache to recalculate (or whatever is actually happening).

Main problem is, it's not always possible to get the rover to settle and be saveable before destruction.

Share this post


Link to post
Share on other sites
12 hours ago, scimas said:

I was so excited about Making History when it was first announced a year ago (or was that 2 years? Don't remember). But reading all of these bug reports since 1.4 just turned me off from it. And MH itself doesn't feel like that big of a deal anymore either.

You get a bunch of extra parts and a mission building system that doesn't integrate into anything else? (the name of the game is 'space program' not single space missions). And that too for the price of more than half of the base game (the game is priced at ₹849 and the dlc at ₹459). As a result I still haven't bought it, I was so confident at the time of the first announcement that I would be buying it on day 1..

i suggest you comb through the forums first.  There are a number of problematic issues within MH.  That said, buying it and playing around is quite entertaining.  And once they fix all the issues is should be acceptable.  Acceptable, but not outstanding (in my opinion).

Share this post


Link to post
Share on other sites

Anyone else getting a bug where the contract parametres are spammed with parametres that have apparently been met (but haven't actually)?

Edit: I'm getting like ~80 of them.

Edited by PataSolar

Share this post


Link to post
Share on other sites
On 3/28/2018 at 4:32 PM, TriggerAu said:

Please dont be intimidated, what you've posted in the forums looks good, but if it was in the tracker it would be seen by more devs. :)

 

 

Okay.  I posted 4 issues to the bug tracker this morning.  Here's to hoping they are better seen there.  Thanks for the advice.

Share this post


Link to post
Share on other sites

One change from 1.4.1 to 1.4.2 that got to my nerves is on the Editor.

I'm building an aircraft, and there's some clipping needed on a specific part. On 1.4.1, I could snap the thing on the closest spot and then using the Translate tool, fine tune the position until the right place.

Well, now this is way harder - I must hit the sweet spot at first try. If I miss the first try, when I try to translate again, the parts just pop-out into a snap hotspot, even with the Snap Button UNSELECTED. I was never too fond from the Snap and Symmetry buttons changing by their own while editing, more than once this bite me in the back - but now the thing is happening even without the feature being selected, so I just can't know what is going to happen because the feature happens without changing the button state! =/

I don't think it's a testing issue anymore. This kind of regression has deeper roots. I think they're loosing control of the code-base - they can't anticipate anymore the collateral effects of a change in a code, and so they don't know for sure what need to be tested once a change is made.

Edited by Lisias
typo. this time it was the autocorrector. honest. ;-)

Share this post


Link to post
Share on other sites
8 hours ago, PataSolar said:

Anyone else getting a bug where the contract parametres are spammed with parametres that have apparently been met (but haven't actually)?

Edit: I'm getting like ~80 of them.

There's only about a dozen or more references to this bug in this thread alone.. :wink:

Edited by JAFO
Removed some unnecessary snarkiness.

Share this post


Link to post
Share on other sites
27 minutes ago, JAFO said:

There's only about a dozen or more references to this bug in this thread alone..

Hint: Sometimes it pays to actually read a thread before posting in it. :wink:

You're right, of course, and I thought the same thing when I saw it, but it was his first post. I think we can cut him a little slack.

Welcome to the forums, @PataSolar. You'll like it here, but it's a rather tumultuous time at the moment. :)

Share this post


Link to post
Share on other sites
3 minutes ago, Cpt Kerbalkrunch said:

but it was his first post. I think we can cut him a little slack.

Fair point.. I missed that.

G'day and welcome aboard, @PataSolar! My apologies for coming off a little harsh. Like the good Captain says, things are a little stressed just now around here, and I reacted without thinking.

Share this post


Link to post
Share on other sites
1 hour ago, Lisias said:

This kind of regression has deeper roots. I think they're loosing control of the code-base - they can't anticipate anymore the collateral effects of a change in a code

I swear, the way some bugs keep coming back (e.g landed ships bouncing/exploding on load in 1.3.1) it's like they're updating older versions. Or somehow the fix code gets somehow ignored/bypassed when they make an update

Share this post


Link to post
Share on other sites

Something interesting I noticed: the icon in the mission builder for the crew assignment node makes the depicted Kerbal look like the Last Airbender. yUTElsi.png

Edited by prgmTrouble

Share this post


Link to post
Share on other sites
1 hour ago, StrandedonEarth said:

I swear, the way some bugs keep coming back (e.g landed ships bouncing/exploding on load in 1.3.1) it's like they're updating older versions. Or somehow the fix code gets somehow ignored/bypassed when they make an update

This is not uncommon (neither necessarily a bad practice) in the industry. Sometimes the way we fix for a problem last release just don't cope with another fixes (or features) we need to code for the next. And given the enormous complexity of this program, I would not be surprised if this happens a lot here.

But in a way or another, one should keep track of such events. Closely. And coordinately.

Share this post


Link to post
Share on other sites

Was attempting to fly my aircraft, before I even started the engines it bounced off the runway. What's all that about :)

Edited by silverfox101

Share this post


Link to post
Share on other sites
3 minutes ago, silverfox101 said:

Was attempting to fly my aircraft, before I even started the engines it bounced off the runway. What's all that about :)

It's been reported there's an issue with the suspensions in wheels, landing gear, and landing legs :huh:

Share this post


Link to post
Share on other sites
Spoiler
6 minutes ago, silverfox101 said:

Was attempting to fly my aircraft, before I even started the engines it bounced off the runway. What's all that about :)

Perhaps it could have been the landing gear. If the spring strength and damping is too high, it might do that.

EDIT: @StrandedonEarth ninja'd me!

Edited by prgmTrouble

Share this post


Link to post
Share on other sites
1 minute ago, prgmTrouble said:

Perhaps it could have been the landing gear. If the spring strength and damping is too high, it might do that.

I will take a look at that, thanks pal.

Share this post


Link to post
Share on other sites
6 minutes ago, StrandedonEarth said:

It's been reported there's an issue with the suspensions in wheels, landing gear, and landing legs :huh:

@silverfox101 I should add that they appear to load pre-compressed, and then release the compression when loaded. Or so I've heard, since I haven't bothered with 1.4.x yet.

Share this post


Link to post
Share on other sites
1 minute ago, StrandedonEarth said:

@silverfox101 I should add that they appear to load pre-compressed, and then release the compression when loaded. Or so I've heard, since I haven't bothered with 1.4.x yet.

In past versions, this tended to be an issue when I set the suspension to max and the craft happened to be quite large. I think it was because the game loads the springs compressed according to the default settings, and then suddenly adjusts once physics kicks in.

Share this post


Link to post
Share on other sites

I have not really played around with aircraft much, nothing to do with Squad or bugs more of a PEBKAC, I cant land the damn things.  Adjusted the spring strength and damping stuff, anyway problem solved. Thanks for the advice. :)

Share this post


Link to post
Share on other sites
13 hours ago, JAFO said:

Fair point.. I missed that.

G'day and welcome aboard, @PataSolar! My apologies for coming off a little harsh. Like the good Captain says, things are a little stressed just now around here, and I reacted without thinking.

@JAFO, nah, my apologies! I was being lazy, I guess.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.