• 5
Vkihyone

[support] Landing legs exploding in 1.4.2

Question

For some reason my minmus landers' LT2 landing legs explode as soon as I touch down on minmus.  now I know I'm not going too fast because a) I've accidentally landed a lander with the same legs going about 20 m/s on minmus when I ran out of fuel and the legs didn't explode and b) I'm touching down at about .3 m/s.

Share this post


Link to post
Share on other sites

Recommended Posts

  • 1
19 minutes ago, Vkihyone said:

For some reason my minmus landers' LT2 landing legs explode as soon as I touch down on minmus.  now I know I'm not going too fast because a) I've accidentally landed a lander with the same legs going about 20 m/s on minmus when I ran out of fuel and the legs didn't explode and b) I'm touching down at about .3 m/s.

All sorts of collide'r physics are wonky in 1.4.2 I have no Idea what Squad did but they really screwed stuff up. This version is way worse than 1.4.1 . I just got done Obliterating the back half of a Saturn rocket with the decoupler and fairing staging. I had not even fired the second stage motors. And it didn’t just break the first stage from to much force. The stage was just gone like the Kraken ate it whole. I think one engine out of nine survived to tumble away. 1.4.2 has issues  1.4.1 is running way better if that helps. It has problems but it seems playable. I am not wasting my time bug testing another patch until I read on these forums that it actually fixes more things than it breaks. 

  • Like 1

Share this post


Link to post
Share on other sites
  • 1

I've had the same issue too, I've been trying to land on Duna for the first time, and it went very well until the landing part. I touched down at about 3m/s only to have my LT2 landing legs violently de-exist themselves in a ball of flames.

Share this post


Link to post
Share on other sites
  • 1
On 4/1/2018 at 12:36 AM, Delbrutis said:

All sorts of collide'r physics are wonky in 1.4.2 I have no Idea what Squad did but they really screwed stuff up. This version is way worse than 1.4.1 . I just got done Obliterating the back half of a Saturn rocket with the decoupler and fairing staging. I had not even fired the second stage motors. And it didn’t just break the first stage from to much force. The stage was just gone like the Kraken ate it whole. I think one engine out of nine survived to tumble away. 1.4.2 has issues  1.4.1 is running way better if that helps. It has problems but it seems playable. I am not wasting my time bug testing another patch until I read on these forums that it actually fixes more things than it breaks. 

this is it i think. i also had immense trouble docking what would have been a normal standard sized docking port. many many times, it would almost stick magnetically then would glance off to the side and push the ship laterally, as though it had collided....

And yes the legs thing is still an issue. wont be landing anything in career mode until they fix that

Share this post


Link to post
Share on other sites
  • 1
2 hours ago, LameLefty said:

Just FYI, there are already a couple of bugs reported for landing gear related issues. It’s better to add additional info and detail to existing bugs than log a new one (which will probably be combined by Squad when they review it). 

You're right, I didn't even notice the previous bug report (did this one at around 11pm last night) though from looking at the bug report they have they are working on the problem.

Share this post


Link to post
Share on other sites
  • 1

While it's very doable to land without legs, it sure bothers me. I'm right in mid career and will have to stop until next patch. I need my landers to look like landers or it's no fun.

  • Like 2

Share this post


Link to post
Share on other sites
  • 1

Any guessing if this is gonna be fixed this Year ?

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
8 hours ago, Vkihyone said:

For some reason my minmus landers' LT2 landing legs explode as soon as I touch down on minmus.  now I know I'm not going too fast because a) I've accidentally landed a lander with the same legs going about 20 m/s on minmus when I ran out of fuel and the legs didn't explode and b) I'm touching down at about .3 m/s.

I'm experiencing the same thing. I've got a Jool launch window coming up in my Career save, so I've been fooling around in a Sandbox save, using the Cheat menu to put landers in orbit around Laythe and testing designs for an Ore miner/refinery craft and a habitat lander. Generally, as soon as the landing legs touch the terrain, even at 0.5 m/s, they explode violently. The log sates that "LT-2 landing leg collided with terrain."

So my Career game is on hold until there's a fix for this landing leg issue.

Ugh. 

Edited by LameLefty
clarity

Share this post


Link to post
Share on other sites
  • 0

Not everyone wants to watch a video. How ‘bout you just explain what you did? 

BTW - I got far enough in to see you’re editing the LT-5 gear. Many of us are having trouble with the LT-2 gear, which already have CoMOffset, BreakingForce and BreakingTorque values in the config files. So if the issue is related to that, it’s not that the values don’t exist in the files, it’s that they’re wrong. 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
10 hours ago, JPLRepo said:

If people are able to raise bug reports (or even better add to existing bug reports) with craft files and save files that goes a long way to help us resolve the issue.

https://bugs.kerbalspaceprogram.com/issues/18286

Hey there JPLRepo. would love to help.

Can you please tell me how i can create a bug file and i will forward it with craft and save file

Also what is my login and password for the above link?

Edited by hitbox
  • Like 1

Share this post


Link to post
Share on other sites
  • 0
6 hours ago, hitbox said:

Hey there JPLRepo. would love to help.

Can you please tell me how i can create a bug file and i will forward it with craft and save file

Also what is my login and password for the above link?

Login for the bug tracker is self-register. You just create one with an email. There is a register button top right corner of the page.
Once you have done that and logged in. There is a wiki page:
https://bugs.kerbalspaceprogram.com/projects/ksp/wiki

  • Like 3

Share this post


Link to post
Share on other sites
  • 0
On 2.4.2018 at 4:31 AM, JPLRepo said:

If people are able to raise bug reports (or even better add to existing bug reports) with craft files and save files that goes a long way to help us resolve the issue.

I have builded my eagle lander in 1.4.1 - in the 1.4.1 everything works fine. But now in 1.4.2 - the legs are unuseable. I made a short video of this issue. (craft file I will upload later)

 

  • Like 5

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

Just uploaded a bug report #18358 which includes the craft file and save file plus a screenshot of the debug screens report of the incident. Not sure how to set priority but I'd put it at high.

Edited by Vkihyone
furhter info
  • Like 3

Share this post


Link to post
Share on other sites
  • 0

Just FYI, there are already a couple of bugs reported for landing gear related issues. It’s better to add additional info and detail to existing bugs than log a new one (which will probably be combined by Squad when they review it). 

  • Like 2

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

**link removed by moderator** for latest community based fix regarding the stock legs.

Edited by Kerbal101

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

Had same issue, landing like a butterfly on the mun and legs exploded. It was like a giant gorilla on bird legs.  When he jumped, he was cool, but when he hit the ground he was crying like a baby. Don't know what kind of metal Squad was using on those legs! I was thankful to see that video. I had to change the numbers higher than what he did to get the legs to hold up. At least it's cool now until a fix comes.

Edited by MikeO89

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
On 4/9/2018 at 8:24 AM, Jungfaha said:

**link removed by moderator** for latest community based fix regarding the stock legs.

Thank you, Scott Manley, Matt Lowne, The Kraken and all the other Gods of ksp. This actually works,  Dragon Aerospace is a space program again. (As well as my other save files) 

Edited by Kerbal101

Share this post


Link to post
Share on other sites
  • 0

@Jungfaha Hmm, breakingForce and breakingTorgue lead me to this:

However, if you have ModuleManager installed and you create a text file with ".cfg" extension and any name inside "Gamedata", that has the following:
 

@PART[landingLeg1]
{
@crashTolerance = 12
@MODULE[ModuleWheelSuspension]
 {
 @springRatio = 6
 @damperRatio = 1.0
 }
} 

@PART[landingLeg1-2]
{
@crashTolerance = 12
@breakingForce = 80
@breakingTorque = 80
@MODULE[ModuleWheelSuspension]
 {
 @springRatio = 6
 @damperRatio = 1.0
 }
} 

@PART[miniLandingLeg]
{
@crashTolerance = 10
@MODULE[ModuleWheelSuspension]
 {
 @springRatio = 8
 @damperRatio = 1.0
 }
} 

Does it fix the issue? These values are from 1.3.1 and include few vars that were relevant, when I made LY-01 as strong as LY-05.
The most important factor at that time seemed to be "crashTolerance", with LY-05 having a whopping 325. That value should solve the problem, although it still needs bugreport.

It could also be that the problem arises from reported "jumping" in 1.3.1 and 1.4.2 (probably unrelated), there is  this mod that could help combat it.
I would ask test the cases differently, if I may, just to help find the cause more precisely.

  • Like 3

Share this post


Link to post
Share on other sites
  • 0
On 4/9/2018 at 8:24 AM, Jungfaha said:

.... for latest community based fix regarding the stock legs.

Sorry, but I had to snip your links and would like to ask you to please remove the file from github and any other sharing site where you stored it.
I perfectly understand that you are trying to help, but redistributing assets from "Squad" inside "Gamedata" is a no-go, because its copyrighted and a EULA violation.

We could achieve the very same effect plus sustainability over updates using the awesome ModuleManager, the syntax guide can be found [ here ].
Thank you for your understanding.

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

changing the Crash-tolerance to "50m/s" works on the lowlevel gears (also Kerbal X s legs) on Mun/Minmus. 
The problem will possibly be bugfixed in V 1.4.3 announced for last Aprils week.  

new DLCs and new bugs. :-(  


 

 

Edited by sec3

Share this post


Link to post
Share on other sites
  • 0

I still have this issue with 1.4.3. Anybody else?

Share this post


Link to post
Share on other sites
  • 0

I'm getting this issue as well. Touching down at anything higher than 4m/s even with the fix posted by the mod above results in the landing legs violently exploding. I have however discovered that multiplying the crash tolerances by 10 and the break/torque forces by 2 in the provided fix have helped.

Share this post


Link to post
Share on other sites
  • 0
On 5/1/2018 at 11:51 AM, releansol said:

I still have this issue with 1.4.3. Anybody else?

I haven't tested landing yet, but I get exploding legs in 1.4.3 when docking/undocking craft on the ground.

Share this post


Link to post
Share on other sites
  • 0
10 hours ago, psipal said:

I haven't tested landing yet, but I get exploding legs in 1.4.3 when docking/undocking craft on the ground.

Added weight plus shift of centre of mass does this? Im not sure.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now