FreeThinker

[1.7.3/1.6.1/1.5.1/1.4.5/1.3.1] KSP Interstellar Extended 1.23.1 Release Thread

Recommended Posts

Hi, I have a small issue to report. Simply put, name = KspiPebbleBed stops producing power after high warp. I have a Pebble Bed Reactor in a rover on kerbin. Due to other mods I needed to warp time to pass about 30 kerbin days. Things seemed ok when I resumed normal time, but later I noticed I had run out of electricity.
The solution I found was to compare an unlaunched version of the craft with the one I had a problem with. I found three entries in this module that had changed:

Spoiler

                MODULE
                {
                    name = InterstellarPebbleBedFissionReactor
                    isEnabled = True
                    fuelmode_index = 0
                    IsEnabled = True
                    isDeployed = False
                    isupgraded = False
                    breedtritium = True
                    last_active_time = 2227654.9252596581
                    ongoing_consumption_rate = 0
                    ongoing_wasteheat_rate = 0
                    reactorInit = True
                    startDisabled = False
                    neutronEmbrittlementDamage = 0.0038568846542587783
                    maxEmbrittlementFraction = 0.5
                    windowPositionX = 20
                    windowPositionY = 20
                    currentGenerationType = 3
                    storedPowerMultiplier = 0.52991268471505615
                    stored_fuel_ratio = 1
                    thermal_power_ratio = 1
                    charged_power_ratio = 1
                    reactor_power_ratio = 1
                    power_request_ratio = 0
                    maximum_thermal_request_ratio = 0
                    maximum_charged_request_ratio = 0
                    maximum_reactor_request_ratio = 0
                    thermalThrottleRatio = 0
                    chargedThrottleRatio = 0
                    storedIsThermalEnergyGeneratorEfficiency = 0
                    storedIsChargedEnergyGeneratorEfficiency = 0
                    storedGeneratorThermalEnergyRequestRatio = 0
                    storedGeneratorChargedEnergyRequestRatio = 0
                    electricPowerPriority = 4
                    powerPercentage = 100
                    ongoing_total_power_generated = 0
                    ongoing_thermal_power_generated = 0
                    ongoing_charged_power_generated = 0
                    stagingEnabled = True
                    EVENTS

 

The entries were:

Spoiler

                    thermal_power_ratio = 1
                    charged_power_ratio = 1
                    reactor_power_ratio = 1

Once I edited my save game and loaded it, power generation for electricity seems to work fine. I use the early method of electricity generation, the one that uses heat only.
Not sure if this is just me or if it happens to everyone, so I thought I would drop by and let you know what I found.

Share this post


Link to post
Share on other sites

Version 1.19.5 for Kerbal Space Program 1.4.5

Released on 2018-08-30

  • Compiled against KSP 1.4.5
  • Added additional Extreme tech nodes
  • Altered Stock NERVA engine with KSPIE behaviour
  • Updated packaged mods (IDS, KJR, Filter Extensions) to KSP 1.4 compatible versions
  • Renamed Solid Core Nuclear engine to LANTR
  • Balance: increased tech requirement LANTR to improved nuclear propulsion
  • Balance: Increased unlocking tech early nuclear engines and reactors
  • Fixed Crash After vessel with activated Gas Core is reloaded

Share this post


Link to post
Share on other sites

Download Version 1.19.6 for Kerbal Space Program 1.4.5 from here

Released on 2018-09-02

  • Compiled against kSP 1.4.5
  • Added Radio science experiment the Phased Array (credits by Munseeker)
  • Added Improved Radial Vasimr (credits by SpaceMouse)
  • Balance: increased tech requirement Target Fusion Reactor
  • Balanced entry cost Fusion Reactors
  • Removed X-11 Radail Cryogenic Sphere Tank (moved to IFS)
  • Fixed MCF buffer stability issue

Share this post


Link to post
Share on other sites

A new Version 1.19.7 for Kerbal Space Program 1.4.5 is available from here

Released on 2018-09-02

  • compiled against KSP 1.4.5
  • restored persistent thrust capability of Gas core engines and Plasma nozzle
  • hotfix: fixed deletion of a vessel after loading a vessel with an activated VISTA engine
Edited by FreeThinker

Share this post


Link to post
Share on other sites

A new Version 1.19.8 for Kerbal Space Program 1.4.5 van be downloaded from here

Released on 2018-09-04

  • Compiled against KSP 1.4.5
  • Added Persistent thrust for early nuclear engines
  • Added alternative unlocking path specialized fusion though exotic nuclear propulsion
  • Reduced amount of visible fields in Thermal engines
  • Balance: increased tech upgrade requirements for Lightbulb
  • Fixed too High Core Temperature for early nuclear reactors combined with fully upgraded heat control tech nodes
  • Fixed loss of Power Management after Docking or undocking vessels
Edited by FreeThinker

Share this post


Link to post
Share on other sites
On 8/29/2018 at 10:02 PM, Apaseall said:

Hi, I have a small issue to report. Simply put, name = KspiPebbleBed stops producing power after high warp. I have a Pebble Bed Reactor in a rover on kerbin. Due to other mods I needed to warp time to pass about 30 kerbin days. Things seemed ok when I resumed normal time, but later I noticed I had run out of electricity.
The solution I found was to compare an unlaunched version of the craft with the one I had a problem with. I found three entries in this module that had changed:

  Hide contents

                MODULE
                {
                    name = InterstellarPebbleBedFissionReactor
                    isEnabled = True
                    fuelmode_index = 0
                    IsEnabled = True
                    isDeployed = False
                    isupgraded = False
                    breedtritium = True
                    last_active_time = 2227654.9252596581
                    ongoing_consumption_rate = 0
                    ongoing_wasteheat_rate = 0
                    reactorInit = True
                    startDisabled = False
                    neutronEmbrittlementDamage = 0.0038568846542587783
                    maxEmbrittlementFraction = 0.5
                    windowPositionX = 20
                    windowPositionY = 20
                    currentGenerationType = 3
                    storedPowerMultiplier = 0.52991268471505615
                    stored_fuel_ratio = 1
                    thermal_power_ratio = 1
                    charged_power_ratio = 1
                    reactor_power_ratio = 1
                    power_request_ratio = 0
                    maximum_thermal_request_ratio = 0
                    maximum_charged_request_ratio = 0
                    maximum_reactor_request_ratio = 0
                    thermalThrottleRatio = 0
                    chargedThrottleRatio = 0
                    storedIsThermalEnergyGeneratorEfficiency = 0
                    storedIsChargedEnergyGeneratorEfficiency = 0
                    storedGeneratorThermalEnergyRequestRatio = 0
                    storedGeneratorChargedEnergyRequestRatio = 0
                    electricPowerPriority = 4
                    powerPercentage = 100
                    ongoing_total_power_generated = 0
                    ongoing_thermal_power_generated = 0
                    ongoing_charged_power_generated = 0
                    stagingEnabled = True
                    EVENTS

 

The entries were:

  Hide contents

                    thermal_power_ratio = 1
                    charged_power_ratio = 1
                    reactor_power_ratio = 1

Once I edited my save game and loaded it, power generation for electricity seems to work fine. I use the early method of electricity generation, the one that uses heat only.
Not sure if this is just me or if it happens to everyone, so I thought I would drop by and let you know what I found.

Weird problem, but it kind of sounds if the reactor got overheated and automatically shut down. Did you install any mods during those 30 days of timewarp? exactly how did you timewarp?

Share this post


Link to post
Share on other sites

Download Version 1.19.9 for Kerbal Space Program 1.4.5 from here

Released on 2018-09-08

  • Compiled against KSP 1.4.5
  • Added reactor activity animation to Open Cycle Gas Core Reactor
  • Added increased tweakscale sizes for RCS and electric engine
  • Balance: Reduced utilization thermal power/propulsion utilization for Open Cycle Gas Core Reactor
  • Fixed full utilization for MHD power generator combined with Open Cycle Gas Core or Plasma Jet Magneto Inertial Fusion Reactor
  • Fixed Thermal/Plasma/Magnetic nozzle imbalance with multiple reactors
  • Fixed ghost persistent thrust when below 0.1 kn thrust

Share this post


Link to post
Share on other sites

A new version of KSPIE 1.19.10 for Kerbal Space Program 1.4.5 can be download from here

Released on 2018-09-10

  • Compiled against KSP 1.4.5
  • Added Radial Atmospheric Scoop (Credits zzz)
  • Added additional tweak-scale sizes
  • Balance: Reduced minimum isp Plasma Wakefield Accelerator Engine
  • Balance: increased tech requirement Antimatter Initiated Fusion Reactor
  • Fixed 50% reduction in effective isp in thermal and magnetic nozzle

Share this post


Link to post
Share on other sites

Version 1.19.11 for Kerbal Space Program 1.4.5 can now available from here

Released on 2018-09-12

  • Compiled against KSP 1.4.5
  • Fixed hiding of unnecessary buttons in Radiator
  • Fixed linear behavior of thermal nozzle throttle and trust percentage
  • Fixed radiators convection when on the surface
  • Fixed thermal nozzle calculated field when generating thrust
  • Fixed Thermal Receiver compatibility with Thermal Nozzles
Edited by FreeThinker

Share this post


Link to post
Share on other sites
On 9/7/2018 at 1:50 PM, FreeThinker said:

Weird problem, but it kind of sounds if the reactor got overheated and automatically shut down. Did you install any mods during those 30 days of timewarp? exactly how did you timewarp?

Sorry for the delay, I have been on holiday. I think I warped in place, that is to say I was playing the game, and I pressed the key that steps up time, one press gets you one arrow, another press another etc. Thus the time warp was within one play session, which would prohibit installing mods, as the game was not stopped etc.
Great to see you pushing ahead with updates. Thank you again for all your hard work.

Share this post


Link to post
Share on other sites

Oh, version number appears to differ from the download, ie download says 1.19.11 and inside version file we have 1.19.10. I think. So we get told that a new version is available but really we already have it.

Share this post


Link to post
Share on other sites
On 9/18/2018 at 9:20 PM, Apaseall said:

Oh, version number appears to differ from the download, ie download says 1.19.11 and inside version file we have 1.19.10. I think. So we get told that a new version is available but really we already have it.

Well that shouldn't matter, what matters would be the version number of Interstellar_Redist.dll, which is shared between KSPIE and Photon sailor, they have to be exactly the same

Share this post


Link to post
Share on other sites
4 hours ago, FreeThinker said:

Well that shouldn't matter, what matters would be the version number of Interstellar_Redist.dll, which is shared between KSPIE and Photon sailor, they have to be exactly the same

Ok I see that there are two places where Interstellar_Redist.dll can be found, one in \GameData\PhotonSail\Plugins\ and the other in \GameData\WarpPlugin\Plugins\.

In the log provided there are two instances of that .dll in the of Mod DLLs found: In that list the version numbers are identical at v1.2.0.0.

Share this post


Link to post
Share on other sites

Download Version 1.20.0 for Kerbal Space Program 1.4.5 from here

Released on 2018-09-23

  • Integrated Stock Ion Engine into KSPIE, including persistent thrust, exhaust and add power upgrades with electric tech nodes
  • Added: "Discovery" Magnetic Confinement Fusion Rocket
  • Added: Clover Graphene Radiator (texture by SilverSliver)
  • Added Antiproton Storage Ring
  • Added: display of exhaust during persistent thrust to Thermal and Plasma nozzle
  • Added: Persistent thrust drop out of timewarp and cut engines after pressing X button
  • Added: convection radiators to pre-coolers
  • Added Graphene Radiators take dynamic pressure into account and are longer affected by atmosphere
  • Added: Buckballs as an electric propellant
  • Added: Radiators heat-color now range from Dark Red to Bright White
  • Graphics: Switched colour scheme positron and antiproton on containers. Positron: red, Antiproton: blue
  • Re-balanced thermal engines stock wastewheat
  • Re-balanced: limited Ramjet/Turbojet to neutral and oxidizing propellant while Thermal Launch Nozzle is limited to neutral and reducing propellants
  • Balance Fix: removed power requirement Kerbstein and reduced wasteheat by 50%
  • Balance Fix: significantly increased core temperature Magnetic Confinement Fusion Reactors
  • Balance Fix: Doubled power output Quantum Singularity Reactor
  • Balance Fix: unlock Molten Salt reactor upgrades with Thermal Management techs
  • Balance Fix: Increased unlocking tech of VISTA, arcjets and resistojets
  • Balance Fix: Changed tech requirement Thermal Receiver to Thermal management
  • Balance Fix: Lowered unlocking tech of thermal power generator
  • Bug Fix: Double charging of solar sells
  • Bug Fix: issue with Magnetic Confinement Fusion Reactors connected to only a thermal power generator not able to utilize all available power.
  • Bug Fix: problem with haber proces
  • Bug Fix: radiator slow updates
  • Bug Fix: linear behaviour thermal and not geared electric engines
  • Bug Fix: Crusader spool effect sound continuing after stopping engines
Edited by FreeThinker

Share this post


Link to post
Share on other sites

It would be great for everybody if you could also use SpaceDock for releases ...

  1. Curseforge sucks, you announce a new release but it's nowhere to download from - also KSP-AVC tells me there is a new release of IFS and ... there is none
  2. also on Github is no release, "only" the repo

Share this post


Link to post
Share on other sites

Any recommendations on a LS mod to use with this? TAC used to work with the EC generators in the background, but it no longer does. Do people know of any of them that do work with KSPI?

 

Share this post


Link to post
Share on other sites

Download Version 1.20.1 for Kerbal Space Program 1.4.5 from here

Released on 2018-09-26

  • Compiled against KSP 1.4.5
  • Added matched Temperature color with radiator color
  • Linked maximum radiator temperature with maximum operational temperature
  • Added 50% Reduction of Wasteheat and Engine heating when Cryogenic Fuels are used in Thermal Nozzles
  • Added new LFO mode Liquid Hydrogen / Intake Air (unlocked with Specialized Fuel Storage)
  • Added Liquid Carbon Monoxide, Liquid Neon, Liquid Krypton and Liquid Xenon as Thermal Propellants
  • Added Apply Radiator wasteheat convection bonus to part stock convection bonus
  • Balance: Removed or lowered tech requirement of many Thermal Fuel
  • Balance: increased effect of atmosphere on graphene radiators
  • Balance : Made Thermal LiquidFuel thrust equal to Hydrogen thrust (but with 80% lower isp)
  • Balance : Made thrust LiquidFuel/Oxidizer mode equal to Hydrolox fuel mode (but with 80% lower isp)
  • Balance: Prohibit thermal engine shutdown of engine while throttle isn't cut
  • Fixed variable maximum temperature of Thermal Nozzle
  • Fixed hidden parts filter
  • Fixed ability to use D-T fusion mode
  • Fixed negative cost Bosh Einstein antiproton containers
  • Fixed description of some engines
  • Fixed maximum efficiency on Tri Alpha
Edited by FreeThinker

Share this post


Link to post
Share on other sites

Where is the flow chart that shows how to put together the beamed power parts? I can't find it anywhere. *Never mind I was able to eventually find it.*

Edited by nonono

Share this post


Link to post
Share on other sites

I know this has been asked time and time again. But I'll be damned if I can find a proper document listing it.

But is there a general loose rule of thumb regarding the Secondary Power supply requirement for Fusion reactors?

One of the guides "seems" to have wanted to list this requirement but I can't find a list of the fusion reactors and their power supply requirements.

Share this post


Link to post
Share on other sites
8 hours ago, ToastyOats said:

I know this has been asked time and time again. But I'll be damned if I can find a proper document listing it.

But is there a general loose rule of thumb regarding the Secondary Power supply requirement for Fusion reactors?

One of the guides "seems" to have wanted to list this requirement but I can't find a list of the fusion reactors and their power supply requirements.

the Secondary Power supply basically allow s you to use available electric charge. This is largely no longer required as kSPIE power system is compatible with most power reactors but in case its not, it could fall back. In general I would say to keep it at default setting as you don't want it to starve your entire system

Share this post


Link to post
Share on other sites
3 hours ago, FreeThinker said:

the Secondary Power supply basically allow s you to use available electric charge. This is largely no longer required as kSPIE power system is compatible with most power reactors but in case its not, it could fall back. In general I would say to keep it at default setting as you don't want it to starve your entire system

I might've explained myself poorly. I'm having trouble figurring out what the secondary power supply requirement is to "Insure Plasma Heating" on the fusion reactors.

 

Is it in MW or GW? I noticed a readout on the reactor display themselves but I'm trying to build SSTO scale thermal/fusion rockets.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.