FreeThinker

[1.7.3/1.6.1/1.5.1/1.4.5/1.3.1] KSP Interstellar Extended 1.23.8 Release Thread

Recommended Posts

Something seems wrong after the patch:

R62rPq9.png

I have several large apperature satellites including a polar, what's going on here? The aperatures on the relays were calculated to receive and relay full power to a 3 m spot size prior to patch they were working as intended with craft getting full 3 gigwatts.

Power station was checked, it was also full 3 Gigawatt to wall to beam. Also got some odd messages about tweakscale ui prior to game load, not sure if that may be affecting existing apperatures.

... I just noticed it looks like it is favoring bouncing from Mun back to the satellites around Kerbin for.. some.. reason? *headscratch*

 

Edited by Maelstrom Vortex

Share this post


Link to post
Share on other sites

Every time I update interstellar, my satellites using the phased array bulbs are converting to w-band microwave on their own and having to manually be set back.

Nevermind, it appears just to be the one, think I may replace it, may be bugged or something.

Nevermind that nevermind, found a second one doing the same thing and it won't let me correct it!

Edited by Maelstrom Vortex

Share this post


Link to post
Share on other sites

Can someone explain or link where I can figure out how to use the communications devices in this?? I can't figure out which ones work with other ones and the distances. Its all jibberish to me. 

 

Also the whole nuclear thing as well.... always have random issues like no radiators, no power supply, don't know how to use these lasers (what do they do how do they generate power?!).

 

Where can I figure out how to use this mod?? The wiki barely explains anything. 

Share this post


Link to post
Share on other sites

I update my game from 1.6.1 to 1.7.3 and I also update all my mod to the newest version. However, when I log in to the game, it shows that I missing the "JSIPrimitiveExternalCamera" and"KSPiNuclearJetEngine",which killed 4 space station, 7 kinds of rocket and 21kinds of plane....(two years' blood). The interest thing is that I finally find the.cfg file in the mod folders, however it still not works when I secondly try to log in the game. Who can help me? or give me some hint. I love the version 1.7.3, but if it cannot works, my only choose is to return 1.6.1

Share this post


Link to post
Share on other sites
On 9/14/2019 at 10:02 PM, Maelstrom Vortex said:

Every time I update interstellar, my satellites using the phased array bulbs are converting to w-band microwave on their own and having to manually be set back.

Nevermind, it appears just to be the one, think I may replace it, may be bugged or something.

Nevermind that nevermind, found a second one doing the same thing and it won't let me correct it!

It only happens an update, not after a reload?

What I could do is add a cheat that allowed switching wavelength outside of VAB, would that help?

Share this post


Link to post
Share on other sites
1 hour ago, FreeThinker said:

It only happens an update, not after a reload?

What I could do is add a cheat that allowed switching wavelength outside of VAB, would that help?

You already did that. I've set them each time using it. But for some weird reasons each time I've patched IE, it changes the wavelength back to microwave on two sats. I'm going to see if just swapping them may help. Maybe some sort of save error? Not sure. Strangest part is, other sats, exact same model, not same behavior.

Edited by Maelstrom Vortex

Share this post


Link to post
Share on other sites
14 hours ago, Aaron11 said:

I update my game from 1.6.1 to 1.7.3 and I also update all my mod to the newest version. However, when I log in to the game, it shows that I missing the "JSIPrimitiveExternalCamera" and"KSPiNuclearJetEngine",which killed 4 space station, 7 kinds of rocket and 21kinds of plane....(two years' blood). The interest thing is that I finally find the.cfg file in the mod folders, however it still not works when I secondly try to log in the game. Who can help me? or give me some hint. I love the version 1.7.3, but if it cannot works, my only choose is to return 1.6.1

Finally I get the answer, the new version mod had change the name of the part, that's why the system said it cannot find that

Share this post


Link to post
Share on other sites
On 9/13/2019 at 11:43 AM, Maelstrom Vortex said:

Something seems wrong after the patch:

R62rPq9.png

I have several large apperature satellites including a polar, what's going on here? The aperatures on the relays were calculated to receive and relay full power to a 3 m spot size prior to patch they were working as intended with craft getting full 3 gigwatts.

Power station was checked, it was also full 3 Gigawatt to wall to beam. Also got some odd messages about tweakscale ui prior to game load, not sure if that may be affecting existing apperatures.

... I just noticed it looks like it is favoring bouncing from Mun back to the satellites around Kerbin for.. some.. reason? *headscratch*

 

mmm, I see the problem. I think the problem is caused by some code optimalisation , here is a quick fix.Please let me know if this fixes the problem

Edited by FreeThinker

Share this post


Link to post
Share on other sites
11 hours ago, FreeThinker said:

mmm, I see the problem. I think the problem is caused by some code optimalisation , here is a quick fix.Please let me know if this fixes the problem

The satellites had drifted some, but it still determined that it was better to go to mun than to a slightly off facing satellite.. was that the issue you found? Once I corrected the positioning of the satellites they appeared to pick normal priority.

Share this post


Link to post
Share on other sites
24 minutes ago, Maelstrom Vortex said:

The satellites had drifted some, but it still determined that it was better to go to mun than to a slightly off facing satellite.. was that the issue you found? Once I corrected the positioning of the satellites they appeared to pick normal priority.

I used a different method for calculating static presure, which should perform better, but appernetly it doesn't work correctly on unloaded vessels, causing them to calculate static presure wrong which would influence the routing which tries to find the most efficient route.

Share this post


Link to post
Share on other sites

Just a quick question to you, KSP-IE guys.

I plan on starting back a new science campaign and... I would like to do it with this mod. But as I like to colonize, I wanted to use USI stuff as well. But I no longer see RoverDude mods listed as compatible in the compatible mods list (neither the parts or the Life Support one). Must I avoid using it together with your mod then? And does SSTU parts works as well ?

Edited by FrancoisH

Share this post


Link to post
Share on other sites
4 hours ago, FrancoisH said:

Just a quick question to you, KSP-IE guys.

I plan on starting back a new science campaign and... I would like to do it with this mod. But as I like to colonize, I wanted to use USI stuff as well. But I no longer see RoverDude mods listed as compatible in the compatible mods list (neither the parts or the Life Support one). Must I avoid using it together with your mod then? And does SSTU parts works as well ?

Hello,

Currently I am using this list of mods, with KSPI, and as far as I noticed there isn't any problem with those.

  • For Rovers I am using: "FelineUtilityRovers"
  • For Life Support I use: "USI-LS", "USI-FTT" & "USITools"

This is my current list hope it helps:

"ModuleManager"
"NearFutureSpacecraft"
"NearFuturePropulsion-XenonHETs"
"KerbalEngineerRedux"
"ContractConfigurator"
"Mk3Expansion"
"TweakScale"
"USI-LS"
"InterstellarFuelSwitch"
"PhotonSailor"
"ModularFlightIntegrator"
"Konstruction"
"Mk1CabinHatch"
"NearFuturePropulsion-LowThrustEP"
"TarsierSpaceTechnologyWithGalaxies"
"NearFuturePropulsion"
"USI-FTT"
"BetterScienceLabsContinued"
"CommunityCategoryKit"
"SCANsat"
"KWRocketryRebalanced"
"FelineUtilityRovers"
"TexturesUnlimited"
"KerbalPlanetaryBaseSystems"
"RSSDateTimeFormatter"
"unBlur"
"CommunityTerrainTexturePack"
"KIS"
"DMagicOrbitalScience"
"CryoTanks"
"DraggableNavball"
"Kerbalized-SpaceX"
"KerbalAlarmClock"
"TriggerAu-Flags"
"DraggableAltimeter"
"KerbalAtomics-NTRModSupport"
"KerbalAtomics"
"kOS"
"PatchManager"
"NearFutureProps"
"MoarFEConfigs"
"CraftManager"
"KXAPI"
"Mk2Expansion"
"BackgroundResources"
"B9-PWings-Fork"
"Toolbar"
"FirespitterResourcesConfig"
"FirespitterCore"
"SpaceXLegs"
"EasyVesselSwitch"
"OuterKerbin"
"MechJeb2"
"KSPInterstellarExtended"
"NearFutureLaunchVehicles"
"CryoTanks-Core"
"TextureReplacer"
"ClickThroughBlocker"
"ToolbarController"
"NearFutureSolar"
"Ballistanks"
"StationPartsExpansionRedux"
"SpacetuxSA"
"CommunityResourcePack"
"CommunityTechTree"
"HeatControl"
"StockalikeMiningExtension"
"NearFutureConstruction"
"DeployableEngines"
"DynamicBatteryStorage"
"KerbalJointReinforcementContinued"
"KerbalXMod"
"KSPWheel"
"KAS"
"OuterPlanetsMod"
"BetterTimeWarpCont"
"FilterExtensions"
"REPOSoftTech-Agencies"
"HumanColoredFaces"
"InterstellarFuelSwitch-Core"
"B9PartSwitch"
"HangerExtenderExtended"
"USITools"
"JSIAdvancedTransparentPods"
"OrbitalTug"
"BurstAtomicThrust"
"KVVContinued"
"OPTSpacePlaneParts"
"OPTReconfig"
"NearFutureElectrical"
"NearFutureElectrical-Core"
"NearFutureElectrical-DecayingRTGs"
"NearFutureSolar-Core"
"BetterBurnTime"
"HideEmptyTechNodes"
"RemoteTech"
"CivilianPopulation"
"RealPlume"
"SmokeScreen"
"RealPlume-StockConfigs"

 

Share this post


Link to post
Share on other sites

Long time experience tip: Near future likes to restrict power levels on the KSPIE power scales. If you want to play with NF with the power scales on KSPIE scales, you can kill the NF/USI patch but have to watch for the effect the changes cause to the function of the equipment given the scale is about 50 fold difference.

Share this post


Link to post
Share on other sites
38 minutes ago, Maelstrom Vortex said:

Long time experience tip: Near future likes to restrict power levels on the KSPIE power scales. If you want to play with NF with the power scales on KSPIE scales, you can kill the NF/USI patch but have to watch for the effect the changes cause to the function of the equipment given the scale is about 50 fold difference.

Hello,

Do you have an example where that difference is noticed?

 

Share this post


Link to post
Share on other sites
2 minutes ago, pmborg said:

Hello,

Do you have an example where that difference is noticed?

 

I do not have any screenshots currently of that particular config as I remedy it between alterations, but essentially reactor output in KSPIE mode is 50x that of USI-NF compatible mode. Reactors that normally give giga-watts are capped at megawatts. Easy to see on ones own, just cut the file from the patch directory, post to desktop, reload game, look at a reactor's output.. then put back in.

Share this post


Link to post
Share on other sites

This is my current ship:

wPWdFWW.png

I am getting 7.42GW from a "Tri Alpha" scale 19m, do you have more without NF?

BTW: @FreeThinker no idea why those numbers are red but the Ship work perfectly and with no overheat.

Edited by pmborg

Share this post


Link to post
Share on other sites

Super edit: I took the video down since it was inverted (looked fine before I uploaded it). I used a different tool to encode the video (ffmpeg, better quality overall) and it is uploading now. 

Edited by jhook777
upsidedownworld

Share this post


Link to post
Share on other sites
8 hours ago, pmborg said:

BTW: @FreeThinker no idea why those numbers are red but the Ship work perfectly and with no overheat.

The wasteheatheat calculator assumes you use only pure thermal power conversion, which would have been valid if you relied on the Muon Catalized Fusion Engine or any other thermal power reactor

Edited by FreeThinker

Share this post


Link to post
Share on other sites

Fixed it. Check it out if you like. Sorry about the length, I need to reign these tutorials in a bit. Enjoy and please pardon my many mistakes :]

 

 

Edited by jhook777
spelling

Share this post


Link to post
Share on other sites
8 hours ago, pmborg said:

This is my current ship:

wPWdFWW.png

I am getting 7.42GW from a "Tri Alpha" scale 19m, do you have more without NF?

BTW: @FreeThinker no idea why those numbers are red but the Ship work perfectly and with no overheat.

I can get that at a about a 5 meter scale. However, Not only do you get 50 times the energy, you also get the heat that goes with it, as I said, if you change scales there is some adjusting to do.

Share this post


Link to post
Share on other sites
4 hours ago, Maelstrom Vortex said:

I can get that at a about a 5 meter scale. However, Not only do you get 50 times the energy, you also get the heat that goes with it, as I said, if you change scales there is some adjusting to do.

Thanks for the feedback I will try to adapt it and test it without NF, today at night.

4 hours ago, FreeThinker said:

The wasteheatheat calculator assumes you use only pure thermal power conversion, which would have been valid if you relied on the Muon Catalized Fusion Engine or any other thermal power reactor

Hello,

I had " Muon Catalized Fusion Engine" but removed because it seamed that all worked well without that, "dead weight" :)

I will also test again with it.

Thanks.

Share this post


Link to post
Share on other sites

Thank you @Maelstrom Vortex your input was confirmed, I appreciate it very much this means that I can convert the nuclear reactor from 1000 tones to 34 tones.... extra delta V.

Need to think how I will solve the problem now to get-rid of NF parts :)

Edited by pmborg

Share this post


Link to post
Share on other sites

Before:

wPWdFWW.png

After remove NF stuff:

rtg-0625    NearFutureElectrical\Parts\RTG\rtg-0625.cfg

ZIhvcrG.png

 

Just to the sake of record solved the problem by just keeping these files from NF and delete all rest:

D:\SteamLibrary\steamapps\common\Kerbal Space Program\GameData\NearFutureLaunchVehicles>tree /F
D:.
└───Parts
    └───Payload
        └───cargo-5
                cargo-5-1.cfg
                cargo-5-1.mu
                cargo-5-2.cfg
                cargo-5-2.mu
                cargo-5-3.cfg
                cargo-5-3.mu
                cargo-5-4.cfg
                cargo-5-4.mu
                cargo-nose-5-1.cfg
                cargo-nose-5-1.mu
                cargobay-5-1-n.dds
                cargobay-5-1.dds
                cargobay-5-2-n.dds
                cargobay-5-2.dds
                service-bay-5-1-e.dds
                service-bay-5-1-n.dds
                service-bay-5-1.cfg
                service-bay-5-1.dds
                service-bay-5-1.mu

 

Edited by pmborg

Share this post


Link to post
Share on other sites
On 9/19/2019 at 7:50 AM, jhook777 said:

Fixed it. Check it out if you like. Sorry about the length, I need to reign these tutorials in a bit. Enjoy and please pardon my many mistakes :]

 

 

Nice video, we need more of that. I added the video to the OP

Btw, notice the Alcubiere Warpdrive can also be used to redevous with any target, simply select as a target, and head streight for it. It will automaticly jump out of warp at the exact moment, it is the closest to the target and it orbit will perfectly match with the target.  After that its just a matter of applying some RCS to dock with it.  Notice the auto dropping out will also work when traveling to any planet, it will even automaticly slow down and prevent you from flying into the planet and atmosphere.

Edited by FreeThinker

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.