Jump to content

[1.9.1+] OPT Legacy 3.1.2 | Reconfig 3.4 [Apr 20, 2021]


Recommended Posts

An update to the spawn issue...  Note, I'm running 1.11 with a lot of mods - 100+.

I got tired of using VesselMover to spawn my OPT Humpback ssto with the troublesome cargo ramp; and individually boarding kerbals onto it.  So I tried (and failed a lot) ways to get around the problem.  Here's the workaround/solution that I finally settled on.

WorldStabilizer stays as before.  But this time, give it more time to do its thing by bumping up stabilizationTicks to 500 (from 100); groundingTicks to 250 (from 6); maxUpMovement to 25.0 (from 2.0); displayMessage to True (from false).  The settings are in WorldStabilizer.cfg.  By doing this, WS ran for about 10 seconds on my laptop before I got the "World has been stabilized" message.

On the Humpback ssto, give WS some discrete targets to use as reference points when it moves the craft up/down on spawning.  I used a couple of M-2x2 Structural panels as the targets.  These are attached to docking ports that are offset so that the structural panel is level with the landing gear.  Make it so that those targets are easily discarded - I set the docking ports to decouple by staging.  Basically, when the craft spawns, it should rest on the landing gear and the structural panels.

On launching the craft from Editor, give WS a second to get its bearings.  As long as everything is above or flush with the runway, hit stage to decouple the structural panels before WS can finish. The ssto will calmly settle on the runway.

Here's a screenshot of my ssto in the Editor to showing the placement of the structural panels.  They look larger because I'm using Tweakscale to bump up the size to 200%.

 

Spoiler

JuZG1Xe.png

I don't know whether this will work for all cases.  YMMV.  As you can see, I'm using KerbalFoundries for my landing gear.  I don't know whether that is the reason why I ended up having to use the structural panels.  KF landing gear don't have colliders while stock landing gear have.  I did not spend time to try out the stock landing gear because I'm not a fan of them anyway.

Link to post
Share on other sites

This is hopefully the last update on the spawn issue for a while.  Unless I encounter any game-breaking issue, I'll stay put with the current state of mods I have.

Installed the latest Tweakscale update yesterday - TS 2.4.4.5.  Also EVS 2.2.

The spawning issue is gone.  I've switched over to a default config for WorldStabilizer to see if I can get rid of the CFG customizations.  My OPT Humpback SSTO now launches without hiccups.

I don't know which of those 2 updates fixed the issue.  Things are stable so far.  Looking forward to some gameplay this weekend.

Link to post
Share on other sites

Not sure if this is the right place for this, but I'm trying to install OPT after returning to KSP after not playing for a few years. Thankful for finding this reconfig that keeps it working, however I'm having trouble installing it. I'm not quite sure what I'm doing wrong. I've tried manually installing it (by placing the folders into Gamedata, which has worked with all other mods for me) And via CKAN, however CKAN gives out this error when I attempt to install it:

I've tried installing the reconfig via CKAN first, then OPT Continued, I've tried manually downloading them from spacedock and selecting their .zips via CKAN, and some other combinations but always get some form of exception along the lines of Dependency on OPTReconfig version (any) not satisfied. Help appreciated. 

 

Quote

************** Exception Text **************
CKAN.DependencyNotSatisfiedKraken: OPTSpacePlaneMain dependency on OPTReconfig version (any) not satisfied
   at CKAN.RelationshipResolver.ResolveStanza(IEnumerable`1 stanza, SelectionReason reason, RelationshipResolverOptions options, Boolean soft_resolve, IEnumerable`1 old_stanza)
   at CKAN.RelationshipResolver.Resolve(CkanModule module, RelationshipResolverOptions options, IEnumerable`1 old_stanza)
   at CKAN.RelationshipResolver.AddModulesToInstall(IEnumerable`1 modules)
   at CKAN.ChooseRecommendedMods.FindConflicts()
   at CKAN.ChooseRecommendedMods.MarkConflicts()
   at CKAN.ChooseRecommendedMods.RecommendedModsListView_ItemChecked(Object sender, ItemCheckedEventArgs e)
   at System.Windows.Forms.ListView.OnItemChecked(ItemCheckedEventArgs e)
   at System.Windows.Forms.ListView.WmReflectNotify(Message& m)
   at System.Windows.Forms.ListView.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

 

Link to post
Share on other sites
  • 3 weeks later...

@totos_totidis OPT Continued is the main parts pack. OPT Legacy is older and obsolete versions of parts and (for most of the time) also an expansion pack. The original OPT dev allowed parts to be added to by players into Legacy but not the main pack which is now Continued.

Link to post
Share on other sites

Hello!

I was absent from playing KSP for 3 or 4 months, but recently I enjoyed playing again with KSP which was upgraded to 1.11.
I noticed that my favorite SSTO I made earlier wasn't as fast as it used to be. It was equipped with ARI-73 and was operating in LH2 mode.

At the time of takeoff from KSP, the Thrust value did not rise above 180kN.
The performance notation in SPH is Max Thurust: 1200kN (ASL), and in my memory, it seems that the thrust of 1200kN was actually output when taking off from KSP.
Is this behavior normal?

The image and log when reproduced in a simple environment with only OPT3mod and Cryogenic Engine are attached.

I would be happy if you could tell me.
Thank you.
 

LogFile

gKJe0zr.png

bKIqKlr.png

 

Link to post
Share on other sites

@Yomin I've tried very hard to get this engine's specific behavior correct and for stats to show correctly in the part info, but little things about how KSP works proved to be a real pain and nearly impossible to get over without compromising performance. That engine is supposed to always produce 180kN of thrust while its Isp changes. As long as that's what happens, I'm satisfied, sorry.

I -might- try to wrestle it again...

Link to post
Share on other sites
10 hours ago, JadeOfMaar said:

@Yomin I've tried very hard to get this engine's specific behavior correct and for stats to show correctly in the part info, but little things about how KSP works proved to be a real pain and nearly impossible to get over without compromising performance. That engine is supposed to always produce 180kN of thrust while its Isp changes. As long as that's what happens, I'm satisfied, sorry.

I -might- try to wrestle it again...

Thank you for your reply.

In other words, regardless of whether it is LH2 or LFO, the correct specification is that the maximum thrust is 180kN, and the display of 1200kN is wrong, right?
If so, just understanding it is enough for me. I have no more request.

When I traced and read the related cfg file, I couldn't find the element indicating 1200kN, so I thought it was "strange".

Thank you for the development of OPT. I am looking forward to the future.

 

Link to post
Share on other sites
42 minutes ago, Yomin said:

In other words, regardless of whether it is LH2 or LFO, the correct specification is that the maximum thrust is 180kN, and the display of 1200kN is wrong, right?

Correct. It's supposed to show 180kN, not 1200. There is noting that can be traced to why the part info shows 1200, that's the output of a certain calculation somewhere.

Link to post
Share on other sites
26 minutes ago, JadeOfMaar said:

Correct. It's supposed to show 180kN, not 1200. There is noting that can be traced to why the part info shows 1200, that's the output of a certain calculation somewhere.

Thank you!

Link to post
Share on other sites

Good evening.  I was messing with some VTOL concepts and would like to have some help with the OPT-E  M.A.R.G.E. Engine. Such a nice design with the integrated rotating part.   It says in the description it can work in vacuum too and requires EC and atmosphere.  But sorry for my noobness but how can I bring atmosphere to space?

Link to post
Share on other sites

I have OPT spaceplane continued, OPT spaceplane reconfig, and OPT legacy, all at 3.0, with KSP at 1.11 ... I'm having some very serious problems here:

 

1.  Sometimes, OPT-using parts will cause the entire plane to disintegrate immediately upon launch
2.   Sometimes, the CoL stays at the front and never moves when I add wings/other parts, when using any OPT parts on the plane, and this persists until I exit and re-enter the VAB
3.  Control surfaces deflect at ridiculous angles despite limits set in the VAB/SPH (I'm talking like 80%+ deflection in some cases)

and I suppose 4.  There's no transition pieces between K and KH parts (I remember there used to be a surface-mount endcap that'd attach to the top of a K fuselage to let it blend with a KH tank/cargo bay/etc, but I no longer see them/the H parts don't surface attach to the K parts anymore

I thought that this might have been because OPT wasn't yet updated for 1.11 but apparently it is, so I come seeking help.  Should I uninstall anything here?  are these known issues/any workarounds at this time?

Should also mention that yes I am using the latest version of FAR (I keep things updated with CKAN), if that makes any difference here

Link to post
Share on other sites
On 2/14/2021 at 6:32 PM, Davaeron said:

but how can I bring atmosphere to space?

Howdy. :)The Mk2 nose and the drop tanks can hold IntakeAtm. But other parts aren't allowed to hold it, to prevent people getting carried away with the vacuum operation of those engines.

17 hours ago, ss8913 said:

1.  Sometimes, OPT-using parts will cause the entire plane to disintegrate immediately upon launch
2.   Sometimes, the CoL stays at the front and never moves when I add wings/other parts, when using any OPT parts on the plane, and this persists until I exit and re-enter the VAB
3.  Control surfaces deflect at ridiculous angles despite limits set in the VAB/SPH (I'm talking like 80%+ deflection in some cases)

and I suppose 4. There's no transition pieces between K and KH parts (I remember there used to be a surface-mount endcap that'd attach to the top of a K fuselage to let it blend with a KH tank/cargo bay/etc, but I no longer see them/the H parts don't surface attach to the K parts anymore

Howdy.

  1. I mention this in the changelog, visible on SpaceDock. WorldStabilizer no longer protects against the 1km spawn bug in KSP 1.11, and even evolves it into that vicious kraken.
    On 1/2/2021 at 10:56 PM, JadeOfMaar said:

    Take extreme care when spawning crafts containing the following parts, or just don't use them anymore:

    • J Deployment Bay
    • J Inline Large Docking Port
    • Avatar Cargo Ramp
    • Humpback Cargo Ramp
    • Stail Cargo Bay (Mk1, not Mk2)
    ...
  2. That is a VAB bug. I get that at times too.
  3. I have no clue. Never heard of that one before.
  4. You're looking for H Mounted Noses. They are likely in the fuel tank category and you will find them in the H subcategory of the stock custom categories (separate from the CCK category for OPT).

I don't use FAR but I add to and maintain OPT's FAR config. And I haven't done anything in 1.11.1 so I don't know yet if there's some unexplained new issue that's causing OPT parts to fail to load, which I'm now trying to be hopeful doesn't exist.

Link to post
Share on other sites
13 hours ago, JadeOfMaar said:

Howdy. :)The Mk2 nose and the drop tanks can hold IntakeAtm. But other parts aren't allowed to hold it, to prevent people getting carried away with the vacuum operation of those engines.

Howdy.

  1. I mention this in the changelog, visible on SpaceDock. WorldStabilizer no longer protects against the 1km spawn bug in KSP 1.11, and even evolves it into that vicious kraken. ...
  2. That is a VAB bug. I get that at times too.
  3. I have no clue. Never heard of that one before.
  4. You're looking for H Mounted Noses. They are likely in the fuel tank category and you will find them in the H subcategory of the stock custom categories (separate from the CCK category for OPT).

I don't use FAR but I add to and maintain OPT's FAR config. And I haven't done anything in 1.11.1 so I don't know yet if there's some unexplained new issue that's causing OPT parts to fail to load, which I'm now trying to be hopeful doesn't exist.

thanks!  I'll try your suggestions and I will see if I can find better info/reproducible steps for issue #3.

Link to post
Share on other sites
  • 3 weeks later...

OPT Legacy 3.1

  • Updated "Dark Energy" power spheres to hold and use Dark Goo, not XenonGas.

OPT Reconfig 3.1

  • Added kOS Processor to all drone cores.
  • Added a system so you can turn off B9 feature switching to cure Tweakscale problems with these parts. See OPT_Reconfig/OPT_00Tweak.cfg
  • Added Far Future Tech derived system:
    • Dark Drive now uses OPT Black Hole resource instead of Dark Goo.
    • Dark Drive is now a true interstellar grade engine derived from Kugelblitz sci-fi engine. No longer useful in atmosphere.
    • Dark Drive is useless without OPT Reconfig as Reconfig contains Black Hole resource definition.
    • Enabled OPT bodies to hold FFT propellants including Antimatter and to carry the containment module.
  • Fixed RO antenna patch to detect RealAntennas and not RO.
  • Revised "Dark Energy" power sphere fuel options.
  • Revised Dark Goo system:
    • "Dark Energy" power spheres hold this by default and not XenonGas.
    • Dark Goo is its own fusion fuel option and no longer a component of all other fusion fuel options.
    • Phased out Dark Science.
  • Tiny fixes.
  • Updated Tweakscale configs to be less likely to be overlapped by foreign Tweakscale modlets which then cause fatal exceptions.
  • Updated file names and NEEDS concerning CRP vs Classic Stock to reduce likelihood of fatal issues concerning WBI play mode switcher.
  • Updated detection concerning stock inventory system.

DOWNLOAD LEGACY :: SPACEDOCK :: GITHUB

DOWNLOAD RECONFIG :: SPACEDOCK :: GITHUB

Link to post
Share on other sites
4 hours ago, JadeOfMaar said:

OPT Reconfig 3.1

  • Added kOS Processor to all drone cores.
  • Added a system so you can turn off B9 feature switching to cure Tweakscale problems with these parts. See OPT_Reconfig/OPT_00Tweak.cfg
  • Added Far Future Tech derived system:
    • Dark Drive now uses OPT Black Hole resource instead of Dark Goo.
    • Dark Drive is now a true interstellar grade engine derived from Kugelblitz sci-fi engine. No longer useful in atmosphere.
    • Dark Drive is useless without OPT Reconfig as Reconfig contains Black Hole resource definition.
    • Enabled OPT bodies to hold FFT propellants including Antimatter and to carry the containment module.
  • Fixed RO antenna patch to detect RealAntennas and not RO.
  • Revised "Dark Energy" power sphere fuel options.
  • Revised Dark Goo system:
    • "Dark Energy" power spheres hold this by default and not XenonGas.
    • Dark Goo is its own fusion fuel option and no longer a component of all other fusion fuel options.
    • Phased out Dark Science.
  • Tiny fixes.
  • Updated Tweakscale configs to be less likely to be overlapped by foreign Tweakscale modlets which then cause fatal exceptions.
  • Updated file names and NEEDS concerning CRP vs Classic Stock to reduce likelihood of fatal issues concerning WBI play mode switcher.
  • Updated detection concerning stock inventory system.

Am getting 8 module manager errors related to OPT Reconfig 3.1's CryoEngine patches - I think the relevant bits are here:

Spoiler

[LOG 17:11:24.787] Applying update OPT_Reconfig/CRP/OPT_CryoEngine/@PART[opt_vtol_egg|opt_egg]:NEEDS[CryoEngines|KerbalAtomics,!RealismOverhaul,!ClassicStock] to OPT_Legacy/Parts/Engines/VTOL/EnginesEggDog.cfg/PART[opt_vtol_egg]
[WRN 17:11:24.787] Cannot find key VIspThrustASL3K in PART
[ERR 17:11:24.787] Error - Cannot parse variable search when editing key descriptionDetail = #<b>Thrust:</b> $/VIspThrustASL3K$ / $/VIspThrustVac3K$ kN.<br><b>Isp:</b> $/VIspASL3K$ / $/VIspVac3K$s.<br><b>Requires:</b> <color="yellow">$/VIspChargeReq$</color> EC/s at full throttle.<br><color="orange">When in flight, shutdown engine before switching.</color>
[WRN 17:11:24.788] Cannot find key VIspThrustASL4K in PART
[ERR 17:11:24.788] Error - Cannot parse variable search when editing key descriptionDetail = #<b>Thrust:</b> <color="yellow">$/VIspThrustASL4K$ / $/VIspThrustVac4K$</color> kN.<br><b>Isp:</b> <color="yellow">$/VIspASL4K$ / $/VIspVac4K$</color>s.<br><b>Requires:</b> <color="yellow">$/VIspChargeReq$</color> EC/s at full throttle.<br><color="orange">When in flight, shutdown engine before switching.</color>
[WRN 17:11:24.788] Cannot find key VIspThrustASL6K in PART
[ERR 17:11:24.788] Error - Cannot parse variable search when editing key descriptionDetail = #<b>Thrust:</b> <color="yellow">$/VIspThrustASL6K$ / $/VIspThrustVac6K$</color> kN.<br><b>Isp:</b> <color="yellow">$/VIspASL6K$ / $/VIspVac6K$</color>s.<br><b>Requires:</b> <color="yellow">$/VIspChargeReq$</color> EC/s at full throttle.<br><color="orange">When in flight, shutdown engine before switching.</color>
[WRN 17:11:24.788] Cannot find key VIspThrustASL6K in PART
[ERR 17:11:24.788] Error - Cannot parse variable search when editing key descriptionDetail = #<b>maxThrust:</b> <color="yellow">$/VIspThrustASL6K$ / $/VIspThrustVac6K$</color>kN Vac.<br><b>Isp:</b> <color="yellow">$/VIspASL6K$ / $/VIspVac6K$s</color>s<br><b>Requires:</b> <color="yellow">$/VIspChargeReq$ EC/s</color> at full throttle.<br><color="orange">When in flight, shutdown engine before switching.</color>
[LOG 17:11:24.788] Applying update OPT_Reconfig/CRP/OPT_CryoEngine/@PART[opt_vtol_egg|opt_egg]:NEEDS[CryoEngines|KerbalAtomics,!RealismOverhaul,!ClassicStock] to OPT_Legacy/Parts/Engines/VTOL/EnginesEggDog.cfg/PART[opt_egg]
[WRN 17:11:24.789] Cannot find key VIspThrustASL3K in PART
[ERR 17:11:24.789] Error - Cannot parse variable search when editing key descriptionDetail = #<b>Thrust:</b> $/VIspThrustASL3K$ / $/VIspThrustVac3K$ kN.<br><b>Isp:</b> $/VIspASL3K$ / $/VIspVac3K$s.<br><b>Requires:</b> <color="yellow">$/VIspChargeReq$</color> EC/s at full throttle.<br><color="orange">When in flight, shutdown engine before switching.</color>
[WRN 17:11:24.789] Cannot find key VIspThrustASL4K in PART
[ERR 17:11:24.789] Error - Cannot parse variable search when editing key descriptionDetail = #<b>Thrust:</b> <color="yellow">$/VIspThrustASL4K$ / $/VIspThrustVac4K$</color> kN.<br><b>Isp:</b> <color="yellow">$/VIspASL4K$ / $/VIspVac4K$</color>s.<br><b>Requires:</b> <color="yellow">$/VIspChargeReq$</color> EC/s at full throttle.<br><color="orange">When in flight, shutdown engine before switching.</color>
[WRN 17:11:24.789] Cannot find key VIspThrustASL6K in PART
[ERR 17:11:24.789] Error - Cannot parse variable search when editing key descriptionDetail = #<b>Thrust:</b> <color="yellow">$/VIspThrustASL6K$ / $/VIspThrustVac6K$</color> kN.<br><b>Isp:</b> <color="yellow">$/VIspASL6K$ / $/VIspVac6K$</color>s.<br><b>Requires:</b> <color="yellow">$/VIspChargeReq$</color> EC/s at full throttle.<br><color="orange">When in flight, shutdown engine before switching.</color>
[WRN 17:11:24.789] Cannot find key VIspThrustASL6K in PART
[ERR 17:11:24.789] Error - Cannot parse variable search when editing key descriptionDetail = #<b>maxThrust:</b> <color="yellow">$/VIspThrustASL6K$ / $/VIspThrustVac6K$</color>kN Vac.<br><b>Isp:</b> <color="yellow">$/VIspASL6K$ / $/VIspVac6K$s</color>s<br><b>Requires:</b> <color="yellow">$/VIspChargeReq$ EC/s</color> at full throttle.<br><color="orange">When in flight, shutdown engine before switching.</color>

 

Link to post
Share on other sites
4 hours ago, AccidentalDisassembly said:

Am getting 8 module manager errors related to OPT Reconfig 3.1's CryoEngine patches - I think the relevant bits are here:

That should be fixed now. I've posted an update.

Link to post
Share on other sites
  • 3 weeks later...
On 3/6/2021 at 12:50 PM, JadeOfMaar said:
OPT Reconfig 3.1

[. . .]

Enabled OPT bodies to hold FFT propellants including Antimatter and to carry the containment module. [. . .]

Something I have noticed about this change - the patch for these tanks is written like this:

@PART:HAS[#manufacturer[OPT*Division],@MODULE[ModuleB9PartSwitch]]:NEEDS[B9PartSwitch,FarFutureTechnologies]

However, this results in antimatter tanks are being added to many inappropriate parts that happen to have B9 Part Switch and the OPT Division manufacturer. For example - this applies antimatter tanks to all engine parts that have switchable ISPs, such as the "Downswell" (which uses B9PartSwitch to change response profiles).

Perhaps ModuleCommand, ModuleEnginesFX, and ModuleRCSFX could be excluded (these are the ones I noticed, at least) - something like this, assuming I actually wrote it correctly:

@PART:HAS[#manufacturer[OPT*Division],@MODULE[ModuleB9PartSwitch],!MODULE[ModuleCommand|ModuleEnginesFX|ModuleRCSFX]]:NEEDS[B9PartSwitch,FarFutureTechnologies]

 

Secondly: there are two patches applying two different antimatter tanks to parts that currently have them. For instance:

OPTdoubleantimattertank.png?dl=1

This is the offending portion of the OPT_FFT.cfg patch, which doubles up antimatter tanks with the same HAS criteria. Looks like the one inside the fuel-tank-adding patch can simply be removed:

Spoiler

@PART:HAS[#manufacturer[OPT*Division],@MODULE[ModuleB9PartSwitch]]:NEEDS[B9PartSwitch,FarFutureTechnologies]
{
    MODULE
    {
        name = ModuleAntimatterTank
        FuelName = Antimatter
        ContainmentCost = 10
        DetonationKJPerUnit = 4000
        DetonationRate = 5
    }
}

@PART:HAS[#manufacturer[OPT*Division],@MODULE[ModuleB9PartSwitch]]:NEEDS[B9PartSwitch,FarFutureTechnologies]
{
    MODULE
    {
        name = ModuleAntimatterTank
        FuelName = Antimatter
        ContainmentCost = 10
        DetonationKJPerUnit = 36000
        DetonationRate = 5
    }

...

 

EDIT: Also, not sure what's going on here, but Part Upgrades are visible as parts in the editor somehow (at least on a sandbox game) - and they're cargo parts! 'Refunding' is from KSP-Recall (to fix refunding issues with TweakScaled parts), perhaps related? Or perhaps Cargo Part is getting added by KSP Inventory for All, or something...? Odd in any case:

OPTpartupgradething.png?dl=1

Edited by AccidentalDisassembly
Link to post
Share on other sites
Posted (edited)

@AccidentalDisassembly Thanks for pointing out the FFT config problem. THe node with the higher antimatter energy per unit was a temporary thing while I was working out the Dark Drive's black hole resource behavior but I forgot to delete it or forgot to change the targeting to just the Dark Drive. I'll have that fixed right away. As for part upgrades having cargo modules, that's that 3rd party mod's doing: inventory for all. The upgrades are not supposed to be visible unless you're in the editor -> Advanced mode -> sort by manufacturer (which I hadn't anticipated actually. I guess I'll fix that too-- strip the manufacturer value).

Edited by JadeOfMaar
Link to post
Share on other sites
3 minutes ago, JadeOfMaar said:

@AccidentalDisassembly Thanks for pointing out the FFT config problem. THe node with the higher antimatter energy per unit was a temporary thing while I was working out the Dark Drive's black hole resource behavior but I forgot to delete it or forgot to change the targeting to just the Dark Drive. I'll have that fixed right away. As for part upgrades having cargo modules, that's that 3rd party mod's doing: inventory for all. The upgrades are not supposed to be visible unless you're in the editor -> Advanced mode -> sort by manufacturer (which I hadn't anticipated actually. I guess I'll fix that too-- strip the manufacturer value).

The image was in fact in advanced - sort by manufacturer mode, so maybe it's working as intended! I simply hadn't seen it before, wasn't sure if it was meant to be that way

Link to post
Share on other sites

OPT Reconfig 3.2

  • Added Feature Bias "B" tweakable. Edit the values in OPT_Reconfig/OPT_00Tweak.cfg to your liking. Not tested for use with RealismOverhaul but should still work just fine. This tweakable allows for:
    • [1] Reducing the handwavium nature of most OPT engines and the "Tidal Force" (fuel cell) power spheres: give them stockalike or more realistic™️ behavior.
    • [2] Option [1] + Deleting the Dark Drive, WarpJets, Bubble engine, and "Dark Energy" (fusion) power spheres.
  • Enabled all OPT body parts to hold IntakeAtm for maximum use of WarpJets.
  • Fixed redundant FFT Antimatter containment module on parts.
  • Fixed other fatal Classic Stock issues.
  • Improved or fixed integration with Classic Stock and Rational Resources.

DOWNLOAD RECONFIG :: SPACEDOCK :: GITHUB

 

Link to post
Share on other sites

Getting issues with atmospheric engines after i install the Reconfig . For example, engines such as "Nebula" Scramjet will not breath air only propellium. Can't seem to switch this anywhere.

The Valkyrie engine has the same issue.

Or am i doing something wrong ?

 

EDIT:

I just read that it's a feature. So basically all these engines are now useless on kerbin ? Or how am i suppose to use them ?

Love the mod ! Thank you for keeping it alive.

Edited by ikarus
Link to post
Share on other sites

@ikarus Oh, I didn't think that would be such a big problem. It's effectively CryoEngines but on Classic Stock. Propellium is equivalent to LH2, not some super-rare thing like Karborundum or Antimatter. Propellium can be acquired easily enough by splitting water. You can delete OPT_Reconfig/Classic/OPT_CryoEngine.cfg to stop that.

You're welcome. :D

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...