Jump to content

[1.9.1+] OPT Legacy 3.1.2 | Reconfig 3.4 [Apr 20, 2021]


Recommended Posts

Just now, Apaseall said:

I have the same conversation with them regarding auto detect, .dll files and .version files. Hopefully they will write some code and catch up with the modders.

Looks like we are having the same conversation. lol!

Let's hope that with enough people complaining about it they'll fix this issue.

BTW, I love the OPT Series of Mods. I've created several Space Planes that IMHO look great.

Thanks for a Great Mod.

@Apaseall,

BTW, i have 1235-Hours of in-game time on KSP and am use to doing Manual installs because of this CKAN issue. Just wish as you stated they would hurry and write that code.

Link to post
Share on other sites
8 minutes ago, Gryffen1971 said:

Looks like we are having the same conversation. lol!

Let's hope that with enough people complaining about it they'll fix this issue.

BTW, I love the OPT Series of Mods. I've created several Space Planes that IMHO look great.

Thanks for a Great Mod.

@Apaseall,

BTW, i have 1235-Hours of in-game time on KSP and am use to doing Manual installs because of this CKAN issue. Just wish as you stated they would hurry and write that code.

I wonder how many hours I have spent. Where do I look to find out?

Link to post
Share on other sites

If, you use Steam to play just look in your library and click on Kerbal Space Program and look just above the Play Button for how many hours you have played.

Also, i have a Question for you @Apaseall, i take it that you use CKAN. The question is have you noticed that CKAN no longer sees/reads version files since Version 1.24!

Before that Version CKAN would see Mods that were manually installed and did not have a dll file but, a version file.

So, i see it that CKAN's code was changed in some way.

I checked CKAN and it shows that OPT Reconfig will not work with KSP v1.4.5 that it's Max Version is V1.4.4. Is there a mismatch with the CKAN Database and the Version file with the Mod?

Link to post
Share on other sites
5 minutes ago, Gryffen1971 said:

If, you use Steam to play just look in your library and click on Kerbal Space Program and look just above the Play Button for how many hours you have played.

Also, i have a Question for you @Apaseall, i take it that you use CKAN. The question is have you noticed that CKAN no longer sees/reads version files since Version 1.24!

Before that Version CKAN would see Mods that were manually installed and did not have a dll file but, a version file.

So, i see it that CKAN's code was changed in some way.

I checked CKAN and it shows that OPT Reconfig will not work with KSP v1.4.5 that it's Max Version is V1.4.4. Is there a mismatch with the CKAN Database and the Version file with the Mod?

This is Quoted from HebaruSan, "

So when you said "KSP v1.1.2", you did not mean that those mods were released for KSP v1.1.2? That's why I thought that they weren't compatible, because that's an old game version and almost no mods from back then would be compatible with KSP 1.4.5. If those are instead the version numbers of those mods, and the text "KSP" was added in error, then that completely changes what this problem report is about.

As for AD, no it hasn't changed as I've already said; CKAN has never checked .version files for that. The data structure that tracks AD mods has "Dlls" in its name, and CKAN has never tracked the info that would be required to do what you describe (see my comments in #949)."

End Quote.

Then why has CKAN seen these files before? And now.....They don't exist even when done Manually.

Link to post
Share on other sites

@moobien, @kyen @JadeOfMarr

I have installed your Mod Manually because CKAN shows that it is Incompatible with the current version of KSP. When it states in the Incompatible list the it will work with a Max KSP Version of 1.4.9. Is there a problem with there Meta-Data base. I do know that it states in the Version file of the mod that it will work with the current version of KSP.

I am in a discussion/argument with a Member of the CKAN Network. It seems that they have always used the Dll file to read if the Mod(s) will work with the Current Version of KSP. I also posted a Quote that also shows them talking about the Dll vs. Version file to read to see if the mod is Compatible or not.

Link to post
Share on other sites

@Apaseall, @moobien @kyeon @JadeOfMarr

I have done some digging and there seems to be a problem. The problem is that the lastest file for OPT Reconfig that is on Spacedock.info is showing a Max KSP Version of 1.4.4 when the Version File is showing a Version of 1.4.9. I believe that the information has not been updated to show the change. I also see that the version file shows this Mod will work with KSP v1.4.5 but, CKAN will not install it because of either not having a Dll file and/or Wrong information that is used by Spacedock.info that is sent to the Master.tar.gz file on the CKAN-META for KSP_CKAN.

My suggestion is to update said information on Spacedock.info and resubmit it to CKAN's Meta-Data file.

As of this moment the Member of the CKAN-Network is giving me no concise answer as to why CKAN does not Auto-Detect the File. I figured it out within the last Hour of talking to this person and commenting here. I hope what i found out helps with any problems that Modders are having with this issue.

To All Users and Gamers, Please do a Manual Install of your Mods that are not showing as Compatible but do show in the Incompatible list that Match and/or is greater then the Current Version of KSP. The Mod will not show in CKAN but, will be in the Gamedata directory that you just installed it into Manually.

The problem is that information at times does not get updated correctly and will cause this problem.

 

Link to post
Share on other sites

@Nicky21 If, i remember correctly when you rick click on the tank there should be an option to change the type of tank for that piece. The selection i believe are (Liquid Fuel, Liquid Fuel & Oxidizer, Liquid Fuel & Oxidizer & Mono).

Edited by Gryffen1971
Missed including name of person to direct it to.
Link to post
Share on other sites
12 hours ago, Gryffen1971 said:

@Nicky21 If, i remember correctly when you rick click on the tank there should be an option to change the type of tank for that piece. The selection i believe are (Liquid Fuel, Liquid Fuel & Oxidizer, Liquid Fuel & Oxidizer & Mono).

There is no Mono option. Only the  other options. Which is baffling......

Link to post
Share on other sites

OPT Reconfig 1.2.4

  • Added XenonGas to NFPropulsion tank types.
  • Buffed Lithium tankage (maybe by too much. Untested).
  • Added MonoPropellant tank option to all tanks/parts.
  • Arranged new LF, LFO, Mono tank types to prevent using tank switch to cheat dV.
  • Added MonoPropellant tank option to everything.
  • The following cannot be changed in-flight:
    • Structural and Battery.
    • Drop tanks.
  • Raised KIS slot counts.
  • Disabled whitelist entries for OPT labs for experiments. Apparently this causes MOLE experiments to always or only require an OPT lab.

OPT Legacy 1.1.3

  • Moved CoL, CoP and CoM (centers of lift, pressure (drag) and mass) in Legacy wings so they make more sense (or stop making less sense) in aircraft designs. This should fix a good deal more aero problems.

DOWNLOAD - OPT Reconfig

DOWNLOAD - OPT Legacy

 

Edited by JadeOfMaar
Link to post
Share on other sites

@Nicky21

23 hours ago, Nicky21 said:

There is no Mono option. Only the  other options. Which is baffling......

 

19 hours ago, Gryffen1971 said:

I'll fire up KSP today and will respond back later this Afternoon or this Evening.

I was able to get my craft loaded.

Ok, i went and checked the parts for one of the Spaceplanes i have and to Screen Snips of what i did.

https://imgur.com/WB0IPKA

What i did there was as i stated before i right-clicked on the part to bring up the dialogue box so, i could get to the Change Fuel type option

https://imgur.com/VB8tyJo

Next i clicked on Change Fuel type and a list of different Fuel that can be put into that part are listed.

Now mind you that some part(s) might not be able to be switched to have Mono in them. If, that is the case then adding Mono Tanks would be the fallback option.

Now with this image the change fuel type is not a button to press to bring up the dialogue of different types of fuels it has arrows that you click to change the fuel type. Again, not all parts will allow you to have Mono as a fuel type.

https://imgur.com/dPSiMrc

I hope this helps.

7 hours ago, JadeOfMaar said:

OPT Reconfig 1.2.4

  • Added XenonGas to NFPropulsion tank types.
  • Buffed Lithium tankage (maybe by too much. Untested).
  • Added MonoPropellant tank option to all tanks/parts.
  • Arranged new LF, LFO, Mono tank types to prevent using tank switch to cheat dV.
  • Added MonoPropellant tank option to everything.
  • The following cannot be changed in-flight:
    • Structural and Battery.
    • Drop tanks.
  • Raised KIS slot counts.
  • Disabled whitelist entries for OPT labs for experiments. Apparently this causes MOLE experiments to always or only require an OPT lab.

OPT Legacy 1.1.3

  • Moved CoL, CoP and CoM (centers of lift, pressure (drag) and mass) in Legacy wings so they make more sense (or stop making less sense) in aircraft designs. This should fix a good deal more aero problems.

DOWNLOAD - OPT Reconfig

DOWNLOAD - OPT Legacy

 

Thanks @JadeOfMaar for the update and Great Mod.

Link to post
Share on other sites
  • 2 weeks later...

I love the mod, by far the most aesthetic appeal in a space plane pack. 

However, some of my SSTO designs run into real issues. I'm running KSP ver:1.4.5 and use the latest versions of the Legacy and Reconfig files, but when I use the 'Humpback' class tail cargo ramp and 'Avatar' class tail cargo ramp my plane spawns a few hundred meters above the KSC runway. Without these parts, my SSTO spawns normally, but it does prevent me from sending USI rovers to explore/begin colonizing new planets.

From the research I've done the world stabilizer mod may help with this problem, but I wanted to check if there is a fix for this or if it's a bug that you could address in a future release. 

Thank you for your work on such a great mod, and I really hope there is a fix that will allow me to fly more of the SSTOs I've designed. 

Link to post
Share on other sites

Is FAR still patched into OPT Reconfig?

I'm curious to know how extensively it's implemented.

 

@RiskyRe-entry There are a couple other mods that require World Stabilizer in order to avoid that problem, it seems to be a long standing issue nobody has really been able to pin down and resolve.

Edited by ToastyOats
Link to post
Share on other sites
On 10/21/2018 at 9:50 AM, ToastyOats said:

 

@RiskyRe-entry There are a couple other mods that require World Stabilizer in order to avoid that problem, it seems to be a long standing issue nobody has really been able to pin down and resolve.

@ToastyOats thanks for your advice. I'm using World Stabilizer now and it seems to have fixed the issue. 

I've done some some research and it may be the load height for the cargo ramps causing them to spawn clipped into the runway and catapulting my planes high above the runway. However, this issue is certainly above my pay-grade, hopefully a more experienced Kerbonaut can find the exact problem in the mod.   

Link to post
Share on other sites

Im getting B9PS fatal errors with the OPT mods. I had the same problem with a few parts from the MK2/3 expansion mods.  Seems the problem is the lack of a NEEDS Parameter when MFT is also installed. So redistributing the mod packs with a more intuitive MFT patch that checks for B9PS modules...OR could update this reconfig mod with a more intuitive B9PS patch that checks for MFT modules. either way works. Would be more simple to do it here I think if this effects both OPT mods packs.

Just to be super clear here. Both OPT part mods(OPT and OPT LEGACY) come with MFT patching. This reconfig provides B9PS patches without a pass check for lack of already existing MFT modules.

I dont recall this ever being a problem until now..I suppose the 1.5 update or a recent B9PS update made it that much more fickle involving resource management. 

 

Cheers!

Link to post
Share on other sites
On 10/22/2018 at 10:18 AM, RiskyRe-entry said:

@ToastyOats thanks for your advice. I'm using World Stabilizer now and it seems to have fixed the issue. 

I've done some some research and it may be the load height for the cargo ramps causing them to spawn clipped into the runway and catapulting my planes high above the runway. However, this issue is certainly above my pay-grade, hopefully a more experienced Kerbonaut can find the exact problem in the mod.   

check out this reply from Jade, I know for a fact it happens to more parts than just the ramps, as I dont use them and still run into the problem sometimes...The models may need to be rebuilt from scratch..hard to tell, youre right. definitely above my pay grade as well lol! But..I speculate if the craft is getting catapulted into the air on spawn much like how worldstabilizer helped fix the wheels 'popping' issue...it probably wouldn't look like it spawned up there all..mysteriously and casually and be more..tumbling..or better yet; kraken bait. Just my half baked guess tho

 

 

Link to post
Share on other sites
On 10/29/2018 at 2:56 AM, Jesusthebird said:

check out this reply from Jade, I know for a fact it happens to more parts than just the ramps, as I dont use them and still run into the problem sometimes...The models may need to be rebuilt from scratch..hard to tell, youre right. definitely above my pay grade as well lol! But..I speculate if the craft is getting catapulted into the air on spawn much like how worldstabilizer helped fix the wheels 'popping' issue...it probably wouldn't look like it spawned up there all..mysteriously and casually and be more..tumbling..or better yet; kraken bait. Just my half baked guess tho

 

 

@Jesusthebird Since downloading World Stabilizer, my SSTO spawn issues have stopped haunting me thankfully. If I were more advanced in my coding abilities, maybe there is a way to read the codes and find what World Stabilizer fixes/overrides in the OPT parts.

@whale_2, the WS mod author, describes World Stabilizer's function as: "it intercepts all unpacked (i.e. those affected by physics engine) vessels in the scene right before the physics is about to kick in, determines if they are "submerged" into the ground, raises them slightly above and slowly releases."

My (potentially very off-base) guess is it has something to do with some parts having load heights clipping ('submerging') into the ground on load. Might explain why World Stabilizer is helpful stopping OPT SSTOs spawning a thousand meters in the air. There also may be no answer for the Kraken...

Link to post
Share on other sites
3 hours ago, RiskyRe-entry said:

@Jesusthebird Since downloading World Stabilizer, my SSTO spawn issues have stopped haunting me thankfully. If I were more advanced in my coding abilities, maybe there is a way to read the codes and find what World Stabilizer fixes/overrides in the OPT parts.

@whale_2, the WS mod author, describes World Stabilizer's function as: "it intercepts all unpacked (i.e. those affected by physics engine) vessels in the scene right before the physics is about to kick in, determines if they are "submerged" into the ground, raises them slightly above and slowly releases."

My (potentially very off-base) guess is it has something to do with some parts having load heights clipping ('submerging') into the ground on load. Might explain why World Stabilizer is helpful stopping OPT SSTOs spawning a thousand meters in the air. There also may be no answer for the Kraken...

When I was writing/testing WST, I had to deal with some parts, like, for instance, solar panels from Near Future Electric, that have huge components of their model that are not active when panel is retracted, but are still there, hidden from rendering engine and having no colliders. Such components had to be excluded from determining vessel size. I didn't look into OPT models, but my guess is the issue could be somehow related to above.

Edited by whale_2
Link to post
Share on other sites

Hi, @JadeOfMaar!

Just quick question - J-60D has insane (for LFO) engines ISP - 900/1200. What is the logic behind this - is it an "engine from the future" ? Or high EC consumption contributes smth to this? I am trying to decide whether I can use it in my career, which  I try to play based on more or less stock point of view, and for now this engine looks OP. (thats OK, just wondering)

Link to post
Share on other sites
22 minutes ago, pr4ger said:

Hi, @JadeOfMaar!

Just quick question - J-60D has insane (for LFO) engines ISP - 900/1200. What is the logic behind this - is it an "engine from the future" ? Or high EC consumption contributes smth to this? I am trying to decide whether I can use it in my career, which  I try to play based on more or less stock point of view, and for now this engine looks OP. (thats OK, just wondering)

OPT is entirely based in sci-fi, maybe year 21XX ~ 23XX tech. I don't remember well but most of the engines, including this, should be in Aerospace Tech and beyond. In the case of the J-60D, I justify its Isp through the length of the engine body having ample room for technology we can't make yet for commercial use, and the majority of a very long vacuum optimized nozzle concealed within the hull.

In fact, most of OPT's propulsion tech falls under a hybrid plasma propulsion tech (so I make such engines consume EC, and push the player to include beefy power sources in their OPT spaceplanes). This tech is called S.C.O.O.P. and is conceived by the original OPT dev. Conversely to the engine performance, the OPT body parts may be very massive (dry or wet) and can get very draggy (due to their cross section sizes) and will at some point in your career, warrant a superior approach to the usual spamming of stock engines.

These engines are also like this to make them very worthwhile on planets that don't have Oxygen. Why should OPT "Orbit Portal Technology" be limited to Kerbin Orbit? ;) Your late-game, year 99, Eve SSTO is waiting for kerbalkind to eventually build it.

Link to post
Share on other sites
1 hour ago, JadeOfMaar said:

OPT is entirely based in sci-fi, maybe year 21XX ~ 23XX tech.

Good point! So after finally beating EVE and Jool on stock components I will have easy days gliding on my sci-fi planes to the Laythe resorts and back with dozens of kerbals aboard... )))

Link to post
Share on other sites
8 hours ago, Nicky21 said:

Balance report:
the Humpback Crew tank has a recycler of 80% and consumes 12 ec/s
the J Crew  tank has a recycler of 70% and consumes 37 ec/s

The reason for that is that the J cabin's recycler there is set to support 12 kerbals (more than the 8 that can be seated in it). This is for it to support crew in a cockpit that doesn't have a recycler, such as any of the J or smaller cockpits. In addition, I think a lower efficiency recycler is more EC demanding per kerbal. I've lost my source for balancing these things.

I'll nerf this and give the J cockpits some recycler ability.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...