Angel-125

[1.7.X- Pre-release LIVE!] Kerbal Flying Saucers - Build Flying Saucers in KSP!

Recommended Posts

4 hours ago, Angel-125 said:

lXxsQQo.png

VLJerem.png

Now that looks awesome. :cool: The rain of particles coming down from it. 

I've been getting some NRE's, one I have no idea what is causing it. The other is whenever I start or stop the gravity wave generator or the fusion generator.

Spoiler

[EXC 17:02:02.106] NullReferenceException: Object reference not set to an instance of an object
    KerbalActuators.WBIVTOLManager.KillVerticalSpeed ()
    KerbalActuators.WBIVTOLManager.Update ()

[EXC 19:25:36.800] NullReferenceException: Object reference not set to an instance of an object
    WildBlueIndustries.ModuleBreakableConverter.StartResourceConverter ()
    WildBlueIndustries.WBIModuleResourceConverterFX.StartResourceConverter ()
    BaseEvent.Invoke ()
    UIPartActionButton.OnClick ()
    UnityEngine.Events.InvokableCall.Invoke ()
    UnityEngine.Events.UnityEvent.Invoke ()
    UnityEngine.UI.Button.Press ()
    UnityEngine.UI.Button.OnPointerClick (UnityEngine.EventSystems.PointerEventData eventData)
    UnityEngine.EventSystems.ExecuteEvents.Execute (IPointerClickHandler handler, UnityEngine.EventSystems.BaseEventData eventData)
    UnityEngine.EventSystems.ExecuteEvents.Execute[IPointerClickHandler] (UnityEngine.GameObject target, UnityEngine.EventSystems.BaseEventData eventData, UnityEngine.EventSystems.EventFunction`1 functor)
    UnityEngine.EventSystems.EventSystem:Update()

You can find the log here https://www.dropbox.com/s/prb4f0bam129p3m/KSP 092318.log?dl=0

 

Share this post


Link to post
Share on other sites
10 hours ago, shdwlrd said:

Now that looks awesome. :cool: The rain of particles coming down from it. 

I've been getting some NRE's, one I have no idea what is causing it. The other is whenever I start or stop the gravity wave generator or the fusion generator.

  Hide contents

[EXC 17:02:02.106] NullReferenceException: Object reference not set to an instance of an object
    KerbalActuators.WBIVTOLManager.KillVerticalSpeed ()
    KerbalActuators.WBIVTOLManager.Update ()

[EXC 19:25:36.800] NullReferenceException: Object reference not set to an instance of an object
    WildBlueIndustries.ModuleBreakableConverter.StartResourceConverter ()
    WildBlueIndustries.WBIModuleResourceConverterFX.StartResourceConverter ()
    BaseEvent.Invoke ()
    UIPartActionButton.OnClick ()
    UnityEngine.Events.InvokableCall.Invoke ()
    UnityEngine.Events.UnityEvent.Invoke ()
    UnityEngine.UI.Button.Press ()
    UnityEngine.UI.Button.OnPointerClick (UnityEngine.EventSystems.PointerEventData eventData)
    UnityEngine.EventSystems.ExecuteEvents.Execute (IPointerClickHandler handler, UnityEngine.EventSystems.BaseEventData eventData)
    UnityEngine.EventSystems.ExecuteEvents.Execute[IPointerClickHandler] (UnityEngine.GameObject target, UnityEngine.EventSystems.BaseEventData eventData, UnityEngine.EventSystems.EventFunction`1 functor)
    UnityEngine.EventSystems.EventSystem:Update()

You can find the log here https://www.dropbox.com/s/prb4f0bam129p3m/KSP 092318.log?dl=0

 

Have you downloaded the latest wild blue tools?

Share this post


Link to post
Share on other sites

It's Subnautica Sunday, but I managed to sneak in the Excalibur's body flap part (scaled up from the Flapjack) and made a test flight:

y8v6uBn.png

The mothership is more massive than the Flapjack but she flies fairly well. :) It probably needs a larger tailfin.

Share this post


Link to post
Share on other sites
1 hour ago, Angel-125 said:

Have you downloaded the latest wild blue tools?

Yes, version WBT 1.57.4. I got it direct from your GitHub. My install method for WBI is to delete everything in the folder and copy all files from the zip archive. Also, the hover manager should work on all planets and moons? 

Share this post


Link to post
Share on other sites
59 minutes ago, shdwlrd said:

Yes, version WBT 1.57.4. I got it direct from your GitHub. My install method for WBI is to delete everything in the folder and copy all files from the zip archive. Also, the hover manager should work on all planets and moons? 

Do you have BARIS installed? Did you also make sure to copy the 000ABARISBRIDGEDONOTDELETE (or whatever I named it..)?

Share this post


Link to post
Share on other sites

No I don't use BARIS. The baris bridge think it was from the previous version of WBT. Was the baris bridge file updated with WBT?

1GGK7Hd.jpg

Edited by shdwlrd

Share this post


Link to post
Share on other sites
3 hours ago, shdwlrd said:

No I don't use BARIS. The baris bridge think it was from the previous version of WBT. Was the baris bridge file updated with WBT?

1GGK7Hd.jpg

Yes it was.

Share this post


Link to post
Share on other sites

Ok, I reinstalled WBT by deleting and pulling all files from the 1.57.4 archive. I'm still getting these NRE's. Just to be sure I built a simple test craft and tested again.

Spoiler

[EXC 22:13:22.598] NullReferenceException: Object reference not set to an instance of an object
    WildBlueIndustries.ModuleBreakableConverter.StartResourceConverter ()
    WildBlueIndustries.WBIModuleResourceConverterFX.StartResourceConverter ()
    BaseEvent.Invoke ()
    UIPartActionButton.OnClick ()
    UnityEngine.Events.InvokableCall.Invoke ()
    UnityEngine.Events.UnityEvent.Invoke ()
    UnityEngine.UI.Button.Press ()
    UnityEngine.UI.Button.OnPointerClick (UnityEngine.EventSystems.PointerEventData eventData)
    UnityEngine.EventSystems.ExecuteEvents.Execute (IPointerClickHandler handler, UnityEngine.EventSystems.BaseEventData eventData)
    UnityEngine.EventSystems.ExecuteEvents.Execute[IPointerClickHandler] (UnityEngine.GameObject target, UnityEngine.EventSystems.BaseEventData eventData, UnityEngine.EventSystems.EventFunction`1 functor)
    UnityEngine.EventSystems.EventSystem:Update()

[EXC 22:13:46.716] NullReferenceException: Object reference not set to an instance of an object
    WildBlueIndustries.ModuleBreakableConverter.StopResourceConverter ()
    WildBlueIndustries.WBIModuleResourceConverterFX.StopResourceConverter ()
    BaseEvent.Invoke ()
    UIPartActionButton.OnClick ()
    UnityEngine.Events.InvokableCall.Invoke ()
    UnityEngine.Events.UnityEvent.Invoke ()
    UnityEngine.UI.Button.Press ()
    UnityEngine.UI.Button.OnPointerClick (UnityEngine.EventSystems.PointerEventData eventData)
    UnityEngine.EventSystems.ExecuteEvents.Execute (IPointerClickHandler handler, UnityEngine.EventSystems.BaseEventData eventData)
    UnityEngine.EventSystems.ExecuteEvents.Execute[IPointerClickHandler] (UnityEngine.GameObject target, UnityEngine.EventSystems.BaseEventData eventData, UnityEngine.EventSystems.EventFunction`1 functor)
    UnityEngine.EventSystems.EventSystem:Update()

https://www.dropbox.com/s/r3oyd5vf0w3lmb7/KSP 092318_2247.log?dl=0

The only thing I'm seeing that is unusual is the VFX for the gravity wave generator is missing. 

Spoiler

Cfw6K5S.png

r4iuaaS.png

 

Share this post


Link to post
Share on other sites

Ok, found a couple of issues and fixed them. First is @shdwlrd's issue with converters not running when BARIS isn't installed. The second involves crazy mode not working when other vessels are loaded in scene and the Crazy Mode controls vanish on screen. That's now working again:

SZcQ7eV.png

Here you can see debris in the scene, and the saucer is flying along just fine. :) One thing I haven't tried: can multiple saucers within physics range hover at the same time? I don't mean air park, but actually hover in place. I don't think I had that in mind when I originally built the hover manager. In retrospect it's kind of a crappy design under the hood, but I was in a hurry at the time... Anyway, I've got some more stuff to fix before I can kick out another release.

Edited by Angel-125

Share this post


Link to post
Share on other sites

Have you tried the hover manager on a planet without an atmosphere? It works, but it doesn't work. The controls are there and work. The auto hover function doesn't work. It will stop your vertical momentum when you press the zero control button, but you start falling immediately afterwards. 

Share this post


Link to post
Share on other sites
38 minutes ago, shdwlrd said:

Have you tried the hover manager on a planet without an atmosphere? It works, but it doesn't work. The controls are there and work. The auto hover function doesn't work. It will stop your vertical momentum when you press the zero control button, but you start falling immediately afterwards. 

Haven’t tried in awhile. Ladt time I did, the saucer hovered fine. Since I’ll be stepping into that area of the plugin, I can check operations on airless bodies and other planets.

Share this post


Link to post
Share on other sites
5 hours ago, Angel-125 said:

Haven’t tried in awhile. Ladt time I did, the saucer hovered fine. Since I’ll be stepping into that area of the plugin, I can check operations on airless bodies and other planets.

Thanks for looking into it. 

Share this post


Link to post
Share on other sites

More refactoring needed, but the fix is working for airless bodies:

SoGaJYU.png

Interestingly, on an airless body, you are considered sub-orbital after you lift off. But when you're hovering in an atmosphere, you're considered flying. I've also fixed Crazy Mode so that if you're on an airless body and are sub-orbital, you can still use it. I might just fix it so that Crazy Mode is available if you're flying or sub-orbital regardless of whether or not you're on an airless body.

Share this post


Link to post
Share on other sites

Kerbal Flying Saucers 0.3.9 is now available.
GitHub URL: https://github.com/Angel-125/FlyingSaucers/releases/tag/v0.3.9
 
Changes
 
Excalibur (WORK IN PROGRESS!)
- Added Large Body Flap. It works the same way as the Flapjack's body flap.
- Added S-4 "Excalibur" Cockpit prototype.
- Finished modeling and unwrap of the storage sections and engineering core- texturing to follow.
- Removed Double Outer Section.
- Updated wording on node switching for the Inner Section, and added visual cues to help identify configuration for the outer sections.
- Added particle effects to the engineering core.

Bug Fixes & Enhancements
- Fixed Crazy Mode controls vanishing when a vessel without a gravitic engine is loaded into scene.
- Fixed NRE produced by converters when BARIS isn't installed.
- Fixed issue preventing multiple saucers within physics range of each other from hovering at the same time.
- Fixed issue where craft wouldn't hover on airless bodies.
- Graviolium won't be stripped from your vessels upon launching from the VAB/SPH if you're in Sandbox or Science mode.
- Crazy Mode can now be used when the craft is considered to be sub-orbital as well as when it is flying.

Share this post


Link to post
Share on other sites

I downloaded the update and nothing seems to have changed. No new parts. the double outer section is still there. No this is an installation problem, the folder the update came in has no changes.

Anyone else having this problem?

 

 

Edited by Scorpiodude

Share this post


Link to post
Share on other sites
3 hours ago, Scorpiodude said:

Anyone else having this problem?

Looking through the files, it looks like the Excalibur updates wasn't included in the release. But all the other updates look like they are included. I won't be able to know for certain until I get some KSP time this weekend.

Share this post


Link to post
Share on other sites

It seems that my automated build process failed to copy the new part files over. I’ll have that straightened out this weekend. Regardless, the Excalibur parts are WIP...

Edited by Angel-125

Share this post


Link to post
Share on other sites

KFS 0.3.10 is now available:

- Added missing parts.
- Added new WBIGraviticLift module. You can control it via the Flight Operations Managar, or via throttle. Example config:

Spoiler

    MODULE
    {
        name = WBIGraviticLift
        ConverterName = Gravitic Lift
        StartActionName = Start Gravitic Lift
        StopActionName = Stop Gravitic Lift
        ToggleActionName = Toggle Gravitic Lift
        FillAmount = 1.0
        AutoShutdown = false
        GeneratesHeat = false
        UseSpecialistBonus = false
        startEffect = effectStart
        stopEffect = effectStop
        runningEffect = effectRunning

        //Maximum acceleration in meters per second per second.
        maxAcceleration = 20

        //EfficiencyBonus is auto-calculated. The more massive the craft, the higher the "bonus," which translates into
        //consuming and producing input/output resources faster.
        //So instead of EfficiencyBonus, we use specific impulse to determine how well we use the resources.
        //Math: acceleration * total vessel mass = lift force.
        //EfficiencyBonus = lift force / (9.81 * specificImpulse).
        //Resources are consumed & produced at Ratio * EfficiencyBonus.
        specificImpulse = 1
        
        //...or liquid fuel, or whatever...
        INPUT_RESOURCE
        {
            ResourceName = Graviolium
            Ratio = 0.0016875
            FlowMode = STAGE_PRIORITY_FLOW
        }
        OUTPUT_RESOURCE
        {
            ResourceName = StaticCharge
            Ratio = 0.05
            DumpExcess = false
        }
    }

@Eskandare@JadeOfMaar

1Ccg4IW.png

Edited by Angel-125

Share this post


Link to post
Share on other sites

Started working on the S4 gravitic engine:

pifOf5Z.png

Unlike the Flapjack's engine, which doubles as the central keel, the S4 engine is separate from the Engineering Core. That allows you to place an underside module of some sort. The engine is 7m in diameter at present. Anyway, as with most of the saucer, there's a lot to do. I need to make some revisions to the gravitic engine part module, for instance, to leverage some lessons I learned while prototyping the Excalibur's particle effects. It's slow progress to be sure, but life is busy for me these days. At least it's progress. :)

Share this post


Link to post
Share on other sites

So out of curiosity I attempted to install this with the Engineering Tech Tree, and found out that it seems to annihilate a couple of Alien Tech relevent nodes, I've unlocked the flapjacks Aerospike, the alien tech super computer & the SAFER reactor, but everything else is kaput.

 

I should add I'm also running KSPI-E besides that everything seems to work. That Coana hover engine tho seems unable to lift the flapjack off the floor

Share this post


Link to post
Share on other sites
17 hours ago, ToastyOats said:

So out of curiosity I attempted to install this with the Engineering Tech Tree, and found out that it seems to annihilate a couple of Alien Tech relevent nodes, I've unlocked the flapjacks Aerospike, the alien tech super computer & the SAFER reactor, but everything else is kaput.

Angel (and most players) don't use ETT so no compatibility may exist for it in his mods. It would make sense that ETT buries his tech nodes, or his tech nodes bury some in ETT.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.