Jump to content

Kerbin Side Remastered [1.0.1] [1.7.3]


Eskandare
 Share

Recommended Posts

1 hour ago, si2504 said:

I'm on 1.11.1 but others said that KSR works fine on 1.11?

I've used KSR on 1.11.1 and am now using it on 1.11.2. 
Can you post your ksp.log and your player.log and we can look at what's going on when you load

Link to comment
Share on other sites

17 minutes ago, Caerfinon said:

I've used KSR on 1.11.1 and am now using it on 1.11.2. 
Can you post your ksp.log and your player.log and we can look at what's going on when you load

what's the best method to upload the KSP.log file?

Link to comment
Share on other sites

@si2504

I see that you have Kerbal Konstructs installed. And it loads correctly.
FAR v0.16.0.1 is throwing the majority of the exceptions

Spoiler

[EXC 20:59:50.585] KeyNotFoundException: The given key was not present in the dictionary.
	System.Collections.Generic.Dictionary`2[TKey,TValue].get_Item (TKey key) (at <ad04dee02e7e4a85a1299c7ee81c79f6>:0)
	FerramAerospaceResearch.FARAeroComponents.FARAeroSection.UpdateAeroSection (System.Single potentialFlowNormalForce, System.Single viscCrossflowDrag, System.Single diameter, System.Single flatnessRatio, System.Single hypersonicMomentForward, System.Single hypersonicMomentBackward, UnityEngine.Vector3 centroidWorldSpace, UnityEngine.Vector3 xRefVectorWorldSpace, UnityEngine.Vector3 nRefVectorWorldSpace, UnityEngine.Matrix4x4 vesselToWorldMatrix, UnityEngine.Vector3 vehicleMainAxis, System.Collections.Generic.List`1[T] moduleList, System.Collections.Generic.List`1[T] dragFactor, System.Collections.Generic.Dictionary`2[TKey,TValue] partWorldToLocalMatrixDict) (at <45fd449fcf964b8bb82fdc5e8afc0628>:0)
	FerramAerospaceResearch.FARAeroComponents.VehicleAerodynamics.CalculateVesselAeroProperties () (at <45fd449fcf964b8bb82fdc5e8afc0628>:0)
	FerramAerospaceResearch.FARAeroComponents.VehicleAerodynamics.CreateVoxel (Vessel vessel) (at <45fd449fcf964b8bb82fdc5e8afc0628>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	FerramAerospaceResearch.FARLogHandler:LogException(Exception, String, Object)
	FerramAerospaceResearch.FARThreading.ThreadSafeDebugLogger:Update()

 

'RCSBuildAidToolbar' has not met dependency 'Toolbar' V1.0.0
You do not have Kerbin Side Remastered installed in this instance, rather this log shows that you are using RO which is incompatible with Kerbin Side Remastered

Is this the correct log? From game instance C:\Games\Kerbal Space Program 1.11.1 RO\GameData\

Edited by Caerfinon
Link to comment
Share on other sites

2 minutes ago, Caerfinon said:

@si2504

I see that you have Kerbal Konstructs installed. And it loads correctly.
FAR v0.16.0.1 is throwing the majority of the exceptions

  Hide contents


[EXC 20:59:50.585] KeyNotFoundException: The given key was not present in the dictionary.
	System.Collections.Generic.Dictionary`2[TKey,TValue].get_Item (TKey key) (at <ad04dee02e7e4a85a1299c7ee81c79f6>:0)
	FerramAerospaceResearch.FARAeroComponents.FARAeroSection.UpdateAeroSection (System.Single potentialFlowNormalForce, System.Single viscCrossflowDrag, System.Single diameter, System.Single flatnessRatio, System.Single hypersonicMomentForward, System.Single hypersonicMomentBackward, UnityEngine.Vector3 centroidWorldSpace, UnityEngine.Vector3 xRefVectorWorldSpace, UnityEngine.Vector3 nRefVectorWorldSpace, UnityEngine.Matrix4x4 vesselToWorldMatrix, UnityEngine.Vector3 vehicleMainAxis, System.Collections.Generic.List`1[T] moduleList, System.Collections.Generic.List`1[T] dragFactor, System.Collections.Generic.Dictionary`2[TKey,TValue] partWorldToLocalMatrixDict) (at <45fd449fcf964b8bb82fdc5e8afc0628>:0)
	FerramAerospaceResearch.FARAeroComponents.VehicleAerodynamics.CalculateVesselAeroProperties () (at <45fd449fcf964b8bb82fdc5e8afc0628>:0)
	FerramAerospaceResearch.FARAeroComponents.VehicleAerodynamics.CreateVoxel (Vessel vessel) (at <45fd449fcf964b8bb82fdc5e8afc0628>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	FerramAerospaceResearch.FARLogHandler:LogException(Exception, String, Object)
	FerramAerospaceResearch.FARThreading.ThreadSafeDebugLogger:Update()

 

'RCSBuildAidToolbar' has not met dependency 'Toolbar' V1.0.0
You do not have Kerbin Side Remastered installed in this instance, rather this log shows that you are using RO which is incompatible with Kerbin Side Remastered

Is this the correct log? From game instance C:\Games\Kerbal Space Program 1.11.1 RO\GameData\

yes it is the correct log file. I installed Kerbinside Remastered, noticed that I couldn't bring up my KK static menu so I then deleted Kerbinside to see if that was the issue. Booted back up and then indeed I could once again open my KK statics menu. And yes, this is an RO save so which may also explain it. I also have absolutely no idea why FAR is having such a mental breakdown in the log all the time.

Link to comment
Share on other sites

3 minutes ago, si2504 said:

so I then deleted Kerbinside to see if that was the issue.

Kerbin Side Remastered is for a stock planet install. No guarantee it will function (or not wreck) your other solar system installs.

I don't use FAR so I can't speak as to why it is spamming exceptions.

Edited by Caerfinon
Link to comment
Share on other sites

1 minute ago, Caerfinon said:

Kerbin Side Remastered is for a stock planet install. No guarantee it will function (or not wreck) your other solar system installs.

I only wanted the Runway statics mainly...

Edited by si2504
Link to comment
Share on other sites

Just now, si2504 said:

I only wanted the Runway statics mainly...

You could "harvest them" This involves the following;

  • Install the mode as normal
  • delete the directory \KerbinSideRemastered\Statics\ExampleBases to remove all bases
  • delete the file \KerbinSideRemastered\MiniAVC.dll
  • Never Update the mod after doing this.

Then you will have access the the statics that make up the runways and taxiways and should be able to use then in your bases.  But test and if it causes issues, if so, remove the mod completely.

I've done this with a number of older Kerbal Konstruct mods to access their parts for private use and it mostly works. 

Anything you build with these parts that you might want to distribute to others must carry the original grant of License for this mod.

 

Link to comment
Share on other sites

On 6/1/2021 at 1:53 PM, Caerfinon said:

Kerbin Side Remastered is for a stock planet install. No guarantee it will function (or not wreck) your other solar system installs.

I don't use FAR so I can't speak as to why it is spamming exceptions.

KSR will also work for a resized stock Kerbin, but in that case it requires manually adjusting the elevation on many/most of the statics in order to have them remain at ground level. I've done that with a 2.7x scaled Kerbin.

Link to comment
Share on other sites

  • 1 month later...

Just a quick note. You don't have to install a mod to get it's statics. Just pop in to the zip file and only extract the statics folder, then pop it in GameData. KK will find them just like MM finds configs.

Link to comment
Share on other sites

In version 1.12.1, the context menu of Kerbin Кonstruction does not work. Therefore, you cannot change the position of objects, add new ones, and so on. Kerbin Side Remasterеd and original Kerbin Side, Kosmodrome, Kerbin City and others are working. At least on my installation.

Link to comment
Share on other sites

@Sokol_323 Yes. the CTL-K edit feature of Kerbal Konstructs does not work in 1.12.1. However the function of the KK static facilities that make up Kerbin Side Remastered work as intended. 

I keep a KSP 1.11.2 instance installed and I make all of my KK edits there and copy the updated instances to my KSP 1.12.1 active game as required. 

Link to comment
Share on other sites

On 7/14/2021 at 8:22 AM, Ben J. Kerman said:

Does Kerbinside work with KSP 1.12? 

Caerfinon says he hasn't had any problems. Anyone else?

Kerbinside Remastered mostly works fine, the only problem I've found so far is that Kojave Sands AFB has bugged terrain colors (but that's likely a problem with KSR and not a version incompatibility). Old Kerbinside conflicts with KSR. KSR is newer and has more stockalike bases. So go and install KSR (and Kerbal Konstructs, and KK's bundled dependency CustomPreLaunchChecks)

Link to comment
Share on other sites

2 hours ago, OrdinaryKerman said:

Old Kerbinside conflicts with KSR

Sections or old Kerbin Side work without conflict. You can install Kerbin-Side Kampus cont and delete the base configs it comes with, and then you have some really nice KK statics that you can use to spice up your own bases.

Link to comment
Share on other sites

4 hours ago, Caerfinon said:

Sections or old Kerbin Side work without conflict. You can install Kerbin-Side Kampus cont and delete the base configs it comes with, and then you have some really nice KK statics that you can use to spice up your own bases.

Well, the models are so old and don't follow a lot of good practice, but AlphaAsh was learning at the time. Even the models made by lack was lacking. Nonetheless, that was the beginning. the styles and features have changed. An even now, the use of a mask for the ground texture is the now standard.  KSR is in the process of upgrading and adding AO to the statics.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...