Jump to content
  • 1

Orbit Changing During Timewarp


Question

Recently I have been having an issue in KSP where anytime I time warp, my ship's periapsis and apoapsis will change. If I am only orbiting Kerbin, it may only change a few meters or so each time I enter time warp; however, when flying to Minmus I sometimes miss my entire encounter or my periapsis will change by 10,000+ meters because of it. This makes getting to minmus difficult, but now it is almost impossible to encounter a planet outside of Kerbin like Duna. This happens at all levels of warp including only x5. I have the game on steam and have verified the integrity of the game files along with deleting the files, but to no avail. Any help would be much appreciated.

Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

Try before the warp to turn off SAS and RCS and switch Hibernation in Warp to auto.(And even deactivate the engines in case there is some weird thrust bug).

Also right before you warp check again if your orbit/speed is stable and the one you aiming for.

Sometimes even the shortest bursts of RCS cause massive changes to your transfer orbit.

After that i really cant think of something else.

Edited by Boyster
Link to post
Share on other sites
  • 0
10 hours ago, Boyster said:

Try before the warp to turn off SAS and RCS and switch Hibernation in Warp to auto.(And even deactivate the engines in case there is some weird thrust bug).

Also right before you warp check again if your orbit/speed is stable and the one you aiming for.

Sometimes even the shortest bursts of RCS cause massive changes to your transfer orbit.

After that i really cant think of something else.

I will definitely check again and try this when I get on later today. Thanks for the tips.

7 hours ago, Rocket In My Pocket said:

I had this issue myself awhile back, turned out it was a mod causing it: BetterTimeWarp I think?

Specifically an option inside the mod for "lossless physics time warping."

4 hours ago, Jestersage said:

Hyperedit seems to cause problem.

I have no mods downloaded so I don't believe that could be the problem.

 

For some more details, when I time warp, sometimes locations on Kerbi, like the KSC, seem to jump around alot when in map view. Almost as if they are not fixed to the surface of the planet. This happens only in the map view, when I go to said locations they appear fine.

Edited by blackxhk_army
Link to post
Share on other sites
  • 0

Have you tempered with the ingame settings?

Like turning off Orbital drift Compensation or Ease in gravity?

If yes that might be the problem cause they should be always on.

I just hope your savegame is not corrupted, i dont want to scare you but if you have an older backup and cant figure out the problem 

you might need to see if thats the issue.Except if you had this problem since the start.Good luck.
 

Edited by Boyster
Link to post
Share on other sites
  • 0
1 hour ago, Boyster said:

Have you tempered with the ingame settings?

Like turning off Orbital drift Compensation or Ease in gravity?

If yes that might be the problem cause they should be always on.

I just hope your savegame is not corrupted, i dont want to scare you but if you have an older backup and cant figure out the problem 

you might need to see if thats the issue.Except if you had this problem since the start.Good luck.
 

Oh jeez, I hope it's not corrupted, this is the farthest I've gone in career mode. Orbital drift compensation and ease in gravity are both on. I really appreciate the effort.

Link to post
Share on other sites
  • 0
7 hours ago, blackxhk_army said:

For some more details, when I time warp, sometimes locations on Kerbi, like the KSC, seem to jump around alot when in map view. Almost as if they are not fixed to the surface of the planet. This happens only in the map view, when I go to said locations they appear fine.

I forgot to say that if the icons just blink a bit and move around like trembling its usual, nothing to worry about, it happens.

Link to post
Share on other sites
  • 0

Old bug. The conversion calculation between on rails and physical orbit is occasionally off by a bit. This looks really bad the farther down the line your intercept or encounter  is. Also noticeable if you have a near perfect orbit.

some tips;

Before warping fire engine ever so slightly in a radial or normal direction. ( or whichever way you didn’t burn before the warp. ) Seems to help.

quicksave and reload. Then warp. Not sure why but it helps me.

if you really want to be careful on longer warps, warp in the tracking station or from another vessel. Again no clue why that seems to help.

 

Anyway you can probably blame unity and floating point thingamagigs. 

 

 

Oh yes ,  the on map icons just do that. They aren’t actually jumping around, it’s just ksp having a kraken attack. Will probably get fixed in the future.

Edited by Mark Kerbin
Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...