Jump to content

[1.12.x] Malah's Quick Mods - IMPORTANT UPDATE FOR ZEROMINIAVC


linuxgurugamer
 Share

Recommended Posts

This is what I'm thinking of doing, comments, please:

33oXK0O.png

3 hours ago, Tacombel said:

@linuxgurugamer

zero Mini AVC is also detecting for me two sets of duplicated dlls, the already mentioned katlib.dll and also CLSInterfaces.dll, but I am having no problems, that I know. Would it be wiser to leave things alone if it is working?

Which mods have the CLSInterfaces .dll installed?

Link to comment
Share on other sites

Think I found another issue, but it could be related to a few of the ones most recently posted. I just updated ZeroMiniAVC this morning. loaded KSP and get a fatal exception. Here is the portion of the log file:

[EXC 10:51:30.367] [ModuleManager] The patching thread threw an exception: System.IO.FileNotFoundException: C:\Program Files\KSP_1.12.2_w_BG1.7.1\GameData\KIS\Plugins\MiniAVC-V2.dll
  at System.Diagnostics.FileVersionInfo.GetVersionInfo (System.String fileName) [0x0000d] in <ef151b6abb5d474cb2c1cb8906a8b5a4>:0 
  at ModuleManager.ModListGenerator.GenerateModList (System.Collections.Generic.IEnumerable`1[T] modsAddedByAssemblies, ModuleManager.Progress.IPatchProgress progress, ModuleManager.Logging.IBasicLogger logger) [0x000a2] in <a0f9d7e5c0864d32839c501c53536c2a>:0 
  at ModuleManager.MMPatchLoader.Run () [0x000f3] in <a0f9d7e5c0864d32839c501c53536c2a>:0 
  at ModuleManager.MMPatchRunner+<>c__DisplayClass10_0.<Run>b__1 () [0x00001] in <a0f9d7e5c0864d32839c501c53536c2a>:0 
  at ModuleManager.Threading.BackgroundTask+<>c__DisplayClass0_0.<Start>g__RunAction|0 () [0x00002] in <a0f9d7e5c0864d32839c501c53536c2a>:0 
 

Link to comment
Share on other sites

2 minutes ago, Michel Bartolone said:

Think I found another issue, but it could be related to a few of the ones most recently posted. I just updated ZeroMiniAVC this morning. loaded KSP and get a fatal exception. Here is the portion of the log file:

[EXC 10:51:30.367] [ModuleManager] The patching thread threw an exception: System.IO.FileNotFoundException: C:\Program Files\KSP_1.12.2_w_BG1.7.1\GameData\KIS\Plugins\MiniAVC-V2.dll
  at System.Diagnostics.FileVersionInfo.GetVersionInfo (System.String fileName) [0x0000d] in <ef151b6abb5d474cb2c1cb8906a8b5a4>:0 
  at ModuleManager.ModListGenerator.GenerateModList (System.Collections.Generic.IEnumerable`1[T] modsAddedByAssemblies, ModuleManager.Progress.IPatchProgress progress, ModuleManager.Logging.IBasicLogger logger) [0x000a2] in <a0f9d7e5c0864d32839c501c53536c2a>:0 
  at ModuleManager.MMPatchLoader.Run () [0x000f3] in <a0f9d7e5c0864d32839c501c53536c2a>:0 
  at ModuleManager.MMPatchRunner+<>c__DisplayClass10_0.<Run>b__1 () [0x00001] in <a0f9d7e5c0864d32839c501c53536c2a>:0 
  at ModuleManager.Threading.BackgroundTask+<>c__DisplayClass0_0.<Start>g__RunAction|0 () [0x00002] in <a0f9d7e5c0864d32839c501c53536c2a>:0 
 

Restart and try again, that can happen when the dll is deleted.

Link to comment
Share on other sites

Please try this beta:

  • Added suggested DLL to keep
  • Added special code for KatLib.dll, since it gets loaded out-of-order
     

https://www.dropbox.com/s/pj54he415zpydcs/ZeroMiniAVC-1.1.2.1-BETA.zip?dl=0

 

Also, if you come across any other DLLs which deleting the DLLs which aren't listed as "Keep" causes problems, please let me know

Link to comment
Share on other sites

  • 2 weeks later...
On 10/18/2021 at 5:34 AM, linuxgurugamer said:

This is what I'm thinking of doing, comments, please:

That works for Katlib.dll. Leave it in KXAPI and remove from CraftManager.  When I mentioned renaming the file before I meant the extension, like "name.dll.ignore" 

Link to comment
Share on other sites

  • 1 month later...

Minor versioning glitch: QuickGoTo v1.4.0.9 version file reports version as v1.4.0.8.  KSP-AVC-1.12.0-1.4.1.8 sometimes, but not always, reports new version of QuickGoTo v1.4.0.9 available. Manually editing the version file for QuickGoTo to the correct version number appears to solve the issue. FYI.

Link to comment
Share on other sites

  • 4 weeks later...

QuickSearch Release, 3.3.1

  • To fix extreme lag in both the Editor and R&D screen:
    • Fixed PressEnterToSearch for the RnD screen
    • Added timed delay for when immediate search requested, to delay before doing search to be sure typing is done, 
    • Added new slider to QS config to control the delay from the last keystroke to the search

The default for the delay is set to 1/2 second, which seems to work for me.  Use the slider to increase the delay if you are a slow typer

Edited by linuxgurugamer
Link to comment
Share on other sites

GameData\QuickMods\QuickSearch\QuickSearch.version

{
  "NAME": "QuickSearch",
  "URL": "http://ksp.spacetux.net/avc/QuickSearch",
  "CHANGE_LOG_URL": "https://raw.githubusercontent.com/linuxgurugamer/QuickMods/master/QuickSearch/README.md",
  "DOWNLOAD": "http://spacedock.info/mod/101/QuickSearch",
  "GITHUB": {
    "USERNAME": "linuxgurugamer",
    "REPOSITORY": "QuickMods"
  },
  "VERSION": {
    "MAJOR": 3,
    "MINOR": 3,
    "PATCH": 0,
    "BUILD": 9
  },
	"KSP_VERSION_MIN": {
		"MAJOR": 1,
		"MINOR": 8,
		"PATCH": 0
	}
} 

http://ksp.spacetux.net/avc/QuickSearch:

{ "NAME": "QuickSearch", "URL": "http://ksp.spacetux.net/avc/QuickSearch", "CHANGE_LOG_URL": "https://raw.githubusercontent.com/linuxgurugamer/QuickMods/master/QuickSearch/README.md", "DOWNLOAD": "http://spacedock.info/mod/101/QuickSearch", "GITHUB": { "USERNAME": "linuxgurugamer", "REPOSITORY": "QuickMods" }, "VERSION": { "MAJOR": 3, "MINOR": 3, "PATCH": 0, "BUILD": 11 }, "KSP_VERSION": { "MAJOR": 1, "MINOR": 12, "PATCH": 2 }, "KSP_VERSION_MIN": { "MAJOR": 1, "MINOR": 12, "PATCH": 0 } }

3.3.0.9 vs. 3.3.1.1 vs. 3.3.1 (as previous post says).
Confuzizous!

Link to comment
Share on other sites

5 hours ago, Gordon Dry said:

GameData\QuickMods\QuickSearch\QuickSearch.version

{
  "NAME": "QuickSearch",
  "URL": "http://ksp.spacetux.net/avc/QuickSearch",
  "CHANGE_LOG_URL": "https://raw.githubusercontent.com/linuxgurugamer/QuickMods/master/QuickSearch/README.md",
  "DOWNLOAD": "http://spacedock.info/mod/101/QuickSearch",
  "GITHUB": {
    "USERNAME": "linuxgurugamer",
    "REPOSITORY": "QuickMods"
  },
  "VERSION": {
    "MAJOR": 3,
    "MINOR": 3,
    "PATCH": 0,
    "BUILD": 9
  },
	"KSP_VERSION_MIN": {
		"MAJOR": 1,
		"MINOR": 8,
		"PATCH": 0
	}
} 
 

http://ksp.spacetux.net/avc/QuickSearch:

{ "NAME": "QuickSearch", "URL": "http://ksp.spacetux.net/avc/QuickSearch", "CHANGE_LOG_URL": "https://raw.githubusercontent.com/linuxgurugamer/QuickMods/master/QuickSearch/README.md", "DOWNLOAD": "http://spacedock.info/mod/101/QuickSearch", "GITHUB": { "USERNAME": "linuxgurugamer", "REPOSITORY": "QuickMods" }, "VERSION": { "MAJOR": 3, "MINOR": 3, "PATCH": 0, "BUILD": 11 }, "KSP_VERSION": { "MAJOR": 1, "MINOR": 12, "PATCH": 2 }, "KSP_VERSION_MIN": { "MAJOR": 1, "MINOR": 12, "PATCH": 0 } }
 

3.3.0.9 vs. 3.3.1.1 vs. 3.3.1 (as previous post says).
Confuzizous!

That gets updated later this evening, sorry for the confusion

Link to comment
Share on other sites

  • 4 weeks later...

I'm having an issue with QuickHide having way too many entries in the menu, as in the mods I have appear on the list again and again. Another issue (which is possibly related) is that when I unset a mod to "Can be hidden", i.e. leaving it on the list when one clicks the "Hide" button, it doesn't seem to save the setting at all. Once I switch from the craft to the Space Center, or revert the flight, or even go from Space Center to VAB, every button go back to being hidden. When I then look in the menu (assuming I've unset every instance of the same mod on the list) and check, the instances of the mods lover down are still not set to "Can be hidden" but the ones at the top of the list have reset themselves.

EDIT: I have discovered that after installing the mod it has only the mods for the space center on the list. As you go through the VAB, the SPH, the launch pad, and the tracking station it adds the buttons for those four to the list even if they're already there. Which does explain the multiple instances, but not the resetting settings.

2nd EDIT: I've discovered that every single time it loads up a scenario with the toolbar present, the mod re-adds the elements of the toolbar to the list. I can keep changing settings all I want, but because it keeps assigning new ID's to every toolbar button the settings will never be applied.

Edited by NomenNescio
New Information
Link to comment
Share on other sites

On 1/24/2022 at 1:24 PM, NomenNescio said:

I'm having an issue with QuickHide having way too many entries in the menu, as in the mods I have appear on the list again and again. Another issue (which is possibly related) is that when I unset a mod to "Can be hidden", i.e. leaving it on the list when one clicks the "Hide" button, it doesn't seem to save the setting at all. Once I switch from the craft to the Space Center, or revert the flight, or even go from Space Center to VAB, every button go back to being hidden. When I then look in the menu (assuming I've unset every instance of the same mod on the list) and check, the instances of the mods lover down are still not set to "Can be hidden" but the ones at the top of the list have reset themselves.

EDIT: I have discovered that after installing the mod it has only the mods for the space center on the list. As you go through the VAB, the SPH, the launch pad, and the tracking station it adds the buttons for those four to the list even if they're already there. Which does explain the multiple instances, but not the resetting settings.

2nd EDIT: I've discovered that every single time it loads up a scenario with the toolbar present, the mod re-adds the elements of the toolbar to the list. I can keep changing settings all I want, but because it keeps assigning new ID's to every toolbar button the settings will never be applied.

I haven't used this one in a long time, will look at it over the weekend

Link to comment
Share on other sites

On 1/24/2022 at 1:24 PM, NomenNescio said:

EDIT: I have discovered that after installing the mod it has only the mods for the space center on the list. As you go through the VAB, the SPH, the launch pad, and the tracking station it adds the buttons for those four to the list even if they're already there. Which does explain the multiple instances, but not the resetting settings.

Which list?

On 1/24/2022 at 1:24 PM, NomenNescio said:

2nd EDIT: I've discovered that every single time it loads up a scenario with the toolbar present, the mod re-adds the elements of the toolbar to the list. I can keep changing settings all I want, but because it keeps assigning new ID's to every toolbar button the settings will never be applied.

Which toolbar?

 

I've been testing it, and while I do see a couple of minor issues, I don't see this happening.  So I will need a full log (Player.log) to be able to continue investigating

Link to comment
Share on other sites

  • 2 weeks later...
On 10/18/2021 at 1:34 PM, linuxgurugamer said:

This is what I'm thinking of doing, comments, please:

33oXK0O.png

Which mods have the CLSInterfaces .dll installed?

I just got this issue - what do I do, and why does the window not give the slightest bit of advice on what I should do? Surely these DLLs aren't a bit important for the mods?

Link to comment
Share on other sites

4 hours ago, Bej Kerman said:

I just got this issue - what do I do, and why does the window not give the slightest bit of advice on what I should do? Surely these DLLs aren't a bit important for the mods?

In the window, it says:

It is suggested that you keep the first of each and delete the rest

 

Link to comment
Share on other sites

1 hour ago, Bej Kerman said:

And you're absolutely sure that mod isn't using that DLL for something?

You have 2 identically named DLL files.  That breaks things.  You need to remove one.

Link to comment
Share on other sites

  • 1 month later...
On 2/7/2022 at 12:47 AM, linuxgurugamer said:

In the window, it says:

It is suggested that you keep the first of each and delete the rest

 

Hello @linuxgurugamer

[1] Actually I have exactly the same problem, long time ago, with my Kerbol System installation on KSP 1.12.3

Directory of K:\SteamLibrary\steamapps\common\Kerbal Space Program\GameData\CraftManager\Plugins\KatLib.dll

Directory of K:\SteamLibrary\steamapps\common\Kerbal Space Program\GameData\KXAPI\Plugins\KatLib.dll

This happen when we install the CraftManager plugin.

 

The problem: Once when I deleted that dll suggested I also had another FATAL error, so I decided to use an old version to workaround this problem, I forgot also to comment on it at that time.

My suggested solution: Is to install this version of ZeroMiniAVC:

q1as91B.png

(it still works perfectly for me at least on KSP 1.12.3)

 

[2] But today I took another shot to try it and update it again to latest version and I got a FATAL exception that close the KSP loading window.

ERROR:

[EXC 14:47:51.094] [ModuleManager] The patching thread threw an exception: System.IO.FileNotFoundException: K:\SteamLibrary\steamapps\common\Kerbal Space Program\GameData\KIS\Plugins\MiniAVC-V2.dll
  at System.Diagnostics.FileVersionInfo.GetVersionInfo (System.String fileName) [0x0000d] in <ef151b6abb5d474cb2c1cb8906a8b5a4>:0 
  at ModuleManager.ModListGenerator.GenerateModList (System.Collections.Generic.IEnumerable`1[T] modsAddedByAssemblies, ModuleManager.Progress.IPatchProgress progress, ModuleManager.Logging.IBasicLogger logger) [0x000a2] in <a0f9d7e5c0864d32839c501c53536c2a>:0 
  at ModuleManager.MMPatchLoader.Run () [0x000f3] in <a0f9d7e5c0864d32839c501c53536c2a>:0 
  at ModuleManager.MMPatchRunner+<>c__DisplayClass10_0.<Run>b__1 () [0x00001] in <a0f9d7e5c0864d32839c501c53536c2a>:0 
  at ModuleManager.Threading.BackgroundTask+<>c__DisplayClass0_0.<Start>g__RunAction|0 () [0x00002] in <a0f9d7e5c0864d32839c501c53536c2a>:0 

logs just in case if they are needed: https://www.dropbox.com/s/filmmxfr925jiso/AVC.zip?dl=0

Also the content of that directory:

5LpuFJ5.png

Cheers

 

Edited by pmborg
Link to comment
Share on other sites

  • 4 weeks later...

I absolutely love your Quick mods! I refuse to play the game without QuickStart and QuickExit. Baffling how such fantastic QoL features are not in the base game.

While using QuickMute today, I wondered, how about creating QuickMuteMusic, @linuxgurugamer? If I play with the base game soundtrack, I really can't stand that one song in the VAB anymore :D .

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...