Jump to content

[1.12.x] Malah's Quick Mods - ZEROMINIAVC in new thread


linuxgurugamer
 Share

Recommended Posts

OK... Here how I got the error:

  1. fresh KSP 1.10.1 install (cloned with CKAN from base Steam install)
  2. install QuickStart 2.2.0.10 with CKAN, which installs dependencies CTB, toolbar controller and Zero MiniVAC
  3. launch KSP, disable QS and start new sandbox career
  4. Go to VAB
  5. Place command pod (not time sensitive)
  6. delete part (drag and drop it on part menu, not time sensitive)
  7. wait
  8. 4 "frustum" errors appear in <= 30 sec. and then repeat every 30 sec.

Notes:

  1. Going to the VAB and doing nothing (skipping #5 and #6) does NOT produce errors.  
  2. Creating a new ship, instead of deleting the part at step 6, does NOT produce errors

Yeah, sorry I wasn't careful enough in my description before. It's very obscure. I only got a subsequent null ref that one time I posted above when I couldn't select a part. Otherwise it seemed to have no effect. 

Link to comment
Share on other sites

  • 1 month later...
  • 4 weeks later...
On 2/23/2021 at 4:46 PM, frankieorabona said:

I would like to know if the Quick Sas Mod is working.
I installed it but nothing happens. Maybe I'm doing something wrong?

I just tested Quick SAS and it seems to be working fine.

Configuration: Windows 10 x64 | KSP 1.10.0.2917 | Clean KSP install with just Quick SAS and it's dependencies. | Quick SAS 1.2.0.7

Please note, that Quick SAS has dependencies: ClickThroughBlocker, ToolbarController,  Zero MiniAVC (dependency of ToolbarController) so make sure you have those installed.

You can install the mod through CKAN to make sure those dependencies are met.

Also note that the Quick SAS toolbar button which is used for configuration of the keybindings is only available in the main Space Center scene.

Edited by ronillon
Link to comment
Share on other sites

On 2/24/2021 at 11:07 AM, frankieorabona said:

But now I am experiencing this problem. USB controller inputs cannot be set. It only accepts keyboard input. 

 

10 hours ago, ricina_frank said:

I have the same problem! 

USB controller inputs cannot be set...there is no one who can solve this problem?

Why not just map your controller inputs to the appropriate keyboard keys?

Link to comment
Share on other sites

3 hours ago, leatherneck6017 said:

Why not just map your controller inputs to the appropriate keyboard keys?

The reason could be wanting more keys, than just what he has available on his keyboad. Otherwise I agree, controller-keyboard chain mapping is the easiest way to go.

Although I hardly use half of my keyboard keys myself in KSP, I can imagine someone wanting more, it all depends on playstyle I guess.

For example I'm playing this other space game, where although you can manage with keyboard+mouse with clever modkeys, it would be much more convenient to have 2-3 full keyboards, couple hotas, mouse and touchscreen or two.

Link to comment
Share on other sites

51 minutes ago, frankieorabona said:

Because there are no keys available...
I use a custom controller... associating 10 keys to the controller means reprogramming my entire configuration...

Have you looked at AFBW?  It might be able to do what you want, not sure

Link to comment
Share on other sites

  • 3 weeks later...

Aight, so i have this game breaking glitch with MINIAVC where it pops up saying that EL launchpads is out of date, and only EL. Even though i have other outdated mods. and whenever KSP fully boots up i cant close the window, but i deleted ALL files related to MiniAVC and i even dowloaded zeroMiniAVC!

I can close it when KSP is loading

Screenshots and a log coming soon, i need KSP to fully boot up for a full log

Link to comment
Share on other sites

One small issue on Quick Goto: the LVES is not consistently going to the last vessel. It might go to the second prior one or some other random place. Once it jumped to an asteroid that I was tracking but had not visited. So that's a minor spoiler. Sorry I don't have logs now. There was no in game error. I can try to reproduce it with logs... but it might not show anything. 

I'm running 1.4.0.8 on KSP 1.11.2 now. Saw this on earlier 1.11 versions and maybe 1.10 - not sure.

Edited by Krazy1
versions
Link to comment
Share on other sites

5 hours ago, Souptime said:

Aight, so i have this game breaking glitch with MINIAVC where it pops up saying that EL launchpads is out of date, and only EL. Even though i have other outdated mods. and whenever KSP fully boots up i cant close the window, but i deleted ALL files related to MiniAVC and i even dowloaded zeroMiniAVC!

I can close it when KSP is loading

Screenshots and a log coming soon, i need KSP to fully boot up for a full log

Your log shows that you don't have any MiniAVC dlls there.

Why do you assume it's a MiniAVC error?

From the log file:

[LOG 04:23:28.951] [AddonLoader]: Instantiating addon 'CompatibilityChecker' from assembly 'Launchpad'

[LOG 04:23:29.619] [AddonLoader]: Instantiating addon 'CompatibilityChecker' from assembly 'Kopernicus'

[LOG 04:23:30.069] [AddonLoader]: Instantiating addon 'CompatibilityChecker' from assembly 'ProceduralParts'

[WRN 04:25:26.850] [CompatibilityChecker] Incompatible mods detected: Launchpad

Looks like you have an old version of LaunchPad installed (probably EPL).

31 minutes ago, Krazy1 said:

One small issue on Quick Goto: the LVES is not consistently going to the last vessel. It might go to the second prior one or some other random place. Once it jumped to an asteroid that I was tracking but had not visited. So that's a minor spoiler. Sorry I don't have logs now. There was no in game error. I can try to reproduce it with logs... but it might not show anything. 

I'm running 1.4.0.8 on KSP 1.11.2 now. Saw this on earlier 1.11 versions and maybe 1.10 - not sure.

I'm going to need more specifics than that, sorry.  This is pretty low on a list of issues right now

Link to comment
Share on other sites

20 hours ago, linuxgurugamer said:

Your log shows that you don't have any MiniAVC dlls there.

Why do you assume it's a MiniAVC error?

From the log file:

[LOG 04:23:28.951] [AddonLoader]: Instantiating addon 'CompatibilityChecker' from assembly 'Launchpad'

[LOG 04:23:29.619] [AddonLoader]: Instantiating addon 'CompatibilityChecker' from assembly 'Kopernicus'

[LOG 04:23:30.069] [AddonLoader]: Instantiating addon 'CompatibilityChecker' from assembly 'ProceduralParts'

[WRN 04:25:26.850] [CompatibilityChecker] Incompatible mods detected: Launchpad

Looks like you have an old version of LaunchPad installed (probably EPL).

I tried to get help from the EL thread but they just told me to go over here, i have literally NOTHING related to miniAVC but the thing still shows up for EL and EL only, not any other outdated mods

I even got zeroMiniAVC but that didnt do anything for the popup

21 hours ago, Souptime said:

I have a video of the thing here

Link to comment
Share on other sites

15 minutes ago, Souptime said:

I tried to get help from the EL thread but they just told me to go over here, i have literally NOTHING related to miniAVC but the thing still shows up for EL and EL only, not any other outdated mods

I even got zeroMiniAVC but that didnt do anything for the popup

I have a video of the thing here

Well, why didn't you post the entries from the log which I showed you in the EL thread?  They can only respond to what you post.

Your first mistake was incorrectly identifying MiniAVC as the culprit, so of course they would send you over here.   

Your second mistake was not posting the log files there, and your third mistake was posting a totally incomprehensible post without any information there.

I've done you the favor and posted the relevant information there for you.  I suggest that you apologize there for the misdirection, etc.

Link to comment
Share on other sites

  • 3 months later...

@linuxgurugamer Can you do me a favor and confirm a Unity crash with QuickStart and QuickExit on 1.12.1? I was hoping to keep using these older mods for QoL purposes. 

You are going to call me crazy but I've spent better part of the past three days tracking down which mod is causing an unspecified Unity crash, and these were the last two I removed to see if it was the cause. The crash is occurring in the VAB at random, whether clicking and moving parts/windows or just sitting there. I removed those two mods and have been sitting in the VAB randomly clicking away trying to force another Unity crash for the past hour and thus far all seems stable. So only variable I can find right now is QuickStart and QuickExit.

Last Unity crash logs located at the following link: https://drive.google.com/file/d/1eiI1xjqE_xjxgjgVHN3nVynpIBMDxwSF/view?usp=sharing

Link to comment
Share on other sites

30 minutes ago, thunder175 said:

@linuxgurugamer Can you do me a favor and confirm a Unity crash with QuickStart and QuickExit on 1.12.1? I was hoping to keep using these older mods for QoL purposes. 

You are going to call me crazy but I've spent better part of the past three days tracking down which mod is causing an unspecified Unity crash, and these were the last two I removed to see if it was the cause. The crash is occurring in the VAB at random, whether clicking and moving parts/windows or just sitting there. I removed those two mods and have been sitting in the VAB randomly clicking away trying to force another Unity crash for the past hour and thus far all seems stable. So only variable I can find right now is QuickStart and QuickExit.

Last Unity crash logs located at the following link: https://drive.google.com/file/d/1eiI1xjqE_xjxgjgVHN3nVynpIBMDxwSF/view?usp=sharing

It's not QuickStart, I'm using that myself.

How did you install everything?  

I'll test it out, both quickstart and quickexit

Link to comment
Share on other sites

1 hour ago, linuxgurugamer said:

It's not QuickStart, I'm using that myself.

How did you install everything?  

I'll test it out, both quickstart and quickexit

Ok, maybe something else going on with my installation then. Went to breakfast and just got back and still sitting just fine at the VAB, no Unity crash. Everything was installed via latest version of CKAN, including overriding the version check on both QuickStart and QuickExit. I'm going to start rolling some mods back in and see if I can force another Unity crash. I frankly can't believe its either QS or QE either but here I am... 

 

EDIT: Here is my current mod listed, all installed via CKAN save for SigmaDimensions which was pulled directly from GitHub

Spoiler

AlphaMensae's Modular Launch Pads (ModularLaunchPads 2.2.0.b)
AltimeterAutoHide (AltimeterAutoHide 1.4)
Antenna Helper (AntennaHelper 2:1.0.7.2)
AntennaSleep (AntennaSleep 1.1)
Aviation Lights (AviationLights 1:v4.1.2)
B9 Part Switch (B9PartSwitch v2.18.0)
BetterBurnTime (BetterBurnTime 1.10)
Chatterer (Chatterer 0.9.99)
Chatterer Extended (ChattererExtended 0.6.2)
ClickThrough Blocker (ClickThroughBlocker 1:0.1.10.16)
CommNet Relays (ContractConfigurator-CommNetRelays v2.1.0)
Community Category Kit (CommunityCategoryKit v5.2.0.0)
Community Parts Titles (CommunityPartsTitles 0.8.2)
Community Parts Titles Extras: Categories (CommunityPartsTitlesExtrasCategory 0.8.2)
Community Parts Titles Extras: CCK - No Duplicates (CommunityPartsTitlesExtrasNoCCKDup 0.8.2)
Community Resource Pack (CommunityResourcePack 1.4.2)
Community Tech Tree (CommunityTechTree 1:3.4.4)
Contract Configurator (ContractConfigurator 1.30.5)
Contract Pack: Bases and Stations Reborn (ContractConfigurator-KerbinSpaceStation 2:3.7.2.5)
Contract Pack: Exploration Plus (ContractConfigurator-ExplorationPlus 2.0.1)
Contract Pack: Field Research (ContractConfigurator-FieldResearch 1.2.2)
Craft Manager (CraftManager 1.2.0)
Crew R&R (CrewQueueTwo 1.1.11.1)
Crowd Sourced Science (CrowdSourcedScience v6.0)
Custom Asteroids (CustomAsteroids v1.9.0)
Custom Asteroids (inner stock system data) (CustomAsteroids-Pops-Stock-Inner v1.9.0)
Custom Asteroids (outer stock system data) (CustomAsteroids-Pops-Stock-Outer v1.9.0)
Custom Barn Kit (CustomBarnKit 1.1.21.0)
Distant Object Enhancement Continued (DistantObject v2.0.2.0)
Distant Object Enhancement Continued default config (DistantObject-default v2.0.2.0)
DMModuleScienceAnimateGeneric (DMagicScienceAnimate v0.23)
Earn Your Stripes! (EarnYourStripes 4.1)
Environmental Visual Enhancements - Stock Planet Config files (EnvironmentalVisualEnhancements-HR 2:EVE-1.2.2-1)
Environmental Visual Enhancements Redux (EnvironmentalVisualEnhancements 3:1.11.3.1)
Feline Utility Rovers (FelineUtilityRovers 1.3.3)
Ferram Aerospace Research Continued (FerramAerospaceResearchContinued 3:0.16.0.3)
Final Frontier (FinalFrontier 1.10.0-3485)
Flight Tracker (FlightTracker 3.0.0.2)
Harmony 2 (Harmony2 2.0.4.0)
Hide Empty Tech Tree Nodes (HideEmptyTechNodes 1.3.0)
HyperEdit (HyperEdit 1.5.8.0)
ID Flags and Decals (IDFlagsandDecals 1.4.1)
JX2Antenna (JX2Antenna 2.0.5)
Kerbal Changelog (KerbalChangelog v1.4.2)
Kerbal Construction Time (KerbalConstructionTime 1:1.4.11)
Kerbal Engineer Redux (KerbalEngineerRedux 1.1.9.0)
Kerbal Planetary Base Systems (KerbalPlanetaryBaseSystems v1.6.14)
Kerbal Renamer (KerbalRenamer v1.4.0)
Kerbalism (Kerbalism 3.14)
Kerbalism - Default Config (Kerbalism-Config-Default 3.14)
Kopernicus Planetary System Modifier (Kopernicus 2:release-1.12.1-55)
KSP Data Export (KSP-Data-Export 0.6)
KXAPI (KXAPI 1.2.0)
MagiCore (MagiCore 1.3.2.3)
MechJeb 2 - DEV RELEASE (MechJeb2-dev 2.12.0.0-1089)
ModularFlightIntegrator (ModularFlightIntegrator 1.2.10.0)
Module Manager (ModuleManager 4.1.4)
Near Future IVA Props (NearFutureProps 1:0.6.5)
Parallax (Parallax 1.3.0)
Parallax - Stock Planet Textures (Parallax-StockTextures 1.3.0)
PersistentRotation Upgraded (PersistentRotationUpgraded 1.9.1.4)
Phoenix Industries EVA Survival Suit (PhoenixIndustriesEVASuit 1)
PlanetShine (PlanetShine 0.2.6.3)
PlanetShine - Default configuration (PlanetShine-Config-Default 0.2.6.3)
Pood's Calm Nebula Skybox (PoodsCalmNebulaSkybox v1.3.0)
Project Manager (ProjectManager v2.4)
Rational HydroDynamics (RationalHydroDynamics 1.1)
Rational Resources (RationalResources 1.18.1)
RCS Build Aid (RCSBuildAid v1.0.6)
Real Plume (RealPlume 2:v13.3.2)
Real Plume - Stock Configs (RealPlume-StockConfigs v4.0.8)
RealChute Parachute Systems (RealChute v1.4.8.3)
Realistic Atmospheres (RealisticAtmospheres 1.3.2)
RemoteTech Redev Antennas (RemoteTechRedevAntennas 0.1.1)
SCANsat (SCANsat v20.4)
scatterer (Scatterer 3:v0.0772)
Scatterer Default Config (Scatterer-config 3:v0.0772)
Scatterer Sunflare (Scatterer-sunflare 3:v0.0772)
Simple Adjustable Fairings - Plugin (SimpleAdjustableFairings v1.12.0)
SmokeScreen - Extended FX Plugin (SmokeScreen 2.8.14.0)
SpaceTux Library (SpaceTuxLibrary 0.0.6)
Speed Unit Annex (SpeedUnitAnnex 1.4.0)
Surface Mounted Lights (surfacelights 1.19)
TextureReplacer (TextureReplacer v4.5.1)
Toolbar (Toolbar 1:1.8.0.5)
Toolbar Controller (ToolbarController 1:0.1.9.4)
Trajectories (Trajectories v2.4.1)
Waterfall Core (Waterfall 0.6.6)
Zero MiniAVC (ZeroMiniAVC 1:1.1.0.1)
 

EDIT2: Alright, just rolled QuickExit back in with my full mod list and couldn't replicate the Unity crash again. Only difference I was that I started a new sandbox test session. Very odd.

Edited by thunder175
Link to comment
Share on other sites

Just now, linuxgurugamer said:

could be a problem with the save.  I just  finished leaving the game running in the VAB for more than an hour, no problem

Alright, sorry for wasting your time then. Standard troubleshooting led to me to these two as possible causes, so I'll just chalk that up as 'false positives'.  I'll let you know if I have any other problems.

Link to comment
Share on other sites

20 hours ago, thunder175 said:

Alright, sorry for wasting your time then. Standard troubleshooting led to me to these two as possible causes, so I'll just chalk that up as 'false positives'.  I'll let you know if I have any other problems.

If you have procedural fairings installed, it's broken in 1.12 and causing CTDs

Link to comment
Share on other sites

  • 2 weeks later...

New release,  1.4.0.8

  • QuickStart 2.2.1
    • Added line written to log showing total time from startup to the MainMenu
    • Fixed edge case in editor causing a CTD:
  1. Create new ship and add root part
  2. Delete root part
  3. Wait for next save
  • Added AssemblyFileVersion

 

  • All of the following:
  • QuickBrake 1.4.0.8
  • QuickContracts 1.3.0.8
  • QuickCursorHider 1.1.0.7
  • QuickExit 2.2.0.8
  • QuickFineControl 1.1.0.7
  • QuickGoTo 1.4.0.9
  • QuickHide 3.3.0.9
  • QuickIVA 1.3.0.8
  • QuickMute 1.4.0.7
  • QuickRevert 3.2.0.8
  • QuickSAS 1.2.0.8
  • QuickSearch 3.3.0.11
    • Added AssemblyFileVersion
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...