Jump to content
  • 0

KSP -force-glcore crashes game


ISE
 Share

Question

So I can only use Textures unlimited correctly if I start my game via  "-force-glcore" startup command with it. But when I do so, it crashes my game. 

the original issue being this was solved by removing the -force-glcore obliviously, but I need the command to use Textures unlimited as I said. Anyway, before today I simply could would get a crash message with no specific reason for it other than the line and a crash dmp. But now I get another crash message instead of the other one. This one says as follows in the spoiler. 

 

Spoiler

Switching to resolution 1920x1080 failed, trying lower one
All resolution switches have failed
Screen: could not switch resolution (1920x1080 fs=0 hz=0)

 

removing the -force-glcore command from the launch option also fixes it, but as I said I need the launch option command for that mod. 

I have also set my native screen resolution in the graphics setting as well with no fix. 

I at one time found that it all was an issue with nvidia64.dll im pretty sure, but I could never figure out anything else. 

I tried updating and uninstalling/reinstalling graphics drivers, this did not fix the problem either. I of course did this when I saw the nvidia64.dll looking thing causing the issue. 

And I have also tried a clean install of KSP, along with updating windows and everything else that needed it and restarting the computer. 

Also am running KSP 1.4.2, but I saw this issue in 1.3.1 as well so. 

Help would be greatly appreciated, as I simply have run out of ideas of fixing this. 

My computer specs and a crash dmp will be under all this. 

 

[Display]
 

Spoiler

Operating System:    Windows 10 Home, 64-bit
DirectX version:    12.0 
GPU processor:        GeForce GTX 1080
Driver version:        391.35
Direct3D API version:    12
Direct3D feature level:    12_1
CUDA Cores:        2560 
Core clock:        1632 MHz 
Memory data rate:    10010 MHz
Memory interface:    256-bit 
Memory bandwidth:    320.32 GB/s
Total available graphics memory:    24537 MB
Dedicated video memory:    8192 MB GDDR5X
System video memory:    0 MB
Shared system memory:    16345 MB
Video BIOS version:    86.04.17.00.24
IRQ:            Not used
Bus:            PCI Express x16 Gen3


 

[Components]

Spoiler

nvui.dll        8.17.13.9135        NVIDIA User Experience Driver Component
nvxdplcy.dll        8.17.13.9135        NVIDIA User Experience Driver Component
nvxdbat.dll        8.17.13.9135        NVIDIA User Experience Driver Component
nvxdapix.dll        8.17.13.9135        NVIDIA User Experience Driver Component
NVCPL.DLL        8.17.13.9135        NVIDIA User Experience Driver Component
nvCplUIR.dll        8.1.940.0        NVIDIA Control Panel
nvCplUI.exe        8.1.940.0        NVIDIA Control Panel
nvWSSR.dll        23.21.13.9135        NVIDIA Workstation Server
nvWSS.dll        23.21.13.9135        NVIDIA Workstation Server
nvViTvSR.dll        23.21.13.9135        NVIDIA Video Server
nvViTvS.dll        23.21.13.9135        NVIDIA Video Server
nvLicensingS.dll        6.14.13.9135        NVIDIA Licensing Server
NVSTVIEW.EXE        7.17.13.9135        NVIDIA 3D Vision Photo Viewer
NVSTTEST.EXE        7.17.13.9135        NVIDIA 3D Vision Test Application
NVSTRES.DLL        7.17.13.9135        NVIDIA 3D Vision Module
nvDispSR.dll        23.21.13.9135        NVIDIA Display Server
NVMCTRAY.DLL        23.21.13.9135        NVIDIA Media Center Library
nvDispS.dll        23.21.13.9135        NVIDIA Display Server
PhysX        09.17.0524        NVIDIA PhysX
NVCUDA.DLL        23.21.13.9135        NVIDIA CUDA 9.1.84 driver
nvGameSR.dll        23.21.13.9135        NVIDIA 3D Settings Server
nvGameS.dll        23.21.13.9135        NVIDIA 3D Settings Server
 

Here is a crash dmp I could pull from a couple weeks ago where I was having this exact same issue regarding the opengl and crashing. So i figured it might be useful. As I can now not get a crash dmp with the screen resolution bug. (You can see this very frustrating predicament I am in now.) 
Crash File ZIP

  

 

Edited by ISE
Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 1
8 hours ago, Shadowmage said:

A bit of an oddball -- but have you tried moving KSP out of its default directory?  Having things inside the windows ProgramFiles directories can cause issues with privileges and user accounts.

Aside from that, openGL _should_ be working on your system; the hardware all supports it.

Agreed, I think I have fixed it, I got a program that uninstalls graphic drivers correctly and cleans the install once done. This seems to have fixed the issue. 

Along with fullscreen value :1 or 0 

And making the resolution smaller when it says to.  

Link to comment
Share on other sites

  • 0
2 hours ago, ISE said:

Switching to resolution 1920x1080 failed, trying lower one
All resolution switches have failed
Screen: could not switch resolution (1920x1080 fs=0 hz=0)

This particular error can be solved with some registry editing.  Find the KSP-resolution related entries at:

Computer\HKEY_CURRENT_USER\Software\Squad\Kerbal Space Program

And edit the values listed for the 'fullscreen'  ( Screenmanager Is Fullscreen mode_h3981298716 ) -- change the setting from 0 to 1, or 1 to 0.  (just reverse it from whatever it currently is)

(not sure that this will solve your openGL problems; but it should solve that particular inability to load the game)

Link to comment
Share on other sites

  • 0
9 hours ago, Shadowmage said:

This particular error can be solved with some registry editing.  Find the KSP-resolution related entries at:

Computer\HKEY_CURRENT_USER\Software\Squad\Kerbal Space Program

And edit the values listed for the 'fullscreen'  ( Screenmanager Is Fullscreen mode_h3981298716 ) -- change the setting from 0 to 1, or 1 to 0.  (just reverse it from whatever it currently is)

 (not sure that this will solve your openGL problems; but it should solve that particular inability to load the game)

yeah I had it set to :false have tried what you said before earlier and no change. Changed it to 0, and tried 1, no change. 

Link to comment
Share on other sites

  • 0

Okay I have solved the resolution issue, and have an accurate crash dump of the clean install with textures unlimited and module manager installed starting KSP in   -force-glcore  

Crash Folder ZIP

Hopefully someone can look at the crash dmp and shed some light on this issue. 

Edited by ISE
Link to comment
Share on other sites

  • 0

A bit of an oddball -- but have you tried moving KSP out of its default directory?  Having things inside the windows ProgramFiles directories can cause issues with privileges and user accounts.

Aside from that, openGL _should_ be working on your system; the hardware all supports it.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...