Trufiadok

Inverse kinematics robotcontroller for Canadarm1, Canadarm2 and ANY

Recommended Posts

1 hour ago, Trufiadok said:

Note that if you have saved the game, it will not work when it is reloaded. (WireSnare)

That's true for any IR stuff so i try to save it in positions where it is far from stuff it could break :D

Always store the arm in "0" position

The Wiresnare is only a temporary connection agreed

Edited by Jasseji

Share this post


Link to post
Share on other sites
56 minutes ago, Jasseji said:

That's true for any IR stuff so i try to save it in positions where it is far from stuff it could break :D

Always store the arm in "0" position

The Wiresnare is only a temporary connection agreed

Nah, the TRF Sphere is a bit too bulky, my solution is more flat, now if the LEE itself could have built-in RCS it would be different :D

Share this post


Link to post
Share on other sites
20 minutes ago, Jasseji said:

Nah, the TRF Sphere is a bit too bulky, my solution is more flat, now if the LEE itself could have built-in RCS it would be different :D

Can be scaled the size of TRF-Spheres in trf_spheres.cfg file.

Currently it is 1.0 /rescaleFactor = 1/ -> rescaleFactor = 0.75 in this case size is 75%.

Another option is to place an RCS module description in the LEE config file, but also need to edit the LEE model.

Share this post


Link to post
Share on other sites
23 minutes ago, Trufiadok said:

Can be scaled the size of TRF-Spheres in trf_spheres.cfg file.

Currently it is 1.0 /rescaleFactor = 1/ -> rescaleFactor = 0.75 in this case size is 75%.

Another option is to place an RCS module description in the LEE config file, but also need to edit the LEE model.

After realising the LEE has a probe core and a lot of El Charge, i changed the cfg:

// attachment rules: stack, srfAttach, allowStack, allowSrfAttach, allowCollision
attachRules = 1,1,1,1,0

i am considering to add an internal SAS too because it's a little unstable when redocking but it works good enough.

My modification looks now like this (RCS Tanks are from Tantares but one could add Monoprop to the Canadarm itself - in the Arms for instance):

b0KASzX.png

Share this post


Link to post
Share on other sites
1 hour ago, Jasseji said:

After realising the LEE has a probe core and a lot of El Charge, i changed the cfg:

// attachment rules: stack, srfAttach, allowStack, allowSrfAttach, allowCollision
attachRules = 1,1,1,1,0

i am considering to add an internal SAS too because it's a little unstable when redocking but it works good enough.

My modification looks now like this (RCS Tanks are from Tantares but one could add Monoprop to the Canadarm itself - in the Arms for instance):

b0KASzX.png

I move the robot arm with TRF-Spheres according to the video below.

 

 

Share this post


Link to post
Share on other sites
7 hours ago, Cheesecake said:

From which mod is this sphere? And do you have a working version of the dragon for 1.5.1?

The Sphere is from Github, the Dragon from LazTek - it's working more or less fine but some issues are there

Share this post


Link to post
Share on other sites
3 hours ago, Jasseji said:

The Sphere is from Github, the Dragon from LazTek - it's working more or less fine but some issues are there

Thanks

@Trufiadok I testet now with the latest github. Issue is still there. Here is a pic:

XTIS2fq.png

And here is the log:

https://www.file-upload.net/download-13403353/KSP.log.html

You can see: The white ball is farther at the dockingport of the little module I moved from one side to the other. After that I did the same thing to rearrange the root part (white ball) to the LEE: Mouseover Lee and left ALT. But nothing happened.

Also: is it possible to detect structures so that the Canadarm didn?t glitch through other parts?

Edited by Cheesecake

Share this post


Link to post
Share on other sites
1 hour ago, Cheesecake said:

Thanks

@Trufiadok I testet now with the latest github. Issue is still there. Here is a pic:

XTIS2fq.png

And here is the log:

https://www.file-upload.net/download-13403353/KSP.log.html

You can see: The white ball is farther at the dockingport of the little module I moved from one side to the other. After that I did the same thing to rearrange the root part (white ball) to the LEE: Mouseover Lee and left ALT. But nothing happened.

Also: is it possible to detect structures so that the Canadarm didn?t glitch through other parts?

did you try mouse over nothing + left Alt then click VEE ?

Share this post


Link to post
Share on other sites
6 hours ago, Cheesecake said:

Thanks

@Trufiadok I testet now with the latest github. Issue is still there. Here is a pic:

XTIS2fq.png

And here is the log:

https://www.file-upload.net/download-13403353/KSP.log.html

You can see: The white ball is farther at the dockingport of the little module I moved from one side to the other. After that I did the same thing to rearrange the root part (white ball) to the LEE: Mouseover Lee and left ALT. But nothing happened.

If you choose "LeftAlt" without selecting anything and pressing "VEE", LEE will be the endeffector,  again - This is the "Clear VirtualEndEffector" function.

Also: is it possible to detect structures so that the Canadarm didn?t glitch through other parts?

 

Edited by Trufiadok
Before you move the VEE (white ball) to another part you have to clear the previous one. If you have better ideas for controlling this function, let's talk about it.

Share this post


Link to post
Share on other sites
10 hours ago, Jasseji said:

The Sphere is from Github, the Dragon from LazTek - it's working more or less fine but some issues are there

"but some issues are there" - What do you think? I redefined the model in Unity. Maybe I can help.

Share this post


Link to post
Share on other sites
20 minutes ago, Trufiadok said:

"but some issues are there" - What do you think? I redefined the model in Unity. Maybe I can help.

I didnt load it in Unity but for me, any one of the Dragons from Laztek, first there is a huge lag when using them (only the Dragon Cargo and Dragon crew Pod) and second if i attach the Pods to Any rocket and launch them - they appear 1000m above the launchpad - this only happens for the capsules, i can use other parts of the mod without problems

I have switched to using Tundra version which is nice as well (Laztek is nicer tho :P)

Share this post


Link to post
Share on other sites
15 minutes ago, Jasseji said:

I didnt load it in Unity but for me, any one of the Dragons from Laztek, first there is a huge lag when using them (only the Dragon Cargo and Dragon crew Pod) and second if i attach the Pods to Any rocket and launch them - they appear 1000m above the launchpad - this only happens for the capsules, i can use other parts of the mod without problems

I have switched to using Tundra version which is nice as well (Laztek is nicer tho :P)

Try using World Stabilizer. I have found it useful for craft parts that load too high in the air. (there's an issue with some parts with colliders or transforms that are in weird places that make KSP think they need to be higher up when spawning in. MUCH MUCH higher....) Other players have not found it to help... So YMMV...

 

Share this post


Link to post
Share on other sites
1 hour ago, Jasseji said:

I didnt load it in Unity but for me, any one of the Dragons from Laztek, first there is a huge lag when using them (only the Dragon Cargo and Dragon crew Pod) and second if i attach the Pods to Any rocket and launch them - they appear 1000m above the launchpad - this only happens for the capsules, i can use other parts of the mod without problems

I have switched to using Tundra version which is nice as well (Laztek is nicer tho :P)

I use this part (TRF_DragonCargo), Is this part a problem too?

First, I loaded the model.mu file to Blender, saved it to model.fbx and then loaded it to Unity.

Edited by Trufiadok

Share this post


Link to post
Share on other sites
48 minutes ago, Trufiadok said:

I use this part (TRF_DragonCargo), Is this part a problem too?

First, I loaded the model.mu file to Blender, saved it to model.fbx and then loaded it to Unity.

Do you have the Crew Dragon too?

Edited by Cheesecake

Share this post


Link to post
Share on other sites
12 hours ago, Cheesecake said:

Do you have the Crew Dragon too?

 

13 hours ago, Trufiadok said:

I use this part (TRF_DragonCargo), Is this part a problem too?

First, I loaded the model.mu file to Blender, saved it to model.fbx and then loaded it to Unity.

Hm, this one is working fine actually - are you able to share the version with the PDGF port ?

The crew Dragon is spawning high above the launchpad 

Share this post


Link to post
Share on other sites

STOP: i just checked the original LazTek thread, unfortunately you are not allowed to redistribute anything due to it's license (unless you have explicit confirmation from Lazarus himself) :(

i have made some cfg fixes myself for the animations and i am doing a list of all parts which have collider issues but without the original Author's blessing nothing can be done sadly to share it

Share this post


Link to post
Share on other sites
2 hours ago, Jasseji said:

STOP: i just checked the original LazTek thread, unfortunately you are not allowed to redistribute anything due to it's license (unless you have explicit confirmation from Lazarus himself) :(

Thanks, I'll remove Laztekbase content.

i have made some cfg fixes myself for the animations and i am doing a list of all parts which have collider issues but without the original Author's blessing nothing can be done sadly to share it

 

16 hours ago, Cheesecake said:

Do you have the Crew Dragon too?

Jasseji indicated, unfortunately, we can not share the Laztek content.

Edited by Trufiadok

Share this post


Link to post
Share on other sites
On 11/26/2018 at 1:57 PM, Trufiadok said:

 

Jasseji indicated, unfortunately, we can not share the Laztek content.

As far as I know the LazTek was long gone so will be difficult to ask for something about its distribution

Could you share the pdgf door ?

Edited by Briso

Share this post


Link to post
Share on other sites
48 minutes ago, Briso said:

As far as I know the LazTek was long gone so will be difficult to ask for something about its distribution

Could you share the pdgf door ?

The license is still in effect unfortunately, no matter if he never comes back

Share this post


Link to post
Share on other sites
11 minutes ago, Jasseji said:

The license is still in effect unfortunately, no matter if he never comes back

And it's sad ( That is Trufiadok cannot provide pdgf door ?

Share this post


Link to post
Share on other sites
1 minute ago, Briso said:

And it's sad ( That is Trufiadok cannot provide pdgf door ?

it would be redistributing a part of Lazarus's work i think

Share this post


Link to post
Share on other sites
4 minutes ago, Jasseji said:

it would be redistributing a part of Lazarus's work i think

It's a pity many would have liked the addition of the door (personally, I was very pleased) I would have done (because of the license only for myself) but at the moment doing another project

Share this post


Link to post
Share on other sites

Did you use this mod ?

Personally, I'm annoyed by its magnetic End Effector. I like it better as it was in real life (as in fashion from Trufiadok). But since Canadarm 2 is not designed to be placed in a Space Shuttle, you will have to use Candarm 1 with a magnetic End Effector. I'd be in seventh heaven if Trufiadok remade it with the same Kanadarm 2.

Share this post


Link to post
Share on other sites
12 minutes ago, Briso said:

Did you use this mod ?

Personally, I'm annoyed by its magnetic End Effector. I like it better as it was in real life (as in fashion from Trufiadok). But since Canadarm 2 is not designed to be placed in a Space Shuttle, you will have to use Candarm 1 with a magnetic End Effector. I'd be in seventh heaven if Trufiadok remade it with the same Kanadarm 2.

ye, the shuttle RMS would be nice to have, also nice would be a working Gantry (to use as a Mobile Base System :P)

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.