LopoMetello

How to prevent collisions?

Recommended Posts

Hello,

Can someone tell me if there is a mod which can help to avoid collisions with asteroids?

I recently lost a space station and I suppose an asteroid to be the killer...

Thank you

Share this post


Link to post
Share on other sites

Belated welcome to the KSP forums @LopoMetello!!!!

I don't think it's very likely that an asteroid happened to kill your space station. Are you sure you haven't disabled the ship icons at the top of the tracking station screen (You have to put your mouse to the top of the screen. If there are any greyed out icons then click them to enable them) or you've terminated your station by mistake?

I reckon it'd be very rare for a randomly generated asteroid to have a path that would result directly in a space station collision. So I'm not sure a mod like that would be necessary.

Share this post


Link to post
Share on other sites

Thank you.

No, I didn't disabled the ship icon neither terminated it by mistake. She was on the tracking station screen with her icon as all was good but when I click on the ship's icon to move to her ... I found a lot of debris !!! No more station in that place.

 

Share this post


Link to post
Share on other sites
1 minute ago, LopoMetello said:

Thank you.

No, I didn't disabled the ship icon neither terminated it by mistake. She was on the tracking station screen with her icon as all was good but when I click on the ship's icon to move to her ... I found a lot of debris !!! No more station in that place.

 

Sounds like you've got a Kessler syndrome there. Have you ever watched the film Gravity? While most of the physics in that film is a bit unrealistic, that effect is shown there.

Share this post


Link to post
Share on other sites
9 minutes ago, RealKerbal3x said:

I reckon it'd be very rare for a randomly generated asteroid to have a path that would result directly in a space station collision. So I'm not sure a mod like that would be necessary.

Even if this happened, nothing would be destroyed, unless the asteroid or station were in focus.  No collisions happen between objects when neither are focused, which is why a Kessler syndrome in KSP is not going to happen.

 

I'd say what OP has is some kind of bug... an asteroid didn't just come by and take out the station when they weren't looking.

Share this post


Link to post
Share on other sites
4 minutes ago, Geonovast said:

Even if this happened, nothing would be destroyed, unless the asteroid or station were in focus.  No collisions happen between objects when neither are focused, which is why a Kessler syndrome in KSP is not going to happen.

 

I'd say what OP has is some kind of bug... an asteroid didn't just come by and take out the station when they weren't looking.

^ This.

10chars

Share this post


Link to post
Share on other sites

This sounds very like the autostrut bug -- if autostrut is on, especially to "heaviest part," you can get wild oscillations when physics eases in as you load from save or otherwise switch focus to a craft.  The long term solution is not to use autostrut to "heaviest part," instead setting it to "grandparent" (or sometimes, "parent" may be useful), if you really need it at all (you usually won't once a space station is assembled, unless you need to boost the station on occasion).

Share this post


Link to post
Share on other sites

It wasn't an asteroid. 

It was the kraken.   

Upon loading, sometimes stations go Boom.   They just do.    Reload the save and they're fine.  \_(0,0)_/

Share this post


Link to post
Share on other sites
2 hours ago, Gargamel said:

It was the kraken.   

Upon loading, sometimes stations go Boom.   They just do.    Reload the save and they're fine.  \_(0,0)_/

True, true. A good reason to quicksave often. "Dated Quicksave" (one of Magico's modlets) helps with that. KAC sometimes makes a "JumptoShip" save, but I've never figured out exactly when that's triggered. Use Alt-F9 to load a specific quicksave, and Alt-F5 (don't press Alt-F4 by mistake or KSP will quit!) to make a named quicksave

 

Share this post


Link to post
Share on other sites
4 hours ago, StrandedonEarth said:

. KAC sometimes makes a "JumptoShip" save, but I've never figured out exactly when that's triggered.

I believe, good sir, that a save is created whenever you click "Jump to Ship" when an alarm pop up appears....    But I've never had to use it yet.....

Share this post


Link to post
Share on other sites
15 hours ago, Gargamel said:

It wasn't an asteroid. 

It was the kraken.   

Upon loading, sometimes stations go Boom.   They just do.    Reload the save and they're fine.  \_(0,0)_/

The only time I've ever had that happen was when I left SAS on... which is a bad move on a station to start with. Other than that, maybe excessive clipped parts and/or certain mods might be the culprit. Otherwise, I say 'no' to that theory... because I have several huge stations that have been sitting in their orbits for years, seeing regular focus/activity, and none of them have exploded on me yet.

 

8 hours ago, Gargamel said:

I believe, good sir, that a save is created whenever you click "Jump to Ship" when an alarm pop up appears....    But I've never had to use it yet.....

This is true; KAC does just that.

Share this post


Link to post
Share on other sites

if it makes you feel better, I once lost a ship during launch when an Asteroid that I failed to re-direct collided with it.

Asteroid collisions are rare, but do happen.

Share this post


Link to post
Share on other sites
40 minutes ago, Xyphos said:

if it makes you feel better, I once lost a ship during launch when an Asteroid that I failed to re-direct collided with it.

Asteroid collisions are rare, but do happen.

Wow, really? Thats like a 1 in a million. 

Share this post


Link to post
Share on other sites
8 hours ago, Pthigrivi said:

Wow, really? Thats like a 1 in a million. 

I think that's way way low.... 

I've collided with a station I was trying to dock with during the circularization burn during a launch to rendezvous, but I was supposed to get close, just not that close.   I called it docking with emphasis. 

Share this post


Link to post
Share on other sites

This actually used to be more common than it is now. A lot of old-timers learned to habitually save before jumping to a new focus ship, which is why KAC started doing it by default. Physics used to be turned on much more abruptly than it is now.

Share this post


Link to post
Share on other sites
On 5/21/2018 at 11:24 AM, LordFerret said:

The only time I've ever had that happen was when I left SAS on... which is a bad move on a station to start with.

+1.  Basic mechanical engineering, when things start getting big enough to resonate, you better have a plan.

Share this post


Link to post
Share on other sites
11 hours ago, Corona688 said:

Basic mechanical engineering, when things start getting big enough to resonate, you better have a plan.

Second time in 48 hours I could reference the Tacoma Narrows here....

*started changing the Humpty dance lyrics to become the Kraken dance, but I gave up*

Share this post


Link to post
Share on other sites

I don’t know. I would say autostut, but maybe your game glitched.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now