Jebman82

[1.3.x/1.4.x/1.5.x/1.6.x/1.7.x] B9 Procedural Wings Fork - Go big or go home update (40% larger wings)

Recommended Posts

5 hours ago, Jebman82 said:

Yeah backport should work fine dude, will probably look at the shader issue on that version soon as well. Ping me if you get stuck!

If "J" works again for those edits, I'm fine :D

Just super rusty after not playing for...dunno...2 years now? :)

[edit]

Thx again, with PW working again I managed to pass the KL with my basic sounding rocket :)

[/edit]

Edited by TeiwazVIE

Share this post


Link to post
Share on other sites

@Jebman82

Since this appears to be the latest updated version of B9PW, would you like me to get the CKAN info updated to point to this?  I can also fix the two there so limit their upper KSP version

Share this post


Link to post
Share on other sites

Ok, I have a problem.

I've downloaded and installed 0.71 into a 1.5.1 test environment

Right-clicking on a wing part and selecting "Show wing data" gives the following Nullref:

NullReferenceException: Object reference not set to an instance of an object
  at WingProcedural.WingProcedural.InfoToggleEvent () [0x00000] in <filename unknown>:0 
  at BaseEvent.Invoke () [0x00000] in <filename unknown>:0 
  at UIPartActionButton.OnClick () [0x00000] in <filename unknown>:0 
  at UnityEngine.Events.InvokableCall.Invoke () [0x00000] in <filename unknown>:0 
  at UnityEngine.Events.UnityEvent.Invoke () [0x00000] in <filename unknown>:0 
  at UnityEngine.UI.Button.Press () [0x00000] in <filename unknown>:0 
  at UnityEngine.UI.Button.OnPointerClick (UnityEngine.EventSystems.PointerEventData eventData) [0x00000] in <filename unknown>:0 
  at UnityEngine.EventSystems.ExecuteEvents.Execute (IPointerClickHandler handler, UnityEngine.EventSystems.BaseEventData eventData) [0x00000] in <filename unknown>:0 
  at UnityEngine.EventSystems.ExecuteEvents.Execute[IPointerClickHandler] (UnityEngine.GameObject target, UnityEngine.EventSystems.BaseEventData eventData, UnityEngine.EventSystems.EventFunction`1 functor) [0x00000] in <filename unknown>:0 
UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
UnityEngine.DebugLogHandler:LogException(Exception, Object)
UnityEngine.Logger:LogException(Exception, Object)
UnityEngine.Debug:LogException(Exception)
UnityEngine.EventSystems.ExecuteEvents:Execute(GameObject, BaseEventData, EventFunction`1)
UnityEngine.EventSystems.StandaloneInputModule:ProcessMousePress(MouseButtonEventData)
UnityEngine.EventSystems.StandaloneInputModule:ProcessMouseEvent(Int32)
UnityEngine.EventSystems.StandaloneInputModule:ProcessMouseEvent()
UnityEngine.EventSystems.StandaloneInputModule:Process()
UnityEngine.EventSystems.EventSystem:Update()

 

Share this post


Link to post
Share on other sites
13 hours ago, linuxgurugamer said:

@Jebman82

Since this appears to be the latest updated version of B9PW, would you like me to get the CKAN info updated to point to this?  I can also fix the two there so limit their upper KSP version

That would be super appreciated bro, currently changing jobs and moving house, so rl is taking up most my time atm. I have a 1.6 version ready, just been too lazy to commit it (at least I am honest :) )

In regards to the nullreferror, I know where the functions are for the flight data, so will switch on debugging and check everything over. Were you using stock aero or FAR?

Share this post


Link to post
Share on other sites
41 minutes ago, Jebman82 said:

That would be super appreciated bro, currently changing jobs and moving house, so rl is taking up most my time atm. I have a 1.6 version ready, just been too lazy to commit it (at least I am honest :) )

In regards to the nullreferror, I know where the functions are for the flight data, so will switch on debugging and check everything over. Were you using stock aero or FAR?

Stock.

I’ll get ckan updated this evening

Share this post


Link to post
Share on other sites
4 hours ago, linuxgurugamer said:

CKAN is now updated

Legend, thanks for that bro, will pop a credit on the OP for you! 

Share this post


Link to post
Share on other sites

is this version of procedural wings not compatible with tweakscale?
in 1.5.1 i used the "B9 Procedural Wings Modified" by Me1_Base  and i was able to increase the length of the wing to 100m++, but now with this version it only maxed at 20.
i'm trying to make the Arsenal Bird, i moved on from 1.5.1 because of performance issues, then i decided to try it in 1.6.1.
 

 

Edited by faryzal2020
correction for the source

Share this post


Link to post
Share on other sites

Hi and nice day to everyone, has anyone tried using PWings on 1.6.1? The latest "1.6.1 compatible" version from CKAN just doesn't react to J button. Maybe some different mods for making procedural wings? Need them badly for my new SSTO. Maybe i am doing something wrong?

Share this post


Link to post
Share on other sites
48 minutes ago, Proximity4 said:

Hi and nice day to everyone, has anyone tried using PWings on 1.6.1? The latest "1.6.1 compatible" version from CKAN just doesn't react to J button. Maybe some different mods for making procedural wings? Need them badly for my new SSTO. Maybe i am doing something wrong?

That’s weird, all seems ok in 1.6.1. I will take a look, but in the mean time have you tried installing without CKAN and no other mods to check it’s a not a conflict?

Share this post


Link to post
Share on other sites

There was numerous reports about non working "J" key, not only for this fork, but for other (older) B9PW forks/releases. Also from KSP 1.3.x up to KSP 1.6.x veresions too. Might be even earlier.
Some people were said that they solved issue by re-install, but noone reported about exact conflicting mod or something else.

For others it just works, so it is hard to tell.

Share this post


Link to post
Share on other sites

Yeah so for my install I have a crap load of mods. When I do a new release I test it against a fresh install with no mods and then my modded install. One thing I haven’t tested is the CKAN install. I will get around to sorting it out tho and any logs or lists of the mods you run will help. I also might include the debug version moving forward as I’ve added extra console logs to make it easier to to track down issues. Hang in there peeps as I guess you all love making massive SSTO’s like me :)

Share this post


Link to post
Share on other sites
6 hours ago, Jebman82 said:

That’s weird, all seems ok in 1.6.1. I will take a look, but in the mean time have you tried installing without CKAN and no other mods to check it’s a not a conflict?

Thanks, i'll try. Module Manager and CKAN see no errors/warnings, but i'll do it and reply whether it works directly from stock or not.

Share this post


Link to post
Share on other sites
6 hours ago, Jebman82 said:

That’s weird, all seems ok in 1.6.1. I will take a look, but in the mean time have you tried installing without CKAN and no other mods to check it’s a not a conflict?

No, it doesn't work from a clear new install, B9PW is the only installed mod. Maybe i should run a 32-bit not 64-bit version? Can it cause instability?

Share this post


Link to post
Share on other sites
34 minutes ago, Proximity4 said:

No, it doesn't work from a clear new install, B9PW is the only installed mod. Maybe i should run a 32-bit not 64-bit version? Can it cause instability?

Should be fine on both, let me check and will get back to you!

Share this post


Link to post
Share on other sites
46 minutes ago, Jebman82 said:

Should be fine on both, let me check and will get back to you!

Thank you very much for supporting me, another important detail: i do not have the B9 button. Neither in bottom right nor anywhere else. The icon in B9 folder is present, but isn't shown in the game.

Share this post


Link to post
Share on other sites
51 minutes ago, Proximity4 said:

Thank you very much for supporting me, another important detail: i do not have the B9 button. Neither in bottom right nor anywhere else. The icon in B9 folder is present, but isn't shown in the game.

Seems to me that something was not loaded properly when MM do it's thing when you start game. You should upload log file on some cloud (dropbox, pastebin, one drive..) and post link for it here. Screenshot of gamedata folder might help as well. Most probably you missing something silly, but you need to help devs to be able to help you.

Share this post


Link to post
Share on other sites
55 minutes ago, kcs123 said:

Seems to me that something was not loaded properly when MM do it's thing when you start game. You should upload log file on some cloud (dropbox, pastebin, one drive..) and post link for it here. Screenshot of gamedata folder might help as well. Most probably you missing something silly, but you need to help devs to be able to help you.

Yes, of course.

Root folder

GameData

Me clicking crazy on J button

KSP log file

 

 

Share this post


Link to post
Share on other sites

Very first part of log reveals that PW plugin is not loaded properly:

Spoiler

[ERR 00:00:37.310] AssemblyLoader: Exception loading 'B9_Aerospace_WingStuff': System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0 
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0 

Additional information about this exception:

 System.TypeLoadException: Could not load type 'WingProcedural.StaticWingGlobals' from assembly 'B9_Aerospace_WingStuff, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'WingProcedural.WingProcedural' from assembly 'B9_Aerospace_WingStuff, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'WingProcedural.WingTankConfiguration' from assembly 'B9_Aerospace_WingStuff, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.

 System.IO.FileNotFoundException: Could not load file or assembly 'KSPUtil, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
File name: 'KSPUtil, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'

 System.TypeLoadException: Could not load type '<>c' from assembly 'B9_Aerospace_WingStuff, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type '<SetupReorderedForFlight>d__248' from assembly 'B9_Aerospace_WingStuff, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type '<updateAeroDelayed>d__296' from assembly 'B9_Aerospace_WingStuff, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type '<>c__DisplayClass4_0' from assembly 'B9_Aerospace_WingStuff, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.

Though, I don't know why. But, it is starting point, where to look to solve this.

Can you check out that you have PW dll plugin inside B9 folder ? It might happen that your antivirus software deleted it or something similar.

Edited by kcs123

Share this post


Link to post
Share on other sites

Also if the DLL is present, right click > properties and check Windows hasn’t blocked it!

Share this post


Link to post
Share on other sites
14 minutes ago, Jebman82 said:

Also if the DLL is present, right click > properties and check Windows hasn’t blocked it!

Nothing is blocked by Windows, i disabled the Defender temporary, checked all local files via Steam and re-installed B9PW via CKAN, booted to KSP and still not working, the new log:
log
But i think, i have the same problem. Maybe i should start KSP.exe via Steam, not from folder?

Edited by Proximity4

Share this post


Link to post
Share on other sites

Can you try grabbing the one from my github repo instead (just copy the files from the zip into Gamedata). I’m just gonna commit a 1.6.1 version now...

Edited by Jebman82
message duplicated 3 times what is that about

Share this post


Link to post
Share on other sites

New version here for KSP 1.6.1, recompile and bigger wings. Don't say I don't love you all

https://github.com/Rafterman82/B9-PWings-Fork/releases/tag/0.80

33 minutes ago, Proximity4 said:

Nothing is blocked by Windows, i disabled the Defender temporary, checked all local files via Steam and re-installed B9PW via CKAN, booted to KSP and still not working, the new log:
log
But i think, i have the same problem. Maybe i should start KSP.exe via Steam, not from folder?

Shouldn't matter where you launch it from, but just try a manual install of the mod (as it might be an issue with CKAN)

Edited by Jebman82
Added URL

Share this post


Link to post
Share on other sites
1 hour ago, Jebman82 said:

New version here for KSP 1.6.1, recompile and bigger wings. Don't say I don't love you all

OH MY GOD ARE U FRIGGIN SERIOUS IT WORKS FINALLY!!!! You are the best!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.