Jump to content

[1.6.1 | 1.5.1 | 1.4.5 | 1.3.1] The World Beyond - 100 new celestial bodies [v1.1.1 - 2018-10-31]


Recommended Posts

1 hour ago, Iso-Polaris said:

It is indeed.

However without dx11 my 12Gig can't handle the full pack

With OnDemand loading 12GB should be enough, unless you also happen to run other big planet/part mods.

You can always remove a system that you don't want though.

 

Also, regarding changing the homeworld: I thought about doing that, but considering the potential glitches that might come with replacing the homeworld with a planet that's orbiting a star that is orbiting another star (that might be orbiting another star if I keep Sun/Kerbol as the center of the universe), it is unlikely to happen.

Link to post
Share on other sites
2 minutes ago, TheProtagonists said:

Also, regarding changing the homeworld: I thought about doing that, but considering the potential glitches that might come with replacing the homeworld with a planet that's orbiting a star that is orbiting another star (that might be orbiting another star if I keep Sun/Kerbol as the center of the universe), it is unlikely to happen.

I could not be like that.

Is it possible to make it like RSS, by deleting the stock planets completely and replace it with Dawn or something

Link to post
Share on other sites

Okay so just a couple of clarification questions, this mod does not have Distant Object Enhancement support right? I can still use DOE at the same time though right? I just won't see the planets from this pack far away?

Also how close are these systems compared to Valentine's distance from Kerbol in Extrasolar.

I also use AVP, so I was wondering if this is compatible with it.

And lastly, how do I enable OnDemand loading; I read about it in this thread and I have no idea how to enable it.

 

Update: Installed the full .zip, and all my planets are black :(

Edited by EliteMaster512
Link to post
Share on other sites
On 2/3/2019 at 10:02 AM, Diliver said:

I've installed mod, but when the download reaches the end, everything hangs and crashes.

Here are screenshots of folders https://imgur.com/a/CYFKzLI. Need help!

Sorry about the late reply.

So the game will hang after the loading is complete, and if it's your first time loading the mod, it could hang for 5-15 minutes to generate the caches. Wait and ignore any "not responding" warning.

On 2/4/2019 at 10:00 AM, EliteMaster512 said:

Okay so just a couple of clarification questions, this mod does not have Distant Object Enhancement support right? I can still use DOE at the same time though right? I just won't see the planets from this pack far away?

Also how close are these systems compared to Valentine's distance from Kerbol in Extrasolar.

I also use AVP, so I was wondering if this is compatible with it.

And lastly, how do I enable OnDemand loading; I read about it in this thread and I have no idea how to enable it.

 

Update: Installed the full .zip, and all my planets are black :(

1. I don't see why you can't use DOE with this together. Tell me if something weird happens.

2. Dawn is about 4 times further than Valentine from the Sun.

3. AVP works perfectly with TWB visuals. Make sure you have BOTH SCATTERER AND EVE if you use TWB full.

4. OnDemand is automatic, no action is needed.

Edited by TheProtagonists
Link to post
Share on other sites

For some reason, some of the planet (Nyarlathotep for example) is completely black, while most of the atmospheric planets do not have this issue.

216.png

217.png

I have Scatterer and AVP correctly installed. running x64 ksp 1.6.1 on dx9

It's EVE problem, the problem does not persist after I removed EVE, so how is it possible

 

I found out the reason:

The planets with the aurora path: TheWorldBeyond/EVE_Textures/aurora1 have this issue.

Change it to TheWorldBeyond/EVE_Textures/aurora2 will resove it.

Edited by Iso-Polaris
Link to post
Share on other sites
On 5/31/2018 at 2:52 AM, billybob579 said:

I believe I've narrowed the pitch-black planet bug down to the EVE component of the TWB_Visuals packs. The planets are visible when EVE is uninstalled but scatterer and TWB_Visuals are installed, and also when EVE and scatterer are installed but the TWB_Visuals are not. This makes me think the problem is specifically within the EVE component.

I'm still not sure why only a handful of planets throughout all the different planet-packs are effected, but I've made certain the install was done correctly (including a full reinstall of the base game), used only the mods listed in your install guide, and used the correct versions of each. The planets effected are Gersemi, Yggdrasil, Kaze, Adeon, Matterhorn, Mirai, Lyria, and Everest.

I can also confirm this issue as in now, have you figured out a solution?

Edited by Iso-Polaris
Link to post
Share on other sites
On 2/6/2019 at 2:48 PM, Iso-Polaris said:

I can also confirm this issue as in now, have you figured out a solution? 

Very sorry about the late reply.

I am not certain, but I am strongly suspecting it is a memory problem since you said that you have 12GB of RAM.

If you installed the entirety of TWB and many other mods (as seen in the screenshot), it is possible that there are just not enough memory for the clouds.

 

You can try reinstalling EVE, but I would suggest you to start with a clean install with just TWB, EVE and scatterer and see if the planets still turn black.

Link to post
Share on other sites
On 2/11/2019 at 11:10 AM, TheProtagonists said:

You can try reinstalling EVE, but I would suggest you to start with a clean install with just TWB, EVE and scatterer and see if the planets still turn black.

I found out the reason:

The planets with the aurora path: TheWorldBeyond/EVE_Textures/aurora1 have this issue.

Change it to TheWorldBeyond/EVE_Textures/aurora2 will resove it.

 

BTW

I only play on career mode, so it really took a long time to explore all of your planets in time. Since there's very few ways to get to dawn cluster within a reasonable time unless on the very late stage of a game even with KSPI installed.

So I hope you can reconsider the proposition of making a small OPTIONAL patch to move KSC on one of your beautiful planet such as Nyarlathotep, all at least explain how it can be done.

The stock system doesn't have to be gone like in GPP or GPO. it doesn't have to be perfectly balanced or bug-free. Just an attempt of doing so would create some completely different yet exciting career experience, such as:

-Start on Nyarlathotep, use jet engine to gather tons of science (becuase of the presence of “exotic material” of course), aquire enough to unlock electric and nuclear propulsion in order to explore other stars in the cluster and kerbol system.

-Start on Paradise, build bases and tourist attractions (better with some contract mods) because of course that will happen, making paradisian a truely multiplanetary species.

-Start on Border, we are ancient remnants who resided on this abandoned rock hundreds of years ago, we fianlly have the resources to build our first rocket home. science value is scarce and stars are afar, where would be our homeland?

_ ...

With later balance adjustment, you can even come up with excellent stories similar to @Gameslinx 's Kerbal chronical.

Tis way better than a simple extrasolar planet pack full of amazing places people may or may not able to reach and mostly being admired in the tracking station along.

I've been dreaming about these quite a lot.

Edited by Iso-Polaris
Link to post
Share on other sites
3 hours ago, Iso-Polaris said:

I found out the reason:

The planets with the aurora path: TheWorldBeyond/EVE_Textures/aurora1 have this issue.

Change it to TheWorldBeyond/EVE_Textures/aurora2 will resove it.

 

BTW

I only play on career mode, so it really took a long time to explore all of your planets in time. Since there's very few ways to get to dawn cluster within a reasonable time unless on the very late stage of a game even with KSPI installed.

So I hope you can reconsider the proposition of making a small OPTIONAL patch to move KSC on one of your beautiful planet such as Nyarlathotep, all at least explain how it can be done.

The stock system doesn't have to be gone like in GPP or GPO. it doesn't have to be perfectly balanced or bug-free. Just an attempt of doing so would create some completely different yet exciting career experience, such as:

-Start on Nyarlathotep, use jet engine to gather tons of science (becuase of the presence of “exotic material” of course), aquire enough to unlock electric and nuclear propulsion in order to explore other stars in the cluster and kerbol system.

-Start on Paradise, build bases and tourist attractions (better with some contract mods) because of course that will happen, making paradisian a truely multiplanetary species.

-Start on Border, we are ancient remnants who resided on this abandoned rock hundreds of years ago, we fianlly have the resources to build our first rocket home. science value is scarce and stars are afar, where would be our homeland?

_ ...

With later balance adjustment, you can even come up with excellent stories similar to @Gameslinx 's Kerbal chronical.

Tis way better than a simple extrasolar planet pack full of amazing places people may or may not able to reach and sometimes can only admire it in the tracking station.

I've been dreaming about these quite a lot.

I see.

I'm not satisfied with how the first two aurora textures look right now so I will remake them completely, and hopefully that will solve the issue.

 

Thank you so much for such an insightful comment and advice.

I will definitely see if I can add some sort of optional patches for starting on other worlds, although that most likely mean the removal of most Kerbin easter eggs/features and possibly unbalaned science values

Sadly I can't guarantee when that will drop. A lot other projects/things are going on for me and working on TWB has to take a backseat for me at this time, but if nothing else, I will at the very least continue to maintain everything.

 

I actually have a very grand backstory for why the TWB systems are like this that ties in to my vision of the entire Kerbal universe, but I don't have plans to implement it at this moment, besides hinting them through descriptions...

Link to post
Share on other sites
  • 2 weeks later...

Anyone figure 24GB of RAM is adequate to run GPP, GEP, TWB, all Nertea's Mods as well as ~10 other Larger Part packs, ~10 smaller ones, and ~50 small utility mods / tools? (All graphics maxed out as well) Just upgraded from 16 GB as I could play the game with intermittent crashes every half hour or so.. (Notably because when my game first loaded, KSP would go up to about 12GB of usage which would max out my system RAM (OS + other stuff uses up the other 4) and Windows would end up throwing half of KSP into a page file lol)

Worst case if it's not possible I'll just go get more RAM, but figured I'd ask for opinions first.

Edit: Also I'll note with the 16 I was running all of the above except for TWB.

TL;DR How much RAM does TWB use by itself?

On a side note, kinda unrelated .. Just tried playing the game with my now 24GB of RAM and it still crashes -_- so it's clearly not a RAM problem I've been having.. Went ahead and tried an install with just a basic GPP install on it and it's still crashing.. Time to try a stock install. (Also only crashes on scene change .. Usually to / from the VAB. Odd.)

EDIT: Guess when I said "basic GPP install" I should have said "including the optional mods for it as well" ... Took 4 hours to narrow down the culprit to my CTD's... Sigma Descriptions. lol that CTD is what made me buy more RAM to begin with, on the up side I now have more RAM.

EDIT: Well I decided to just give it a try.. The game did load, but not before I watched the RAM (for the KSP program alone) go up to 20GB and then proceed to page abput 5GB and then load about 2 more GB lol.

By the time it made it to the main menu, the RAM was running at a steady 18GB.. Something tells me I'm going to be ordering more RAM this week.

Edited by CoriW
Link to post
Share on other sites
On 3/1/2019 at 2:47 PM, CoriW said:

Anyone figure 24GB of RAM is adequate to run GPP, GEP, TWB, all Nertea's Mods as well as ~10 other Larger Part packs, ~10 smaller ones, and ~50 small utility mods / tools? (All graphics maxed out as well) Just upgraded from 16 GB as I could play the game with intermittent crashes every half hour or so.. (Notably because when my game first loaded, KSP would go up to about 12GB of usage which would max out my system RAM (OS + other stuff uses up the other 4) and Windows would end up throwing half of KSP into a page file lol)

Worst case if it's not possible I'll just go get more RAM, but figured I'd ask for opinions first.

Edit: Also I'll note with the 16 I was running all of the above except for TWB.

TL;DR How much RAM does TWB use by itself?

On a side note, kinda unrelated .. Just tried playing the game with my now 24GB of RAM and it still crashes -_- so it's clearly not a RAM problem I've been having.. Went ahead and tried an install with just a basic GPP install on it and it's still crashing.. Time to try a stock install. (Also only crashes on scene change .. Usually to / from the VAB. Odd.)

EDIT: Guess when I said "basic GPP install" I should have said "including the optional mods for it as well" ... Took 4 hours to narrow down the culprit to my CTD's... Sigma Descriptions. lol that CTD is what made me buy more RAM to begin with, on the up side I now have more RAM.

It's really hard to say the exact amount of RAM a mod uses, since the situation for everyone is different.

For me, I was able to load a install with TWB, GPP, GEP, OPM, OWR, Extrasolar and all their visuals, plus four dozen part mods and even more smaller mods, adding to a ~150 mod total with just 16GB (although it takes 45 minutes to load up).

If you are still crashing, it's most likely not a RAM problem and you should start by a stock install and add mods one by one.

Link to post
Share on other sites
6 minutes ago, TheProtagonists said:

It's really hard to say the exact amount of RAM a mod uses, since the situation for everyone is different.

For me, I was able to load a install with TWB, GPP, GEP, OPM, OWR, Extrasolar and all their visuals, plus four dozen part mods and even more smaller mods, adding to a ~150 mod total with just 16GB (although it takes 45 minutes to load up).

If you are still crashing, it's most likely not a RAM problem and you should start by a stock install and add mods one by one.

Yeah, if you read one of my edits I discovered that it was Sigma Descriptions causing the CTD's.

And whoa that's a lot of mods! If you can do all that with 16GB without any crashing resulting from RAM I think I can certainly do less than that with 24GB. Thanks.

EDIT: Heh, just remembering the good old days of modding 32-bit KSP ... Trying to stay within the 4GB RAM limitations, fun times.

Edited by CoriW
Link to post
Share on other sites
  • 4 weeks later...

@TheProtagonistsAs a bit of a heads up, the latest Scatterer version - while fixing a lot of bugs with itself - has broken pretty much every planet pack that has planets that use scatterer effects (atmosphere, oceans, etc.) I've heard from Gameslinx and Niako that the fix does not take long to make, though their mods do not add nearly as many celestial bodies.

I might look in to what one needs to do to fix the problem and attempt to start to work on a patch myself to save you a bit of time.

Link to post
Share on other sites
On 3/30/2019 at 2:00 PM, Raptor22 said:

@TheProtagonistsAs a bit of a heads up, the latest Scatterer version - while fixing a lot of bugs with itself - has broken pretty much every planet pack that has planets that use scatterer effects (atmosphere, oceans, etc.) I've heard from Gameslinx and Niako that the fix does not take long to make, though their mods do not add nearly as many celestial bodies.

I might look in to what one needs to do to fix the problem and attempt to start to work on a patch myself to save you a bit of time.

I am aware of the change and the effect it has on TWB. Regrettably due to my interests and my other projects I don't see myself updating the mod anytime soon.

I will probably get back to the development during the summer. I apologize for the lack of anything happening during this time.

Link to post
Share on other sites
3 minutes ago, TheProtagonists said:

I am aware of the change and the effect it has on TWB. Regrettably due to my interests and my other projects I don't see myself updating the mod anytime soon.

I will probably get back to the development during the summer. I apologize for the lack of anything happening during this time.

Well, dang... I guess I'll have to take a crack at making a community patch until then.

Link to post
Share on other sites
  • 2 weeks later...

For some reason, none of the added planets/stars appear when i load up KSP, despite the fact that I followed all the instructions.

The game still works, but it's just the stock system and nothing else. Any ideas on what's wrong?

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...