linuxgurugamer

[1.2.*, 1.3.*, 1.4.*, 1.5.*] RLA Reborn

Recommended Posts

3 hours ago, TheNowMovement1 said:

Already got em! :D I'm super into informational mods.  They seem to add more value to the game for me than more items... though you do need something new to keep you going! lol

For improved editing, I'd also recommend the WASDEditorCamera, and EditorExtensionsRedux

Share this post


Link to post
Share on other sites
12 minutes ago, ObsessedWithKSP said:

Crikey, is there a mod you haven't adopted?! Cheers for doing this mate, much appreciated!

Yes, there are lot of mods I haven't adopted

Share this post


Link to post
Share on other sites

I'm looking for a 1.3 version, but spacedock doesn't have it, and github doesn't display versions.

Edited by TheronEpic
grammar

Share this post


Link to post
Share on other sites
17 hours ago, TheronEpic said:

I'm looking for a 1.3 version, but spacedock doesn't have it, and github doesn't display versions.

The current version supports ALL the KSP versions from 1.2 to 1.5.1. There isn't a separate mod version for each game version.

So just get the newest. RLA Reborn 0.15.1.4.

Share this post


Link to post
Share on other sites
5 hours ago, emirkustirika said:

ı waıntıng 1.6 support plsss :) or ckan on 1.6 rla reborn version plsss :)

For now, you can tell CKAN to allow 1.5 mods as compatible.  I've pushed an update to the .version file which may fix the issue, if it does, then it will be fixed by this evening, otherwise I'll have to push out a complete release for this

Share this post


Link to post
Share on other sites

 

 

On 1/3/2019 at 1:47 PM, emirkustirika said:

ı waıntıng 1.6 support plsss :) or ckan on 1.6 rla reborn version plsss :)

 

On 1/3/2019 at 7:35 PM, linuxgurugamer said:

For now, you can tell CKAN to allow 1.5 mods as compatible.  I've pushed an update to the .version file which may fix the issue, if it does, then it will be fixed by this evening, otherwise I'll have to push out a complete release for this

Owww thanks this is great tips ;)

Share this post


Link to post
Share on other sites

FYI, CKAN now lists RLA as 1.6.0 compatible

Share this post


Link to post
Share on other sites

New release, 0.15.1.6

  • Update small_decoupler_stack.cfg
  • Hide 0.6m Decoupler
Edited by linuxgurugamer

Share this post


Link to post
Share on other sites
4 hours ago, linuxgurugamer said:

New release, 0.15.1.6

  • Update small_decoupler_stack.cfg
  • Hide 0.6m Decoupler

Just started my 1.5.1 game after installing this update. When I loaded the save, I got a notice that many of my crafts were missing "small decoupler stack" (and would be deleted? cant remember for sure) Aborted loading save, Rolled back to 0.15.1.5 and everything was ok.

Maybe a typo in the updated cfg?

Share this post


Link to post
Share on other sites
6 hours ago, BlackHat said:

Just started my 1.5.1 game after installing this update. When I loaded the save, I got a notice that many of my crafts were missing "small decoupler stack" (and would be deleted? cant remember for sure) Aborted loading save, Rolled back to 0.15.1.5 and everything was ok.

Maybe a typo in the updated cfg?

Would have helped to provide a log file

Share this post


Link to post
Share on other sites

New release, 0.15.1.7

  • Fixed typo in category for small decoupler, "none" needed to be in lower case
  • Added indentations to a number of parts
     

Share this post


Link to post
Share on other sites

New release, 0.15.1.8

Added small patch for ReStock, thanks github user  @pietralbi

Share this post


Link to post
Share on other sites
On 2/27/2019 at 6:32 AM, linuxgurugamer said:

New release, 0.15.1.7

  • Fixed typo in category for small decoupler, "none" needed to be in lower case
  • Added indentations to a number of parts
     

Hello linuxgurugamer.

I believe the first point causes said small decoupler ("RLA_small_decoupler_stack" AKA "TR-1V") to be absent of any categories in the editor... Perhaps changing to the "Coupling" category instead?

I am using the Filter Extension mod. I can still find it under the manufacturer tab (RLA) but it took me a while to figure it out.

Thanks a lot for all you do for KSP!

Share this post


Link to post
Share on other sites
8 hours ago, Galenmacil said:

Hello linuxgurugamer.

I believe the first point causes said small decoupler ("RLA_small_decoupler_stack" AKA "TR-1V") to be absent of any categories in the editor... Perhaps changing to the "Coupling" category instead?

I am using the Filter Extension mod. I can still find it under the manufacturer tab (RLA) but it took me a while to figure it out.

Thanks a lot for all you do for KSP!

 

I'm not sure what you are looking at.  I just installed RLA using CKAN, and it is currently set to Coupling.

Please check to see if you have the latest version.

Looking at the commit  history, I see that the "none" came in a PR from @yalov, released on Feb 27, and was fixed the next day in the version listed as 0.15.1.7.  Current version is 0.15.1.8

Share this post


Link to post
Share on other sites

Well, using CKAN to install the mod, the listed version is 0.15.1.8. Opening the downloaded archive and browsing to the following file:

.\RLA_Reborn\Parts\Structural\struct_various\small_decoupler_stack.cfg

Excerpt from said file, line 25:

[...]

category = none

[...]

Looking at the same file from the Github repository shows the exact same thing.

I know this is a minor problem but it had me searching for a while, in the game editor, why I could not find the "TR-1V Stack Decoupler" to complete a contract...

There seems to be some confusion as to what was actually included in that latest CKAN release.

 

Share this post


Link to post
Share on other sites
Posted (edited)
On 4/30/2019 at 5:52 PM, Galenmacil said:

Well, using CKAN to install the mod, the listed version is 0.15.1.8. Opening the downloaded archive and browsing to the following file:

.\RLA_Reborn\Parts\Structural\struct_various\small_decoupler_stack.cfg

Excerpt from said file, line 25:

[...]

category = none

[...]

Looking at the same file from the Github repository shows the exact same thing.

I know this is a minor problem but it had me searching for a while, in the game editor, why I could not find the "TR-1V Stack Decoupler" to complete a contract...

There seems to be some confusion as to what was actually included in that latest CKAN release.

 

Please send me that file, I'd like to figure out what's different.

It's possible that this was a change which I never pushed to github, I'll check when I get home

 

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites

I found the problem, I was looking at the wrong file.

Sorry.

will get an update out later this evening

Share this post


Link to post
Share on other sites

New release, 0.15.1.9

  • Changed category from "none" to "Coupling" in the small_decoupler_stack

Share this post


Link to post
Share on other sites
Posted (edited)

So im on 1.6.1, what version should i use? ;) Is the latest version backward compatible?

Thank you for a great mod :cool:

Edited by Cratzz

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.