• 1
Sign in to follow this  
Cooly568

Inexplicable Sudden Lockups/Crashes - KSP 1.4.3

Question

Right, here we go.

KSP has been getting more and more funky as I've played more and more of my career save. The garbage collection lag spikes aren't so so bad, but after getting out of the remade GPO Kerbin system, and having around 25 ships in flight at once, the game just, started dying.

System details:
KSP 1.4.3 64-bit
CPU: Ryzen 7 1700
GPU: GTX 1070
RAM: 16GB

I wish I could detail more exactly as to what's going on, but the game just, dies randomly.

Modlist, as covered by the gamedata folder.

Folders and files in GameData:
001_ToolbarControl
ASET
Astrogator
AtmosphereAutopilot
B9PartSwitch
BonVoyage
Chatterer
ClickThroughBlocker
CommNetVisualisation
CommunityCategoryKit
CommunityResourcePack
CommunityTechTree
ContractConfigurator
ContractPacks
CrewRandR
CriticalTemperatureGauge
CryoTanks
CTTP
CustomBarnKit
DeployableEngines
DistantObject
DMagicOrbitalScience
DMagicUtilities
DynamicBatteryStorage
EditorExtensionsRedux
EnvironmentalVisualEnhancements
Firespitter
FP_DPSoundFX
FShangarExtender
GPO
GroundConstruction
HeatControl
HGR
HideEmptyTechTreeNodes
Impact
INSTANTIATOR
KAS
KerbalAtomics
KerbalJointReinforcement
KerboKatz
KIS
Kopernicus
MagiCore
MechJeb2
MemGraph
ModularFlightIntegrator
MouseAimFlight
MSP3000
NearFutureElectrical
NearFutureLaunchVehicles
NearFutureProps
NearFuturePropulsion
NearFutureSolar
NearFutureSpacecraft
PlanetaryBaseInc
QuickMods
RealPlume
RealPlume-Stock
RetractableLiftingSurface
SCANsat
scatterer
Science-Full-reward
Sigma
SlingShotter
SmartStage
SmokeScreen
spacetux
Stock folder: Squad

StageRecovery
StationPartsExpansionRedux
StationScience
Strategia
SXT
ThroughTheEyes
TimeControl
TriggerTech
VanguardTechnologies
WaypointManager
WernherChecker
WetterWingsMM
WildBlueIndustries
[x] Science!
KSPModFileLocalizer.dll
ModuleManager.3.0.7.dll
ModuleManager.ConfigCache
ModuleManager.ConfigSHA
ModuleManager.Physics
ModuleManager.TechTree

I'm not running Making History as it caused issues with GPO.

Right, so after around a mission or two, the game simply, truncates. It will lock up, and sometimes regain posture and snap out of it's "program not responding" state, but more often than not, the game will automatically crash without even leaving a crash folder within the game install directory. Viewing the logs... don't help either.

[LOG 01:30:23.727] Remaining in Ascent
[LOG 01:30:23.750] Remaining in Ascent
[LOG 01:30:23.774] Remaining in Ascent
[LOG 01:30:23.793] Remaining in Ascent
[LOG 01:30:23.819] Remaining in Ascent
[LOG 01:30:23.840] Remaining in Ascent
[LOG 01:30:23.858] Remaining in Ascent
[LOG 01:30:23.881] Remaining in Ascent
[LOG 01:30:23.900] Remaining in Ascent
[LOG 01:30:23.920] Remaining in Ascent
[LOG 01:30:23.938] Remaining in Ascent
[LOG 01:30:23.956] Remaining in Ascent
[LOG 01:30:23.974] Remaining in Ascent
[LOG 01:30:23.993] Remaining in Ascent
[LOG 01:30:24.012] Remaining in Ascent
[LOG 01:30:24.031] Remaining in Ascent

Remaining in ascent is a Mechjeb message generated every frame while ascent autopilot is active. This was, the last recorded thing in the log. Before the log simply, stops.

I've never seen KSP go above 8GB of RAM usage, and Windows never goes above 70%.

MemGraph reveals nothing weird.

Even more bizarre, I run this install off of a hard drive. When I ran it off an SSD, the game started sometimes having the music stutter as if my computer was blue-screening, but the game kept on playing just fine. This was not observed with the hard drive. Meaning I'm only more confused to this all. Is it a save thing? Is it a mod thing? Is it a Windows 10 thing?

 

Edit: Did a lot of looking into it. I think it may be a RAM issue? But there's still 5GB of system RAM open before the game crashes. The game never gets past 10GB ever. I've also found this happening where if I got to the Tracking Station on a new save, the game still gives out. I removed quite a few non-critical mods in order to eliminate possible issues, but that, didn't do anything. What puzzles me is this ran perfectly fine days ago. No mods have been changed when the game worked properly.

Edit 2: Attempted to uninstall MSI Afterburner as has been referenced in the past. Lockups and crashes were still observed, even with RAM sucking mods besides GPO uninstalled. The same locking up behavior also manifested still in new saves. The mods have not been changed in a week on this install, and these issues only started as of last night. Even on new saves, with no mods changed in or out, when this install worked perfectly before. Windows issue due to the lack of crash log output? If so, what to do?

Edited by Cooly568

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 1

So I ended up solving it on my own, but I feel like the knowledge could be useful to others.

I was running my RAM at 2667 MHz on my Ryzen system. Even with the most recent firmware, this was unstable. But was ONLY unstable in KSP for some reason. All other programs ran just fine.

So if anyone is getting odd crashes like this on Ryzen, back down your RAM speed.

KSP is a RAM heavy game with a ton of mods after all, so errors in the memory would become more critical.

So I ended up solving it on my own, but I feel like the knowledge could be useful to others.

I was running my RAM at 2667 MHz on my Ryzen system. Even with the most recent firmware, this was unstable. But was ONLY unstable in KSP for some reason. All other programs ran just fine.

So if anyone is getting odd crashes like this on Ryzen, back down your RAM speed.

KSP is a RAM heavy game with a ton of mods after all, so errors in the memory would become more critical.

 

 

Aaaaand I take that back. Still happening.

I still think it's a Ryzen issue.

Edited by Cooly568

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this