Recommended Posts

Does the making History Expansion work with Kerbal EDU?  We have EDU at our library and do some basic classes. I think the Mission Builder is ideal for setting up scenarios for the kids.

  • Like 2

Share this post


Link to post
Share on other sites

I do not think so.  Making History requires KSP 1.4.1 at the very least, and EDU has only been updated to 1.3.1. 

Share this post


Link to post
Share on other sites

EDIT: YES! appears to work even in the x32 KerbalEDU 1.4.5 .... with x32 KerbalEDU running in Windows you MUST launch ksp.exe with the Unity flag -force-d3d11 to keep the RAM within x32 limits.

@MarkZero   does the EDU event system conflict with the TT DLC or was any code removed for the KerbalEDU build that would prevent the DLC from running in KerbalEDU 1.4.5?

@Klapaucius  So far what I see for KerbalEDU 1.4.5 :  [EDIT: the crash was due to hitting the approx 3.6 GB x32 memory limit )

  • the windows .exe installer for DLC 1.4.0 for 1.4.5 does extract into the new KerbalEDU 1.4.5,
  • KerbalEDU successfully loads the expansion folder,
  • selecting Play Missions or Mission Builder does load the respective menus,
  • & can  launch _into_ the builder & tutorials,
  • however _exiting_ either of those or
  • trying to run a DLC mission (either the TT included ones or a downloaded .zip) appear to crash KerbalEDU 1.4.5 for me so far...

[EDIT: x64 KerbalEDU is now included in the download from the Windows TG app] also note, for now I appear to only be able to download a x32 bit version of KerbalEDU 1.4.5 ( I normally use x64 in all prior versions that offered x64 )

Some relevant screenshots:

Spoiler

416Eo7E.png

CazGLT8.png

a9uV7My.png

rqIHPPN.png

 

 

 

 

 

Edited by AloE
figured out crash was due to RAM limit of current release of KerbalEDU in the TG app download being x32 not x64

Share this post


Link to post
Share on other sites

@Klapaucius @MarkZero

Yes: the appropriate Making History Expansion for 1.4.5 is actually working for me even in x32 KerbalEDU 1.4.5

Since I am in a MS Windows environment, for x32 KerbalEDU I do need to launch ksp.exe with the -force-d3d11 unity engine flag. 

Spoiler

Here is a screenshot of what a MS Windows shortcut to launch KerbalEDU looks like with Unity engine flags (note that -force-d3d11 is a flag only for Windows, also note you can use as many or as few Unity flags as you want):

1XmEvOR.png

Doing so, the RAM use running the Making History Expansion in x32 KerbalEDU is approx 2.5 GB.  where as with the default launch with d3d9 rapidly exceeds 3.5GB of RAM and crashes ksp.

Here is an example screenshot of the DLC working in x32 KerbalEDU with the first 'stock' mission...

wG84HPx.png

Frk72pB.png

Edited by AloE

Share this post


Link to post
Share on other sites
On 10/26/2018 at 11:28 PM, AloE said:

 

@MarkZero   does the EDU event system conflict with the TT DLC or was any code removed for the KerbalEDU build that would prevent the DLC from running in KerbalEDU 1.4.5?

No code has been removed so there should be no conflict.

Sorry about the 64bit version. You can't currently download it. We have usually simply included both executables in the download but in the 1.4.5 windows build we had some problems with that. We are working on a solution.

  • Like 1

Share this post


Link to post
Share on other sites

We have just updated the Windows build of version 1.4.5e882 available in the TeacherGaming app. We added the 64-bit executable and files required by it that were previously missing.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now